gifts2017

Программа Дисплей покупателя: второй монитор (Информационное табло). Поддержка видео

Опубликовал Александр (tvixeg) в раздел Обработки - Рабочее место

Программа Дисплей покупателя: второй монитор (Информационное табло) предназначена для работы на любых кассах с различным кассовым программным обеспечением. Взаимодействие происходит с помощью текстовых файлов. На одной половине экрана крутятся изображения с вашей рекламой или акциями, на другой половине отображается текущий заказ покупателя. Фоновое изображение и рекламные картинки вы можете использовать свои. Приложение открывается на полный экран, скрывая панель Пуска. Можно запустить его на втором мониторе, подключенном к кассе или на отдельном компьютере, отправляя на него информацию по сети. Также в качестве дисплея удобно использовать планшет на Windows. Появилась возможность прокручивать видео-ролики со звуком во время простоев. Также можно отключить рекламу и выводить текстовую информацию на весь экран. В версии 2.0 появилась возможность отображать картинки товаров и изменять размер дисплея.

Если включена поддержка видео, то на весь экран проигрывается видеоролик 1.avi, который находится в папке с программой. При выводе текста, видео ставится на паузу и исчезает. После очистки дисплея снова продолжает показываться видео. Видеоролик прокручивается бесконечное число раз.

Информация о текущем заказе берется из текстового файла. В нем может содержаться любой текст. Последняя строка файла выводится в Итого. Также можно выводить полученную сумму и сдачу. Формат вывода в примере ниже. Товары лучше записывать в файл в обратном порядке, чтобы на дисплее новые товары отображались сверху, старые будут опускаться вниз до надписи Итого, а затем исчезать. Записывать в файл нужно каждый раз все товары. Формировать файл нужно после ввода каждой новой позиции, изменения количества, отмены товара, после пробития чека. Программа проверяет наличие файла у себя в каталоге несколько раз в секунду, когда  он появляется она считывает его, выводит на дисплей и удаляет. Для очистки дисплея записываем в файл символ "@". Если нам необходимо отображать картинку товара, то отправляем файл tovar.txt с именем файла картинки.

Видео работы: http://www.youtube.com/watch?feature=player_embedded&v=Fz8zNLA6nGo

 

Новая версия с поддержкой видео-рекламы:

Внешний вид дисплея:

 

На одной половине прокручиваются ваши изображения с рекламой, на другой - информация для покупателя:

 

 Поддержка любого языка:

 

Отключение рекламы и вывод текста на весь экран:

Интеграция дисплея с конфигурацией Управление торговлей 10.3.

Для подключения дисплея нужно в модуль двух форм документа ЧекККМ: ФормаДокумента и ФормаРегистрацииПродаж добавить процедуру вывода на дисплей:

 

 //Процедрура осуществляет вывод информации на дисплей-монитор

 Процедура ВывестиНаДисплейМонитор()

	     ПутьИИмяФайла = "C:\displ\vivod.txt";

	     СуммаВсего = Товары.Итог("Сумма");

	     Текст = Новый ТекстовыйДокумент;

	     

	     СписокТоваров = Новый ТаблицаЗначений;

	     СписокТоваров = ЭтотОбъект.Товары.Выгрузить();

	     Ном = СписокТоваров.Количество();

	     Пока Ном>0 Цикл

	         Колво = СписокТоваров[ном-1].Количество;

	         ТекЦена = СписокТоваров[ном-1].Цена;

	         ТекТовар = СписокТоваров[ном-1].Номенклатура.Наименование;

	         Текст.ДобавитьСтроку(Строка(ТекТовар));

	         Текст.ДобавитьСтроку("Количество: "+Формат(Колво,"ЧЦ=10; ЧДЦ=3")+"       Цена: "+Формат(ТекЦена,"ЧЦ=10; ЧДЦ=2; ЧН=")+"руб.");

	         Текст.ДобавитьСтроку("");

	         Ном = Ном-1;

	     КонецЦикла;

	     Если СуммаВсего>0 Тогда    

	         Текст.ДобавитьСтроку("Итого: "+Формат(СуммаВсего,"ЧЦ=10; ЧДЦ=2")+"руб.");

	     ИначеЕсли СписокТоваров.Количество()=0 Тогда

	         Текст.ДобавитьСтроку("@");

	     КонецЕсли;

	     Попытка

	         Текст.Записать(ПутьИИмяФайла,КодировкаТекста.ANSI);

	     Исключение

	         

	     КонецПопытки

 КонецПроцедуры    

 

После этого нужно добавить в этих формах в процедуре ВывестиИнформациюНаДисплейПокупателя() вызов нашей добавленной процедуры вывода на монитор: ВывестиНаДисплейМонитор();

На этом изменение торговли заканчивается. Можете сами поправить путь записи файла с информацией, в том числе, можете указать его как сетевой. Также можете дописать в этот файл что-нибудь еще по вашему усмотрению.

Интеграция дисплея с конфигурацией Розница 2.0.

Для подключения дисплея нужно в модуль формы Форма обработки РМК  добавить процедуру вывода на дисплей: ВывестиНаДисплейМонитор() (текст процедуры смотрите выше, ничем не отличается от текста для Управления торговлей).  После этого нужно в этой же форме в начало процедуры ВывестиИнформациюНаДисплейПокупателя(Команда) добавить строчку ВывестиНаДисплейМонитор();

На этом изменение Розницы заканчивается. Можете сами поправить путь записи файла с информацией, в том числе, можете указать его как сетевой. Также можете дописать в этот файл что-нибудь еще по вашему усмотрению.

Интеграция дисплея с конфигурацией Управление торговлей 11.1 при продажах через документ Реализация товаров и услуг.

Для подключения дисплея нужно в модуль формы ФормаДокумента документа РеализацияТоваровУслуг добавить процедуру вывода на дисплей:

 &НаСервере Процедура ВывестиНаДисплейМонитор()
	ПутьИИмяФайла = "C:\displ\vivod.txt";
	СуммаВсего = Объект.Товары.Итог("СуммаСНДСБезВозвратнойТары");
	Текст = Новый ТекстовыйДокумент;
	СписокТоваров = Новый ТаблицаЗначений;
	СписокТоваров = Объект.Товары.Выгрузить();
	Ном = СписокТоваров.Количество(); Пока Ном>0 Цикл
	Колво = СписокТоваров[ном-1].Количество;
	ТекЦена = СписокТоваров[ном-1].Цена;
	ТекТовар = СписокТоваров[ном-1].Номенклатура.Наименование;
	Текст.ДобавитьСтроку(Строка(ТекТовар));
	Текст.ДобавитьСтроку("Количество: "+Формат(Колво,"ЧЦ=10; ЧДЦ=3")+" Цена: "+Формат(ТекЦена,"ЧЦ=10; ЧДЦ=2; ЧН=")+"руб.");
	Текст.ДобавитьСтроку("");
	Ном = Ном-1; КонецЦикла;
	Текст.ДобавитьСтроку("Итого: "+Формат(СуммаВсего,"ЧЦ=10; ЧДЦ=2")+"руб."); Попытка
	Текст.Записать(ПутьИИмяФайла,КодировкаТекста.ANSI); Исключение КонецПопытки КонецПроцедуры

Затем в процедуру Процедура ТоварыПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования) добавить строчку: ВывестиНаДисплейМонитор();

Для очистки дисплея при закрытии документа реализации нужно изменить процедуру ПриЗакрытии():

 &НаКлиенте Процедура ПриЗакрытии()
	МенеджерОборудованияКлиент.ОтключитьОборудованиеПриЗакрытииФормы(ЭтаФорма);
	ПутьИИмяФайла = "C:\displ\vivod.txt";
	Текст = Новый ТекстовыйДокумент;
	Текст.ДобавитьСтроку("@"); Попытка
	Текст.Записать(ПутьИИмяФайла,КодировкаТекста.ANSI); Исключение КонецПопытки КонецПроцедуры

 По вашему запросу интегрируем в любую конфигурацию.

Инструкция по установке программы:

Копируем программу в любое место себе на компьютер или планшет. В папке с программой есть файл фоновой картинки, которую вы можете поменять на любую картинку. Также есть папка с картинками, которые постоянно меняются на одной половине экрана. Вы тоже можете все эти картинки поменять. Это обычные файлы в формате .jpg. Если у вас второй монитор подключается к тому же компьютеру, где и касса, то ставите эту программу прямо на кассу. При запуске она автоматически откроется на весь экран на втором мониторе. Если у вас монитор для дисплея подключается к другому отдельному компьютеру, то ставим программу на тот компьютер. При запуске она откроется на нем на весь экран. Папку с программой в таком случае нужно будет сделать сетевой, чтобы с кассы 1С могла записывать текстовые файлы с информацией для вывода на дисплей, на тот второй компьютер. Программа считывает эти файлы, выводит на экран и удаляет.

Настраиваем файл Settings.ini:

1) В параметре Interval задаем интервал смены картинок. По умолчанию 10 секунд.

2) В параметре ColorText задаем цвет текста. Таблицу цветов смотрим ниже. По умолчанию цвет черный.

3) В параметре ColorItogo задаем цвет Итого. Таблицу цветов смотрим ниже. По умолчанию цвет черный.

4) В параметре SizeText задаем размер шрифта текста. По умолчанию размер 15.

5) В параметре SizeItogo задаем размер шрифта Итого. По умолчанию размер 45.

6) В параметре Reklama включаем или отключаем рекламу. 1 - включена, 0 - отключена. По умолчанию 1.

7) В параметре Video включаем или отключаем видео. 1 - включено, 0 - отключено. По умолчанию 0.

8) В параметре Font задаем имя шрифта. 1 - значение по умолчанию. Это шрифт в формате Unicode, поддерживает любой язык. В качестве значения может быть использовано имя стандартных шрифтов, например, Comic Sans MS.

9) В параметре Width задаем ширину дисплея, если 0, то откроется на всю ширину экрана. По умолчанию 0.

10) В параметре Height задаем высоту дисплея, если 0, то откроется на всю высоту экрана. По умолчанию 0.

Список поддерживаемых шрифтов:  Arial, Arial Black, Arial Narrow, Calibri, Comic Sans MS, Courier, Courier New, Impact,  Microsoft Sans Serif, Modern, MS Sans Serif, Tahoma, Times New Roman, Verdana и т.д.

Не все приведенные выше шрифты поддерживают русский язык. Также вы можете  указать любой свой шрифт, главное чтобы он был установлен в вашей операционной системе.

Таблица соответствия цветов:

Номер цвета Цвет
1 Черный
2 Бордовый
3 Зеленый
4 Оливковый
5 Морской
6 Пурпурный
7 Бирюзовый
8 Серый
9 Серебряный
10 Красный
11 Лимонный
12 Желтый
13 Синий
14 Малиновый
15 Водный
16 Белый

Любые интересующие вас вопросы вы можете задавать по телефону: 8-800-5555-256

Причины купить

1) Повысит привлекательность вашего заведения.

2) Информирование покупателей об акциях.

3) Реклама продукции.

4) Использование вместо стандартных маленьких дисплеев покупателей.

Достоинства

Наиболее полная информация для покупателей

Возможность прокрутки своей рекламы

Поддержка любого языка

Прокрутка видео-роликов во время простоев

Возможность вывода на экран картинок товаров

Сравнение версий

Версия 2.0

Добавлена возможность изменять размеры дисплея

Добавлена возможность отображать картинки товаров

Добавлена возможность проигрывания видео-роликов без необходимости устанавливать кодеки.

Версия 1.05

Добавлена возможность изменять шрифт текста.

Версия 1.0.4

Добавлена поддержка прокрутки видео-роликов со звуком во время простоев.

Версия 1.0.3

Добавлена возможность отключения рекламы и вывода текстовой информации на весь экран.

Версия 1.0.2

Добавлена  поддержка любых языков, формат Unicode.

Версия 1.0.1

Добавлен файл настроек Settings.ini. В нем можно задавать размер шрифта текста и Итого, указывать их цвет. Также можно задавать интервал смены картинок.

Скачать файлы

Наименование Файл Версия Размер
Демонстрационная версия 2.0 (новая) 127
.zip 28,14Mb
18.10.16
127
.zip 28,14Mb Бесплатно
Техническая поддержка на 1 год
18.10.2016
500 руб.
Дисплей покупателя: второй монитор 2.0 (1 рабочее место)
18.10.2016
5500 руб.

Моментальная
доставка

Дисплей покупателя: второй монитор 2.0 (2 рабочих места)
18.10.2016
10000 руб.
Дисплей покупателя: второй монитор 2.0 (10 рабочих мест)
18.10.2016
45000 руб.

См. также

Автор запретил комментарии