gifts2017

Печать заявления на банковское обслуживание в Сбербанке

Опубликовал Виталий Жиляев (VitRu) в раздел Печать - Печатные формы документов

Конфигурация ЗУП имеет хороший функционал по обмену данными со Сбербанком РФ. Но нам, например, не хватило печати заявления на обслуживание, выгрузки реестра на открытие карт и загрузки лицевых счетов. В нашей строительной компании часто набирают бригады рабочих, и надо быстро оформить человек 50, а делать это средствами Сбербанка (экселевские файли с макросами) очень трудоемко, и велика вероятность ошибок. Предлагаю очень простую внешнею обработку печати заявлений на обслуживание. Самое сложное при ее написании это было набрать форму макета.
  

       В обработке используется функция ЛатинскаяТранскрипция из общего модуля VitОбщийМодуль.

       Я предполагал, что она будет использоваться из разных обработок и общий модуль всё равно уже есть,

       а Вы можете поместить эту функцию в модуль обработки. Я внимательно разбирался с правилами трансляции.

       Было несколько вариантов. Остался этот, самый простой. Но банк устроил именно он.

 

Функция ЛатинскаяТранскрипция(НаиФио) Экспорт
 
 //Между 2-мя гласными “S” пишется дважды ВАСИЛИЙ – VASSILI   ВАСИН – VASSINE ?????
 //Все фамилии, оканчивающиеся на “ин”, пишутся с “E” на конце:  СИНИЦЫН – SINITSINE, КУЗИН – KOUZINE ??????
 //“G” – перед E,I,Y пишется с “U”: ГЕННАДИЙ – GUENNADI
 //ОЛЬГА, НАТАЛЬЯ и т.п. – без “ь”: OLGA, NATALIA
 //Имена и фамилии, оканчивающиеся на “ий”, пишутся с “I” на
 // конце: ЮРИЙ – IOURI, БЕЛЯВСКИЙ – BELIAVSKI.
 //Если в фамилии после “ь” следует “e” то пишется “IE”:
 //ВАСИЛЬЕВ – VASSILIEV.
 
 
 Фио = ВРег(НаиФио); Нп = Найти(Фио, " ");
 Если Нп = 0 Тогда Возврат Фио; КонецЕсли; 
 Фам = Лев(Фио, Нп-1); Фио = Сред(Фио, Нп+1); Нп = Найти(Фио, " ");
 Если Нп = 0 Тогда Возврат Фио; КонецЕсли;
 Фио = Лев(Фио, Нп-1)+" "+Фам; 
 
 ТабСоо = Новый ТаблицаЗначений;
 ТабСоо.Колонки.Добавить("Рус");
 ТабСоо.Колонки.Добавить("Лат");
 Ст = ТабСоо.Добавить(); Ст.Рус = "Ь"; Ст.Лат = "";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Ъ"; Ст.Лат = "";
 Ст = ТабСоо.Добавить(); Ст.Рус = " "; Ст.Лат = " ";
 Ст = ТабСоо.Добавить(); Ст.Рус = "А"; Ст.Лат = "A";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Б"; Ст.Лат = "B";
 Ст = ТабСоо.Добавить(); Ст.Рус = "В"; Ст.Лат = "V";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Г"; Ст.Лат = "G";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Д"; Ст.Лат = "D";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Е"; Ст.Лат = "E";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Ё"; Ст.Лат = "E";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Ж"; Ст.Лат = "ZH";
 Ст = ТабСоо.Добавить(); Ст.Рус = "З"; Ст.Лат = "Z";
 Ст = ТабСоо.Добавить(); Ст.Рус = "И"; Ст.Лат = "I";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Й"; Ст.Лат = "Y";
 Ст = ТабСоо.Добавить(); Ст.Рус = "К"; Ст.Лат = "K";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Л"; Ст.Лат = "L";
 Ст = ТабСоо.Добавить(); Ст.Рус = "М"; Ст.Лат = "M";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Н"; Ст.Лат = "N";
 Ст = ТабСоо.Добавить(); Ст.Рус = "О"; Ст.Лат = "O";
 Ст = ТабСоо.Добавить(); Ст.Рус = "П"; Ст.Лат = "P";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Р"; Ст.Лат = "R";
 Ст = ТабСоо.Добавить(); Ст.Рус = "С"; Ст.Лат = "S";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Т"; Ст.Лат = "T";
 Ст = ТабСоо.Добавить(); Ст.Рус = "У"; Ст.Лат = "U";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Ф"; Ст.Лат = "F";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Х"; Ст.Лат = "KH";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Ц"; Ст.Лат = "TC";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Ч"; Ст.Лат = "CH";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Ш"; Ст.Лат = "SH";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Щ"; Ст.Лат = "SHCH";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Ы"; Ст.Лат = "Y";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Э"; Ст.Лат = "E";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Ю"; Ст.Лат = "IU";
 Ст = ТабСоо.Добавить(); Ст.Рус = "Я"; Ст.Лат = "IA";
 
 Рез = "";
 Длин = СтрДлина(Фио);
 Для Сч=1 По Длин Цикл
  Сим = Сред(Фио, Сч, 1);
  Ст = ТабСоо.Найти(Сим, "Рус");
  Если Ст = Неопределено Тогда
   Возврат Фио;
  КонецЕсли; 
  Рез = Рез + Ст.Лат;
 КонецЦикла; 
 
 Возврат Рез;
 
КонецФункции // ЛатинскаяТранскрипция()

 

 

      В форме обработки всего две кнопки просто подбираем сотрудников

  

      и печатаем их заявления

  

    

 

 

 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ЗаявлениеНаОбслуживание
.epf 43,01Kb
27.11.14
13
.epf v01.1 43,01Kb 13 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Макас (makas) 27.11.14 15:30
Возьму на заметку вашу форму, скоро потребуется +
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа