gifts2017

Обмен документами MEDOC и 1С 7.7

Опубликовал Sergii Bortnyk (ukrod) в раздел Обмен - Обмен с другими системами

Обработка предназначена для обмена некоторыми типами документов между ПК "MEDOC" и 1С 7.7 "Бухгалтерия + Торговля + Склад + Зарплата" для Украины

Обработка предназначена для обмена некоторыми типами документов между ПК "MEDOC" и 1С 7.7 "Бухгалтерия + Торговля + Склад + Зарплата" для Украины

Документы, передаваемые в MEDOC:
  - Налоговая накладная
  - Приложение 2

Документы, принимаются из MEDOC:
  - Запись книги приобретения

Требования для корректной работы обработки:
1) MEDOC не ниже версии 10.1
2) MEDOC и сеанс 1С7 должны быть запущены на одном компьютере
3) Запущенный MEDOC
4) Для приема документов - запущена обработка и окно обработки активное
5) Для отслеживания наличия переданных документов в MEDOC, во избежание их дублирования, в структуру
    документов "Налоговая накладная" и "Приложение 2" добавлен реквизит GUID Строка (96). Обработка заполняет его
    при передаче.

Обработка может одновременно использоваться как для приема, так и для передачи документов в MEDOC.
Для передачи документов из журнала "Книга продаж" в форму обработки нужно передать ссылку на документ.

Пример вызова:
------------------------------------------------------------------------------------------------------------------

// ===============================
Процедура ПередатьВMEDOC ()

ОткрытьФорму ("Обработка", ТекущийДокумент, КаталогИБ () + "\ ExtForms \ ОбменСMEDOC.ert");

КонецПроцедуры


------------------------------------------------------------------------------------------------------------------

При написании обработки были осуществлены некоторые упрощения. А именно задано пустое значение номеров филиала и еще некоторых
параметров.
Обработка тестированы на "Бухгалтерия + Торговля + Склад + Зарплата" для Украины

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Архив. Обработка и инструкция
.zip 26,77Kb
20.01.15
16
.zip 1.0.0 26,77Kb 16 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

2. Володя Долінський (vdolynsky) 04.02.15 21:41
Вопрос!
Пробую переделать данную обработку для "Бухгалтерии для Украины".
Не подскажете как боротся с МЕДКом : при попытке отправить документ мз МЕДКа в 1с 7.7 Медок выдает сообщение "Для передачі документів в 1с необхідно виконати необхідні налаштування" и в обработкуСобытия обработки не возвращается????!!!

Спасибо!
3. Володя Долінський (vdolynsky) 04.02.15 22:09
Обработка при открытии выводит сообщение "НЕудачная попытка создания объекта (MEDOC.ZApplication)" строка обработки №31. Компоненту medoc1c.dll сервером регистрации компонент regsvr32.exe зарегистировал, regsvr32.exe,???

Help!

Нашел ответ:
Нужно на форму добавить кнопку с следующей функцией:
Процедура ЗапуститьМедок()
Если ПустоеЗначение(ПутьКФайлуМедка)=0 Тогда
Параметры="\ezvit.exe";
Если ФС.СуществуетФайл(ПутьКФайлуМедка+Параметры)=1 Тогда
Параметры= Параметры+"";
ЗапуститьПриложение(ПутьКФайлуМедка + Параметры);
Возврат;
Иначе
Предупреждение("Указанного файла не существует!" + РазделительСтрок + "Возможно, М.E.Doc IS удален, перемещен, или переименован.");
КонецЕсли;
Иначе
Предупреждение("Не указан путь к М.E.Doc IS!");
КонецЕсли;
КонецПроцедуры
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа