gifts2017

Рабочий стол Менеджера CRM для УТ

Опубликовал СЕРГЕЙ СЕЛИКОВСКИЙ (SERGQ) в раздел Обработки - Рабочее место

Обработка "Рабочий стол менеджера" предназначена для легкой работы с клиентами.

Интерфейс рабочего стола менеджера в 1С для повседневной работы в течение всего дня.
-Работа с номенклатурой, подбор, редактирование цен, ввод заказов, продаж.
-Остатки в списке, остатки по складам, товары в пути, заказы поставщикам, история продаж покупателю.
-Вывод картинок товара, описания, свойств
-Суперпоиск номенклатуры по множеству критериев. Поиск по любым слогам
-Подбор по нескольким складам, печать комплекта документов.
-Монитор-журнал заказов - управление активными заказами, статусы заказов, просроченные, оплаченные, к отгрузке.
-Пакетная отгрузка заказов, групповая печать документов, перемещение резервов.
-Множество удобных функций для удобства работы. Усовершенствованный поиск и работа с навигацией по номенклатуре.
Это рабочее место будет основным инструментом, с которым ваши менеджеры будут работать всегда.

Подбор номенклатуры, оформление заказов и продаж.

управляемая с клавиатуры форма, автоматизирующпя подбор.

быстрый вывод и отображение дополнительной расширенной информации по товару.

вывод остатков по основному складу (свободные, резервы, свободно в пути)

вывод детальных остатков по всем складам (свободные, резервы, заказы поставщикам). 

вывод характеристик и цен по характеристикам. 

вывод информации об остатках у поставщиков.

многофункциональный полнотекстовый поиск и отбор номенклатуры. 

отбор номенклатуры, которая есть на остатках

вывод информации о заказах поставщикам (свободных количествах). Видна дата поступления заказа, количество по заказу, склад поступления, заказ поставщику. Реализована возможность подобрать в корзину Размещение указав конкретный заказ поставщику (менеджер может оперировать по конкретной дате поступления)

вывод истории заказа и продаж товара покупателю

вывод информации по взаиморасчетам с выбранным покупателем.

Данная обработка тестировалось на УТ для РБ 2.0

Скачать файлы

Наименование Файл Версия Размер
Рабочий стол менеджера для УТ 65
.epf 433,90Kb
02.02.15
65
.epf 433,90Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Константин Юрин (kostyaomsk) 03.02.15 07:19
Хорошая идея с АРМ менеджера для УТ. Такая же работа предстоит. Запомню.
2. Пимшин 1 (Pim) 07.02.15 12:59
Хотелось бы увидеть код процедуры модОформление.СоздатьКнопкиПодменюТовары.
3. СЕРГЕЙ СЕЛИКОВСКИЙ (SERGQ) 09.02.15 15:09
(2) Pim,

Спасибо за интерес к обработке:
Вот сама процедура:
Процедура СоздатьКнопкиПодменюТовары(КоманднаяПанель,Объект = Неопределено) Экспорт
	//В зависимости от объекта создаем соответствующие кнопки.
	//1. Объект = неопределено. Это главная форма, 
	ДобавлятьОтчетыПоДоговору = Ложь;
	ДобавлятьОтчетыПоКонтрагенту = Ложь;
	ДобавлятьОтчетыПоНоменклатуре = Ложь;
	ДобавлятьОтчетыПоСкладу = Ложь;
	ДобавлятьОтчетыПоКассе = Ложь;
	ДобавлятьОтчетыПоЗаказамПоставщикам = Ложь;
	ДобавлятьОтчетыПоЗаказамПокупателей = Ложь;
	
	Если СокрЛП(КоманднаяПанель.ИсточникДействий) = "Форма" Тогда
		Если ТипЗнч(КоманднаяПанель.ИсточникДействий.Ссылка) = Тип("СправочникСсылка.ДоговорыКонтрагентов") Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
		ИначеЕсли ТипЗнч(КоманднаяПанель.ИсточникДействий.Ссылка) = Тип("СправочникСсылка.Контрагенты") Тогда
			ДобавлятьОтчетыПоКонтрагенту = Истина;
		ИначеЕсли ТипЗнч(КоманднаяПанель.ИсточникДействий.Ссылка) = Тип("СправочникСсылка.Номенклатура") Тогда
			ДобавлятьОтчетыПоНоменклатуре = Истина;
		Иначе
			Возврат;
		КонецЕсли;
	ИначеЕсли (Объект <> Неопределено) И (ТипЗнч(Объект) = Тип("ОбработкаОбъект.РабочееМесто")) Тогда
		//Перебираем командные панели рабочего стола
		Если КоманднаяПанель.Имя = "КоманднаяПанельРеализации" Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
			ДобавлятьОтчетыПоСкладу = Истина;
			ДобавлятьОтчетыПоКассе = Истина;
		ИначеЕсли КоманднаяПанель.Имя = "КоманднаяПанельВозвратовОтПокупателей" Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
			ДобавлятьОтчетыПоСкладу = Истина;
			ДобавлятьОтчетыПоКассе = Истина;
		ИначеЕсли КоманднаяПанель.Имя = "КоманднаяПанельЗаказовПокупателей" Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
			ДобавлятьОтчетыПоСкладу = Истина;
			ДобавлятьОтчетыПоЗаказамПокупателей = Истина;
		ИначеЕсли КоманднаяПанель.Имя = "КоманднаяПанельЗаказовПоставщикам" Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
			ДобавлятьОтчетыПоСкладу = Истина;
			ДобавлятьОтчетыПоЗаказамПоставщикам = Истина;
		ИначеЕсли КоманднаяПанель.Имя = "КоманднаяПанельПоступлений" Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
			ДобавлятьОтчетыПоСкладу = Истина;
		ИначеЕсли КоманднаяПанель.Имя = "КоманднаяПанельВозвратовПоставщикам" Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
			ДобавлятьОтчетыПоСкладу = Истина;
		ИначеЕсли КоманднаяПанель.Имя = "КоманднаяПанельНоменклатуры" Тогда
			ДобавлятьОтчетыПоНоменклатуре = Истина;
		ИначеЕсли КоманднаяПанель.Имя = "КоманднаяПанельПеремещенийТоваров" Тогда
			ДобавлятьОтчетыПоНоменклатуре = Истина;
			ДобавлятьОтчетыПоСкладу = Истина;
		ИначеЕсли КоманднаяПанель.Имя = "КоманднаяПанельОприходований" Тогда
			ДобавлятьОтчетыПоСкладу = Истина;
		ИначеЕсли КоманднаяПанель.Имя = "КоманднаяПанельСписаний" Тогда
			ДобавлятьОтчетыПоСкладу = Истина;
		ИначеЕсли КоманднаяПанель.Имя = "КоманднаяПанельКассовыхДокументов" Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
			ДобавлятьОтчетыПоКассе = Истина;
		ИначеЕсли КоманднаяПанель.Имя = "КоманднаяПанельБанковскихДокументов" Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
		ИначеЕсли КоманднаяПанель.Имя = "КоманднаяПанельПКО" Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
			ДобавлятьОтчетыПоКассе = Истина;
		ИначеЕсли КоманднаяПанель.Имя = "КоманднаяПанельРКО" Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
			ДобавлятьОтчетыПоКассе = Истина;
		ИначеЕсли КоманднаяПанель.Имя = "КоманднаяПанельПеремещенийМеждуКассами" Тогда
			ДобавлятьОтчетыПоКассе = Истина;
		ИначеЕсли КоманднаяПанель.Имя = "КоманднаяПанельППВ" Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
		ИначеЕсли КоманднаяПанель.Имя = "КоманднаяПанельППИ" Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
		ИначеЕсли КоманднаяПанель.Имя = "КоманднаяПанельУстановокЦен" Тогда
			
		ИначеЕсли КоманднаяПанель.Имя = "КоманднаяПанельКонтрагентов" Тогда
			ДобавлятьОтчетыПоКонтрагенту = Истина;
		ИначеЕсли КоманднаяПанель.Имя = "КоманднаяПанельДоговоров" Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
		КонецЕсли;
	Иначе
		Если Объект = Неопределено Тогда
			Возврат;
		КонецЕсли;
		Если ТипЗнч(Объект) = Тип("ДокументОбъект.ЗаказПоставщику") Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
			ДобавлятьОтчетыПоНоменклатуре = Истина;
			ДобавлятьОтчетыПоСкладу = Истина;
			ДобавлятьОтчетыПоЗаказамПоставщикам = Истина;
		ИначеЕсли ТипЗнч(Объект) = Тип("ДокументОбъект.ПоступлениеТоваровУслуг") Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
			ДобавлятьОтчетыПоНоменклатуре = Истина;
			ДобавлятьОтчетыПоСкладу = Истина;
		ИначеЕсли ТипЗнч(Объект) = Тип("ДокументОбъект.РеализацияТоваровУслуг") Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
			ДобавлятьОтчетыПоНоменклатуре = Истина;
			ДобавлятьОтчетыПоСкладу = Истина;
			ДобавлятьОтчетыПоКассе = Истина;
		ИначеЕсли ТипЗнч(Объект) = Тип("ДокументОбъект.ВозвратТоваровОтПокупателя") Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
			ДобавлятьОтчетыПоНоменклатуре = Истина;
			ДобавлятьОтчетыПоСкладу = Истина;
			ДобавлятьОтчетыПоКассе = Истина;
		ИначеЕсли ТипЗнч(Объект) = Тип("ДокументОбъект.ВозвратТоваровПоставщику") Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
			ДобавлятьОтчетыПоНоменклатуре = Истина;
			ДобавлятьОтчетыПоСкладу = Истина;
		ИначеЕсли ТипЗнч(Объект) = Тип("ДокументОбъект.ПеремещениеТоваров") Тогда
			ДобавлятьОтчетыПоНоменклатуре = Истина;
			ДобавлятьОтчетыПоСкладу = Истина;
			ДобавлятьОтчетыПоКассе = Истина;
		ИначеЕсли ТипЗнч(Объект) = Тип("ДокументОбъект.ЗаказПокупателя") Тогда
			ДобавлятьОтчетыПоДоговору = Истина;;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
			ДобавлятьОтчетыПоНоменклатуре = Истина;
			ДобавлятьОтчетыПоСкладу = Истина;
			ДобавлятьОтчетыПоЗаказамПокупателей = Истина;
		ИначеЕсли ТипЗнч(Объект) = Тип("ДокументОбъект.ОприходованиеТоваров") Тогда
			ДобавлятьОтчетыПоНоменклатуре = Истина;
			ДобавлятьОтчетыПоСкладу = Истина;
		ИначеЕсли ТипЗнч(Объект) = Тип("ДокументОбъект.СписаниеТоваров") Тогда
			ДобавлятьОтчетыПоНоменклатуре = Истина;
			ДобавлятьОтчетыПоСкладу = Истина;
		ИначеЕсли ТипЗнч(Объект) = Тип("ДокументОбъект.ПриходныйКассовыйОрдер") Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
			ДобавлятьОтчетыПоКассе = Истина;
		ИначеЕсли ТипЗнч(Объект) = Тип("ДокументОбъект.РасходныйКассовыйОрдер") Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
			ДобавлятьОтчетыПоКассе = Истина;
		ИначеЕсли ТипЗнч(Объект) = Тип("ДокументОбъект.ПлатежноеПоручениеВходящее") Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
		ИначеЕсли ТипЗнч(Объект) = Тип("ДокументОбъект.ПлатежноеПоручениеИсходящее") Тогда
			ДобавлятьОтчетыПоДоговору = Истина;
			ДобавлятьОтчетыПоКонтрагенту = Истина;
		ИначеЕсли ТипЗнч(Объект) = Тип("ДокументОбъект.УстановкаЦенНоменклатуры") Тогда
			ДобавлятьОтчетыПоНоменклатуре = Истина;
		ИначеЕсли ТипЗнч(Объект) = Тип("ДокументОбъект.ВнутреннееПеремещениеНаличныхДенежныхСредств") Тогда
			ДобавлятьОтчетыПоКассе = Истина;
		КонецЕсли;
	КонецЕсли;
	
	Список = Новый СписокЗначений;
	НуженРазделитель = Ложь;
	Если ДобавлятьОтчетыПоНоменклатуре Тогда
		Если РаботаСРолями.ОпределитьПраво("ДоступностьВедомостиПоНоменклатуре") Тогда
			Список.Добавить("ВедомостьПоПартиям_Номенклатура","Ведомость по товару");
			НуженРазделитель = Истина;
		КонецЕсли;
		Если РаботаСРолями.ОпределитьПраво("ДоступностьСпискаДокументовПоНоменклатуре") Тогда
			Список.Добавить("ДокументыПоНоменклатуре_Номенклатура","Документы по номенклатуре");
			НуженРазделитель = Истина;
		КонецЕсли;
		Если РаботаСРолями.ОпределитьПраво("ДоступностьОстатковСерийныхНомеров") Тогда
			Список.Добавить("ОстаткиСерийныхНомеров_Номенклатура","Остатки серийных номеров");
			НуженРазделитель = Истина;
		КонецЕсли;
		Если РаботаСРолями.ОпределитьПраво("ДоступностьИнформацииОЗакупкахНоменклатуры") Тогда
			Список.Добавить("ЗакупочныеЦены_Номенклатура","История закупок");
			НуженРазделитель = Истина;
		КонецЕсли;
		Если РаботаСРолями.ОпределитьПраво("ДоступностьАнализаКомплектующих") Тогда
			Список.Добавить("АнализКомплектующих_Номенклатура","Анализ комплектующих");
			НуженРазделитель = Истина;
		КонецЕсли;
	КонецЕсли;
	
	Если ДобавлятьОтчетыПоКонтрагенту Тогда
		Если НуженРазделитель Тогда
			Список.Добавить("Разделитель1");
			НуженРазделитель = Ложь;
		КонецЕсли;
		Если РаботаСРолями.ОпределитьПраво("ДоступностьИнформацииОКонтрагенте") Тогда
			Список.Добавить("ИнформацияОКонтрагенте_Контрагент","Информация о контрагенте");
			НуженРазделитель = Истина;
		КонецЕсли;
		Если РаботаСРолями.ОпределитьПраво("ДоступностьАктаСверкиПоКонтрагенту") Тогда
			Список.Добавить("АктСверкиПоКонтрагенту_Контрагент","Акт сверки по контрагенту");
			НуженРазделитель = Истина;
		КонецЕсли;
		Если РаботаСРолями.ОпределитьПраво("ДоступностьВедомостиВзаиморасчетовПоКонтрагенту") Тогда
			Список.Добавить("ВедомостьВзаиморасчетовПоКонтрагенту_Контрагент","Ведомость взаиморасчетов по контрагенту");
			НуженРазделитель = Истина;
		КонецЕсли;
		Если РаботаСРолями.ОпределитьПраво("ДоступностьСобытийПоКонтрагенту") Тогда
			Список.Добавить("СобытияПоКонтрагенту_Контрагент","События по контрагенту");
			НуженРазделитель = Истина;
		КонецЕсли;
		Если РаботаСРолями.ОпределитьПраво("ДоступностьДебиторкиПоКонтрагенту") Тогда
			Список.Добавить("ДебиторкаПоКонтрагенту_Контрагент","Дебиторка по контрагенту");
			НуженРазделитель = Истина;
		КонецЕсли;
		Если РаботаСРолями.ОпределитьПраво("ДоступностьДебиторкиПоДоговору") Тогда
			Список.Добавить("ДебиторкаПоКонтрагенту_Договор","Дебиторка по договору");
			НуженРазделитель = Истина;
		КонецЕсли;
	КонецЕсли;
	Если ДобавлятьОтчетыПоДоговору Тогда
		Если НуженРазделитель Тогда
			Список.Добавить("Разделитель2");
			НуженРазделитель = Ложь;
		КонецЕсли;
		Если РаботаСРолями.ОпределитьПраво("ДоступностьАктаСверкиПоДоговору") Тогда
			Список.Добавить("АктСверкиПоДоговору_Договор","Акт сверки по договору");
			НуженРазделитель = Истина;
		КонецЕсли;
		Если РаботаСРолями.ОпределитьПраво("ДоступностьВедомостиВзаиморасчетовПоДоговору") Тогда
			Список.Добавить("ВедомостьВзаиморасчетовПоДоговору_Договор","Ведомость взаиморасчетов по договору");
			НуженРазделитель = Истина;
		КонецЕсли;
	КонецЕсли;
	Если ДобавлятьОтчетыПоСкладу Тогда
		Если НуженРазделитель Тогда
			Список.Добавить("Разделитель3");
			НуженРазделитель = Ложь;
		КонецЕсли;
		Если РаботаСРолями.ОпределитьПраво("ДоступностьВедомостиПоСкладу") Тогда
			Список.Добавить("ВедомостьПоСкладу_Склад","Ведомость по складу");
			НуженРазделитель = Истина;
		КонецЕсли;
	КонецЕсли;
	Если ДобавлятьОтчетыПоКассе Тогда
		Если НуженРазделитель Тогда
			Список.Добавить("Разделитель4");
			НуженРазделитель = Ложь;
		КонецЕсли;
		Если РаботаСРолями.ОпределитьПраво("ДоступностьВедомостиПоКассе") Тогда
			Список.Добавить("ВедомостьПоКассе_Касса","Ведомость по кассе");
			НуженРазделитель = Истина;
		КонецЕсли;
		Если РаботаСРолями.ОпределитьПраво("ДоступностьДвиженияДенежныхСредств") Тогда
			Список.Добавить("ДвиженияДенежныхСредств_Касса","Движения денежных средств");
			НуженРазделитель = Истина;
		КонецЕсли;
	КонецЕсли;
	Если ДобавлятьОтчетыПоЗаказамПоставщикам Тогда
		Если НуженРазделитель Тогда
			Список.Добавить("Разделитель5");
			НуженРазделитель = Ложь;
		КонецЕсли;
		Если РаботаСРолями.ОпределитьПраво("ДоступностьОтчетовПоЗаказамПоставщикам") Тогда
			Список.Добавить("ОтчетПоТекЗаказу_ЗаказПоставщику","Отчет по текущему заказу");
			Список.Добавить("ОтчетПоВсемЗаказам_ЗаказПоставщику","Отчет по незакрытым заказам");
		КонецЕсли;
	КонецЕсли;
	Если ДобавлятьОтчетыПоЗаказамПокупателей Тогда
		Если НуженРазделитель Тогда
			Список.Добавить("Разделитель6");
			НуженРазделитель = Ложь;
		КонецЕсли;
		Если РаботаСРолями.ОпределитьПраво("ДоступностьАнализаЗаказов") Тогда
			Список.Добавить("АнализЗаказов_ЗаказПокупателя","Анализ текущего заказа");
		КонецЕсли;
	КонецЕсли;
	
	Попытка
		КоманднаяПанель.Кнопки.Товары.Текст = "Быстрые отчеты";
	Исключение
		//Сообщить(КоманднаяПанель.Имя);
	КонецПопытки;
	Для Каждого Стр Из Список Цикл
		Если Лев(Стр,11) = "Разделитель" Тогда
			КоманднаяПанель.Кнопки.Товары.Кнопки.Добавить(,ТипКнопкиКоманднойПанели.Разделитель);
			Продолжить;
		КонецЕсли;
		Попытка
			НоваяКнопка = КоманднаяПанель.Кнопки.Товары.Кнопки.Добавить(Стр.Значение,ТипКнопкиКоманднойПанели.Действие,Стр.Представление,Новый Действие("ДействиеПодменюКнопкиТовары"));
		Исключение
			
		КонецПопытки;
	КонецЦикла;
КонецПроцедуры
...Показать Скрыть
4. Кирилл Морозов (Volfy) 21.08.15 11:09
Интересно =) посмотрим что внутри
5. sashajat (sashajat) 19.12.15 08:10
Ошибки при открытии хотя все зааполнено
{ВнешняяОбработка.РабочееМесто.МодульОбъекта(10,32)}: Переменная не определена (мТекущийПользователь)
НовыйДокумент.Ответственный = <<?>>мТекущийПользователь;
{ВнешняяОбработка.РабочееМесто.МодульОбъекта(14,85)}: Переменная не определена (мТекущийПользователь)
НовыйДокумент.Подразделение = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(<<?>>мТекущийПользователь,"ОсновноеПодразделение");
{ВнешняяОбработка.РабочееМесто.МодульОбъекта(15,77)}: Переменная не определена (мТекущийПользователь)
НовыйДокумент.Склад = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(<<?>>мТекущийПользователь,"ОсновнойСклад");
{ВнешняяОбработка.РабочееМесто.МодульОбъекта(22,78)}: Переменная не определена (мТекущийПользователь)
НовыйДокумент.ТипЦен = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(<<?>>мТекущийПользователь,"ОсновнойТипЦенПродажи");
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа