gifts2017

Универсальная загрузка из файла Excel в табличную часть документа

Опубликовал Вадик Лавин (LavinVadik) в раздел Обработки - Обработка документов

Загрузка остатков, инвентаризаций, заявок, требований из произвольных файлов формата Excel.
Загрузка строк из файла Excel, в любой документ конфигурации по выбору, имеющий табличную часть.
Установка на ПК MS Excel не требуется.

Загрузка файла

    возможность настройки загрузки колонок и строк файла по фильтру,

    загрузка всех листов книги

    выбор загружаемых строк

Настройка загрузки

    создание для каждого листа отдельного документа, либо один документ для всех листов книги по выбору 

    предварительный выбор значений для шапки документа

методы загрузки

    поиск по реквизиту или фиксированному значению

    поиск по наименованию,по реквизиту справочника (метод можно использовать только для реквизитов с установленным признаком "Сортировка"), по штрихкоду для справочника «Единицы»

Документы

    вывод реестра созданных документов для последующего редактирования 

    проведение вновь созданных документов по выбору

Функция сохранение настроек загрузки для каждого вида документа конфигурации индивидуально для каждого пользователя

Без пароля.

Возможность редактирования.


Поправил проблему с дробной частью.

Скачать файлы

Наименование Файл Версия Размер
ЗагрузкаИзExcel 13
.ert 211,50Kb
26.02.16
13
.ert 211,50Kb Скачать
ЗагрузкаИзExcelV2 13
.ert 212,00Kb
26.02.16
13
.ert V2 212,00Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

2. Сергей (Che) Коцюра (CheBurator) 12.02.15 01:58
Где синхронизация по подчиненному справочнику АНалоги?
3. Константин Юрин (kostyaomsk) 17.02.15 08:23
Стоит запомнить, раз стали попадаться задачи по 1С 7.7
4. Oleg Sys (olsy) 18.02.15 20:54
Спасибо! Мне понравилось, работает быстро!
5. Makc Saipl (Saipl) 24.02.15 12:20
Спасибо, замечательная обработка.
Пожелание. Сделать возможность заполнять ТЧ существующего документа, т.к. некоторые реквизиты документа проще заполнить из формы документа.
6. Makc Saipl (Saipl) 24.02.15 13:50
Столкнулся с проблемой, в Excell разделитель целого числа "," в 7.7 "." не загружается дробная часть.
7. LavBabay (LavinVadik) 24.02.15 13:56
(5) Saipl, после создание документов если перейти на вкладку "Документы" и щелкнуть на документе,
документ откроется и можно дополнительно заполнить оставшиеся реквизиты.
8. LavBabay (LavinVadik) 24.02.15 13:56
(6) Saipl, полную ошибку можно ? что пишет 1С в окне собщений? и скриншот вкладки "Основной"?
9. Makc Saipl (Saipl) 25.02.15 06:41
(8) LavBabay, 1С Ничего не пишет, просто в документ числа попадают без дробной части.

в 7.7 программировать не умею только в 8.2 но поковырявшись добавил код
ИначеЕсли ТипЗначения(Тип) = 2 Тогда
   Док.УстановитьАтрибут(Идентификатор,СтрЗаменить(текЗначениеРеквизита, ",", "."));	
Иначе
   Док.УстановитьАтрибут(Идентификатор,текЗначениеРеквизита)
КонецЕсли;
...Показать Скрыть


После этого "копейки" загрузились.
10. LavBabay (LavinVadik) 25.02.15 07:41
(9) Saipl, поправил
можно еще так

Если  Тип = "Число" Тогда 
	текЗначениеРеквизита = СтрЗаменить(текЗначениеРеквизита,",",".");
КонецЕсли; 
Док.УстановитьАтрибут(Идентификатор,текЗначениеРеквизита)
...Показать Скрыть
11. Makc Saipl (Saipl) 09.03.15 08:16
Не хватает возможности поиска справочника по владельцу. Загружал документ "Реализация" реквизит "единица измерения" не проставился.
12. Вадик Лавин (LavinVadik) 03.06.15 08:14
(11) Saipl,
В алгоритме предусмотрена возможность поиска по владельцу. В случаи если реквизит в документе не определен для загрузки по номеру колонки, при условии, что вид этого реквизита «Справочник», определяется «Владелец» этого справочника и по реквизитам «Владельца» пытается определить значение для реквизита «Подчиненного». См. код ниже.
	Если Тип = "Справочник" Тогда 
	        Спр = СоздатьОбъект("Справочник."+ Вид);
		текВладелец = ?(Метаданные.Справочник(Вид).Владелец.Выбран()=1,Метаданные.Справочник(Вид).Владелец.Идентификатор,"");
		Если ПустоеЗначение(текВладелец)=0 Тогда
			Для ИндексВладелец=1 По Метаданные.Документ(ВидДок).РеквизитТабличнойЧасти() Цикл
					ИдентификаторВладелец 	= Метаданные.Документ(ВидДок).РеквизитТабличнойЧасти(ИндексВладелец).Идентификатор;
					ТипВладелец 			= Метаданные.Документ(ВидДок).РеквизитТабличнойЧасти(ИндексВладелец).Тип;
					ВидВладелец 			= Метаданные.Документ(ВидДок).РеквизитТабличнойЧасти(ИндексВладелец).Вид;
							
				       Если ВидВладелец = текВладелец Тогда
							
					    ЗначениеВладелец = Док.ПолучитьАтрибут(ИдентификаторВладелец);
								
					    Для ИндексПодч=1 По Метаданные.Справочник(ВидВладелец).Реквизит() Цикл
						ЗначениеПодч	= Метаданные.Справочник(ВидВладелец).Реквизит(ИндексПодч).Идентификатор;
						ТипПодч 		= Метаданные.Справочник(ВидВладелец).Реквизит(ИндексПодч).Тип;
						ВидПодч 		= Метаданные.Справочник(ВидВладелец).Реквизит(ИндексПодч).Вид;
									
						Если  ВидПодч = Вид Тогда
                                                      Док.УстановитьАтрибут(Идентификатор,ЗначениеВладелец.ПолучитьАтрибут(ЗначениеПодч));
						КонецЕсли;
					    КонецЦикла;
								
					Прервать;
				КонецЕсли;
			КонецЦикла;				
		КонецЕсли;
	КонецЕсли;		
...Показать Скрыть


Можно конечно усложнить задачу, осуществлять поиск по наименованию, навешать возможность условий, согласований, но пока не вижу смысла …
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа