gifts2017

Консоль запросов для УФ универсальная 8.3.2.21

Опубликовал Александр Кораблев (akor77) в раздел Программирование - Инструментарий

Реализован программный вызов консоли для захвата "рваного" запроса и параметров. В консоли реализована полная поддержка работы с таблицами значений. Выборочный просмотр пакетов и временных таблиц. Возможность выборочной выгрузки пакета запроса в ТЗ, с последующим её редактированием, сохранением на диск. Использование сохранённой ТЗ в качестве параметра для других запросов. Возможность обхода ТЗ в цикле с выполнением кода. Отсутствуют ошибки при наличии уничтожения временных таблиц. Замер времени выполнения каждого пакета запроса. Приличное окно настройки типа (только для параметров запроса), лёгкое преобразование в список значений и обратно. Поддержка дополнительных типов: ТЗ, Граница, Момент времени, Вид счёта, Вид движения и т.д. Форматирование типа значения при выводе запроса (NULL, пустая ссылка, пустая строка и т.п.). Наверное, самый лучший подбор ширины колонок. Возможность добавлять листы для вывода результатов запросов. Генерируется текст для конфигуратора с учётом количества результирующих пакетов, для каждого пакета можно настроить выборку или выгрузку и пересоздать текст.... Короче, лучше один раз увидеть ...

Окно настройки типа значения.
Установив флаг "Список значений" параметр примет соответствующий тип с учётом ограничения типа указанном в дереве. Например, список из документов двух типов РТиУ и ПТиУ.

Окно вызывается кнопкой "Т" расположенной на командной панели над параметрами запроса.

Установив флаг "Дополнительные типы" откроется таблица, где можно выбрать дополнительно предложенные типы.

Результат запроса можно выгрузить в таблицу значений и делать с ней что потребуется.

Для этого установите флаг "Выгрузить" в соответствующей строке пакета запроса.

Выполните запрос. В результате, жирный шрифт в строке пакета указывает, что таблица выгружена и её можно открыть, нажав на кнопку открытия.

В результате откроется окно с выгруженной таблицей значений.

Таблицу можно сохранить в файл на диске. Ещё это окно вызывается при выборе значения параметра запроса, если у него тип значения равен "Таблица значений".
В это окно можно загрузить файл с диска, можно создать таблицу с нуля с помощью редактора колонок.

Редактирование колонок возможно после нажатия на кнопку "Редактировать колонки".
Откроется табличная часть, где можно изменить имя и тип колонки, добавить новые или удалить ненужные колонки.

ВНИМАНИЕ! Если вы указали в параметре таблицу значений, а таблица пуста, то при открытии формы будет пустое место. Нажмите кнопку "Редактировать колонки" и начинайте создавать новые колонке. В результате появится поле новой таблицы. Или загрузите из файла раннее выгруженную ТЗ.

Данные таблицы значений можно выгрузить в табличную часть справочника, документа, обработки или внешней обработки. Для этого нажмите кнопку "Выгрузить в объект" и в открывшемся окне укажите объект, имя и таблицу. Если будет выбрана внешняя обработка, то путь к файлу внешней обработки указывается в поле "Имя объекта".
В нижней табличной части формы будут выведены колонки "таблицы-приёмника".
Первые две колонки (Колонка таблицы приёмника, Тип колонки приёмника) описывают имя и тип колонок приёмника. В колонке "Колонка источник" необходимо указать из какой колонки-источника выгружать данные. При нажатии на строки приёмника и источника, в противоположной таблице будут выделяться строки жирным шрифтом с совпадающими типами значений.

Кнопка "Заполнить автоматически колонки источника" попытается автоматически подобрать соответствующие поля приёмника и источника.
Теперь можно будет нажать "ОК" и перед вами откроется форма заполненного объекта.

Если редактируемая таблица планируется использоваться в качестве параметра для запроса, то можно получить запрос, который будет обращаться к данной таблице. Для этого достаточно нажать на кнопку "Создать текст запроса к ТЧ". В последствии надо будет сохранить ТЗ в файл на диск. Скопировать созданный текст запроса в буфер обмена. Вернуться в главное окно консоли запросов. Создать новую ветку в дереве запросов. Вставить текст запроса и выйти из текстового поля. Консоль автоматически определит параметр и установит тип значения для параметра "Таблица значений". Нажмите на кнопку выбора значения. В результате откроется пустое окно редактора ТЗ. Загрузите, раннее сохранённую ТЗ из файла и нажмите "ОК".

Результат выгрузки можно обойти в цикле. Примитивные заготовки текста добавляются в текстовое поле "Модуль" при нажатии на кнопки "Цикл" или "Проведение".

Таблица значений будет помещена в переменную "Результат".

На рисунке изображён другой код, он подправлен вручную для добавления комментария элементам справочника. Здесь можно изменить значения в самой ТЗ. Например, можно с помощью редактора колонок создать колонку "Выполнено" с типом "булево" и в "тексте модуля" в теле цикла добавить "Строка.Выполнено = Истина;" (Этот пример на картинке не изображён).

Нажатие на кнопку "Выполнить" вызовет выполнение кода.

Вывод текста запроса для конфигуратора. Если в запросе используются временные таблицы, то будет создана строка с менеджером временных таблиц. Можно задать значение для отображения переменной запроса. Так же можно указать, каким образом вывести результат запроса, выборкой или выгрузкой. Конструктор текста для конфигуратора автоматически определит количество результирующих пакетов и применит выполнение обычного запроса или пакета запросов. Так же будет сформирован обход в цикле каждого результата запроса с выводом полей пакета запроса.

P.S.: Надеюсь, идеи, реализованные в этой консоли, будут полезны. На данном этапе работы над данной консолью стоит задача протестировать и отладить то, что имеется. В ближайших планах, данная консоль будет модернизироваться. Она изначально задумывалась как консоль-функция для управляемых приложений. Те, кто успел поработать с запросами в бухгалтерии 3.0 и столкнулся с кучей временных таблиц, "рваных запросов" и жонглированием с менеджерами временных таблиц поймут, что для анализа подобного "безобразия" необходим специализированный инструмент. Так вот эта консоль как раз и будет вызываться из кода, собирать переданные в неё параметры запроса, тексты запроса, менеджеры временных таблиц из всех кусков рваного запроса и показывать все данные как на блюдце.

Ваша моральная поддержка ускорит этот процесс!

Версия 2.0


Отдельная благодарность h00k за предоставленный универсальный код для платформ 8.2 и 8.3.
Мне очень понравилась идея предложенная пользователем h00k  - создать на панели кнопку проверки текста запроса, это оказалось очень удобно.

Для табличного документа добавлены команды отображения/скрытия заголовков строк и колонок (удобно выделять строку/колонку целиком).
Добавлена кнопка фиксации заголовков и строк таблицы для прокрутки.

Добавлены некоторые типы значений в форме выбора типов.

Поле редактирования запроса заменил на поле текстового документа.
Доработал процедуры комментирования текста.

Часть ошибок запроса выводится не типовым сообщением, а в специальном поле под текстом запроса.

Доработана форма выгрузки в объект.
Форма выбора границы.

В форме для редактирования таблицы значений добавлена кнопка "Уникальный идентификатор" которая выводит текст получения соответствующего значения.

Пока на этом всё. Делитесь впечатлениями и пожеланиями.

Версия 8.3.2.1

Добавлена кнопка выполнения нескольких запросов с одним менеджером временных таблиц. Обход выделенной ветки происходит иерархически.
Удаление выгруженных ТЗ (пакеты) из сохраняемых параметров в системе перед закрытием консоли. Для файла опция не реализована.
Отображение времени выполнения пакета в ТЧ временных таблиц.
Кнопки "скопировать в буфер" и "вставить из буфера" появляются когда функционал доступен.
Новые кнопки для окрашивания фона ячеек табличного документа, шрифта и рамок.
Добавлена кнопка сворачивания и разворачивания групп табличного документа.
Запрос выполняется по F5

Исправлены ошибки при загрузке файла.
Исправлены ошибки при отказе от загрузки файла.
Исправлено отображение ошибки в запросе при нажатии на гиперссылку с описанием ошибки.
Исправлена ошибка при удалении ветки дерева без родителя и др.

Пример программного вызова консоли для захвата "рваного" запроса и параметров.

Сначала создаётся объект обработки:

ВнешниеОбработки.Создать("C:\КонсольЗапросовУФ.epf", Ложь)

Потом вызывается экспортная процедура, в которую передаётся запрос и имя файла.

.ОбработатьВнешнийЗапрос(Запрос, "ИмяФайла");

Новый файл будет сохранён в ту же папку, из которой вызвана консоль.

По умолчанию имя файла = "РезультатыЗапроса".

Файл накапливает результаты вызовов при каждом вызове в новую ветку.

После чего, можно открыть файл в консоли и выполнить эти запросы собранные в одну ветку с использованием общего МВТ.

!!! ЕСЛИ БАЗА ДАННЫХ НАХОДИТСЯ НА СЕРВЕРЕ, ТО УКАЗЫВАЙТЕ ПУТЬ ДОСТУПНЫЙ С СЕРВЕРА !!!

Функция  НашаПроцедура1()

	Запрос = Новый Запрос();
	МВТ = Новый МенеджерВременныхТаблиц;
	Запрос.МенеджерВременныхТаблиц = МВТ;
	
	Запрос.Текст = ПолучетьТекстЗапроса1();
	Запрос.УстановитьПараметр("Ххх", "ххх");
	
	Запрос.Выполнить();
	ВнешниеОбработки.Создать("C:\КонсольЗапросовУФ.epf", Ложь).ОбработатьВнешнийЗапрос(Запрос, "ИмяФайла");
	
	НашаПроцедура2(МВТ);
	
	Запрос.Текст = ПолучетьТекстЗапроса3();

	Запрос.Выполнить();
	ВнешниеОбработки.Создать("C:\КонсольЗапросовУФ.epf", Ложь).ОбработатьВнешнийЗапрос(Запрос, "ИмяФайла");
	
	Возврат НашаФункция(Запрос);

КонецФункции

Процедура НашаПроцедура2(МВТ)

	Запрос = Новый Запрос();
	Запрос.МенеджерВременныхТаблиц = МВТ;
	
	Запрос.Текст = ПолучетьТекстЗапроса2();
	Запрос.УстановитьПараметр("Yyy", "yyy");

	Запрос.Выполнить();
	ВнешниеОбработки.Создать("C:\КонсольЗапросовУФ.epf", Ложь).ОбработатьВнешнийЗапрос(Запрос, "ИмяФайла");
	
КонецПроцедуры

Функция НашаФункция(Запрос)

	Запрос.Текст = ПолучетьТекстЗапроса4();
	Запрос.УстановитьПараметр("Zzz", "zzz");

	ВнешниеОбработки.Создать("C:\КонсольЗапросовУФ.epf", Ложь).ОбработатьВнешнийЗапрос(Запрос, "ИмяФайла");
	Возврат Запрос.Выполнить();
	
КонецФункции.

Версия 8.3.2.2

Сохраняются тексты модулей.
Добавлена кнопка выполнения кода модуля из командной панели таблицы пакетов.
Отображение количества строк в таблице пакетов и в заголовке пакета табличного документа.
В табличный документ не выводится заголовки пакетов для которых не установлен флаг "Показать результат".
Добавлены кнопки на форму для управления видимостью элементов.
Задаётся вопрос перед закрытием формы.

Версия 8.3.2.3

Добавлено дерево функций языка запросов. Поддерживается перетаскивание мышью.
Закомментировать - Ctrl+Num /
Убрать комментарий - Ctrl+Shift+Num /
Запрос проверяется не всегда, а только по кнопке или вызовом по грячим клавишам, смене ветки запроса.

Решена проблема сохранением дерева запросов и их параметров. (по крайней мере на моих тестовых базах).

Исправлена ошибка после нажатия "Вывод текста запроса".


Версия 8.3.2.4

Не выкладывал, т.к. обнаружил кучу ошибок.

Версия 8.3.2.5

Добавлена команда для открытия 'файла дерева запроса' указав путь c 'сервера приложения'.
Поиск текста в табличном документе.
Команда для просмотра предопределённых значений. Она удобна для просмотра бухгалтерских счетов, узнать номер. Требуется редко, но "дорога ложка к обеду".
Свернуть/развернуть результат - Ctrl + R
Свернуть/развернуть текст запроса - Ctrl + T
Кнопки для свернуть/развернуть ТД и ТЧ перенёс на командную панель ДЗ.
Пока убрал видимость кнопки 'Свернуть/развернуть параметры'.
Исправление ошибок
Открытие 'Дерева запросов' и сохранение реализовано через хранилище.
Загрузка 'Таблиц значений' и сохранение реализовано через хранилище.
Исправлена ошибка в 8.2 возникающая при окрашивании ячеек/текста/границ





Версия 8.3.2.6


В окне выбора файла на 'сервере приложения' добавлено 'дерево каталогов'.

Доработки сделанные пользователем h00k:
В окне генерации текста модуля добавлена опция "Проверить результат запроса".
В окне генерации текста модуля в ТЧ добавлена колонка "Итератор" для обозначения переменной итератора при обходе выгрузки.
Добавлена функция авторегистрации внешней обработки.

Отдельное спасибо пользователю dj_serega за тестирование и подсказки.

Версия 8.3.2.7




В окне функций добавлены новые заготовки.
Добавлена форма для получения предопределенных значений или имён объектов:
- Справочники,
- Документы,
- Перечисления,
- Планы видов характеристик,
- Планы счетов,
- Планы видов расчёта,
- Бизнес-процессы
- Задачи.

1. Выделить замещаемый текст,
2. Нажать на кнопку "Получить предопределённое значение",
3. Заполнить поля открывшегося диалогового окна.
4. Нажать "ОК".

Исправлена ошибка:
Перед выполнением запроса применяются изменения сделанные вручную.

В 

ВЕРСИЯ 8.3.2.8


Добавлены кнопки:

  • - Сохранение в Excel,
  • - Удаление страницы (первая страница не удаляется!).

Исправлены ошибки:

  • - 138. dj_serega. Внёс все предложенные исправления.
  • - 142. StepByStep. {Форма.ФормаТаблицаЗначений.Форма(251,9)} Переименовал ПолучитьФайл(), в ПолучитьФайл_()
  • - 139. klinval. Если удалить неиспользуемый параметр через Del, то он "возвращается" после изменения запроса. Удаление через кнопку работает корректно.
  • - 133. sommid . Доработана очистка параметров запроса, теперь система не падает.
  • - Очистка параметров при удалении ветки в дереве запросов.
  • - И некоторые другие ошибки.




ВЕРСИЯ 8.3.2.9

Релиз содержит обновление от tristarr1:

  • В параметр можно подставить любое значение получаемое произвольным исполняемым кодом. Значение присваивается пременной "Параметр".



ВЕРСИЯ 8.3.2.10

Исправлены ошибки:

  • 156. tristarr1 Значение Параметра с типом "Граница" не преобразуется в пустую дату при выполнении запроса.
  • 160. dj_serega Корректно работает табличное поле "Временные таблицы" при попытке просмотреть выгруженную таблицу.

ВЕРСИЯ 8.3.2.11

Вывод вложеных результатов запроса из табличного документа.

Модификация от dj_serega: В форме выбора предопределённых элементов добавлен флаг "ЗНАЧЕНИЕ(<...>).

Исправление ошибок:

  • 165 snikers44 Устранена ошибка при выводе в табличный документ результата запроса.
  • dj_serega исправил ошибку - "дата без времени в параметрах".

ВЕРСИЯ 8.3.2.12

Модификации:

  • Поддержка английского синтаксиса.
  • Перевод Ру-En и En-Ру. Коструктор запроса всегда возвращает синтасис на русском.

ВЕРСИЯ 8.3.2.13

Модификация от tristarr1: оптимизоравно открытие формы выбора типа.

Исправлен ряд ошибок связанных с формой выбора типа.

ВЕРСИЯ 8.3.2.14

Изменена форма выбора типа.

При выборе "Выражение параметра" текстовое поле заполняется шаблоном текста.

Добавлена простая панель редактирования.

Исправлены некоторые ошибки связанные с изменением типа параметра при выполнении/проверке запроса.

ВЕРСИЯ 8.3.2.15

Исправлены ошибки в форме генерации текста для модуля с вязанные с использованием английского синтаксиса и с вложенными запросами в полях запроса.

ВЕРСИЯ 8.3.2.16

Исправление ошибок при изменении 'типа значения' параметров плавно перерасло в принципиальную переделку самого механизма.

Добавлена примитивная проверка в тексте 'выражения параметра', проверка смотрит, есть ли в 'выражении парамера' имена испоьзуемых переменных.

ВЕРСИЯ 8.3.2.17


Доработки:
1. При нулевом значении вместо пустой ячейки отображается: "<0>".

2. Новая команда "Создать код установки значений переменным параметров".
В 

Откроется окно с таким текстом:

3. Добавлены два шаблона кода для обработки в цикле результатов выгрузки в таблицу:
    

а. "Создать текст получения уникального идентификатора + добавить колонку в ТЗ".
   

б. "Создать текст обработки движений регистра бухгалтерии".
В 


Исправлены ошибки:
1. При создании текста запроса удалены лишние кавычки.
2. Сохраняется текст модуля в форме "Работа с таблицей значений".

ВЕРСИЯ 8.3.2.18

 Исправлена ошибка возникающая при режиме совместимости конфигурации не равном значению "Не использовать". При некоторых режимах совместимости не работает функция СтрНайти(,).

ВЕРСИЯ 8.3.2.19

 Исправлена ошибка при открытии формы генерации текста для модуля.

ВЕРСИЯ 8.3.2.20

 Добавлена возможность выгружать/загружать данные через XML.

 Значение сериализуется процедурой -

 ЗаписатьXML(<ЗаписьXML>, <Значение>, <НазначениеТипа>)

 

ВЕРСИЯ 8.3.2.21

1. Исправлена ошибка при закрытии консоли в WEB-клиенте (dj_serega).
2. Если в тексте запроса были одни временные таблицы без пакетов с результатами, то при нажатии на кнопку "Вывод текста запроса" не открывалась форма "Текст для модуля".
3. В командную панель дерева запросов добавлена кнопка "Открыть редактор таблиц значений", иногда требуется поработать с выгруженной ТЗ на прямую.
4. Исправлено форматирование типа Булево при выводе результата запроса в табличный документ. Значение ложь отображалось как "<0>", теперь "Нет".


________________________________________________________________________________________________________________________________________________
P.S.: Просьба. При обнаружении ошибок указывать релиз консоли, версию платформы, режимы модальности и синхронных вызовов,
т.к. не получается воспроизвести некоторые из указанных ошибок.

Скачать файлы

Наименование Файл Версия Размер
Консоль запросов для УФ 8.3.2.21 1857
.epf 130,38Kb
23.08.16
1857
.epf 8.3.2.21 130,38Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Константин Юрин (kostyaomsk) 12.03.15 06:40
Маленький вопрос по первоисточникам, наработками этой консоли. Что взято за основу? Я всегда честно указываю источники. Даже уже не с целью авторства, а с целью функционала - какой она наследует функционал, а, главное, глюки?
Консолей то миллион. Мне даже для себя эти приходится дорабатывать. Особенно чтоб поля <NULL> и <Неопределено>, <ПустаяХарактеристика> и прочее в той же опере где лучше 1 раз увидеть.
2. Александр Кораблев (akor77) 12.03.15 07:19
(1) kostyaomsk, за основу взята моя прежняя разработка: http://infostart.ru/public/175229/

Заимствования со стороны:
1. Раскраску кода заимствовал из одной консоли, она раскрашивала строки таблицы значений при выводе сроки.
2. Идею обхода выгруженной табличной части в цикле подсказал коллега.
shalimski; +1 Ответить
3. Александр Кораблев (akor77) 12.03.15 07:29
(1) kostyaomsk, Про глюки. Данная консоль унаследовала лишь часть функционала от "предшественницы". Консоль писалась заново с использовоанием части раннее созданных форм, алгоритмов. так называемое "ядро" переписано заново с учётом накопленного опыта прежних ошибок. Воя я уже сам нашёл недочёт - не все типы значений в ФормаВыбораТипа. В обработчик "ПриСозданииНаСервере" надо добавить строки:
ВывестиКоллекцию(Дерево, "ПланыСчетов" , "ПланСчетов");
ВывестиКоллекцию(Дерево, "ПланыВидовРасчета" , "ПланВидовРасчета");
ВывестиКоллекцию(Дерево, "БизнесПроцессы" , "БизнесПроцесс");
ВывестиКоллекцию(Дерево, "Задачи" , "Задача");
kostyaomsk; +1 Ответить 3
4. Илья Коротков (molodoi1sneg) 12.03.15 07:40
5. Allexey (alex_4x) 12.03.15 10:15
Радует подробная инструкция. Прям красотищща :-)
Oleg_nsk; fzt; JesteR; Quasar; veretennikoff; dj_serega; klaus38; TrinitronOTV; tormozit; h00k; spetzpozh; +11 Ответить
6. Vadim Петров (Vadim75) 12.03.15 16:13
Спасибо за консоль! Плюс однозначно.
7. Андрей (h00k) 12.03.15 16:31
(3)
Не помню когда последний раз запускал толстый клиент УФ, поэтому изменил код процедур открытия конструктора запросов под тонкий клиент:
&НаКлиенте
Процедура КонструкторЗапроса(Команда)
	
	ТекущиеДанные = Элементы.ДеревоЗапросов.ТекущиеДанные;
	
	Если ТекущиеДанные = Неопределено Тогда
	
		Предупреждение("Выберите строку дерева запросов!");
		Возврат;
	КонецЕсли;

	ТекДанныеДерева = Элементы.ДеревоЗапросов.ТекущиеДанные;
	Если ТекДанныеДерева = Неопределено Тогда
		
		Предупреждение("Не выбрана строка в дереве запросов!");
		Возврат;
	КонецЕсли;
	Текст = СокрЛП(ТекДанныеДерева.Текст);
	
	Попытка
		
		КонструкторЗапроса = Новый КонструкторЗапроса(Текст);		
		КонструкторЗапроса.Показать(Новый ОписаниеОповещения("ПослеРедактированияЗапроса", ЭтотОбъект, ТекДанныеДерева));
		
	Исключение
		ОписаниеОшибки = ОписаниеОшибки();
		Сообщить(ОписаниеОшибки());
		Предупреждение(ОписаниеОшибки());
	КонецПопытки;

КонецПроцедуры

&НаКлиенте
Процедура ПослеРедактированияЗапроса(Текст, ЭлементДерева) Экспорт
		Если Не ПустаяСтрока(Текст) Тогда
			ЭлементДерева.Текст = Текст;
			ПроверитьТекстЗапроса_ПолучитьПараметры_ОбновитьДанные();
		Иначе
			Модифицированность = Ложь;
		КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура РедактироватьВыделенныйПакет(Команда)
	
	Текст = Элементы.ДеревоЗапросовТекст.ВыделенныйТекст;
	Если ПустаяСтрока(Текст) Тогда
	
		Предупреждение("Не выделен пакет запроса для редактирования!");
		Возврат;	
	КонецЕсли;
	
	Попытка
		
		КонструкторЗапроса = Новый КонструкторЗапроса(Текст);
		КонструкторЗапроса.Показать(Новый ОписаниеОповещения("ПослеРедактированияПакета", ЭтотОбъект, Текст));
	Исключение
		ОписаниеОшибки = ОписаниеОшибки();
		Сообщить(ОписаниеОшибки());
		Предупреждение(ОписаниеОшибки());
	КонецПопытки;
	
КонецПроцедуры

&НаКлиенте
Процедура ПослеРедактированияПакета(Текст, СтарыйТекст) Экспорт
		Если НЕ ПустаяСтрока(Текст) Тогда
			Элементы.ДеревоЗапросов.ТекущиеДанные.Текст = СтрЗаменить(Элементы.ДеревоЗапросов.ТекущиеДанные.Текст, СтарыйТекст, Текст);
			ПроверитьТекстЗапроса_ПолучитьПараметры_ОбновитьДанные();
		Иначе
			Модифицированность = Ложь;
		КонецЕсли;
КонецПроцедуры
...Показать Скрыть


соответственно код работает в 8.3.5 и выше.
По хорошему обрабатывать открытие конструктора нужно в зависимости от версии платформы, но у меня платформ ниже 8.3.5 нет, поэтому проверку не стал добавлять.

Полезную процедуру ПроверитьТекстЗапроса_ПолучитьПараметры_ОбновитьДанные стоит добавить в качестве кнопки по умолчанию.
&НаКлиенте
Процедура ПроверитьЗапрос(Команда)
	ПроверитьТекстЗапроса_ПолучитьПараметры_ОбновитьДанные();
КонецПроцедуры
...Показать Скрыть

Тогда процесс написания/ корректировки запроса руками становится гораздо комфортнее.
rpgshnik; creatermc; akor77; kostyaomsk; HitGroove; +5 Ответить 3
8. Aleksey (HitGroove) 12.03.15 17:00
9. Андрей (h00k) 12.03.15 17:36
(3)akor77 Из того чего явно не хватает в этой консоли - получение плана запроса, ну и возможно вывода GUID для ссылочных данных.
10. Сергей Галюк (dj_serega) 12.03.15 19:01
Не смог Не скачать. Очень удобно (с виду).
Надеюсь запросник 8.3 уйдет в прошлое :)

Поспешил. Не работает в тонком клиенте :( Допиливать себе или ждать релиза 2.0?
11. Александр Кораблев (akor77) 12.03.15 20:00
(7) h00k, Обязательно учту пожелания. А тобой предложенный код используется в конфигурациях где нет поддержки модальных окон в Такси. В тонком клиенте на 8.2 он не будет работать.
12. Александр Кораблев (akor77) 12.03.15 20:07
(10) dj_serega,
В тонком клиенте конструктор запроса работает только на платформе с версии 8.3.5 и выше.

В толстом клиенте конструктор запроса работает, но не работает в конфигурациях с интерфейсом - Такси где нет поддержки модальных окон.

Для Такси (без поддержки модальных окон) буду делать отдельную версию.
но она не будет работать в 8.2 ни в толстом ни в тонком клиентах.

13. Сергей Галюк (dj_serega) 12.03.15 22:17
(12) akor77,
В тонком клиенте конструктор запроса работает только на платформе с версии 8.3.5 и выше.

У меня: 8.3.5. Тонкий клиент. Такси. Модальность - Использовать.

В толстом клиенте конструктор запроса работает, но не работает в конфигурациях с интерфейсом - Такси где нет поддержки модальных окон.

Так вот и предлагаю реализовать конструктор для тонкого. Там же пара строчек кода ;)

Для Такси (без поддержки модальных окон) буду делать отдельную версию.
но она не будет работать в 8.2 ни в толстом ни в тонком клиентах.

8.3 не только под такси может работать. У нас половина пользователей на обычных управляемых, другая половина на такси.
14. Андрей (h00k) 13.03.15 00:16
(10)dj_serega
Поспешил. Не работает в тонком клиенте

Для 8.3.5 решение в сообщении (7), чуть ниже добавлю универсальное решение.

(11)akor77
В тонком клиенте на 8.2 он не будет работать.

Знаю, в свое время делал пример консоли на управляемых формах, в которой можно было запускать конструктор запросов.

(12)akor77
Для Такси (без поддержки модальных окон) буду делать отдельную версию.
но она не будет работать в 8.2 ни в толстом ни в тонком клиентах.

Зачем?! Лучше сделать одну универсальную, чем 10 под разные платформы...
15. Андрей (h00k) 13.03.15 00:39
(11)akor77, Вот этот вариант работает и в 8.2.19 и в 8.3.6
&НаКлиенте
Процедура КонструкторЗапроса(Команда)
	
	#Если НЕ ТолстыйКлиентУправляемоеПриложение Тогда
	Если ВерсияПлатформыНиже835() Тогда
		Сообщить("Внимание! Данная версия клиента платформы 1С: Предприятие 
		| не поддерживает запуск конструктора запросов.");
		Возврат;
	КонецЕсли;
	#КонецЕсли

	ТекущиеДанные = Элементы.ДеревоЗапросов.ТекущиеДанные;
	Если ТекущиеДанные = Неопределено Тогда
	
		Предупреждение("Выберите строку дерева запросов!");
		Возврат;
	КонецЕсли;

	Текст = СокрЛП(ТекущиеДанные.Текст);
	
	КодПрограммы = "
	|КонструкторЗапроса = Новый КонструкторЗапроса;
	|Если Не ПустаяСтрока(Текст) Тогда
	|		КонструкторЗапроса.Текст = Текст;
	|КонецЕсли;
	|";
		
	#Если ТолстыйКлиентУправляемоеПриложение Тогда
	Попытка
		
		КодПрограммы = КодПрограммы+ "
		|КонструкторЗапроса.АвтоДобавлениеПредставлений = ТекущиеДанные.АвтоДобавлениеПредставлений;
		|КонструкторЗапроса.РежимКомпоновкиДанных		= ТекущиеДанные.РежимКомпоновкиДанных;
		|
		|Если КонструкторЗапроса.ОткрытьМодально() Тогда
		|	ТекущиеДанные.Текст = КонструкторЗапроса.Текст;
		|	ПроверитьТекстЗапроса_ПолучитьПараметры_ОбновитьДанные();
		|КонецЕсли;
		|";
		Выполнить(КодПрограммы);
	Исключение
		ОписаниеОшибки = ОписаниеОшибки();
		Сообщить(ОписаниеОшибки());
		Предупреждение(ОписаниеОшибки());
	КонецПопытки;
	
	#Иначе
		
	Попытка
		
		КодПрограммы = КодПрограммы+ "
		|КонструкторЗапроса.Показать(Новый ОписаниеОповещения(""ПослеРедактированияЗапроса"", ЭтотОбъект, ТекДанныеДерева));
		|";
		Выполнить(КодПрограммы);
	Исключение
		ОписаниеОшибки = ОписаниеОшибки();
		Сообщить(ОписаниеОшибки());
		Предупреждение(ОписаниеОшибки());
	КонецПопытки;
	#КонецЕсли

КонецПроцедуры


&НаКлиенте
Процедура ПослеРедактированияЗапроса(Текст, ЭлементДерева) Экспорт
		Если Не ПустаяСтрока(Текст) Тогда
			ЭлементДерева.Текст = Текст;
			ПроверитьТекстЗапроса_ПолучитьПараметры_ОбновитьДанные();
		Иначе
			Модифицированность = Ложь;
		КонецЕсли;
КонецПроцедуры


&НаСервереБезКонтекста
Функция ВерсияПлатформыНиже835()
	
	лРезультат = СравнениеСТекущейВерсией("8.3.5.1068");
	
	Возврат ?(лРезультат = -1, Истина, Ложь);	
КонецФункции // ВерсияПлатформыНиже835()

	

&НаКлиенте
Процедура РедактироватьВыделенныйПакет(Команда)
	
	#Если НЕ ТолстыйКлиентУправляемоеПриложение Тогда
	Если ВерсияПлатформыНиже835() Тогда
		Сообщить("Внимание! Данная версия клиента платформы 1С: Предприятие 
		| не поддерживает запуск конструктора запросов.");
		Возврат;
	КонецЕсли;
	#КонецЕсли

	Текст = Элементы.ДеревоЗапросовТекст.ВыделенныйТекст;
	Если ПустаяСтрока(Текст) Тогда
	
		Предупреждение("Не выделен пакет запроса для редактирования!");
		Возврат;	
	КонецЕсли;
	КодПрограммы = "
	|КонструкторЗапроса = Новый КонструкторЗапроса(Текст);
	|";
	
	#Если ТолстыйКлиентУправляемоеПриложение Тогда
	Попытка
		КодПрограммы = КодПрограммы+ "
		|КонструкторЗапроса.АвтоДобавлениеПредставлений = Ложь;
		|КонструкторЗапроса.РежимКомпоновкиДанных = Ложь;

		|Если КонструкторЗапроса.ОткрытьМодально() Тогда
		|	Текст = КонструкторЗапроса.Текст;
		|	Элементы.ДеревоЗапросовТекст.ВыделенныйТекст = Текст;
		|КонецЕсли;
		|";
		
		Выполнить(КодПрограммы);	
	Исключение
		ОписаниеОшибки = ОписаниеОшибки();
		Сообщить(ОписаниеОшибки());
		Предупреждение(ОписаниеОшибки());
	КонецПопытки;
	
	#Иначе
		
	Попытка
		
		КодПрограммы = КодПрограммы+ "
		|КонструкторЗапроса.Показать(Новый ОписаниеОповещения(""ПослеРедактированияПакета"", ЭтотОбъект, Текст));
		|";
		Выполнить(КодПрограммы);
	Исключение
		ОписаниеОшибки = ОписаниеОшибки();
		Сообщить(ОписаниеОшибки());
		Предупреждение(ОписаниеОшибки());
	КонецПопытки;
	#КонецЕсли
	
КонецПроцедуры

&НаКлиенте
Процедура ПослеРедактированияПакета(Текст, СтарыйТекст) Экспорт
		Если НЕ ПустаяСтрока(Текст) Тогда
			Элементы.ДеревоЗапросов.ТекущиеДанные.Текст = СтрЗаменить(Элементы.ДеревоЗапросов.ТекущиеДанные.Текст, СтарыйТекст, Текст);
			ПроверитьТекстЗапроса_ПолучитьПараметры_ОбновитьДанные();
		Иначе
			Модифицированность = Ложь;
		КонецЕсли;
КонецПроцедуры
...Показать Скрыть

Конструктор запросов работает и в толстом клиенте, и, если версия платформы 8.3.5 или выше, то и в тонком и в веб-клиентах.
В общем, если заменить код соответствующих процедур, то получится вполне себе универсальная консоль.

П.С.: В функции СравнениеСТекущейВерсией(ВерсияДляСравнения)
строка
ВерсияДляСравнения = "8.3.5.823";
лишняя, она нивелирует передаваемый параметр.
16. Сергей Галюк (dj_serega) 13.03.15 00:56
(14) h00k,
Для 8.3.5 решение в сообщении (7), чуть ниже добавлю универсальное решение.
Так я ж говорю: для себя писать или ждать релиза :)
17. Андрей (h00k) 13.03.15 01:34
(12)akor77
Для Такси (без поддержки модальных окон) буду делать отдельную версию.

Кстати, я понимаю там конструктор запросов, а для остальных то окон зачем было делать модальный вызов? Обычная команда
ОткрытьФорму
вполне себе неплохо работает.
18. Андрей (h00k) 13.03.15 02:04
(16) dj_serega, можно и не писать. Мою переделку из (15) скопипасть и будет то что нужно.
Правда еще стоит пройтись по модулям и заменить ОткрытьФормуМодально на ОткрытьФорму ну и настроить контекстное меню в табличных полях, но это уже дело вкуса.
19. Александр Кораблев (akor77) 13.03.15 04:11
(18) h00k, Ок, на выходных сделаю.
20. Александр Кораблев (akor77) 14.03.15 15:52
Файл для скачивания обновлён.
21. Сергей Галюк (dj_serega) 15.03.15 18:25
(20) akor77, Спасибо! Теперь попробуем применить на практике.
22. Александр Кораблев (akor77) 15.03.15 18:37
(21) dj_serega, Это хорошо! Жду результатов теста. Одну ошибку в версии 2.0 я уже нашёл. Но она мелкая и её легко устранить. Жду отзывов. К стати. Я уже сделал первый вариант для вызова консоли из файла на диске при отладке и собирать данные о "рваных" запросах, которве в БП и ЗУПе на УФ. На неделе буду тестировать. Надеюсь, что к выходным будет новая версия.
23. olga pt (pt_olga) 16.03.15 12:41
скачала, вещь полезная
только не разобралась пока, как результирующюю таблицу сохранить в эксель

подскажете?
24. Александр Кораблев (akor77) 16.03.15 16:46
(23) pt_olga, Пока только "копи-пастом". В следующем релизе "прикручу" кнопку.
25. Сергей Галюк (dj_serega) 17.03.15 17:49
(22) akor77,
1. Сделать вопрос перед закрытием консольки (естественно учитывая модальность).

2. Опционально выводить или не выводить результат вычисления временных таблиц:
Сейчас в результате:
втСвернуто (0,019 мс.)
втПолный (0,151 мс.)
Результат1 (0,004 мс.)

Предлагаю так изменить ТЧ ВременыеТаблицы:
Пакет, Показать, Выгрузить, ОтобразитьВремяВыполнения, ОтобразитьКоличествоСтрок.

3. Добавить кнопки на форму для:
а) Управление видимостью левой панели (Дерево запросов, Параметры, Временные таблицы)
б) Управление видимостью Текста запроса
в) Управление видимостью результатов

4. Как-то не логичное наличие кнопок "скопировать в буфер" и "вставить из буфера" если после нажатия пишет "на сервере не доступно". Может как-то можно управлять их видимостью?

5. Не сохраняет и не загружает запросы :(
{Форма.Форма.Форма(1334)}: Ошибка при вызове метода контекста (НайтиПоИдентификатору)
ТекущаяСтрока = ДеревоЗапросов.НайтиПоИдентификатору(Элементы.ДеревоЗапросов.ТекущаяСтрока);
по причине:
Несоответствие типов (параметр номер '1')

Я бы проверку так написал:
	ТекущаяСтрокаДереваЗапросов = Элементы.ДеревоЗапросов.ТекущаяСтрока;
	Если ТекущаяСтрокаДереваЗапросов = Неопределено Тогда
		Возврат;
	КонецЕсли;
	
	ТекущаяСтрока = ДеревоЗапросов.НайтиПоИдентификатору(ТекущаяСтрокаДереваЗапросов);
...Показать Скрыть

Может еще где встречается не смотрел. Но лучше "понатыкивать" таких проверок везде :)

6. Кнопочка "Добавить" страницу результата есть, а удалить нет :|


Пока всё :)

upd: А так консолько порадовало. Спасибо огромное. Буду писать тут о найденных "фичах" и пожелалках.
26. Александр Кораблев (akor77) 17.03.15 19:12
(25) dj_serega, Отлично, спасибо огромное. Буду править. У меня ещё появилась парочка новых идей. Так что интересное ещё впереди!
27. Игорь Дремов (Hitcher) 18.03.15 09:20
(20) akor77,
А можно навести порядок в версиях? Чтобы не просто слова "Файл для скачивания обновлён. ", а какая теперь стала версия.
Желательно с описанием.
И чтобы скачивающий видел не просто надпись "Консоль запросов для УФ 8.2, 8.3" а какая это версия. И мог сравнить со своей версией. И принять решение.

Описания версий можно взять из системы стандартов 1с

Нумерация редакций и версий

1. Номер очередной редакции конфигурации, начинается со следующего целого номера относительно предыдущей редакции. Для обозначения редакции обычно номер редакции объединяют через точку с номером подредакции, например: редакция 1.5, редакция 1.6 и т. д. Для новых конфигураций нумерация начинается с 1.0.

2. Все версии одной подредакции (включая альфа, ознакомительные, бета и финальные версии) нумеруются подряд. Нумерация версий начинается с 1.

3. Информация о номере редакции, номере подредакции и номере версии объединяются в полный номер версии конфигурации. Он указывается в свойстве Версия конфигурации и представляет собой строку символов следующего вида:

{Р|РР}.{П|ПП}.{З|ЗЗ}.{С|СС}

где:
Р - номер редакции (минимум 1 цифра, может занимать и больше разрядов);
П - номер подредакции (минимум 1 цифра, может занимать и больше разрядов);
З - номер версии (минимум 1 цифра, может занимать и больше разрядов);
С - номер сборки (минимум 1 цифра, может занимать и больше разрядов).

Пример:

1.6.4.7 – 7-я сборка, 4-ой версии, редакции 1.6



28. al petrov (petrov_al) 18.03.15 10:41
Все хорошо, но боюсь не буду использовать и половины всех возможностей или очень редко...
29. Сергей Галюк (dj_serega) 18.03.15 12:06
(26) akor77, 1. Нет возможности работать с временными таблицами. Пример можно взять с "Запросник 1.0 (оф) и 2.0 (на уф)".
30. Антон Стеклов (asved.ru) 18.03.15 12:16
Выглядит замечательно. Шикарно, если запрос будет выполняться по F5.
31. Веселов Александр (aves) 18.03.15 12:18
Не сохраняются тексты обработки модулей для выгруженных таблиц. Очень надо.
Хотя сами таблицы сохраняются. Не уверен зачем, но иногда пригодиться может. Тут хотелось бы опцию - чтобы не перегружать сохраняемый файл.

Объясню зачем:
Часто консоль используется не только для получения какого либо результата, но и как достаточно универсальный инструмент обработки данных, где сначала выбирается результат (например ошибки в базе), а затем идет обработка на его исправление.
У меня в консоли для обычных форм есть дерево порядка с 20-30 запросами и обработками для них. Писать для каждого случая внешние обработки было бы неудобно, да и текст запроса там был бы не виден (т.е. управляемость ущербная).

И раз такие пожелания, добавьте новую кнопку рядом со сформировать (Выгрузить результат в ТЗ). для действий аналогичному установке галке в последней строке и открытии таблицы результата. В 99% случаев именно это требуется для обработок БД.
32. poyson (poyson) 18.03.15 13:34
пасибо. подробно. попробуем...
33. Александр Хоменко (scape) 18.03.15 13:54
При отказе от загрузки дерева запросов (кнопка почему то называется "открыть дерево запросов") выдает ошибку и... дальше никак, только убивать программу через диспетчер.
34. Александра Безгодова (ab471vi) 18.03.15 14:01
Скачала, будем пробовать! Отдельное спасибо за отличную инструкцию)
35. Сергей Галюк (dj_serega) 18.03.15 14:45
(30) asved.ru,
Шикарно, если запрос будет выполняться по F5.

Я бы повесил на ctrl+enter. Мне, например, это удобней ;) Я привык документы проводить по этому типовому сочетанию. Так же записывать справочники и тд.
(33) scape, Я это у себя поправил (25), надеюсь разработчик внесет в релиз.

Следующие пожелалки:
1. В результирующем табличном поле выравнивать не только по значению, но и иметь возможность выравнивать по заголовку. Бывает что в колонке нет данных, и не видно как называется колонка. Приходится наводить мышкой на колонку. А если таких много, то неудобно.
2. А можно в параметрах флаг "Список значений" вынести на форму списка параметров (и сделать там кнопку "СписокЗначений". Где Кнопка.Пометка = Истина если СЗ или ложь если это ссылка). Сейчас приходится входить в изменение типа, ставить флаг, закрывать форму.
3. Некорректно отображается ошибка в запросе.
Проверка пишет одно. А вход в конструктор запроса другое.
4. Все модальные окна открывать с блокированием владельца (тоесть консольки). Сейчас выполняется блокировка всего интерфейса.
Прикрепленные файлы:
36. Александр Кораблев (akor77) 18.03.15 17:04
(25) dj_serega, Принял к сведению. Буду делать.
37. Александр Кораблев (akor77) 18.03.15 17:12
(27) Hitcher, Понял, буду указывать версию в названии. Для консоли может будет вполне достаточно номера версии и сборки? Никак не могу представить необходимость редакции и подредакции. Если делать 8.3.Х.Х, то не отражается 8.2, если сделать 8.2-8.3.Х.Х - это коряво всмотрится. Хотя, 8.3.Х.Х мне начинает нравиться.
Тогда сейчас выложена версия 8.3.2.0
Все согласны с такой нумерацией версий?
38. Александр Кораблев (akor77) 18.03.15 17:14
(29) dj_serega, Не могу понять что именно требуется? Это про "Нет возможности работать с временными таблицами"
39. Александр Кораблев (akor77) 18.03.15 17:16
(30) asved.ru, Горячие клавиши надо обсудить вместе.
F5 - выполнение запроса
Ctrl + Enter - проверка на ошибки
Пойдёт?
40. Александр Кораблев (akor77) 18.03.15 17:18
(31) aves, Отличные пожелания! Мне очень нравятся предложенные идеи. Функционал становится богаче. Сделаю.
41. Александр Кораблев (akor77) 18.03.15 17:25
(35) dj_serega, Идея про "список значений" мне тоже понравилась.
А про ширину колонок, это всё по разному. Бывает булево с широченным названием колонки.
Но буду иметь в виду.
А для изменения ширины колонки нажми кнопку которая следующая за "Выполнить запрос" (зелёного карандаша) , там мышкой наведи на правую границу ячейки, курсор изменится и в этот момент кликни 2 раза. Ширина автоматом выравняется по самому широкому значению колонки.
42. Сергей Галюк (dj_serega) 18.03.15 19:36
(38) akor77, Запрос первой строки дерева: "Выбрать Поле1 Поместить втПервыйЗапрос Из Справочник.ТМЦ КАК ТМЦ".
Добавляем подчиненную строку.
В ней пишем: "Выбрать * из втПервыйЗапрос КАК втПервыйЗапрос ГДЕ Поле1 = &Параметр1".
В результате должна получиться таблица из родителя строки но с условием.
Сейчас подчиненная строка не видит временные таблицы родителя. Ну или я не так выполнил запрос.
Если нужно могу со скринами объяснить.

(40) akor77, И про дерево не забыть ;)

(41) akor77,
там мышкой наведи на правую границу ячейки,

Да. Но если колонок 10 то нужно на каждую так делать. В принципе это не горит, и сильно не мешает. Предлагаю добавить в самый конец списка доработок ;)

Пожелалки/фичи:
1. Результат не выгружается в виде дерева
2. Нужно изменить логику проверки корректности текста запроса. Нужно проверять не всегда, а только по кнопке. Я очень часто редактирую текст запроса в ручную. Обычно выполняется лишняя проверка при ctrl+v. Также при удалении части текста запроса.
3. Не забыть решить проблемку сохранением дерева запросов и их параметров.
4. После нажатия "Вывод текста запроса" получаю ошибку: "Задано неправильное имя атрибута стркутуры".
43. Александр Кораблев (akor77) 18.03.15 20:04
(42) dj_serega, На счёт "Сейчас подчиненная строка не видит временные таблицы родителя." - это будет реализовано в следующей сборке. Я это назвал "рваный запрос", может это как-то по другому называется, то подскажите.
Сегодня мне удалось протестировать консоль в режиме функции, т.е. вызов консоли из модуля объекта. В задании было необходимо посмотреть как формируются проводки в БП 3.0. Тест прошёл успешно. Там консоль собирает "рваные запросы" как сучки на одну ветку. И при выполнении ветки (рекурсивный обход) запросов будет один МВТ на всех.
База была на сервере SQL. Путь к обработке прописывал серверный. В общем, всё сработало. Сегодня ещё подправил критические ошибки. Завтра, если успею, опишу и выложу. С перепроверкой согласен - перемудрил, надо сделать её только на горячих клавишах. Исправлю.
44. Антон Стеклов (asved.ru) 19.03.15 05:11
(39) akor77, проверку мне было бы удобнее по Ctrl+F5, как в SSMS (кстати, F5 на выполнить запрос - это оттуда же), но лично я этой функцией пользуюсь крайне редко.
45. Дмитрий Кудинов (ZloyProger) 19.03.15 14:39
Отдельное спасибо за привычный интерфейс консоли запросов)
46. Сергей Галюк (dj_serega) 19.03.15 18:09
(43) akor77,
Сегодня ещё подправил критические ошибки. Завтра, если успею, опишу и выложу.
Не сильно спешите :) Главное что бы стабильные релизы доработок/исправлений ;) Я к тому что в спешке можно где-то что-то упустить.


Крит при удалении последней строки дерева запросов.

МодульФормы.УдалитьПараметрыЗапроса(ИДСтроки).
В коде:
СтрДЗ.Родитель.Строки.Удалить(СтрДЗ);

СтрДЗ.Родитель = Неопределено
47. Никита (nikbrik) 20.03.15 09:22
Еще бы прикрутить сюда получение плана запроса как в консоли с ИТС под 8.3.5, было бы вообще шикарно.
48. Сергей Галюк (dj_serega) 20.03.15 15:26
Некорректно отображается период с типом ДатаВремя
49. Александр Кораблев (akor77) 20.03.15 18:23
50. Александр Кораблев (akor77) 20.03.15 18:31
(47) nikbrik, честно говоря, я с этой штуковиной не работал, но с интересом изучу и постараюсь прикрутить.
51. борян петров (TODD22) 22.03.15 09:32
А как у этой обработки дело с модальностью и асинхронностью?
Будет ли работать на самописных конфигурациях?
52. Александр Кораблев (akor77) 22.03.15 10:04
(51) TODD22, Дома тестил на УФ 8.2 и в интерфейсе Такси на самописных конфигурациях. На демке бухгалтерии УФ. На тестовых базах при отладке. Без разницы где работать. Модальность используется в УФ 8.2. Так же работает в условиях где модальные окна не поддерживаются. на счёт асинхронности особо не заморачивался. Продукт создан для разработчика, а не пользователя. С интерфейсом Такси я недавно столкнулся и не обращал внимание на этот момент. Возможно, вылезут ошибки при нарушении последовательности открытия диалоговых окон. Надо будет это отдельно потестить.
53. борян петров (TODD22) 22.03.15 13:19
(52) akor77,
на счёт асинхронности особо не заморачивался. Продукт создан для разработчика, а не пользователя.

Как мне кажется нужно заморочиться. Раз асинхронность это курс партии :)
54. Александр Кораблев (akor77) 22.03.15 13:45
(53) TODD22, Хорошо, буду знать, обязательно изучу эту тему.
55. Сергей Галюк (dj_serega) 23.03.15 12:28
(49) akor77, Свисните, когда новый релиз будет. Очень понравилась консолька. Уже пользуюсь и, пока, закрываю глаза на баги.
56. pau74 (pau74) 23.03.15 16:39
Спасибо за консоль.
Жаль не работает с английским синтаксисом запроса.
58. Александр Кораблев (akor77) 23.03.15 18:46
(55) dj_serega, Релизы нумеруются. Какой период с типом "ДатаВремя" ты имел ввиду? Опиши пример.
60. Александр Кораблев (akor77) 23.03.15 19:00
(55) dj_serega, В следующем релизе добавлю навороты как раз, для тех, кто пишет руками.
61. Александр Кораблев (akor77) 23.03.15 20:30
67. Сергей (necropunk) 24.03.15 12:16
Начал использовать. Замечания пока мелкие, например, по Ctrl+/ не комментирует выделенный блок, надо мышкой в соответствующую кнопку тырцать, не очень удобно, а к хоткею привык уже...
dj_serega; +1 Ответить
68. Сергей Галюк (dj_serega) 24.03.15 12:25
(58) akor77,
Релизы нумеруются.

Тоесть у меня обработка, поэтому нужно скачать новую. Так как уже есть новый вариант. Хорошо. Спасибо.
Какой период с типом "ДатаВремя" ты имел ввиду? Опиши пример.
В параметрах запроса "&НачалоПериода", "&КонецПериода" или "&Период". Так вот в таблице параметров иногда проскакивает значение параметра с типом Дата и видом Дата а не ДатаВремя. Сейчас не могу повторить ошибку. Как только появится закриню.
(67) necropunk, Согласен. Но не писал об этом так как есть другие более важные замечания и пожелалки ;)

akor77 Спасибо большое за кнопулины по сворачиванию групп... Много удобностей и нововведений. ОЧЕНЬ круто!!! Продолжаю тестить новый релиз ;)

1. По кнопке "Сохранить файл запросов" ошибка:
{(3)}: Метод объекта не обнаружен (Показать)
ДиалогОткрытияФайла.Показать(Оповещение);

Аналогично и по "открыть файл запросов".
2. Если свернуть левую панель, потом свернуть текст запроса. Развернуть текст запроса. Текст запроса пустой. Если при пустом тексте запроса отобразить левую панель, текст появляется.
69. Сергей (necropunk) 24.03.15 15:42
"Зафиксировать" работает как-то специфически... Вообще, мелких интерфейсных багов хватает, но пока не систематично, будет что-нибудь еще доставать - напишу. Еще не нашел как сделать постобработку запроса. Как обработать ТЗ если она параметр запроса (О_о) - нашел, а чтобы просто таблицу результата обежать и что-нибудь страшное с ней сделать - нет, возможно, плохо искал...
70. Сергей (necropunk) 24.03.15 15:50
Вывод данных в форме дерева неплохо бы сделать тоже, для обходов по группировкам полезно бывает иногда...
71. Сергей (necropunk) 24.03.15 16:28
Если с пустым деревом запросов вызвать меню открытия файла с запросами, а потом передумать - будет куча ошибок о несоответствии параметра:

{Форма.Форма.Форма(1334)}: Ошибка при вызове метода контекста (НайтиПоИдентификатору)
ТекущаяСтрока = ДеревоЗапросов.НайтиПоИдентификатору(Элементы.ДеревоЗапросов.ТекущаяСтрока);
по причине:
Несоответствие типов (параметр номер '1')
72. Александр Кораблев (akor77) 24.03.15 17:46
(69) necropunk, Надо установить флаг в самой правой колонке таблицы пакетов. Выполнить запрос, название пакета станет жирным шрифтом - это означает, что таблица выгружена. Кликаешь по колонке с названием и нажимаешь на просмотр (кнопка с лупой). Откроется форма для редактирования ТЗ. Под ТЗ есть текстовое поле "модуля" для кода. На командной панели есть кнопки, нажав на которые в "модуль" будет добавлен шаблон обхода в цикле. На счёт выгрузки деревьев, возьму на заметку. Со временем реализую.
73. Александр Кораблев (akor77) 24.03.15 18:34
(68) dj_serega, (71) necropunk, Ребята, спасибо за подсказки и замечания. Сейчас выложил новый релиз 8.3.2.3. Описание обновлений смотрите в статье. В постскриптум статьи добавлены пожелания для описания ошибок. Не могу воспроизвести часть ошибок.
74. Александр Кораблев (akor77) 24.03.15 18:46
(53) TODD22, Хорошо. А можно ссылку на толковую статейку?
75. Сергей Галюк (dj_serega) 24.03.15 19:05
А сложно допилить выводить состояния работы? Это конечно рюшечка, но... было бы красиво :)

Пример:
&НаКлиенте
Процедура ВыполнитьЗапрос(Команда)

Если Объект.ОшибкиВЗапросе Тогда
Сообщить("Исправьте текст запроса!");
Возврат;
КонецЕсли;

// Дописать вот такое
Состояние("Выполняется запрос.");
// Или так
Состояние("Выполняется запрос: " + ИмяЗапросаВДереве);
76. Александр Кораблев (akor77) 24.03.15 19:10
(75) dj_serega, Попробую реализовать.
77. Сергей Галюк (dj_serega) 24.03.15 19:15
Получилось повторить очистки текста запроса. Насколько я понял, нужно где-то хранить текст запроса при скрытой левой панели.
Последовательность действий на скринах (скрины пересортировались, поэтому смотреть на названия).

А к этой ошибке я так понял руки не дошли ;)
{(3)}: Метод объекта не обнаружен (Показать)
ДиалогОткрытияФайла.Показать(Оповещение);
Прикрепленные файлы:
78. Александр Кораблев (akor77) 24.03.15 19:23
(77) dj_serega, про очистку текста запроса я понял, у меня эта ошибка тоже выходит. На днях буду искать причину. А вот это
{(3)}: Метод объекта не обнаружен (Показать)
ДиалогОткрытияФайла.Показать(Оповещение);
не могу воспроизвести. Что там с настройкой модальности и синхронности вызовов. для меня это пока ещё тёмный лес, надо разбираться. У меня всё работает.
79. Сергей Галюк (dj_serega) 24.03.15 21:51
(78) akor77, будет время подсоблю :) ошибку с диалогом проанализирую, поправлю и отпишусь.
80. Александр Кораблев (akor77) 25.03.15 03:53
(79) dj_serega, Я кажется уже догадался. Надо смотреть не на версию платформы (8.2 или 8.3), а на то - есть модальность или нет. В 8.2 всегда модальность, а в 8.3 зависит от соответствующей настройки. на неделе поправлю.
81. Доминант ГК (ingmar) 25.03.15 11:24
Можно добавить обработку изменения типа параметра запроса с типом ПланыВидовХарактеристик
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
....
ВывестиКоллекцию(Дерево, "ПланыВидовХарактеристик"       , "ПланВидовХарактеристик");
....
...Показать Скрыть
82. Сергей Галюк (dj_serega) 25.03.15 14:20
(80) akor77, Вот в этой статье нашел следующий текст:
Следует обратить внимание, что объект ДиалогВыбораФайла не имеет метода Показать() в отличие от диалогов выбора цвета или шрифта, поскольку реализация этих диалогов существенно разная.
.
У нас еще используется модальность. Поэтому не вижу метода: "ДиалогОткрытияФайла.Показать()".
В 8.3 без модальности СП дал эти методы:
Выбрать (Choose)
Показать (Show)


Пожелалка:
1. Сделай, пожалуйста, переход к тексту пакета с таблицы "Временные таблицы". Аналогично как с результирующего табличного документа.
В принципе будет достаточно перейти на текст "поместить ..."
83. Артур Аюханов (artbear) 25.03.15 16:50
(0) Из описания совершенно непонятно, работает ли в 8.2 тонкий клиент? с какой версией 8.3 работает? 8.3.4 работает?
инфу о версии платформы желательно указать где-то в начале описания.
Жду ответа.
84. Сергей Галюк (dj_serega) 25.03.15 17:03
(83) artbear, Я успешно пользуюсь на 8.3.5 (без режима совместимости с модальностью). На 8.2, говорят, работает.
85. Артур Аюханов (artbear) 25.03.15 17:53
На 8.2 невозможно закрыть форму.
Сценарий - тонкий клиент 8.2, открываю форму обработки, ничего не делаю и тут же пытаюсь закрыть.
Выдается ошибка:
{Форма.Форма.Форма(90)}: Ошибка компиляции при вычислении выражения или выполнении фрагмента кода
		Выполнить(КодВыполнения);
по причине:
{(3,26)}: Переменная не определена (Результат)
ПередЗакрытиемЗавершение(<<?>>Результат, Параметры);
...Показать Скрыть


и все. форму невозможно закрыть без перезагрузки 1С :(
86. Сергей Галюк (dj_serega) 25.03.15 18:05
(85) artbear, Это разработчик немного налажал :(
|Ответ = Вопрос(ТекстВопроса, РежимДиалогаВопрос.ДаНет);
			|ПередЗакрытиемЗавершение(Результат, Параметры);";

Вместо "Результат" должен быть "Ответ"

Себе замените, а он посмотрит и исправит.

В любом случае за такую консольку на это можно закрыть глаза ;)
87. Сергей (Che) Коцюра (CheBurator) 25.03.15 19:13
Этих консолей на Исе - вагон и телега разных.
какую использовать - непонятно...
88. Александр Кораблев (akor77) 25.03.15 19:15
(81) ingmar, (85) artbear, (86) dj_serega, Замечания принял, исправлю.
89. Александр Кораблев (akor77) 25.03.15 19:22
(83) artbear, (84) dj_serega, (82) dj_serega, На данный момент точно работает
8.2 толстый клиент - весь функционал,
8.2 тонкий клиент - весь функционал кроме конструктора запроса
8.3.5.1482 без модальности - весь функционал
90. Александр Кораблев (akor77) 25.03.15 19:26
(82) dj_serega,
Следует обратить внимание, что объект ДиалогВыбораФайла не имеет метода Показать() в отличие от диалогов выбора цвета или шрифта, поскольку реализация этих диалогов существенно разная.
Похоже всё дело в старом релизе платформы, обнови платформу. У меня 8.3.5.1482, полёт нормальный, скорее всего предыдущая версия не поддерживает Показать() .
91. Александр Кораблев (akor77) 25.03.15 20:20
(83) artbear, (85) artbear, да, на 8.2 куча ошибок, правлю, в выходные выложу с исправлением очень многих ошибок.
93. Сергей Галюк (dj_serega) 26.03.15 11:39
(90) akor77,
Похоже всё дело в старом релизе платформы, обнови платформу. У меня 8.3.5.1482, полёт нормальный, скорее всего предыдущая версия не поддерживает Показать() .
.
Походу так и есть Дело в релизах.
Рабочая база 8.3.5.1248. Просто взять и обновить не получится.
Посмотрим что там будет в 8.3.6. (кстати опять перенесли дату релиза).
94. Сергей Галюк (dj_serega) 26.03.15 15:24
Удалось повторить проблему с датой в параметрах (01 - скрин параметров, 02 - скрин текста запроса).

Пожелалка:
1. В форме текста для модуля есть "ПеременнаяЗапроса". Там можно установить имя переменной. Всё круто! Но было бы неплохо изменить еще и результат.
Вместо:
РезультатЗапроса = ЗапросПроверка.Выполнить();

Реализовать:
РезультатЗапросаПроверка = ЗапросПроверка.Выполнить();


2. Сделайте, на досуге, замер производительности. Очень долго первый раз открывается обработка. Потом где-то лишнее (мне кажется) думает при активизации поля текста запроса.
Вот самая ресурсоемкая строка:
Обработка.КонсольЗапросовУФ.Форма.Форма.Форма 211 ПроверитьТекстЗапроса_ПолучитьПараметры_ОбновитьДанные(, Ложь, ); 1 0,749873 91,29

Я к чему. Может когда основные вопросы будут решены дойдут руки до оптимизации.
Прикрепленные файлы:
95. Александр Кораблев (akor77) 26.03.15 19:32
(94) dj_serega, Хорошая идея с именем переменной, уже добавил. А по ошибкам работы ещё непочатый край. Я немного промахнулся, думал, что тестирую на платформе 8.2, а на самом деле на 8.3 Сегодня на работе "перехватывал" запрос где клиентская часть на терминальном сервере, а сервер базы данных на другом серваке. Необходимо при обращении к консои из кода указывать путь доступный с сервера приложения. Здесь всё нормально срабатывает и файл создаётся. Но открыть его невозможно. Я в окне диалога указываю путь видимый с клиентской машины, а надо указывать путь видимый с сервера приложения. В итоге в коде принудительно присвоил значение пути к файлу результата и всё открылось. В эти выходные буду работать над косяками.
96. Александр Кораблев (akor77) 28.03.15 09:16
97. Андрей (h00k) 28.03.15 22:07
(94)dj_serega, (95)akor77
В форме текста для модуля есть "ПеременнаяЗапроса".

По форме текста запроса для модулей есть и у меня несколько замечаний. Раньше не озвучивал, так-как не хотел отвлекать, просто себе их реализовал.
1. если текст запроса пустой, то форма не открывается.
2. опциональная вставка куска кода проверки запроса.
3. избавился от конструкции "РезультатЗапроса = Запрос.Выполнить()" там где она избыточна.
4. добавил в таблицу "ВыводРезультатаЗапроса" колонку "Итератор" и соответственно изменил формирование конструкции "для каждого" добавив переменную "Итератор".

Единственный нюанс - весь текст формируется в привычной мне "венгерской" нотации.
98. Александр Кораблев (akor77) 28.03.15 23:04
(97) h00k, Посмотрел твой вариант, он лучше чем прежний. добавлю в следующую сборку.
99. Андрей (h00k) 28.03.15 23:26
(96) В версии 8.3.2.5 Ошибка в имени функции "ПолучитьФайл()", нельзя давать локальным функциям имена предопределенных, странно что у тебя синтаксис контроль такое пропустил.
заменил имя на "ПолучитьФайлНаСервере()".

минут через 15 отправлю тебе в лс ссылку на 8.3.2.5 с измененным блоком генерации текста для модуля переименованной функцией ПолучитьФайл() и встроенным шаблоном авторегистрации обработки. Посмотри, может что-то "прикрутишь" к консоли.
100. Сергей Галюк (dj_serega) 30.03.15 10:24
1.
в 8.3.2.6 появилась ошибка с выполнением запроса.
Меняю "ручками" запрос. Нажимаю F5 (выполнение запроса). Запрос выполнился без изменений. Нажимаю Проверить запрос. Проверка прошла успешно. Нажимаю Выполнить запрос. Запрос выполняется с учетом правок.
Получается что где-то текст запроса закешировался. И для обновления нужно выполнять проверку.

2.
Расширение файла запросов лучше изменить с txt. Допустим на sel.
101. Глеб Зломанов (Glebis) 30.03.15 15:55
Понимаю что может не к месту, но не могли бы вы, товарищи, добавить дополнительную форму для обычного приложения (неуправляемого интерфейса). Очень хочется мне использовать единую (одну) консоль для всех конфигураций.
Если хотите могу попытаться переделать консоль с отказом от модальных окон.
102. Сергей Галюк (dj_serega) 30.03.15 16:12
(101) Glebis,
Если хотите могу попытаться переделать консоль с отказом от модальных окон.

Имхо, лучше это дело переложить на плечи Уважаемого текущего разработчика. У него тут всё схвачено + могут идеи появиться.
103. Алекс Ю (AlexO) 30.03.15 16:44
(87) CheBurator, это - не консоль в широком понимании, это - больше "сформируй ТЗ за 10 сек". А запросы там так, для галочки.
104. Александр Кораблев (akor77) 30.03.15 18:14
(103) AlexO, Привет, дружище!

Кто мешает развитию?
- Подавляющая личность (ПЛ).
http://admintech.ru/articles/protivodeistvie-uluchsheniyam-na-predpriyatii
Такой человек в основном занимается тем, что распространяет плохие новости, делает критические или враждебные замечания, обесценивает и вообще оказывает подавление. Он никогда не передает никаких хороших новостей или одобрительных замечаний.
Подавляющие личности просто отравляют все вокруг себя и оказывают влияние на свое окружение.
Такие люди являются хорошо замаскировавшимися сумасшедшими.
Все кто находится в тесном контакте с ПЛ очень часто испытывают то спады, то подъёмы, один день может много дел переделать, а потом ничего не может ничего. Если вы заметили это в себе, то ищите ПЛ-а.

Вся подноготная о подавляющих личностях хорошо раскрыта в этой книге:

Книга "Сады и подъёмы", автор Рут Мишнулл.
http://www.klex.ru/79

Если вас подавляют в семье, дома или на работе, обязательно научитесь выявлять ПЛ-ов.

Кроме того, подавлению обучают:
1. Подавляющее влияние: как и на чем любят играть любители обманывать, пугать, подавлять...
http://www.nrpsy.ru/psy_podavlenie.html
2. Подавляющее влияние: Подавляющее влияние 2: подавление авторитетом...
http://www.nrpsy.ru/psy_podavlenie_avtoritet.html
3. Подавляющее влияние 2: интриги, подставы, шантаж...
http://www.nrpsy.ru/psy_podavlenie_intrigi.html
JohnyDeath; sashocq; Diego_Iv; creatermc; tristarr1; vovan_victory; dgolovanov; h00k; dj_serega; +9 Ответить 1
105. Александр Кораблев (akor77) 30.03.15 18:35
106. Александр Кораблев (akor77) 30.03.15 18:41
(101) Glebis, В планах есть намерение сделать подобную консоль для обычного приложения.
107. Александр Кораблев (akor77) 30.03.15 18:53
(103) AlexO, Ты мне напоминаешь того ПЛа, которого показывают на 3.50 минуте.
https://youtu.be/k-52Be8EmqA