gifts2017

Заполнение справочника "Виды алкогольной продукции" Бухгалтерия 3.0

Опубликовал Сергей Кенжин (Kesak) в раздел Обработки - Обработка справочников

Обработка позволяет заполнить справочник "Виды алкогольной продукции" в Бухгалтерии 3.0 из файла базы данных программы Декларант-Алко, если она установлена на компьютере. Если таковой не имеется, берем файлик из архива с обработкой.

Файл с кодами также стянут из Декларант-Алко на 14.07.2016 г (обновление!). Выбрана база из данной проги по причине полной и актуальной (при своевременных обновлениях) заполненности таблицы кодов алкогольной продукции.

Инструкция:

Открываем обработку в 1С Бухгалтерии 3.0. Указываем путь до файла данных SDF, обычно он находится в папке с установленной прогой Декларант-Алко, или выбираем наш файл из архива с обработкой. Выбираем файл типа *****base (в нем содержатся виды алкогольной продукции).

Галка и поле "Вид лицензии" определет вид лицензии для одноименного поля нового элемента справочника и, если стоит галка "корректировать существующий вид лицензии", переопределяет существующий элемент справочника.

Признак "Маркируемый" определет признак маркируемости для нового элемента справочника, и, если стоит галка "корректировать существующую маркируемость", переопределяет существующий элемент справочника.

Галка "Корректировать существующие элементы" делает доступными для редактирования признака для корректировки отдельных существующих полей элемента справочника.

"Корректировать существующее наименование" - тут думаю все понятно :)

Жмем кнопку "Загрузить виды алкогольной продукции". Радуемся :)

Обновление 14.07.2016:

  • Доработка в связи с заменой справочника актальной на данный момент БП (новая структура справочника).
  • Расширен функционал загрузки.
  • Обновлена база  кодов алкогольной продукции на 14.07.2016.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Заполнение справочника видов алкогольной продукции БП3.zip
.zip 433,13Kb
14.07.16
15
.zip 1.1.0 433,13Kb 15 Скачать

См. также

Contragent+ 5.0 от 2 500
Подписаться Добавить вознаграждение

Комментарии

1. pallid *** (white_sochi) 28.03.15 02:58
2. Сергей Кенжин (Kesak) 28.03.15 18:52
Там нет кодов из декларации №12 - 261, 262, 263. Самая актуальная и полная таблица в базе Декларант-Алко.
3. Людмила Стрыгина (strlb1960) 12.07.15 18:26
При попытке загрузки вышло сообщение: Произошла исключительная ситуация (ADODB.Connection): Не удается найти указанный поставщик. Возможно он установлен неправильно. Что не так? Релиз бухгалтерии 3.0.40.37 Базовая. Платформа 8.3.6.2076
4. Алексей Ермилов (Alex_E) 12.07.15 22:38
Вроде как эти виды можно из самих регламентированных отчетов самой БП 3.0 - они там в макетах лежат...
5. Сергей Кенжин (Kesak) 14.07.15 22:12
(4) Alex_E, поведайте же где конкретно?
6. Алексей Ермилов (Alex_E) 14.07.15 22:27
(5) Kesak, Не думал что это великая тайна - в макетах 11 и 12 декларации, загрузить в справочник из них достаточно просто, помню ж в расширение включал для одного клиента:
&НаСервере
Процедура ЗаполнитьИзМакета(МакетМД, ДекларацияНомер)
	Если ДекларацияНомер = 11 Тогда
		Макет = Отчеты.РегламентированныйОтчетАлкоПриложение11.ПолучитьМакет(МакетМД.Имя);
	Иначе
		Макет = Отчеты.РегламентированныйОтчетАлкоПриложение12.ПолучитьМакет(МакетМД.Имя);
	КонецЕсли;
	ОбластьВидыПродукции = Макет.ПолучитьОбласть("ВидыПродукции");
	Для а = 1 По ОбластьВидыПродукции.ВысотаТаблицы Цикл
		КодВидаПродукции = ОбластьВидыПродукции.Область(а, 1).Текст;
		Наименование = ОбластьВидыПродукции.Область(а, 2).Текст;
		Найден = Справочники.ВидыАлкогольнойПродукции.НайтиПоРеквизиту("КодВидаПродукции", КодВидаПродукции);
		Если Найден = Справочники.ВидыАлкогольнойПродукции.ПустаяСсылка() Тогда
			ЭтоНовый = Истина;
			вп = Справочники.ВидыАлкогольнойПродукции.СоздатьЭлемент();
			вп.УстановитьНовыйКод();
		Иначе
			ЭтоНовый = Ложь;
			вп = Найден.ПолучитьОбъект();
		КонецЕсли;
		вп.Наименование = Наименование;
		вп.КодВидаПродукции = КодВидаПродукции;
		вп.Записать();
	КонецЦикла;
КонецПроцедуры
	
&НаСервере
Процедура спво_ЗаполнитьИзРегламентированнойОтчетностиНаСервере()
	//Заполним справочник по макетам 11 декларации
	СписокМакетов = Новый Массив;
	Для Каждого макет Из Метаданные.Отчеты.РегламентированныйОтчетАлкоПриложение11.Макеты Цикл
		ИмяМакета = макет.Имя;
		Если Лев(макет.Имя, 6) = "Списки" Тогда
			СписокМакетов.Добавить(макет);
		КонецЕсли;
	КонецЦикла;
	Для Каждого стр Из СписокМакетов Цикл
		ЗаполнитьИзМакета(стр, 11);
	КонецЦикла;
	
	//добавим, если получится из 12
	СписокМакетов.Очистить();
	Для Каждого макет Из Метаданные.Отчеты.РегламентированныйОтчетАлкоПриложение12.Макеты Цикл
		ИмяМакета = макет.Имя;
		Если Лев(макет.Имя, 6) = "Списки" Тогда
			СписокМакетов.Добавить(макет);
		КонецЕсли;
	КонецЦикла;
	Для Каждого стр Из СписокМакетов Цикл
		ЗаполнитьИзМакета(стр, 12);
	КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура спво_ЗаполнитьИзРегламентированнойОтчетности(Команда)
	Состояние("Заполнение списка видов алкогольной продукции...");
	спво_ЗаполнитьИзРегламентированнойОтчетностиНаСервере();
	Элементы.Список.Обновить();
КонецПроцедуры
...Показать Скрыть
Прикрепленные файлы:
7. Сергей Кенжин (Kesak) 14.07.16 15:49
Обновил файл с данными(из базы Декларант Алко) на 14.07.2016 и обработку загрузки, которая теперь работает с последними (на данный момент) версиями БП 3.0.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа