gifts2017

Программное обращение к внешней обработке

Опубликовал Смирнов Дмитрий (lonlilokli) в раздел Программирование - Практика программирования

В УПП зарегистрированы внешние отчеты в Сервис\Дополнительные отчеты и обработки\отчеты. Нужно к ним программно обратиться.

Для наглядности создадим внешнию обработку, на ней форму, а в форме пропишем действие для кнопки "Выполнить"

Находим номер нужного отчета для подстановки, а код, собственно, следующий:

 

	Внешняя=Справочники.ВнешниеОбработки.НайтиПоКоду("000000025");
	ДвоичныеДанные = Внешняя.ХранилищеВнешнейОбработки.Получить();
	ИмяФайла = ПолучитьИмяВременногоФайла();
	ДвоичныеДанные.Записать(ИмяФайла);    
	Обработка = ВнешниеОтчеты.Создать(ИмяФайла);
	Обработка.ПолучитьФорму().Открыть();
	

Скачать файлы

Наименование Файл Версия Размер
ОткрытиеВнешнегоОтчета.epf 3
.epf 6,06Kb
28.04.15
3
.epf 6,06Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

2. Денис Новосёлов (binex) 28.04.15 16:21
3. город в Мексике (acapulco) 28.04.15 17:48
Зачем, спрашивается, помещать обработку во внешние обработки, когда ее можно включить в конфигурацию?
Чем обоснована эта необходимость?
Да и зачем изгаляться с внешними обработками, когда ее можно разместить на диске и по такой же схеме открывать, указав путь к файлу на диске.
5. борян петров (TODD22) 28.04.15 17:55
(3) acapulco,
спрашивается, помещать обработку во внешние обработки, когда ее можно включить в конфигурацию?

Для того что бы не включать режим редактирования конфигурации.
Чем обоснована эта необходимость?

Тем что база с включенным режимом редактирования будет дольше обновляться. А если его не включать то в обновление пройдёт автоматическом режиме.
Да и зачем изгаляться с внешними обработками, когда ее можно разместить на диске и по такой же схеме открывать, указав путь к файлу на диске.

Для того что бы обработка выгружалась в резервную копию вместе с базой. То есть хранилась в самой базе данных.
Alex_E; Рамзес; lonlilokli; h00k; +4 Ответить 1
6. Андрей (h00k) 28.04.15 18:09
(0) Круто. Теперь ждем цикл статей как подключить обработку из справочника без создания временного файла на диске...
7. Андрей (h00k) 28.04.15 18:18
(3) acapulco,
Да и зачем изгаляться с внешними обработками, когда ее можно разместить на диске и по такой же схеме открывать, указав путь к файлу на диске.

Ну ка, расскажите нам не сведущим, как обработку/ отчет размещенную на диске подключить к конфигурации, добавив команды открытия в нужные разделы интерфейса, указав конкретного пользователя/ группу имеющую право запускать эту обработку или просто настроить запуск по расписанию.

(5) TODD22, на мой взгляд удобное назначение права доступа более веская причина, хотя да, хранение обработки в базе тоже причина достаточно важная.
lonlilokli; TODD22; +2 Ответить
8. Смирнов Дмитрий (lonlilokli) 28.04.15 21:24
(3) acapulco, собственно задачка простенькая, особенно я так понимаю для Вас. Нужно формировать отчет с разными настройками для менеджеров. Менеджеров 50 настроек тоже. Если можно расскажите как бы Вы это реализовали.
9. Андрей Карпов (karpik666) 29.04.15 09:36
(0) Это троллинг, или автор действительно называет это "Публикацией"?
EliasShy; artbear; +2 Ответить
10. Николай Петров (Kolyasik) 29.04.15 10:11
а на ИТС разве нет описания работы с внешними отчетами обработками?
11. Смирнов Дмитрий (lonlilokli) 29.04.15 14:13
(10) Kolyasik, Ок, посмотрю. Иногда бывает нет под рукой. А если можно подскажите как это там найти.
12. город в Мексике (acapulco) 30.04.15 09:33
(10) Kolyasik, конечно есть http://its.1c.ru/db/metod8dev#content:3556:hdoc
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)

    //Помещаем обработку во временном хранилище
    АдресХранилища = "";
    Результат = ПоместитьФайл(АдресХранилища, "C:\ВнешняяОбработка.epf", , Ложь);           
    ИмяОбработки = ПодключитьВнешнююОбработку(АдресХранилища);
    
    // Откроем форму подключенной внешней обработки
    ОткрытьФорму("ВнешняяОбработка."+ ИмяОбработки +".Форма");

КонецПроцедуры

&НаСервере
Функция ПодключитьВнешнююОбработку(АдресХранилища)

    Возврат ВнешниеОбработки.Подключить(АдресХранилища);

КонецФункции 
...Показать Скрыть
lonlilokli; +1 Ответить 1
13. Смирнов Дмитрий (lonlilokli) 30.04.15 09:48
(12) acapulco, Ок ! Спасибо! У меня просто стояла задачка брать обработки сохраненные во внешних в 1с предприятии.
А так тоже надо было, но не смог найти. А оказалось точно просто набираешь в поиске на итс "открыть внешнюю обработку" и на тебе пожалуйста.
Сколько раз уже на эти грабли натыкался, ищешь часами в нет, нет что бы просто в синтакспомощник заглянуть :))
14. Андрей Карпов (karpik666) 30.04.15 10:03
(13) lonlilokli, а еще можно в конфигураторе найти справочник "ВнешниеОбработки" и глянуть как в форме списка открываются внешние обработки. Обработчик события при выборе:
	
Справочники.ВнешниеОбработки.ВыполнитьВнешнююОбработку(ВыбраннаяСтрока);

...

Процедура ВыполнитьВнешнююОбработку(ВнешняяОбработкаСсылка) Экспорт
	
	ЭтоОбработка = ?(ВнешняяОбработкаСсылка.ВидОбработки = Перечисления.ВидыДополнительныхВнешнихОбработок.Обработка, Истина, Ложь);
	ЭтоОтчет = ?(ВнешняяОбработкаСсылка.ВидОбработки = Перечисления.ВидыДополнительныхВнешнихОбработок.Отчет, Истина, Ложь);
	
	Если НЕ (ЭтоОбработка ИЛИ ЭтоОтчет) Тогда
		Возврат;
	КонецЕсли;
	
	ИмяФайла = КаталогВременныхФайлов() + ВнешняяОбработкаСсылка.УникальныйИдентификатор() + ".tmp";
	ДвоичныеДанные = ВнешняяОбработкаСсылка.ХранилищеВнешнейОбработки.Получить();
	ДвоичныеДанные.Записать(ИмяФайла);
	
	Если ЭтоОбработка Тогда
		
		Форма = ВнешниеОбработки.ПолучитьФорму(ИмяФайла);
		
	Иначе
		
		Форма = ВнешниеОтчеты.ПолучитьФорму(ИмяФайла);
		
	КонецЕсли;
	
	Если Не Форма = Неопределено Тогда
		
		Форма.Открыть();
		
	Иначе
		
		Если ЭтоОбработка Тогда
			ВнешняяОбработка = ВнешниеОбработки.Создать(ИмяФайла, Не ВнешняяОбработкаСсылка.ОтключитьБезопасныйРежим);
		Иначе
			ВнешнийОтчет = ВнешниеОтчеты.Создать(ИмяФайла, Не ВнешняяОбработкаСсылка.ОтключитьБезопасныйРежим);
			Форма = ВнешнийОтчет.ПолучитьФорму();
			Если Форма <> Неопределено Тогда
				Форма.Открыть();
			КонецЕсли;
		КонецЕсли;
		
	КонецЕсли;
	
КонецПроцедуры

...Показать Скрыть

Но наверное это было сложно сделать.
P.S. Нет возможности заглянуть в синтакс-помощник, зато есть время такое публиковать.
15. Смирнов Дмитрий (lonlilokli) 01.05.15 00:03
(14) karpik666, Ты добрый малый! А если не секрет что тебя так задевает? Ну опубликовал такую фигню. Тебе от этого плохо? Или я тебе чем-то помешал. Вообще не слишком ли много чести,зачем ты потратил стока своего драгоценного времени?
16. Смирнов Дмитрий (lonlilokli) 01.05.15 00:14
(14) karpik666, А собственно. Вопрос все равно остался. Пусть обработка или отчет есть в конфе. У отчета есть n-ное количество пользовательских настроек. Нужно программно вызывать все эти настройки, и формировать отчеты.
17. Андрей (h00k) 01.05.15 04:14
(8) lonlilokli, Вот я не понимаю, отчет ведь для какой-то конфигурации, правильно?
Неужели в этой конфигурации нет ни одного объекта/ формы сохраняющего свои настройки?!

Поищите в этой конфигурации либо в синтаксис помощнике
ХранилищеОбщихНастроек.Сохранить
ХранилищеОбщихНастроек.Загрузить


Метод работает как для объектов в составе конфигурации, так и для внешних отчетов/обработок хранящихся на диске, главное не промахнуться с ключами объекта и настроек.

П.С.: Ну и незнание некоторых методов - это не повод писать "мусорные статьи" в надежде получить ответ в комментариях, лучше просто задать вопрос на форуме...
18. Андрей Карпов (karpik666) 01.05.15 07:50
(16) lonlilokli, Извини, если мои комментарии были грубые, но меня задевает, что нет премодерации по содержанию, а только по оформление, что инфостарт уже какая-то свалка, чтобы найти что-то стоящее нужно часами копаться. И в данном случае твоя статья не содержит в себе ничего, с таким же успехом можно было справку из синтакс-помощника здесь разместить. А хотелось бы, чтобы инфостарт был похож на хабр, какой он сейчас, где каждая статья содержит в себе ценность.
19. Андрей Карпов (karpik666) 01.05.15 08:53
(16) lonlilokli, в типовых конфигурациях на обычных формах есть регистр сведений "сохраненные настройки", если отчет был сделан на универсальном отчете, то настройки попадают туда, чтобы посмотреть как эти настройки загружаются из этого регистра нужно открыть "универсальный отчет" модуль объекта процедура "восстановить настройки". Если на скд, то настройки попадают в "хранилище общих настроек", но тут я не смогу подсказать, потому как сам не знаю.
lonlilokli; +1 Ответить 1
20. Андрей (h00k) 01.05.15 17:40
(19) karpik666,
то настройки попадают в "хранилище общих настроек", но тут я не смогу подсказать, потому как сам не знаю.

В (17) я показал "как они туда попадают", остается только посмотреть в синтаксис помощнике методы объекта ХранилищеОбщихНастроек и воспользоваться ими...
karpik666; +1 Ответить
21. Василий Коровин (vasyak319) 01.05.15 21:15
(15) lonlilokli, удали фигню. Это проще и правильнее, чем фигню публиковать.
22. Смирнов Дмитрий (lonlilokli) 05.05.15 12:46
(21) vasyak319, А все-таки не такая уж и фигня, как кажется, если в поисковиках на первом месте и 100 просмотров.
23. Василий Коровин (vasyak319) 05.05.15 17:10
(22) lonlilokli, у блюющего котёнка на ТыТрубе вообще 15 миллионов просмотров. И что?
24. Смирнов Дмитрий (lonlilokli) 05.05.15 19:50
(23) vasyak319, о эко тебя, но ты то, что здесь искал если не секрет. Еще поражает столь сильное Ваше внимание к столь не нужной теме. А может ты просто так зарабатываешь:) тогда ок!


25. Александр Журавлев (apostal86) 06.05.15 11:35
А теперь еще сделаем одну обработку для открытия описанной в публикации обработки с тем же кодом и так далее - по циклу... бесконечно. Похоже, что автор просто хотел поделиться наработкой.
26. Смирнов Дмитрий (lonlilokli) 07.05.15 15:34
(25) apostal86, ну да именно так запускаем обработку и выполняем отчеты. Для Вас задачка я так понимаю простенькая. Может подскажите как выполнять отчет для n-ного количества сотрудников, соответственно каждому с его настройкой и отправлять на мыло?
27. Андрей (h00k) 07.05.15 15:51
(26) lonlilokli,
Для Вас задачка я так понимаю простенькая.

Эта задачка для любого "простенькая". Или начните пользоваться головой по назначению или наймите программиста.
28. Смирнов Дмитрий (lonlilokli) 08.05.15 07:58
короче, у вас есть решение хотите продать? Или я у Вас хлеб отнимаю, от того такая неприязнь? Чем Вам я конкретно мешаю? Может Вы хотите чтобы я оценил Ваши публикации? Ну так прямо бы и сказали. Каждый конечно выживает по своему.
29. Василий Коровин (vasyak319) 08.05.15 10:36
(28) lonlilokli,
от того такая неприязнь? Чем Вам я конкретно мешаю?


Вам уже отвечали на этот вопрос. Вы загаживаете сайт нашего сообщества мусором, плюс начинаете юродствовать, когда вам на это указывают, отсюда и отношение.
30. Смирнов Дмитрий (lonlilokli) 08.05.15 15:22
(29) vasyak319, Дорогой мой человек! Спасибо за столь внимательное отношение к теме. Но наверно есть более простые способы удалять не нужные публикации. Вы являетесь модератором? Просто удалите её. Или может если не являетесь, то обратитесь к модератору и он удалит. Может быть есть публикация и я повторил её, укажите это модератору. А Вы настолько уверены в себе, что можете утверждать, что Ваши публикации ничего не засоряют? Или может у Вас их нет? Не знаю, что Вы имеете ввиду говоря "юродствовать" , объяснитесь. Но на самом деле не допускаете ли мысли, что это и есть тот случай?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа