gifts2017

Перенумерация документов

Опубликовал Денис Михайлович Радченко (denis13) в раздел Обработки - Обработка документов

Обработка для последовательной перенумерации документов за период.

 

При непоследовательном вводе документов происходит не сквозная нумерация, к примеру, для документов вида "Приходный кассовый ордер" и "Расходный кассовый ордер". А в дальнейшем для формирования кассовой книги необходимо их "выстроить" в последовательной нумерации, в этом поможет данная обработка.

Перенумерация осуществляется с наибольшего номера за предыдущий период, увеличенного на один. Если документов в предыдущем периоде нет, то нумерация начинается с единицы.

Для работы с обработкой необходимо выбрать период (дата начала и окончания), организацию и нажать кнопку Заполнить, в которой будет видно текущую нумерацию и будущую.

Для выполнения перенумерации необходимо нажать кнопку "Выполнить".

Скачать файлы

Наименование Файл Версия Размер
Перенумирация документов 62
.epf 17,18Kb
29.04.15
62
.epf 1.1 17,18Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Евгений Балыков (ugeen) 30.04.15 13:09
Не вижу строки для выбора документов
2. Денис Михайлович Радченко (denis13) 01.05.15 09:48
(1) ugeen, на форме реквизит "Вид документа".
3. Константин Юрин (kostyaomsk) 04.05.15 18:35
Пишут что перенумераторов миллионы, но под рукой вовремя не оказывается когда надо :)
4. Константин Юрин (kostyaomsk) 04.05.15 18:38
Плюс за поддержку и обычных и управляемых форм. Конечно, ничего универсального нет. Запустил инструмент в УТ 11.1.10.86 выдало кучу ошибок :)
Ошибка инициализации модуля: Форма.ФормаУправляемая.Форма
по причине:
{Форма.ФормаУправляемая.Форма(22,2)}: Процедура или функция с указанным именем не определена (СохранитьЗначение)
	<<?>>СохранитьЗначение("мисНумерацияДокументов_ДатаНачала",		ЭтаФорма.Элементы.ДатаНачала);
{Форма.ФормаУправляемая.Форма(23,2)}: Процедура или функция с указанным именем не определена (СохранитьЗначение)
	<<?>>СохранитьЗначение("мисНумерацияДокументов_ДатаОкончания",	ЭтаФорма.Элементы.ДатаОкончания);
{Форма.ФормаУправляемая.Форма(24,2)}: Процедура или функция с указанным именем не определена (СохранитьЗначение)
	<<?>>СохранитьЗначение("мисНумерацияДокументов_Организация",		ЭтаФорма.Элементы.Организация);
{Форма.ФормаУправляемая.Форма(29,16)}: Процедура или функция с указанным именем не определена (ВосстановитьЗначение)
	ДатаНачала		= <<?>>ВосстановитьЗначение("мисНумерацияДокументов_ДатаНачала");
{Форма.ФормаУправляемая.Форма(30,18)}: Процедура или функция с указанным именем не определена (ВосстановитьЗначение)
	ДатаОкончания	= <<?>>ВосстановитьЗначение("мисНумерацияДокументов_ДатаОкончания");
{Форма.ФормаУправляемая.Форма(31,17)}: Процедура или функция с указанным именем не определена (ВосстановитьЗначение)
	Организация		= <<?>>ВосстановитьЗначение("мисНумерацияДокументов_Организация");
...Показать Скрыть
5. Константин Юрин (kostyaomsk) 04.05.15 18:53
Думал дело только в особенностях хранения настроек управляемой формы типа как описано тут, оказалось просто шаблон, который придется заполнить самому.
Быстрая заплатка которую обычно использую не помогает :)
&НаКлиенте
Процедура ВыборПериода(Команда)
	// Заполнить период.
	
КонецПроцедуры

&НаКлиенте
Процедура Заполнить(Команда)
	// Заполнить документами на перенумерацию.
	//ЗаполнитьДокументы();
КонецПроцедуры

&НаКлиенте
Процедура ВыполнитьПеренумерацию(Команда)
	// Выполнить перенумерацию.
	
КонецПроцедуры

&НаКлиентеНаСервереБезКонтекста
Процедура СказатьПользователю(текст1, Поле1=Неопределено)
	СП = Новый СообщениеПользователю;
	СП.Текст = Текст1;
	Если Поле1<>Неопределено Тогда
		СП.Поле = Поле1;
	КонецЕсли;	
	СП.Сообщить();
КонецПроцедуры	

&НаКлиенте
Процедура ПриЗакрытии()                           
	Попытка
		СохранитьЗначение("мисНумерацияДокументов_ДатаНачала",		ЭтаФорма.Элементы.ДатаНачала);
		СохранитьЗначение("мисНумерацияДокументов_ДатаОкончания",	ЭтаФорма.Элементы.ДатаОкончания);
		СохранитьЗначение("мисНумерацияДокументов_Организация",		ЭтаФорма.Элементы.Организация);
	Исключение
		СказатьПользователю("Сбой при сохранении настроек при закрытии управляемой формы "+ПодробноеПредставлениеОшибки(ИнформацияОбОшибке() ) );
	КонецПопытки;
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	Попытка
		ДатаНачала		= ВосстановитьЗначение("мисНумерацияДокументов_ДатаНачала");
		ДатаОкончания	= ВосстановитьЗначение("мисНумерацияДокументов_ДатаОкончания");
		Организация		= ВосстановитьЗначение("мисНумерацияДокументов_Организация");
	Исключение
		СказатьПользователю("Сбой при восстановлении настроек при открытии управляемой формы "+ПодробноеПредставлениеОшибки(ИнформацияОбОшибке() ) );
	КонецПопытки;
КонецПроцедуры
...Показать Скрыть

Настройки, то дело некритичное :) Дописать - вот для многих будет практика перехода на толстого на тонкий клиент :)
6. М Б (Obscurus) 14.05.15 10:42
Каждый программист должен хотя бы раз написать свою правильную обработку для перенумерации документов :)
StBender; +1 Ответить
7. Дмитрий (Dimakgb) 14.05.15 16:57
Бухгалтерия предприятия, редакция 3.0 (3.0.40.24)

ошибка при подключении обработки
"Невозможно подключить дополнительную обработку из файла.
Возможно, она не подходит для этой версии программы.

Метод объекта не обнаружен (СведенияОВнешнейОбработке)"

Просьба исправить!
8. Елена Мызникова (mamashka-1) 02.03.16 18:34
1С:Предприятие 8.3 (8.3.7.1917)
Конфигурация Элит-строительство. Бухгалтерский учет, редакция 3.0 (3.0.43.75) (http://www.eprof.ru/develops/es80/)
Эта конфигурация - просто нашлепка строительства на обычную бухгалтерию. Все обычные обработки для Бухгалтерии 1С идут.
Скачала, пыталась открыть обработку , сообщения. что нет процедуры или фунции "СохранитьЗначение"
и "ВосстановитьЗначение" в модуле управляемой формы и в модуле формы. Закомментировала эти строки в формах. Обработка загрузилась, но реквизита для выбора "Вид документа" нет. Стало быть, надо все выбирать ручками. Что сделать?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа