gifts2017

Акт на списание материалов для Требования-накладной. БП 3.0

Опубликовал Петр Петров (ni690yandex) в раздел Печать - Печатные формы документов

Внешняя печатная форма акта на списание материалов для Требование-накладная БП 3.0

Печатная форма заполняется из табличной части Материалы Требования-накладной.


Как подключить:

1) Открываем меню "Администрирование" -> "Дополнительные отчеты и обработки"

2) Жмём кнопку "Создать"

3) Вводим произвольное наименование

4) Жмём "Загрузить из файла" и выбираем файл с этой обработкой

5) Жмём ссылку "Указать назначение" и проверяем, чтобы была установлена галочка на "Документы" -> "Требование-накладная"

6) Жмём "Записать и закрыть"

Скачать файлы

Наименование Файл Версия Размер
Внешняя печатная форма Акт на списание материало для Требование наклабная БП 3.0 18
.epf 13,24Kb
14.05.15
18
.epf 13,24Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Лидия Кондрашова (lvk74) 08.05.15 12:57
выдает ошибку при попытке вывода на печать "Преобразование значения к типу ЧИСЛО не может быть выполнено"
2. Петр Петров (ni690yandex) 08.05.15 13:41
Тестировалась на платформе 8.3.5.1383
Бухгалтерия предприятия, редакция 3.0.37.32
На ней ошибок не было.
Какая у вас версия?
3. Петр Петров (ni690yandex) 08.05.15 13:50
(1) lvk74, Конкретнее место ошибки, или кусок кода (так как у меня не разу не выподало)
4. Михаил (Оберон) 13.05.15 11:24
5. Михаил (Оберон) 13.05.15 11:26
Функция СведенияОВнешнейОбработке() Экспорт
    ПараметрыРегистрации = Новый Структура;
    ПараметрыРегистрации.Вставить("Вид", …);
    ПараметрыРегистрации.Вставить("Назначение", …);
    ПараметрыРегистрации.Вставить("Наименование", …);
    ПараметрыРегистрации.Вставить("Версия", …);
    ПараметрыРегистрации.Вставить("Информация", …);
    ПараметрыРегистрации.Вставить("ВерсияБСП", "1.2.1.4");
    Команды = ТаблицаКоманд();
    ДобавитьКоманду(Команды,
                    <Имя команды>,
                    <Идентификатор команды>,
                    <Способ вызова команды>,
                    <Показывать оповещение>,
                    <Модификатор>);
    ПараметрыРегистрации.Вставить("Команды", Команды);
    Возврат ПараметрыРегистрации; 
КонецФункции
Функция ТаблицаКоманд()
    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
    Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
    Возврат Команды;
КонецФункции
Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда.Представление = Представление;
    НоваяКоманда.Идентификатор = Идентификатор;
    НоваяКоманда.Использование = Использование;
    НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
    НоваяКоманда.Модификатор = Модификатор;
КонецПроцедуры
...Показать Скрыть
6. Петр Петров (ni690yandex) 15.05.15 11:03
посмотрел форму на такую ошибку. Это у склада не забит подотчетник. Просто в форме нет проверки на попись. Если у складов поставите ответственных лиц ошибки не будет.
7. Петр Петров (ni690yandex) 15.05.15 11:04
(1) lvk74, В складах заполните ответственных лиц.