gifts2017

Выбор цвета из палитры web цветов 1с в обычной и управляемой формах

Опубликовал Александр Янчук (YaSan) в раздел Программирование - Работа с интерфейсом

Все web цвета 1с на одной форме.
Цвета упорядочены по оттенкам и подписаны.
Вариант для обычной и управляемой формы.

Обработка была разработана для быстрого и наглядного выбора конечным пользователем цветов кнопок меню. Используются именно web цвета 1c – проименованые цвета проще запомнить, чем цифровые коды.

Используются стандартные средства платформы — на формах рисуются кнопки выбора цвета с наименованием цвета и соответствующим фоном кнопки.

Количество строк кнопок можно настраивать в реквизите формы КоличествоСтрок при открытии.

Для использования в конфигурации можно либо встроить обработкой, либо общей формой.

Результатом модального вызова формы есть выбранный web цвет.

Примеры вызова разных вариантов для обычной формы:

 

//Если форма общая
ВыбраныйWebЦвет = ПолучитьОбщуюФорму("ПалитраWebЦветов").ОткрытьМодально();
 
//Если встроена в конфигурацию обработкой
ВыбраныйWebЦвет = Обработки.ВыборWebЦвета.ПолучитьФорму("ПалитраWebЦветов").ОткрытьМодально();
 
Если НЕ ВыбраныйWebЦвет = Неопределено Тогда
        Элемент.ЦветФонаКнопки = ВыбраныйWebЦвет;
        Элемент.Заголовок = ВыбраныйWebЦвет;
КонецЕсли;

 

 

Пример вызова для управляемой формы 8.3:

 

&НаКлиенте
Процедура ПриНажатииДемоКнопки(Команда)
Кнопка = ЭтаФорма.ТекущийЭлемент;
Обработчик = Новый ОписаниеОповещения("ПриВыбореWebЦвета", ЭтаФорма);
Режим = РежимОткрытияОкнаФормы.БлокироватьОкноВладельца;
ДопПарам = Новый Структура("ИмяКнопки", Кнопка.Имя);
 
//Если форма общая
ОткрытьФорму("ОбщаяФорма.ПалитраWebЦветовУправляемая", ДопПарам,,,,, Обработчик, Режим);
 
//Если встроена в конфигурацию обработкой
ОткрытьФорму("Обработка.ВыборWebЦвета.Форма.ПалитраWebЦветовУправляемая", ДопПарам,,,,, Обработчик, Режим);
 КонецПроцедуры
 
&НаКлиенте
Процедура ПриВыбореWebЦвета(ВыбраныйWebЦвет, ДополнительныеПараметры) Экспорт
     Если НЕ ВыбраныйWebЦвет = НеопределеноТогда
       ИмяКнопки = ЭтаФорма.ТекущийЭлемент.Имя;
       Элементы[ИмяКнопки].ЦветФона = ВыбраныйWebЦвет;
        Элементы[ИмяКнопки].Заголовок = ВыбраныйWebЦвет;
   КонецЕсли;
 КонецПроцедуры


Пример вызова для управляемой формы 8.2:

 

  

  //Если форма общая
   ВыбраныйWebЦвет = ОткрытьФормуМодально("ОбщаяФорма.ПалитраWebЦветовУправляемая");
    
    //Если встроена в конфигурацию обработкой
   ВыбраныйWebЦвет = ОткрытьФормуМодально("Обработка.ВыборWebЦвета.Форма.ПалитраWebЦветовУправляемая");
    
    
    //Обработка выбора цвета
Если НЕ ВыбраныйWebЦвет = НеопределеноТогда
        ИмяКнопки = ЭтаФорма.ТекущийЭлемент.Имя;
        Элементы[ИмяКнопки].ЦветФона  = ВыбраныйWebЦвет;
        Элементы[ИмяКнопки].Заголовок = ВыбраныйWebЦвет;
    КонецЕсли; 



 

Для платформ 8.2 и 8.3 обычная форма работает одинаково. Для управляемой формы в платформе 8.3 в отличие от 8.2 используется немодальный вызов формы выбора и расширенная подсказка для кнопок.


Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Обработка ВыборWebЦвета платформа 8.3
.epf 15,92Kb
01.07.15
22
.epf 1.0.83 15,92Kb 22 Скачать
Обработка ВыборWebЦвета платформа 8.2
.epf 18,04Kb
01.07.15
7
.epf 1.0.82 18,04Kb 7 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Алексей (Alexey_) 02.07.15 09:08
В следующих публикациях ждем обработки по выбору файла, вводу строки, числа и т.п.
2. Марина Чирина (chmv) 02.07.15 09:40
3. Allexey (alex_4x) 02.07.15 10:12
Клёво! Красочно! Ярко! Креативно! Но зачем?

4. Александр Янчук (YaSan) 02.07.15 11:36
Зачем - в моем случае пользователи так настраиваются себе интерфейс. Выбирают цвета для кнопок в фронте фастфуда под тачскрин
5. Алексей (Alexey_) 02.07.15 11:42
(4) YaSan, Зачем обработка, когда есть ДиалогВыбораЦвета?
6. Александр Янчук (YaSan) 02.07.15 12:12
(5) Alexey_, Под тачскрин нужны были кнопки побольше. Вот и сделал, чтобы все цвета сразу на виду и пальцем проще тыкать.
7. V. L. (Vladal) 02.02.16 17:45
Молодец.
Я себе тоже ваял чтобы видеть наглядно цвет и как он называется программно.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа