Загрузка остатков по счетам из внешней базы данных (БП 2.0)

Обработки - Свертка базы

Обработка позволяет загрузить остатки регистра Хозрасчетный (остатки по счетам учета ОСВ) из внешней БД в текущую. Загрузка делается через СОМ соединение в документ "Операции, введенные вручную". Можно загрузить остатки по всем счетам или только выбранным.

Для корректного подставления справочников требуется сделать их предварительную загрузку с помощью стандартной обработки "Выгрузка загрузка данных XML". Субконто "Партии" усекается и вместо него подставляется "Документ расчетов с контрагентом (ручной ввод)".

Обработка писалась для свертки базы, в которой было несколько организаций, и создания новой чистой базы с документами только по 1 организации.

Обработку можно использовать:

- При свертке Бухгалтерии и переносе остатков в новую базу.

- Для оперативного обновления остатков в уже свернутой новой БД (свернутой с помощью стандартной свертки), если в старую базу были внесены изменения.

Скачать файлы

Наименование Файл Версия Размер
ЗагрузкаОстатковПоСчетам_из внешней БД
.epf 21,13Kb
07.03.17
1
.epf 21,13Kb 1 Скачать

См. также

Комментарии
1. Серж (Levity) 06.03.17 13:57 Сейчас в теме
что за МодульА, на который ругается при открытии обработки?
2. Серж (Levity) 06.03.17 16:18 Сейчас в теме
по ссылке вообще не то, что указано. верните см
3. Александр Светлаков (alek-sand-er) 8 07.03.17 12:03 Сейчас в теме
(1)Добрый день. Функцию действительно пропустил, прошу прощения! Но если не сворачивать по ставкам НДС розничные счета 41.11 и 42.01 то и без нее работать будет. На всякий случай выложу текст функции:

Функция ЗаменитьНоменклатуруПоСтавке(Номенклатура, Отказ=Ложь) Экспорт
	
	СтавкаНДС = Номенклатура.СтавкаНДС; 
	
	Если 		СтавкаНДС=Перечисления.СтавкиНДС.НДС10 Тогда
		НаименованиеТовара = "Товар по ставке НДС 10%";
	ИначеЕсли 	СтавкаНДС=Перечисления.СтавкиНДС.НДС10_110 Тогда
		НаименованиеТовара = "Товар по ставке НДС 10%";
	ИначеЕсли 	СтавкаНДС=Перечисления.СтавкиНДС.НДС18 Тогда
		НаименованиеТовара = "Товар по ставке НДС 18%";
	ИначеЕсли 	СтавкаНДС=Перечисления.СтавкиНДС.НДС18_118 Тогда
		НаименованиеТовара = "Товар по ставке НДС 18%";
	ИначеЕсли 	СтавкаНДС=Перечисления.СтавкиНДС.НДС20 Тогда
		НаименованиеТовара = "Товар по ставке НДС 20%";
	ИначеЕсли 	СтавкаНДС=Перечисления.СтавкиНДС.НДС20_120 Тогда
		НаименованиеТовара = "Товар по ставке НДС 20%";
	Иначе
		НаименованиеТовара = "Товар по ставке без НДС";
	КонецЕсли; 
	
	Значение = Справочники.Номенклатура.НайтиПоНаименованию(НаименованиеТовара);
	Если НЕ ЗначениеЗаполнено(Значение) Тогда
		Сообщить("Не найден товар с наименованием """+НаименованиеТовара+"""", СтатусСообщения.Важное);
		Отказ = Истина;
	КонецЕсли;	
	
	Возврат Значение;
	
КонецФункции
...Показать Скрыть
4. Александр Светлаков (alek-sand-er) 8 07.03.17 12:05 Сейчас в теме
Оставьте свое сообщение