gifts2017

Изменение связей предопределенных элементов

Опубликовал Анатолий Сычёв (stolya) в раздел Обработки - Универсальные обработки

Обработка для настройки связей предопределенных элементов и объектов информационной базы

В платформе 8.3 реализована возможность связать предопределенные данные с элементами соответствующего типа. Для этого у объектов, которые могут иметь предопределенные элементы (они указаны выше), добавлено новое свойство ИмяПредопределенныхДанных. Оно отображается в списке стандартных реквизитов:

 

Чтобы "отсоединить" элемент данных от элемента предопределенных данных, нужно присвоить свойству ИмяПредопределенныхДанных пустую строку и записать элемент:

&НаКлиенте
Процедура Отсоединить(Команда)
    ОтсоединитьНаСервере();
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ОтсоединитьНаСервере()
    ОбъектДанных = Справочники.Организации.ОсновнаяОрганизация.ПолучитьОбъект();
    ОбъектДанных.ИмяПредопределенныхДанных = "";
    ОбъектДанных.Записать();
КонецПроцедуры

Чтобы связать предопределенный элемент с новой записью, нужно присвоить свойству ИмяПредопределенныхДанных имя предопределенного элемента:

&НаКлиенте
Процедура Привязать(Команда)
    ПривязатьНаСервере();
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ПривязатьНаСервере()
    НайденнаяСсылка = Справочники.Организации.НайтиПоНаименованию("Рога и копыта");
    ОбъектДанных = НайденнаяСсылка.ПолучитьОбъект();
    ОбъектДанных.ИмяПредопределенныхДанных = "ОсновнаяОрганизация";
    ОбъектДанных.Записать();
КонецПроцедуры


Функциональные возможности обработки:

  • Выбор объекта конфигурации, содержащего предопределенные данные
  • Визуальное отображение статуса связи ( - связь установлена,  - связь отсутствует)

Скачать файлы

Наименование Файл Версия Размер
ИзменениеСвязейПредопределенныхЭлементов 2
.epf 11,62Kb
09.09.15
2
.epf 1.0.0.1 11,62Kb Скачать

См. также

Contragent+ 5.0 от 2 500
Подписаться Добавить вознаграждение

Комментарии

1. Сергей Галюк (dj_serega) 04.08.15 11:03
2. Анатолий Сычёв (stolya) 04.08.15 17:15
(1) dj_serega,
На это были следующие причины:
1. В этой обработке реализован альтернативный интерфейс по управлению связей предопределенных элементов (на мой взгляд минимальный и достаточный).
2. Я хотел сделать эту обработку бесплатной (что у меня и не получилось, настройка не сохранилась). Сейчас задал вопрос в техническую поддержку для выяснения причины. Как выясню, сразу поменяю на бесплатное скачивание.
3. У меня нету средств для скачивания разработок, поэтому выложил свой вариант обработки.

Основными причинами были пункт 2 и 3.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа