gifts2017

Открытие из обработки табличного документа в общей форме "ПечатьДокументов" с помощью БСП

Опубликовал Петр . (IncomeGroup) в раздел Печать - Универсальные печатные формы

В статье описан механизм создания обработки, табличный документ из которой можно непосредственно вывести в типовую форму печати БП 3.0 и УТ 11.1 (редакция БСП начиная с 2.2.4.43, где-то начало 2015 года). С помощью данного механизма удобно отлаживать печатные формы или создавать внешние обработки, выводящие что-нибудь на печать.

В модуле формы размещаем команду печати с вызовом процедуры на клиенте. В связи с тем, что обработка параллельно используется для формирования внешней печатной формы, то процедура формирования табличного документа находится в модуле обработки и вызвать непосредственно с клиента её мы не можем, следовательно, вызовем серверную процедуру, которой передаем параметр и которая в свою очередь вызывает функцию, формирующую табличный документ.

&НаКлиенте
Перем ТабДокумент;

&НаСервере
Процедура ПолучитьТабличныйДокумент(ТабДокумент)
	Обработка = РеквизитФормыВЗначение("Объект");
	ТабДокумент = Обработка.ПечатьВнешняя(Неопределено, Неопределено);
КонецПроцедуры

&НаКлиенте
Процедура КомандаПечать(Команда)	
	ПолучитьТабличныйДокумент(ТабДокумент);
...

процедура печати в модуле обработки

// Процедура возвращает табличный документа
//
Функция ПечатьВнешняя(МассивОбъектов, ОбъектыПечати) Экспорт
	ТабДокумент = Новый ТабличныйДокумент;
	Макет = ПолучитьМакет("Макет");
	Область = Макет.ПолучитьОбласть("Заголовок");
	Область.Параметры.Дата = ТекущаяДата();
	ТабДокумент.Вывести(Область);
	
	Возврат ТабДокумент;
КонецФункции

При открытии общей формы "ПечатьДокументов", все важные процессы происходят в процедуре "ПриСозданииНаСервере" и вызываемых ею других процедурах и функциях, в целом основная загвоздка была в том, что переменная "КоллекцияПечатныхФорм" при получении данных из внешней печатной формы и стандартной процедуры печати возвращала таблицу значения, но из модуля формы на клиенте таблицу значений передать в открываемую форму нельзя, по этой причине нужно эмулировать таблицу в виде Структуры входящий в Массив. 

//Для стандартных печатных форм используется таблица значений, но создать её на клиенте нельзя
	//по этой причине воспользуемся массивом и структурой 
	КоллекцияПечатныхФормСтруктура = Новый Структура;
	КоллекцияПечатныхФормСтруктура.Вставить("СинонимМакета"        , Неопределено);
	КоллекцияПечатныхФормСтруктура.Вставить("Экземпляров"          , 1);
	КоллекцияПечатныхФормСтруктура.Вставить("ИмяМакета"            , Неопределено);
	КоллекцияПечатныхФормСтруктура.Вставить("ПолныйПутьКМакету"    , Неопределено);
	КоллекцияПечатныхФормСтруктура.Вставить("ИмяФайлаПечатнойФормы", Неопределено);
	КоллекцияПечатныхФормСтруктура.Вставить("ТабличныйДокумент"    , ТабДокумент);	
	КоллекцияПечатныхФорм = Новый Массив;
	КоллекцияПечатныхФорм.Добавить(КоллекцияПечатныхФормСтруктура);
	
	ПараметрыПечати = Новый Структура("ДополнительныеПараметры", Новый Структура);
	//если значение будет Ложь, то система попытается восстановить пользовательские настройки, которых у нас нет
	ПараметрыПечати.Вставить("ПереопределитьПользовательскиеНастройкиКоличества", Истина);	
	//заголовок печатной формы
	ПараметрыПечати.Вставить("ЗаголовокФормы", "Заголовок моей печатной формы");
	
	ПараметрыОткрытия = Новый Структура;
	//не важно, какое значение лишь бы было заполнено, иначе будет ошибка
	ПараметрыОткрытия.Вставить("ИсточникДанных"       , "ВнешняяОбработка");
	ПараметрыОткрытия.Вставить("ПараметрыПечати"      , ПараметрыПечати);	
	ПараметрыОткрытия.Вставить("КоллекцияПечатныхФорм", КоллекцияПечатныхФорм);	
	ОткрытьФорму("ОбщаяФорма.ПечатьДокументов", ПараметрыОткрытия);	
	
КонецПроцедуры

Пример обработки можно скачать ниже.

Скачать файлы

Наименование Файл Версия Размер
Открытие ТД из формы обработки в форме ПечатьДокументов.epf 8
.epf 9,69Kb
01.09.15
8
.epf 9,69Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Ян Декс (infostartfilipich) 17.02.16 12:27
2. v i (vis_tmp) 18.11.16 09:17
Большое спасибо - всё работает!
3. v i (vis_tmp) 18.11.16 09:33
http://infostart.ru/public/402197/

А вот есть ещё похожий вариант - только там "КоллекцияПечатныхФорм" формируется не вручную, а вызовом типовой функции.