gifts2017

Открытие форм нескольких новых документов в тонком и толстом клиенте, УФ

Опубликовал Илья Соловьев (Wezoowy) в раздел Программирование - Работа с интерфейсом

Если Вам необходимо создать несколько документов, а затем открыть их формы для пользователя.

Читая этот ресурс и безудержно юзая Гугл, мне так и не удалось найти информацию о том, как выполнить следующую задачу.

Итак:

Необходимо программно сформировать несколько документов Поступления товаров и показать пользователю формы этих документов. Формироваться эти документы должны на сервере, количество их неизвестно и зависит от текущего состояния информационной базы (к примеру, от остатков на складах).
Конфигурация - типовая УТ 11. Править ее крайне нежелательно.
Работают пользователи в клиент-серверном режиме, используют тонкий и толстый клиенты...

Как создать один новый документ и открыть его форму написано тут или тут.

Однако мне надо было несколько документов.

Вариант решения такой. Для толстого клиента все более/менее ясно:

1. На сервере создаем массив новых объектов типа документ "ПоступлениеТоваровУслуг" с разным заполнением.

2. На клиенте обходим этот массив в цикле, попутно создавая новые формы документов и заполняя их значениями тех объектов, что были созданы ранее.

 

&НаСервере
Функция ПолучитьМассивНовыхДокументовНаСервере()
	
    // Создадим массив из нескольких документов 
    // с разным наполнением (для примера - разные организации)
    // для того, чтобы при открытии форм было сразу понятно, что 
    // это два разных документа
	
    МассивНовыхДокументов = Новый Массив;
    
    НовДок = Документы.ПоступлениеТоваровУслуг.СоздатьДокумент();
    НовДок.Организация = Справочники.Организации.НайтиПоНаименованию("Компания 1");
    
    МассивНовыхДокументов.Добавить(НовДок);
    
    
    НовДок = Документы.ПоступлениеТоваровУслуг.СоздатьДокумент();
    НовДок.Организация = Справочники.Организации.НайтиПоНаименованию("Компания 2");
    
    МассивНовыхДокументов.Добавить(НовДок);
    
    Возврат МассивНовыхДокументов;

КонецФункции

&НаСервере
Функция ЗаполнитьДанныеФормыНаСервере(ДанныеФормыДокумента, НовыйДокументОбъект)
	
    // Здесь происходит непосредственное заполнение
    // Объекта из данных формы документа
    // тем документом, который был создан
    // в процедуре ПолучитьМассивДокументовНаСервере() 
	
    мОбъект = ДанныеФормыВЗначение(ДанныеФормыДокумента, ТипЗнч(НовыйДокументОбъект));
    ЗаполнитьЗначенияСвойств(мОбъект, НовыйДокументОбъект);
    ЗначениеВДанныеФормы(мОбъект, ДанныеФормыДокумента);
    
КонецФункции

&НаКлиенте
Процедура кнОткрытьФормыНовыхДокументов(Команда)
	
    // Кнопка на клиенте (на форме обработки) 
    // из которой необходимо создать 
    // и заполнить несколько новых документов.
    // Количество создаваемых объектов определяется в
    // процедуре ПолучитьМассивДокументовНаСервере()
    
    // 1. На сервере создаем массив новых объектов типа документ "ПоступлениеТоваровУслуг" с разным заполнением.
    МассивНовыхДокументов = ПолучитьМассивНовыхДокументовНаСервере();
    // 2. На клиенте обходим этот массив в цикле, попутно создавая новые формы документов и заполняя их значениями тех объектов, что были созданы ранее.
    Для Каждого НовыйДокументОбъект Из МассивНовыхДокументов Цикл
        
        ФормаДокумента = ПолучитьФорму("Документ.ПоступлениеТоваровУслуг.ФормаОбъекта",,,Истина);
        ДанныеФормыДокумента = ФормаДокумента.Объект;
        
        ЗаполнитьДанныеФормыНаСервере(ДанныеФормыДокумента, НовыйДокументОбъект);
        
        КопироватьДанныеФормы(ДанныеФормыДокумента, ФормаДокумента.Объект);
        
        ФормаДокумента.Открыть();
        
    КонецЦикла;
    
КонецПроцедуры

 

Для тонкого клиента все сложнее. В тонком клиенте 1С начинает ругаться: "Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа". Это в момент передачи массива новых документов с сервера на клиент.

Как пришлось выкручиваться:

1. Точно также создаем массив новых документов.

2. Помещаем этот массив во временное хранилище. На клиент передаем только адрес этого хранилища.

3. На клиенте создаем цикл из такого количества итераций, сколько элементов есть в массиве.

4. В цикле создаем формы новых документов, при этом заполняя их данными из созданного массива документов. А к массиву обращаемся через адрес хранилища.

&НаСервере
Функция ПолучитьМассивНовыхДокументовНаСервере()
	
    // Создадим массив из нескольких документов 
    // с разным наполнением (для примера - разные организации)
    // для того, чтобы при открытии форм было сразу понятно, что 
    // это два разных документа
	
    МассивНовыхДокументов = Новый Массив;
    
    НовДок = Документы.ПоступлениеТоваровУслуг.СоздатьДокумент();
    НовДок.Организация = Справочники.Организации.НайтиПоНаименованию("Компания 1");
    
    МассивНовыхДокументов.Добавить(НовДок);
    
    
    НовДок = Документы.ПоступлениеТоваровУслуг.СоздатьДокумент();
    НовДок.Организация = Справочники.Организации.НайтиПоНаименованию("Компания 2");
    
    МассивНовыхДокументов.Добавить(НовДок);
    
    Возврат МассивНовыхДокументов;

КонецФункции

&НаСервере
Функция ПолучитьАдресМассиваНовыхДокументовНаСервере()
	
    // Поместим массив с документами во временное хранилище
    // для того, чтобы иметь возможность обращаться к нему
    // со стороны клиента (передавая на сервер адрес хранилища)
	
    МассивНовыхДокументов = ПолучитьМассивНовыхДокументовНаСервере();
    
    // 2. Помещаем этот массив во временное хранилище. На клиент возвращаем только адрес этого хранилища.
    АдресМассиваНовыхДокументов = ПоместитьВоВременноеХранилище(МассивНовыхДокументов, Новый УникальныйИдентификатор);
    
    Возврат АдресМассиваНовыхДокументов;
        
КонецФункции

&НаСервере
Функция ЗаполнитьДанныеФормыТонкийКлиентНаСервере(ДанныеФормыДокумента, НомерОбъекта, АдресМассиваНовыхДокументов)
    
    // Здесь происходит непосредственное заполнение
    // Объекта из данных формы документа
    // тем документом, который был создан
    // в процедуре ПолучитьМассивДокументовНаСервере() 
	
    МассивНовыхДокументов = ПолучитьИзВременногоХранилища(АдресМассиваНовыхДокументов);
    НовыйДокументОбъект = МассивНовыхДокументов[НомерОбъекта];
    ЗаполнитьДанныеФормыНаСервере(ДанныеФормыДокумента, НовыйДокументОбъект);
    
КонецФункции

&НаСервере
Функция ПолучитьКоличествоНовыхДокументов(АдресМассиваНовыхДокументов)
    
    МассивНовыхДокументов = ПолучитьИзВременногоХранилища(АдресМассиваНовыхДокументов);
    
    Возврат МассивНовыхДокументов.Количество();
    
КонецФункции

&НаКлиенте
Процедура кнОткрытьФормыНовыхДокументовТонкийКлиент(Команда)

    // 1. Точно также создаем массив новых документов.
    АдресМассиваНовыхДокументов = ПолучитьАдресМассиваНовыхДокументовНаСервере();
    
    КоличествоНовыхДокументов = ПолучитьКоличествоНовыхДокументов(АдресМассиваНовыхДокументов);
	
    // 3. На клиенте создаем цикл из такого количества итераций, сколько элементов есть в массиве.
    Для НомерОбъекта = 0 По КоличествоНовыхДокументов - 1 Цикл
        
        ФормаДокумента = ПолучитьФорму("Документ.ПоступлениеТоваровУслуг.ФормаОбъекта",,,Истина);
        ДанныеФормыДокумента = ФормаДокумента.Объект;
		
        // 4. В цикле создаем формы новых документов, при этом заполняя их данными из созданного массива документов. А к массиву обращаемся через адрес хранилища.
        ЗаполнитьДанныеФормыТонкийКлиентНаСервере(ДанныеФормыДокумента, НомерОбъекта, АдресМассиваНовыхДокументов);
        
        КопироватьДанныеФормы(ДанныеФормыДокумента, ФормаДокумента.Объект);
        
        ФормаДокумента.Открыть();
        
    КонецЦикла;
    
КонецПроцедуры

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Артем Целовальников (slazzy) 30.09.15 10:18
Зачем делать столько костылей...
2. Илья Соловьев (Wezoowy) 30.09.15 12:03
(1) slazzy, если Вы напишите как это сделать без костылей - я буду очень благодарен.
3. Артем Целовальников (slazzy) 30.09.15 12:07
&НаСервереБезКонтекста
Функция СформироватьМассивДокументов()
        
    МассивНовыхДокументов = Новый Массив;
    МассивНовыхДокументов.Добавить(Новый Структура("Организация", Справочники.Организации.НайтиПоНаименованию("Управленческая организация")));
    МассивНовыхДокументов.Добавить(Новый Структура("Организация", Справочники.Организации.НайтиПоНаименованию("Стройснаб")));
   
    Возврат МассивНовыхДокументов;

КонецФункции


&НаКлиенте
Процедура СоздатьДокументы(Команда)
	МассивДокументов = СформироватьМассивДокументов();
	
	Для Каждого Документ из МассивДокументов Цикл
		ПараметрыОткрытия = Новый Структура;
		ПараметрыОткрытия.Вставить("ЗначенияЗаполнения", Документ);
		ОткрытьФорму("Документ.ПоступлениеТоваровУслуг.Форма.ФормаДокумента", ПараметрыОткрытия, ЭтаФорма, Истина);
	КонецЦикла;
	
КонецПроцедуры
...Показать Скрыть


Всё зависит от того какие реквизиты надо заполнить при открытии и заполняются ли эти реквизиты автоматически в уже существующей процедуре ОбработкаЗаполнения. В типовой УТ11 заполняется часть реквизитов и их можно передать через параметр ЗначенияЗаполнения, в таком случае вызов аналогичен вызову из динамического списка с отборами.
Если эти реквизиты не заполняются(зависит от конфигурации) то можно придумать разные варианты. Можно дописать подписку, можно расширение, можно переопределяемый модуль(он создан для того чтобы его переписывать).

В любом случае программное открытие формы в 99% случаев надо делать через ОктрытьФорму(..) с параметрами...и как показывает практика почти всё и всегда можно решить через эти параметры.
ЗЫ В типовой УТ почему-то довольно криво описаны варианты заполнения конкретно для этих документов, но всё равно даже этим кодом можно воспользоваться.
4. Илья Соловьев (Wezoowy) 30.09.15 12:24
(3) slazzy, Спасибо, хороший вариант. Но суть как раз в том, что у меня нет возможности править конфу заказчика. Но при этом конфа изменена, добавлены реквизиты в документ, в ТЧ. Механизм нужен был полностью независимый.
5. Яков Коган (Yashazz) 02.10.15 18:05
(4) Wezoowy, может, я чего не понял, но делать можно так.

а) Предположим, можно обойтись внешней обработкой по пинку пользователя. Тогда на сервере создаются документы, заполняются все нужные реквизиты, и возвращаются ссылки на свежесделанные документы, каковые в цикле на клиенте и открываются. Элементарно. Никакого вмешательства в типовую.

б) Предположим, действие должно происходить по событию, которое случается на сервере. Тогда подключаете глобальный обработчик ожидания с разумным периодом, делаете свой клиентский модуль с процедурой, или опять же обработку, которую этот обработчик пинает. Пинок можно выполнять по факту некоего триггера. Массив открываемых документов либо определяется "по месту", либо при создании загоняем в хранилище и потом берём из него. Не очень страшное вмешательство в типовую.

В любом случае, советую почитать ИТС и советы, как заполнять данными формы новых документов и как их вообще можно открывать.

P.S. УТ 11 может работать в режиме толстого клиента???
6. Илья Соловьев (Wezoowy) 03.10.15 00:31
(5) Yashazz,
а) все верно, если документы записать, то да, просто передать ссылки и открыть. НО! Должны были быть открыты формы новых (незаписанных) документов (Я не указал в описании, извиняюсь).
б) Вмешательство в конфу - крайне нежелательно...

А насчет толстого клиента - таки а почему нет? УФ, толстый клиент.
7. Роман Ложкин (webester) 04.10.15 07:45
В похожих статьях как раз есть статья в которой есть и процесс и отсылки в гугол и мой c##ч с автором на тему да RTFM же!
8. Sema Sema (Sema76) 01.11.15 08:58
Спасибо! Отличная статья! Все работает! Я сначала пытался получить таблицу значений с сервера на клиенте. Оказывается это совсем не нужно. (Время зря только тратил.) Мне надо на основании одного документа создать несколько в зависимости от данных табличной части. Все получилось.
Для полноты. Как заполнить табличную часть.
http://its.1c.ru/db/metod8dev/content/2322/hdoc
9. Гость 30.05.16 00:57
Строка "ФормаДокумента.Объект" не работает. Пишет, что поле "Объект" не найдено.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа