gifts2017

Контроль уникальности элементов справочника по произвольному количеству реквизитов, с использованием "И"

Опубликовал Вячеслав Салин (juker) в раздел Программирование - Практика программирования

Суть описанной мною методологии, в принципе, не ноу-хау, но, поискав на этом ресурсе подобное решение, не нашел.
Универсальный механизм поиска возможного дубликата по произвольному количеству реквизитов через логический "И" при попытке сохранения нового элемента справочника.
Поискав алгоритмы, создал свой.

Методология основана на динамическом формировании текста запроса, где запрос формируется относительно контролируемого объекта и списка реквизитов контроля через "И".
В моем примере используется общий модуль, в котором находится функция контроля возвращающая булево (можно записать или нет).
Функция работает только с объектами "Справочник".

Мне был необходим функционал из заголовка.

Ядро 1С 8.3, конфигурация "СамИздат".

Собственно реализация этой возможности тривиальна:

В моделу объекта в теле процедуры "ПередЗаписью" вставляем код:

Процедура ПередЗаписью(Отказ) 
	ИмяОбъекта = ЭтотОбъект.Метаданные().Имя;
	СтрРеквизитов = Новый Структура; //
	СтрРеквизитов.Вставить("Наименование", Наименование);
	Если Не ОбщегоНазначения.ПрошелКонтрольУникальностиСправочникаПоРеквизиту(ИмяОбъекта, СтрРеквизитов, Ссылка) Тогда
		Сообщить("Подобный элемент справочника /" + Наименование + "/ существует!
				|Модуль: Контроль уникальности элементов справочника." );
		Отказ = Истина;
	КонецЕсли;
КонецПроцедуры

Далее в общем модуле (в моем случае это "ОбщегоНазначения") создаем функцию:

&НаСервере
Функция ПрошелКонтрольУникальностиСправочникаПоРеквизиту(ИмяОбъекта, СтрРеквизитов, ЗначениеСсылка) Экспорт

	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ ПЕРВЫЕ 1
	|	Спр.Ссылка
	|ИЗ
	|	Справочник." + ИмяОбъекта + " КАК Спр
	|ГДЕ
	|	Спр.Ссылка <> &парЗначениеСсылка
	|"; 	
	Нум = 0;
	Для Каждого Знч Из СтрРеквизитов Цикл
		ИмяПараметраВЗапросе = " = &Пар" + Строка(Нум);
		Запрос.Текст = Запрос.Текст + " И Спр." + Знч.Ключ + ИмяПараметраВЗапросе; 
		Запрос.УстановитьПараметр("Пар" + Строка(Нум),	Знч.Значение);
		Нум = Нум + 1;
	КонецЦикла;	
	Запрос.УстановитьПараметр("парЗначениеСсылка", 		ЗначениеСсылка);		
	РезультатЗапроса = Запрос.Выполнить();
        Возврат РезультатЗапроса.Пустой(); 
КонецФункции

Собственно, всё.

Наведен марафет в функции по рекомендациям NeviD
Спасибо. 

Как просто сделать сложно и как сложно сделать просто.

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Дмитрий Царапкин (NeviD) 26.04.16 17:03
1. Зачем нужно добавлять в запрос "СГРУППИРОВАТЬ ПО"? Там же и так уникальные значения будут.
2. Смысл вводить переменную ЗначениеУникально, если она всё равно не меняется и всегда = Ложь?
3. На мой взгляд, лучше в названии параметров не использовать Счетчик, а называть Ключом из СтрРеквизитов. Тогда и нагляднее, если результирующий текст запроса смотреть, и ошибки не будет, если (вдруг) количество параметров будет больше 999.
4. Не нужно получать Выборку и начинать обход цикла. Просто:
Возврат НЕ РезультатЗапроса.Пустой();


И работает только для справочников... Хоть для документов добавить...
В общем, как то слабовато для публикации.
2. Пишу код как картины (yurii_host) 27.04.16 00:51
Вообще для контроля уникальности лучше использовать регистры сведений. См., например, в ERP справочник КлючиАналитикиУчетаНоменклатуры и регистр сведений АналитикаУчетаНоменклатуры. Да и сама функция в общем-то элементарная, проще написать, чем искать где-то
3. Вячеслав Салин (juker) 27.04.16 09:11
(1) NeviD,
1. Группировка осталась как аппендикс.
2. Та же история как и в п.1
3. Да, так намного читабельнее.
4. Тоже верное замечание.
Работает только для справочников - Надо было перефразировать - Применяю только для объектов типа "Справочник".
Слабовато для публикации - Это чисто субъективная оценка.

И спасибо за комментарии.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа