gifts2017

Гибкий подбор расчетного счета в зависимости от контрагента, договора в БП 2.0

Опубликовал Sergey A (serg_info) в раздел Программирование - Практика программирования

Минимальные изменения в конфигурации, не мешает обновлениям.

Алгоритм установки предопределенных р/с организации в зависимости от выбранного Контрагента / Договора

Используется механизм дополнительных реквизитов.
Для контрагентов и для их договоров создается доп. реквизит «Счет организации»

Далее из списка или карточки контрагента/договора вызывается диалог ввода дополнительных реквизитов см. картинку.


При оформлении счета будет происходить следующее:
при выборе договора (в т.ч. и автоматической подстановке основного договора из карточки контрагента) будет проверяться

                А) есть ли переопределение для счета организации на уровне договора (максимальный приоритет)

                Б) есть ли переопределение счета организации на уровне контрагента.

Если такое переопределение есть, то считывается значение, которое должно быть равно № р/с для замены назначенного по умолчанию. При подмене осуществляется контроль того, что счет принадлежит именно той организации, от имени которой происходит выписка счета.

Т.о. подмену счетов можно осуществлять на уровне контрагентов всегда только по какой-то одной организации, а на уровне договоров такого ограничения нет, т.к. сам договор привязан к конкретной организации и к конкретному контрагенту.

Механизм подмены работает ТОЛЬКО в счетах. Далее реквизит «распространяется» благодара механизму ввода на основании.


Для работы алгоритма нужно в процедуру, запускаемую при выборе/изменении договора вставить вызов своей функции, которая будет возвращать ссылку на другой расчетный счет.


Примерно вот так:

 

Процедура ПриИзмененииДоговора()

//..........


 //подмена расчетного счета при изменении договора....
новРС = нтлОбщийМодуль.нтлВыбоаРСОрганизацииПоДоговору(ДоговорКонтрагента, Организация);
Если Не новРС = Неопределено Тогда
  СтруктурнаяЕдиница = новРС;
КонецЕсли;

УстановитьВидимость();

 КонецПроцедуры // ПриИзмененииДоговора()



Саму процедуру промещаем в любой общий модуль (желательно "свой", чтобы не мешать обновлению)


 

Функция нтлВыбоаРСОрганизацииПоДоговору(СсылкаДоговор, СсылкаОрганизация) Экспорт
Перем возврЗначение;

 

возврЗначение = Неопределено;

 

 Запрос = Новый Запрос;
 Запрос.Текст =
  "ВЫБРАТЬ
  | ЗначенияСвойствОбъектов.Объект,
  | ЗначенияСвойствОбъектов.Свойство,
  | ЗначенияСвойствОбъектов.Значение
  |ИЗ
  | РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
  |ГДЕ
  | ЗначенияСвойствОбъектов.Объект = &Объект
  | И ЗначенияСвойствОбъектов.Свойство.Наименование = &Наименование";

 

 Запрос.УстановитьПараметр("Наименование", "Счет организации");
 Запрос.УстановитьПараметр("Объект", СсылкаДоговор);

 

 Результат = Запрос.Выполнить();

 

 ВыборкаДетальныеЗаписи = Результат.Выбрать();
 
 тНомерСчета = "";
 Если Не ВыборкаДетальныеЗаписи.Следующий() Тогда
  Запрос = Новый Запрос;
  Запрос.Текст =
   "ВЫБРАТЬ
   | ЗначенияСвойствОбъектов.Объект,
   | ЗначенияСвойствОбъектов.Свойство,
   | ЗначенияСвойствОбъектов.Значение
   |ИЗ
   | РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
   |ГДЕ
   | ЗначенияСвойствОбъектов.Объект = &Объект
   | И ЗначенияСвойствОбъектов.Свойство.Наименование = &Наименование";

 

  Запрос.УстановитьПараметр("Наименование", "Счет организации");
  Запрос.УстановитьПараметр("Объект", СсылкаДоговор.Владелец);

 

  Результат = Запрос.Выполнить();

 

  ВыборкаДетальныеЗаписи = Результат.Выбрать();
  Если ВыборкаДетальныеЗаписи.Следующий() Тогда
   тНомерСчета = СокрЛП(ВыборкаДетальныеЗаписи.Значение);  
  КонецЕсли;  
 Иначе
  тНомерСчета = СокрЛП(ВыборкаДетальныеЗаписи.Значение);  
 КонецЕсли; 
 
 Если НЕ ПустаяСтрока(тНомерСчета) Тогда

//тут кто понимает сам допишет, а кому лень можно скачать полный код из файла :-)

 КонецЕсли; 
 
 Возврат возврЗначение;
 
КонецФункции

 

Вот, собственно, и все.

Скачать файлы

Наименование Файл Версия Размер
ВыборРСОрганизацииПоДоговору
.txt 4,02Kb
17.10.15
0
.txt 1 4,02Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Ийон Тихий (cool.vlad4) 18.10.15 17:00
может я ошибаюсь, конечно , но если вы все равно меняете конфу, то не проще ли просто добавить новый реквизит , чем мучаться со свойствами? (может возникнуть вопрос для чего вообще тогда свойства. мне кажется для конфы , которую менять не хочется, а нужно некий доп реквизит для внешних отчетов, обработок и печ. форм.). обновлению новый реквизит не помешает, особенно если его назвать с добавлением префикса.
2. Sergey A (serg_info) 18.10.15 23:48
Да как бы не хотелось затрагивать справочники и формы справочников....
Документ счет - это то что можно и поправить, даже если его не обновлять вообще ничего не затронет в конфигурации.
Мне так показалось менее затратно. А доп. реквизиты нужны ТОЛЬКО для переопределения р/с организации при выписки счетов. Далее уже все стандартными механизмами расползается.

Можно конечно было и на подписку на событие повесить переопределение р/с, но тогда не наглядно получается увы....