gifts2017

Доработка WYSIWYG редактор HTML (управляемые формы) / ядро 8.3.3 и выше

Опубликовал Александр Шальнов (Shalnov) в раздел Программирование - Работа с интерфейсом

Теперь редактор работает в веб-клиенте без использования модальности + легко можно встроить в свою форму

Для одного из проектов понадобился редактор HTML, но заказчик хотел его вставить в 5 форм.

Варианты использовать кнопку "Редактировать" и стандартный 1С-ый "ФорматированныйДокумент" его не устраивали.

Нашел тут замечательный вариант http://infostart.ru/public/75313/. Узнав, что он  используется в разработке http://infostart.ru/public/252472/ скачал ее и решил вначале переделать его для быстрой вставки в любую форму.

Все получилось, но вылез нюанс, редактор не работал в веб-клиенте, и заказчик попросил доработать выбор цвета под его "хотелки".

В итоге получился немного доработанный редактор, который можно вставить в свою форму. Работает как под тонким, так и под веб-клиентом (единственное, не работает кнопка вставить из буфера в веб-клиенте, но заказчик принял в таком виде, сказав, что все равно пользуется ctrl+v, а дорабатывать было уже лень).

Порядок интеграции

1. Загрузить конфигурацию через объединение, выделить по подсистеме файла (подсистема "РедакторHTML")

2. Открыть форму "ФормаЭлемента" справочника справочника "ПримерПримененияРедактора"

3. Откройте форму, в которую нужно скопировать редактор

4. Скопируйте в свою форму реквизит ПолеHTMLДокумента

5. Скопируйте в свою форму элемент формы группу "ГруппаHTMLРедактор"

6. Определите, из конструктора формы, процедуры: ПриСозданииНаСервере, ПриОткрытии, ПередЗаписью. (если они не определены)

7. Если у вас новая форма, то просто скопируйте содержимое модуля формы,  если добавляете в уже существующую форму, копируем все кроме процедур ПриСозданииНаСервере,ПриОткрытии,ПередЗаписью, а в эти процедуры в начало модуля процедур копируем строки из соотвествующей процедуры

8. В процедуре "ПриОткрытии", заменяем значение переменной РеквизитОбъектаДляЗаписиHTML, на идентификатор реквизита объекта, где будет храниться HTML документ (тип строка)

9. Если нужно хранить текстовое представление, то в процедуре "ПередЗаписью" заменяем

//Объект.Наименование = Элементы.ПолеHTMLДокумента.Документ.body.innerText;

 на свой код

Скачать файлы

Наименование Файл Версия Размер
Редактор HTML 53
.cf 65,33Kb
27.10.15
53
.cf 2.1 65,33Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Олег Дмитров (baracuda) 28.10.15 15:28
2. ivanov660 ivanov660 (ivanov660) 28.10.15 16:17
Зачем изобретать свой велосипед, можно и нужно использовать готовые и предназначенные для этого решения, к примеру, использовать полноценные редакторы html на javascrip Визуальный html редактор на управляемых формах.
Думаю, что 1С не скоро (совсем не уверен) встроит полноценный hml редактор, будущее за сторонними компонентами, учитывая что впереди маячит работа на "Эклипс".
3. Александр Шальнов (Shalnov) 28.10.15 19:26
(2) ivanov660, Показывал, заказчик отказался...
4. ivanov660 ivanov660 (ivanov660) 28.10.15 20:44
(3) Shalnov, чудной заказчик, т.к. на этих редакторах более половины интернета работает )))
5. Андрей Акулов (DrAku1a) 02.11.15 03:30
А можно подробнее - чем не устроил "Форматированный документ"?
6. Александр Шальнов (Shalnov) 02.11.15 10:41
(5) DrAku1a, Не поддерживает полноценно html. Попробуйте вставить через буфер обмена скопированную таблицу со странички в интернете или даже часть любой печатной формы 1с.
7. Олег Кострицын (recon) 20.01.16 20:26
Добавлю от себя, глюки работы остались от старой версии. К примеру процедура ВыполнитьКомандуСписка()

&НаКлиенте
Процедура ВыполнитьКомандуСписка(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
	
	Команда = Сред(Элемент.Имя, 8);
	Если Элементы.ПолеHTMLДокумента.Документ.queryCommandSupported(Команда) Тогда
		Список = Элемент.СписокВыбора;
		Элементы.ПолеHTMLДокумента.Документ.execCommand(Команда, Истина, ВыбранноеЗначение);
		ПоказатьРежимыКнопок();
	КонецЕсли;
	ЭтаФорма.ТекущийЭлемент = Элементы.ПолеHTMLДокумента;
	
КонецПроцедуры
...Показать Скрыть


Команда queryCommandSupported и execCommand применяется ко всему документу, в результате сделать изменение только куска выделенного текста нельзя.Это относится ко всем функциям форматирования в этом редакторе.

Как вариант, изменил ее у себя на проекте:

&НаКлиенте
Процедура ВыполнитьКомандуСписка(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
	Если Элементы.ПолеHTMLДокумента.Документ = Неопределено Тогда
		Возврат;
	КонецЕсли;
	
	ТекВыделение = Элементы.ПолеHTMLДокумента.Документ.selection;
	Если ТекВыделение = Неопределено Тогда
		Возврат;
	Иначе
		УзелЭлемента = ТекВыделение.createRange();
	КонецЕсли;
	
	Команда = Сред(Элемент.Имя, 8);
	Если УзелЭлемента.queryCommandSupported(Команда) Тогда
		УзелЭлемента.execCommand(Команда, Истина, ВыбранноеЗначение);
		ПоказатьРежимыКнопок();
	КонецЕсли;
	ЭтаФорма.ТекущийЭлемент = Элементы.ПолеHTMLДокумента;
	ЭтаФорма.Модифицированность = ИСтина;
	
КонецПроцедуры
...Показать Скрыть


Но в результате этот код работает только в IE(ну и в тонком клиенте т.к. там урезанный IE7)
А в мозилле или хроме код выдает ошибку т.к. получение выделения там реализовано по другому, пока эту проблему не поборол. Методы которые предлагают разработчики мозиллы не работают т.к. 1С возвращает в Элементы.ПолеHTMLДокумента.Документ в этом случае непонятную хрень с типом "ВнешнийОбъект" и без описания методов и свойств

Может знаете как побороть эту проблему?
8. Олег Кострицын (recon) 21.01.16 11:03
(2) ivanov660, проблем с редактором на javascript несколько: во первых это место и трафик. Для того чтобы у пользователя запустился редактор я должен выкачать на клиента от 3х до 5ти мегабайт трафика. При медленном канале это серьезное замедление работы
Во вторых проблемы запуска скриптов. Во многих организациях запуск скриптов заблокирован, плюс часто пользователи работают на серверах где еще включен режим усиленной безопасности windows что приводит к ошибкам при запуске скриптов (ведь тонкий клиент работает через движок IE). Получается чтобы заставить такой редактор работать у пользователя также нужно сделать настройку браузера и системы
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа