gifts2017

XDTO на службе у лентяев. Самый простой способ чтения xml

Опубликовал Вася Пупкин (Ks_83) в раздел Программирование - Практика программирования

Это статья для лентяев.
Никаких описаний свойств и методов xdto здесь нет. Тем более здесь нет описания формата xml.
Здесь лишь простой и удобный метод чтения xml для тех, кому нужно получить быстрый результат без углубления в теоретические дебри.

Описание проблемы (лентяям можно пропустить):

На Инфостарте немало  статей по работе с XDTO. Они  довольно обширные и требуют времени для изучения и не всегда в них находится сразу то, что нужно в данный момент. Эта маленькая статейка для кодера  (а ля синтакс-помощник), после которой он сразу сможет загрузить несложный  файл обмена из сторонней базы. Честно говоря, чтобы прийти к тому простейшему коду, который указан ниже, мне пришлось читать и о пакетах XDTO, о схемах xml и способе их создания и т.п., получая ту информацию, которая в данный момент мне пока не пригодилась. Все оказалось намного проще.

Собственно суть:

Итак, в качестве примера возьмем образец xml-файла от микрософт.

<?xml version="1.0"?>
<PurchaseOrder PurchaseOrderNumber="99503" OrderDate="1999-10-20">
  <Address Type="Shipping">
    <Name>Ellen Adams</Name>
    <Street>123 Maple Street</Street>
    <City>Mill Valley</City>
    <State>CA</State>
    <Zip>10999</Zip>
    <Country>USA</Country>
  </Address>
  <Address Type="Billing">
    <Name>Tai Yee</Name>
    <Street>8 Oak Avenue</Street>
    <City>Old Town</City>
    <State>PA</State>
    <Zip>95819</Zip>
    <Country>USA</Country>
  </Address>
  <DeliveryNotes>Please leave packages in shed by driveway.</DeliveryNotes>
  <Items>
    <Item PartNumber="872-AA">
      <ProductName>Lawnmower</ProductName>
      <Quantity>1</Quantity>
      <USPrice>148.95</USPrice>
      <Comment>Confirm this is electric</Comment>
    </Item>
    <Item PartNumber="926-AA">
      <ProductName>Baby Monitor</ProductName>
      <Quantity>2</Quantity>
      <USPrice>39.98</USPrice>
      <ShipDate>1999-05-21</ShipDate>
    </Item>
  </Items>
</PurchaseOrder>

Вкратце, ФабрикаXDTO дает возможность получить  xml в виде объекта, где элементы будут являтся свойствами и, следовательно, к ним можно будет обращаться через точку.

А это весь(!) код обхода элементов Adress и Item.

	Чтение=Новый ЧтениеXML;
	Чтение.ОткрытьФайл(ВыбранноеИмяФайла);   
	Фабрика=Новый ФабрикаXDTO;
	ОбXDTO=Фабрика.ПрочитатьXML(Чтение);
	Для Каждого Address из ОбXDTO.Address Цикл 
		
	КонецЦикла;
	Для Каждого Item  из ОбXDTO.Items.Item Цикл 
			
	КонецЦикла;

То что показывает отладчик:

 

 

Бинго! Теперь можно делать с этими данными все, что угодно. 

Возможно, этот метод не подойдет для каких-то сложных задач, но для простейших обменов самое то (имхо).

Теперь осамом главном минусе этого метода и как его обойти по-лентяйски с минимумом кода.

Возьмем наш пример и отсавим в нем только по одному элементу Adress и Item

<?xml version="1.0"?>
<PurchaseOrder PurchaseOrderNumber="99503" OrderDate="1999-10-20">
  <Address Type="Shipping">
    <Name>Ellen Adams</Name>
    <Street>123 Maple Street</Street>
    <City>Mill Valley</City>
    <State>CA</State>
    <Zip>10999</Zip>
    <Country>USA</Country>
  </Address>
  <DeliveryNotes>Please leave packages in shed by driveway.</DeliveryNotes>
  <Items>
    <Item PartNumber="872-AA">
      <ProductName>Lawnmower</ProductName>
      <Quantity>1</Quantity>
      <USPrice>148.95</USPrice>
      <Comment>Confirm this is electric</Comment>
    </Item>
 </Items>
</PurchaseOrder>

Без особого удивления обнаружим, что наш код работать с таким файлом не будет. Поскольку у нас всего по одному элементу в ветке, то ФабрикаXDTO считает,что это не СписокXDTO а ОбъектXDTO, которрый нельзя обойти через цикл.

    Для Каждого Address из ОбXDTO.Address Цикл  //здесь будет ошибка "Итератор для значения не определен"
        
    КонецЦикла;
    Для Каждого Item  из ОбXDTO.Items.Item Цикл // и здесь тоже
            
    КонецЦикла;

 Не стоит отчаиваться и,тем более, не стоит утруждать себя и перед каждым циклом писать проверку на тип значения элемента, как в этой статье. (а вдруг у вас таких циклов будет 10).  За лентяя все сделает маленькая, но очень полезная функция следующего вида:

 
Функция  КоллекцияXDTO(Элемент)
	Если ТипЗнч(Элемент)=Тип("ОбъектXDTO") Тогда
		МассивXDTO=Новый Массив;
		МассивXDTO.Добавить(Элемент);
		Возврат МассивXDTO;
	КонецЕсли;
	Возврат Элемент;
КонецФункции
 Вызвать мы ее будем по-хитрому прямо в строке цикла,  поэтому сложность программы почти не возрастет и количесвто строк кода не увеличится.
  Для Каждого Address из КоллекцияXDTO(ОбXDTO.Address) Цикл
  КонецЦикла;
  Для Каждого Item из КоллекцияXDTO(ОбXDTO.Items.Item) Цикл
  КонецЦикла;
Ну вот, собственно, и все. Теперь лентяйский метод практически совершенен).

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Антонио (Fragster) 03.11.15 15:30
код не работает, если в коллекции один элемент. Или 0 элементов. И автоприведение примитивных типов не работает. В общем все то, ради чего и были придуманы схемы XSD и пакеты XDTO.
Evil Beaver; hulio; PrinzOfMunchen; rtnm; +4 Ответить 1
2. Вася Пупкин (Ks_83) 03.11.15 15:51
(1) Fragster, С одним элементом засада конечно, но это можно обойти условием на тип значения(СписокXDTO или ОбъектXDTO) . Думаю любой ленивый программист догадается об этом, проверив ошибку в отладчике. Автоприведение типов тоже можно пережить.
3. Сан Саныч (herfis) 03.11.15 17:32
Есть гораздо более информативная и тем не менее простая статья, где это уже изложено: Разбор XML документа - почти все возможные способы
В статье это описано как четвертый метод, причем указывается на его недостатки
4. poyson (poyson) 03.11.15 17:39
Блин, зачот! Все так легко красиво и просто! И без заумностей лишних!!!
5. Вася Пупкин (Ks_83) 03.11.15 18:04
(3) herfis, Моя статья для лентяев. Для тех кому лень скролить туда- сюда, искать самый простой метод среди прочих и анализировать код, состоящий более чем из 8 строчек. Моя статья именно о самом простом методе без всяких излишеств. Для вводного знакомства с XDTO. Для тех, кому нужно изучить методы работы с xml и XDTO более детально, существуют другие статьи.
ИНТЕГРА; +1 Ответить 1
6. TMV 03.11.15 19:20
(5) Ks_83, Выглядит так, словно вы зашли в библиотеку, повыдергивали страниц из книг и разбросали их. А че, удобно ж!
7. Вася Пупкин (Ks_83) 03.11.15 21:17
(6) TMV, Ваши метафоры мне непонятны.
8. Сергей Сиренко (ssn1978) 03.11.15 22:01
(7) Ks_83, Отличный познавательный пример, спасибо.
А критиков в сад :)))
yurii_host; Ks_83; +2 2 Ответить
9. Pud Ovan (pudovan) 04.11.15 11:41
Дякую пану, действительно очень простой способ загрузки данных из XML-файла. Очень хорошо подойдёт при загрузке налоговых накладных.
А теперь бы ещё добавить такой же простой пример для выгрузки например той же налоговой накладной согласно XSD-схеме или без неё...
10. Пользователь Инфостарта (infostart user) 04.11.15 12:50
омг, сколько можно, уже 10 раз пилили эту тему. xdto не самый оптимальный вариант работы с xml.
11. Сан Саныч (herfis) 04.11.15 15:32
(10) infostart user, Ну-ка, ну-ка? Можно поподробней или ссылочку? Что у нас там оптимальнее xdto? Хотя, конечно, всё зависит от того, что вы подразумеваете под "работой с xml".
12. Пользователь Инфостарта (infostart user) 04.11.15 18:00
13. Сан Саныч (herfis) 04.11.15 18:25
(12) infostart user, И что? Ты намекаешь на вечную дилемму последовательного чтения файла и считывания файла полностью в память сразу? Так тут никогда не было однозначного подхода. Всё от задач и объемов. По той же отсылке к ИТС говорится, что при последовательном чтении xml, для десериализации всё равно правильно будет использовать XDTO. Оно для этого и придумано. Просто алгоритм несколько усложняется (нужно самому вычленять куски и скармливать их XDTO). А насчет эффективности работы XDTO с файлами целиком - в той же статье результаты сравнительных замеров: на 100000 записей (файл размером 100 мегабайт) обработка проходит в несколько раз быстрее, чем при последовательном чтении XML "руками". Вот и думай.
Мои выводы - на большинстве задач можно не париться. Другое дело, если ты заведомо знаешь, что придется иметь дело с гигабайтными xml. Тогда ясен пень, что придется читать последовательно. Только тогда и алгоритмы 1С тоже надо ориентировать на потоковую работу с данными, а не в табличечку всё засовывать. Иначе вообще смешно получится - экономить на оперативке при чтении, но в 1С пихать в ту самую оперативку. Если уж делать потоковую обработку, не зависящую от объемов, то делать правильно. Только это должно окупаться. Какой смысл так заморачиваться, если постановка задачи исключает файлы огромных размеров?
14. Валентин Бомбин (so-quest) 04.11.15 21:59
Когда еще инфостарт был бесплатный - любой начинающий считал своим долгом нагадить в ленту своей печатной формой для реализации...
Теперь вот чтение/запись xdto
интересно - через пару лет что займет их место ?
15. Вася Пупкин (Ks_83) 05.11.15 00:24
(14) so-quest, Посмотрев ваши посты, понимаю почему у вас так бомбануло ваше негодование.В деле нагадить вы похоже преуспели, но при этом считаете, что вам за это еще и платить должны.Поэтому тег "бесплатно" напротив моего поста вас сильно раздражает. Ведь бесплатная информация - это против ваших правил, а если она еще и полезная, так вообще беспредел...
Tapochki-tmn; pose; igor.svarovskih; Программулькин; shalimski; rozer; +6 Ответить 1
16. Пользователь Инфостарта (infostart user) 05.11.15 14:47
(13) herfis, не спорю с вами. сам так считаю. просто раз уж статья для лентяев, то нужно для лентяев такие, очень важные, моменты уточнять хотя бы. иначе потом приходится переписывать этот копи-паст лентяйский. нельзя всегда рассчитывать на то, что система будет стоять на месте, нужно рассчитывать на то, что она будет скейлиться и стараться сразу закладывать правильный фундамент. мне очень нравится подход с последовательным чтением xml + обработка отдельных фрагментов через фабрику xdto. очень даже круто. извините, если не так выразился.

ПС заведомо знать, будут ли большие объемы или не будет, очень тяжело спрогнозировать, лучше сразу подготовиться. сегодня у магазина 100 заказов в день, через год 10000 заказов в день.

ПС2 прошу автора хотя бы прикрепить ссылку на теорию в шапку, иначе потом тяжело будет.
17. Валентин Бомбин (so-quest) 05.11.15 19:14
(15) Если бы ты смотрел - увидел бы ссылку на гит где это все (и не только) бесплатно качается. Но читать же надо. Проще сразу сделать заключение и поязвить. Плюс на время посмотри когда это делалось. С тех пор написано много статей. И тогда закономерный вопрос - А что тобой двигало когда ты делал эту статью, кроме желания почесать ЧСВ? для чего она? что она дала окружающим?

Говорю же - когда инфостарт был бесплатный сюда выкладывали печатные формы. Сейчас - чтение хмл.

18. Иван Устьянцев (nSpirit2) 06.11.15 11:37
Очередная статья. О том как я самый умны распарсил xml без схемы xsd вон как все просто. Только вот без схемы результат будет выглядеть непредсказуемо и вызывать много ошибок.
19. Вася Пупкин (Ks_83) 06.11.15 12:11
(18) nSpirit2, Очередной бесполезный коммент от негодующего? Что вас так раздражает? То, что я "самый умный"? Хотите показаться умнее с помощью своего комментария ? Не уверен, что у вас это получилось. Для начала научитесь хотя бы писать без ошибок. А по теме вашего вброса скажу следующее. Если вы не понимаете, где можно применять те или иные методы, то у вас и со схемами и без них все будет работать непредсказуемо и вызывать кучу ошибок.
20. Сан Саныч (herfis) 06.11.15 13:48
(19) Ks_83, А где у него написано с ошибками? Ну описки печати, ну знаки препинания, ну небольшой сумбур - это абсолютно нормально при быстрой печати. Но с грамотностью всё в порядке. Или это просто доп-какашка для густоты ответного залпа? Не стоит. Пачкается прежде всего кидающий.
Тем более, что он ведь не полную фигню пишет и конструктив в его словах есть.
Ведь если описать схему - это в самом деле и упростит саму загрузку и исключит хотя бы те же бока с единичными элементами списка.
Не стоит критику статьи воспринимать как личный вызов.
Лучше бы дополнили статью и указали на недостатки такого решения. Про недостатки у вас ни слова. Зато у вас написано что это "самое то" для простых обменов. Это не так. Даже для простых обменов выгоднее описать схему.
ЗЫ. Если это простая обработочка какого-то простого обмена - лучше всего хранить схему в текстовом макете обработки. Очень удобно и наглядно.
veiuper; nSpirit2; +2 Ответить 1
21. Вася Пупкин (Ks_83) 06.11.15 15:25
(20) herfis, Ну что вы прицепились к этим единичным элементам списка. Я уже написал о том, что это легко обходиться условием на тип значения. Если файл сложный и шибко многоуровневый, то это будет не очень красиво смотреться и тогда лучше создать схему, но если у вас простой файл с парой уровней, то смысла морочиться со схемой я не вижу. Да и сами по себе эти схемы в текстовом виде наглядностью не блещут, особенно для тех, кто с ними редко работает( уж не говорю о тех, кто вообще с этим не сталкивался). Тем более, чтобы ее создать нужно овладеть определенными знаниями по теме, навыками работы со сторонним софтом, или ковыряния пакета XDTO( что влечет изменение конфигурации). Не в блокноте же ее рисовать. Можно, конечно, потрать время на изучение , если оно есть, а можно сразу загрузить простой файл с помощью описанного мной метода, тем более, если это какая-то разовая работа и ее нужно сделать быстро.

По поводу критики. Если критикан настолько не уважает своего оппонента, что не удосуживается правильно составлять предложения и ставить знаки препинания, да еще и пытается перейти на личности,то такой критикан идет лесом.
22. Сан Саныч (herfis) 06.11.15 16:46
(21) Ks_83, Единичные элементы были просто как наглядный пример. Вы явно прописываете структуру файла и типы, которые вам нужны. В итоге вы либо получаете именно то, что вам нужно, либо сразу узнаете о том, что файл не соответствует схеме.
Без схемы можно получить файл модифицированного содержимого (поставщик изменил формат, по ошибке взяли другой файл и т.п.), который может быть обработан непредсказуемо - вплоть до печальных последствий. Тут уже всё будет зависеть от алгоритмов обработки и характера изменений.
Схему зачастую дают готовую. Можно получить с помощью сторонних средств. Конфу менять не обязательно, схему можно выгрузить из пакета XDTO. Да и в блокнотике, единожды разобравшись, не так уж сложно набросать.
Да, можно делать на тяп-ляп. Иногда приходится. Но стремиться надо к другому. А не поощрять непрофессиональный подход и хвастаться простотой его применения на практике.
Да, ваша статья будет полезной для новичков, которых пугают более профессиональные статьи по теме. Я всего-то предлагаю указать в статье на недостатки автоматического определения схемы, чтобы не вводить их в заблуждение. Ведь если им так лень читать, то они так и не узнают о существовании лучших вариантов и не поймут преимущества их использования.
23. Иван Устьянцев (nSpirit2) 06.11.15 18:18
(19) Ks_83, Ну а какой принципиальный толк от Вашей статьи ?
Показали что умеете пользоваться синтаксис помощником и отладчиком?
В чем ее принципиальный смысл или вы честно думаете что вы открытие сделали что если использовать "ФабрикаXDTO" можно из XML строки получить структуру XDTO?
Я конечно понимаю что для Вас конкретно это может быть открытием но это помоем совершенно не является таковым.
Кстати следует заметить что в вашем случае саму фабрику можно использовать глобальную и не вызывать конструирование новой это так к слову.

Так что ваша статья скорее не на службе у лентяев а как работают лентяи.
. Можно, конечно, потрать время на изучение , если оно есть, а можно сразу загрузить простой файл с помощью описанного мной метода, тем более, если это какая-то разовая работа и ее нужно сделать быстро.

Во первых не можно а нужно. Так как жизнь это упростить на много это раз.

У меня складывается впечатление что вы не совсем понимаете зачем нужна схема. Основная ее цель чтобы ваш код на вход получал ожидаемые данные. А так вы в результате вполне можете получить на вход то что в лучшем случае вызовет ошибку. А в худшем плохие данные в продакшен решении.

Я уже написал о том, что это легко обходиться условием на тип значения.

А потом смотришь решения вот по такому принципу написаны а там миллион если в ряд.

Вы сгребете все проблемы автоматического построения схемы в конечном итоге включая то что для 2х разных файлов итоговый объектXDTO будет разный настолько что по факту придется писать 2 разных обработчика для него и метод для лентяев превратиться в метод говнокода как это обычно и бывает.
24. Сан Саныч (herfis) 06.11.15 18:41
... или вы честно думаете что вы открытие сделали что если использовать "ФабрикаXDTO" можно из XML строки получить структуру XDTO?

Справедливости для - это в самом деле открытие для любого, кто первый раз этого касается (для меня когда-то было открытием тоже). Из СП нифига непонятно, каким минимальным кодом можно получить реальный результат. Так что статья полезная, считаю. Она может стать хорошей "заманухой" для новичка, который всё откладывает изучение механизмов XDTO "на потом".
skif47; Serega-artem; +2 Ответить
25. Николай Степанов (Tapochki-tmn) 11.11.15 11:19
Для коллег-лентяев : :)

Процедура КнопкаВыполнитьНажатие(Кнопка)
	
	ДиалогОткрытияФайла  = новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
	Фильтр = НСтр("ru = 'XML'; en = 'XML'")	+ "(*.xml)|*.xml";
	ДиалогОткрытияФайла.Фильтр = Фильтр;
	
	Если НЕ ДиалогОткрытияФайла.Выбрать() Тогда
		Возврат;
	Иначе
		
		МассивФайлов = ДиалогОткрытияФайла.ВыбранныеФайлы;
		Для Каждого ИмяФайла Из МассивФайлов Цикл	
			
			Чтение=Новый ЧтениеXML;
			Чтение.ОткрытьФайл(ИмяФайла);   
			Фабрика=Новый ФабрикаXDTO;
			ОбXDTO=Фабрика.ПрочитатьXML(Чтение);
			
			//Сообщить("Адреса:"); 
			//Для Каждого Address из ОбXDTO.Address Цикл 
			//	Сообщить("Address.City: " + Address.City);
			//	Сообщить("Address.Name: " + Address.Name);
			//	Сообщить("Address.Street: " + Address.Street);
			//	Сообщить("Address.Country: " + Address.Country);
			//КонецЦикла;
			
			Сообщить("Адреса. Второй вариант:"); 
				Сообщить(" "); 
			Для Каждого Address из ОбXDTO.Address Цикл
				Для Каждого Свойство из Address.Свойства() Цикл
					Сообщить(Свойство.Имя + ": " + Address.Получить(Свойство));
				КонецЦикла;
				Сообщить(" "); 
			КонецЦикла;
			
			Сообщить("Элементы:"); 
				Сообщить(" "); 
			Для Каждого Item  из ОбXDTO.Items.Item Цикл
				Для Каждого Свойство из Item.Свойства() Цикл
					Сообщить(Свойство.Имя + ": " + Item.Получить(Свойство));
				КонецЦикла;
				//Сообщить("Item.Comment:" + );
				//Сообщить("Item.PartNumber:" + );
				//Сообщить("Item.ProductName:" + );
				//Сообщить("Item.Quantity:" + );
				//Сообщить("Item.USPrice:" + );			
			Сообщить(" "); 
			КонецЦикла;
		КонецЦикла;
	КонецЕсли;
КонецПроцедуры
...Показать Скрыть
26. Вася Пупкин (Ks_83) 11.11.15 14:29
(22) herfis,
Да, ваша статья будет полезной для новичков, которых пугают более профессиональные статьи по теме. Я всего-то предлагаю указать в статье на недостатки автоматического определения схемы

По просьбам трудящихся. Дополнил инфой о том, как обойти ошибку с одним элементом.
27. Данила Володькин (skif47) 12.11.15 10:16
Добавлю второе ограничение данного метода чтения XML:
насколько я помню, XDTO без схемы не может корректно разобрать теги вида
<quantity UnitOfMeasure = "PCE">15</quantity>
т.е. "смешанный тип" в терминах XDTO-пакетов в конфигураторе.
В ОбъектXDTO будет видно атрибут "UnitOfMeasure" = "PCE", а значение "15" пропадет. Совсем.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа