gifts2017

[Расширение] Отключение информации при запуске в базовой БП 3.0

Опубликовал Алексей Ермилов (Alex_E) в раздел Обработки - Универсальные обработки

Как известно, окно "Информация при запуске" в базовой БП 3.0 (и не только) отключить нельзя - разработчики прописали в коде, что окно должно быть показано всегда.
Есть выражение - "Если нельзя, но очень хочется - то можно" :-)
Сделано на платформе 8.3.6.2390 БП 3.0.42.54 (базовая версия).
Можно использовать и для ПРОФ.

В разработчики сделали вывод окна "Информация при запуске" для базовой версии БП 3.0, как говорится "добровольно принудительным". Ниже текст общего модуля "ИнформацияПриЗапуске", Функция ГлобальныеНастройки(), это подтверждаюший:

  

       Если Метаданные.Обработки.ИнформацияПриЗапуске.Макеты.Количество() = 0 Тогда
                 Настройки.Показывать = Ложь;
         ИначеЕсли Не СтандартныеПодсистемыСервер.ЭтоБазоваяВерсияКонфигурации() Тогда
                 // Отключение информации в ПРОФ версии если пользователь отключил флажок.
                 ФлажокПользователя = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("ИнформацияПриЗапуске", "Показывать", Истина);
                 Если Не ФлажокПользователя Тогда
                          ДатаБлижайшегоПоказа = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("ИнформацияПриЗапуске", "ДатаБлижайшегоПоказа");
                          Если ДатаБлижайшегоПоказа <> Неопределено
                                   И ДатаБлижайшегоПоказа > ТекущаяДатаСеанса() Тогда
                                   Настройки.Показывать = Ложь;
                          КонецЕсли;
                 КонецЕсли;
         КонецЕсли;

Пользователи, да и не только (одноэсовцы, ИМХО, то же), не очень любят каждый раз закрывать это окошко руками. Для ПРОФ версии нет проблем один раз снять флажок, и до следующего обновления забыть про это окно (или отключить его, с помощью различный обработок, например: http://infostart.ru/public/333876/), а вот с базовой - засада, нету флажка, и многочисленные обработки ничего с этим окном для базовой версии сделать не могут.

НО! Теперь у нас есть расширения, которое к базовой подключается без каких - либо проблем.

Поэтому создаём расширение, куда включаем обработку "ИнформацияПриЗапуске", туда же включаем форму этой обработки. В модуле формы в расширении включаем в процедуру "ПриСозданииНаСервере" одну строку (спасибо Brawler - так более правильно, чем ЭтаФорма.Закрыть в ПриОткрытии):

&НаСервере
Процедура еаю_ПриСозданииНаСервере(Отказ)
    Отказ = Истина;
КонецПроцедуры

и навязчивое окно при запуске не видно :-)

 

P.S. Проверил на платформе, где используются ПРОФ версии 1С, ограничений для использование расширений для базовых вроде нет? Если не прав - поправьте...

 

Скачать файлы

Наименование Файл Версия Размер
Информация при запуске v 1.0.0.2 12
.cfe 8,67Kb
05.11.15
12
.cfe 1.0.0.2 8,67Kb Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение
Комментарии
1. Игорь Фелькер (Brawler) 05.11.15 10:21
Отказ = Истина;
shalimski; Alex_E; +2 Ответить 1
2. Алексей Ермилов (Alex_E) 05.11.15 10:44
(1) Brawler, Согласен, изменил на Отказ = Истина в процедуре ПриСозданииНаСервере. Спасибо!!!
3. Константин Юрин (kostyaomsk) 06.11.15 07:12
Вот это дельная вещь, задолбали рекламой. Но...Не такие они и простые эти разработчики типовых конфигураций. Они каждый раз будут менять процедуры запуска чтоб Вы запарились решать проблемы с правкой расширения.
4. Алексей Ермилов (Alex_E) 06.11.15 10:56
(3) kostyaomsk, Вызов они пусть меняют как хотят, здесь реклама не в выове отключается, а при попытки открыть обработку, которая её показывает, так что, если не будут каждый раз писать новую, будет работать - ПриСозданииНаСервере форма пропустить не может :-)
5. Виктория Дорохина (vikad) 07.11.15 08:30
ограничений для использование расширений для базовых вроде нет?

судя по последней строке в п. 32.1 http://its.1c.ru/db/v83doc#bookmark:dev:TI000001516 и по по последней строке на стр 3 в http://fs.kursypo1c.ru/free/1C-Administration/02-How-2-use-extentions-in-8.3.6.pdf ограничения все-таки есть(
6. Алексей Ермилов (Alex_E) 07.11.15 11:18
(5) vikad, Написано, что не поддерживается, но в случае, когда базовая версия работает на платформе с ключем ПРОФ расширение подключилось и работает. Проверить, кода работает ТОЛЬКО базовая пока не могу, как получится - отпишусь, или кто - нибудь тут напишет, надеюсь...
7. Максим *** (premier) 09.11.15 13:55
А не проще написать простенькую обработку, которая для всех пользователей установит настройку ДатаБлижайшегоПоказа в какое-то о-о-чень далёкое от сегодняшнего дня значение, 01.01.2500 г., например, и не париться с подключением расширения?
8. Алексей Ермилов (Alex_E) 09.11.15 13:59
(7) premier, Конечно проще, уже написал (http://infostart.ru/public/333876/), только Вы невнимательно прочитали
разработчики сделали вывод окна "Информация при запуске" для базовой версии БП 3.0, как говорится "добровольно принудительным".

В базовой версии пофиг даты - до них просто код не доходит :-)
9. Максим *** (premier) 09.11.15 14:00
К тому же перезапись настройки "ДатаБлижайшегоПоказа" происходит при закрытии формы. А откроется она очень даже не скоро )))
10. Максим *** (premier) 09.11.15 14:02
(8) Alex_E, а там что, код запуска отличается? Просто базовой БП под руками нет, чтобы проверить.
11. Алексей Ермилов (Alex_E) 09.11.15 14:04
(9) premier, Откройте базовую, найдите там галку "не показывать"...
По поводу внешней обработки, в публикации (см. выше) так и сделал внешнюю, но даже в своей базе (не базовой) как то забывается её запускать, расширение. ИМХО, более красивый выход из положения - для ПРОФ просто встроил обработку в расширение, и запускаю её при появлении окна "Информация при запуске" - теперь забыть не получится :-)
12. Алексей Ермилов (Alex_E) 09.11.15 14:05
(9) premier, Уууууу, как всё запущено... Я же код привёл в статье - Вы совсем не смотрите?
       Если Метаданные.Обработки.ИнформацияПриЗапуске.Макеты.Количество() = 0 Тогда
                 Настройки.Показывать = Ложь;
         ИначеЕсли Не СтандартныеПодсистемыСервер.ЭтоБазоваяВерсияКонфигурации() Тогда
                 // Отключение информации в ПРОФ версии если пользователь отключил флажок.
                 ФлажокПользователя = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("ИнформацияПриЗапуске", "Показывать", Истина);
                 Если Не ФлажокПользователя Тогда
                          ДатаБлижайшегоПоказа = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("ИнформацияПриЗапуске", "ДатаБлижайшегоПоказа");
                          Если ДатаБлижайшегоПоказа <> Неопределено
                                   И ДатаБлижайшегоПоказа > ТекущаяДатаСеанса() Тогда
                                   Настройки.Показывать = Ложь;
                          КонецЕсли;
                 КонецЕсли;
         КонецЕсли;
...Показать Скрыть
13. Максим *** (premier) 10.11.15 10:09
(12) Alex_E, я же писал в (10), базовой под руками нет, теперь понятно, что там ФлажокПользователя всегда будет принимать значение Истина. Перемудрили, конечно 1С-ники со своей рекламой навязчивой.
14. Алексей Ермилов (Alex_E) 10.11.15 12:33
(13) premier, ИМХО, базовая - дёшево и сердито - смотрите рекламу :-)
15. 3BEPb777 Семь (3BEPb777) 21.02.16 20:57
А что такое "базовая версия платформы"?
насколько я знаю Платформа одна, а вот ключ и конфигурация может быть Базовой и ПРОФ.
или я что-то путаю?
16. Алексей Ермилов (Alex_E) 21.02.16 21:05
(15) 3BEPb777, Не, ничё не путаете, я неправильно выразился. имеется ввиду, что когда платформа активирована базовой лицензией.
Платформа одна, но ключ ПРОФ может быть на компе, когда есть конфигурации ПРОФ (ну хоть у меня есть ключ, но базовые версии на нём остаются базовыми). В общем то пока работает (хотя что будет дальше, с развитием платформы ХЗ) - уже проверил, хоть и нет "Расширения" в интерфейсе базовой БП, но через "Все функции" ставится и работает...
17. 3BEPb777 Семь (3BEPb777) 22.02.16 01:07
1С:Предприятие 8.3 (8.3.7.1845)
Бухгалтерия предприятия, редакция 3.0 (3.0.43.100)

&НаКлиенте
Процедура еаю_ПриСозданииНаСервере(Отказ)
    Отказ = Истина;
КонецПроцедуры


Не работает.
Надо так
&НаСервере
Процедура еаю_ПриСозданииНаСервере(Отказ)
    Отказ = Истина;
КонецПроцедуры
18. Алексей Ермилов (Alex_E) 22.02.16 01:09
(17) 3BEPb777, Круто, а в чём отличие?
19. 3BEPb777 Семь (3BEPb777) 22.02.16 01:11
(18) Alex_E, НаКлиенте не срабатывает
20. Алексей Ермилов (Alex_E) 22.02.16 01:15
(19) 3BEPb777, Конечно на сервере, а что, выложено на клиенте? вообще то это предопределённая процедура, на клиенте ПриОткрытии()
21. Алексей Ермилов (Alex_E) 22.02.16 01:17
(17) 3BEPb777, Вау, и правда, исправил, спасибо!!!!
3BEPb777; +1 Ответить
22. Серж а (ASV085) 08.06.16 12:56
Спасибо!!! На проф версии , было замечено вообще при снятии этой галки, окно появлялось постоянно. Мои пользователи теперь довольны, как слоны!
23. Алексей Ермилов (Alex_E) 08.06.16 13:54
(22) ASV085, Пожалуйста! Рад, что пригодилось)))
24. Алексей Ермилов (Alex_E) 08.06.16 15:41
(22) ASV085, Вообще то для ПРОФ есть более продвинутая штука http://infostart.ru/public/333876/. Тут не только информация при запуске отключается, но и много чего ещё...
25. 3BEPb777 Семь (3BEPb777) 01.07.16 12:21
(16) Alex_E, на самом деле есть БАЗОВАЯ платформа.
Мой мир больше не будет прежним. (с)
26. Алексей Ермилов (Alex_E) 01.07.16 12:35
(25) 3BEPb777, И что это меняет с точки зрения этой публикации?

ЗЫ Базовая платформа...ссылочкой не поделитесь, откуда скачать?
27. Александр Уткин (duck) 09.08.16 10:13
По поводу подключения расширения к базовой версии. Проверял недавно.
На компе установлена 1С Розница базовая. И только она. Активирована лицензия базовой розницы.
В результате при входе в конфигуратор раздела с Расширениями нет в принципе.
При входе в режим предприятия в меню Все функции - Стандартные - Управление расширениями можно добавить расширение, но оно не работает.
Скорее всего с другими базовыми конфигурациями будет то же самое.
Если же на компьютере активирована обычная лицензия от проф версии любой из конфигурации, то расширения начинают работать и на базовых конфигурациях.
28. Алексей Ермилов (Alex_E) 09.08.16 10:19