gifts2017

Основы языка запросов xpath, базовый синтаксис и применение в 1С 8.3 для работы с xml файлами сложной структуры

Опубликовал Алексей _ (iolko) в раздел Программирование - Практика программирования

Есть много способов работы с XML в 1С. Хотел рассказать еще об одном способе, который, в принципе, описан на просторах, но добавлена теория, и описаны пара примеров работы. Речь пойдет о работе с XML, используя XPath.

Всех категорически приветствую. Ну, и приступим.

Проблема:

Есть файл XML - стандартная выгрузка из Everest.

Структура файла примерно следующая:

 

 

 

Потребовалось разобрать файл и загрузить данные в 1С. В приведенном примере создавать объекты МД не станем, просто посмотрим варианты разбора файла.
В «Интернетах» большое количество примеров, как работать с XML из 1С, вот один из них.

&НаКлиенте
Процедура Сформировать(Команда)
Диалог = новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.ВыборКаталога);
	Если не Диалог.Выбрать() Тогда
Возврат
Иначе
ФЛ = НайтиФайлы(Диалог.Каталог,"*.xml",Ложь);
	Для Каждого Ф Из ФЛ Цикл
	Чтение = Новый ЧтениеXML; 
	Чтение.ОткрытьФайл(Ф.ПолноеИмя); 
	Пока Чтение.Прочитать() Цикл
		Если Чтение.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда 
		ИмяУзла = Чтение.Имя; Сообщить("--" + ИмяУзла);
	Пока Чтение.ПрочитатьАтрибут() Цикл
	ТипУзла = Чтение.ТипУзла; 
	Имя = Чтение.Имя; 
	Значение = Чтение.Значение;
	КонецЦикла;
	ИначеЕсли
Чтение.ТипУзла = ТипУзлаXML.Текст Тогда 
Сообщить("Значение "+Чтение.Значение); 
ИначеЕсли
Чтение.ТипУзла = ТипУзлаXML.КонецЭлемента Тогда 		
КонецЕсли; 
	КонецЦикла;
	КонецЦикла;
КонецЕсли;
КонецПроцедуры

Посмотрим, что данный код выводит:

Значение Системная плата
--Icon
Значение 42
--Item
--Title
Значение Тип ЦП
--Icon
Значение 80
--ID
Значение 517
--Value
Значение DualCore Intel Core 2 Duo, 2400 MHz
--Item
--Title
Значение Системная плата
--Icon
Значение 42
--ID
Значение 518
--Value
Значение Hewlett-Packard HP Compaq dc5800 Microtower
--Item
--Title
Значение Чипсет системной платы
--Icon
Значение 27
--ID
Значение 519
--Value
Значение Intel Bearlake Q33
--Item

Теперь представим, что нам нужно записывать данные по компьютеру в БД. Для этого придется написать большое количество условий, какие элементы забирать, а какие элементы пропускать.

Данный Цикл будет читать XML примерно в таком порядке:

1)

2)

 

3)

 

Из скринов схемы XML видно, что узлов «Page» у нас 2, а узлов Item примерно 30-40. Т.е.  читая, таким образом, файл мы должны будем постоянно отслеживать узлы «Title» - чтобы понять, что за информация, и Узлы «Value»  для получения значений из XML.

 

Теперь посмотрим, как можно работать с данным файлом при помощи выражений Xpath.

Не много теории, возможно, кому то будет полезно:

Ссылка на материал (http://easywebscripts.net/useful/xpath.php)

 

XPath описан в стандарте XPath 1.0. Согласно написанному там "XPath is a language for addressing parts of an XML document ... ". По русски можно сказать, что XPath нужен для разбора (parsing) XML документов. В приведенных ниже примерах рассматриваются наиболее часто употребимые (по мнению автора) конструкции языка. 

1 Если путь начинается с символа /, то он представляет абсолютный путь к заданному элементу. 

/AAA

/AAA/DDD/BBB

     <AAA
          <BBB/> 
          <CCC/> 
          <BBB/> 
          <DDD> 
               <BBB/> 
          </DDD> 
          <CCC/> 
     </AAA>

     <AAA> 
          <BBB/> 
          <CCC/> 
          <BBB/> 
          <DDD> 
               <BBB/> 
          </DDD> 
          <CCC/> 
     </AAA>



2 Если путь начинается с //, то будут выбраны все элементы, соответствующие указанному шаблону.

//BBB

//DDD/BBB

     <AAA> 
          <BBB/> 
          <CCC/> 
          <BBB/> 
          <DDD> 
               <BBB/> 
          </DDD> 
          <CCC> 
               <DDD> 
                    <BBB/> 
                    <BBB/> 
               </DDD> 
          </CCC> 
     </AAA>

     <AAA> 
          <BBB/> 
          <CCC/> 
          <BBB/> 
          <DDD> 
               <BBB/> 
          </DDD> 
          <CCC> 
               <DDD> 
                    <BBB/> 
                    <BBB/> 
               </DDD> 
          </CCC> 
     </AAA>



3 Символ '*' указывает, что надо выбрать все элементы, соответствующие пути перед ней.

/AAA/CCC/DDD/*

/*/*/*/BBB

//*

     <AAA> 
          <XXX> 
               <DDD> 
                    <BBB/> 
                    <BBB/> 
                    <EEE/> 
                    <FFF/> 
               </DDD> 
          </XXX> 
          <CCC> 
               <DDD> 
                    <BBB/> 
                    <BBB/> 
                    <EEE/> 
                    <FFF/> 
               </DDD> 
          </CCC> 
          <CCC> 
               <BBB> 
                    <BBB> 
                         <BBB/> 
                    </BBB> 
               </BBB> 
          </CCC> 
     </AAA>

     <AAA> 
          <XXX> 
               <DDD> 
                    <BBB/> 
                    <BBB/> 
                    <EEE/> 
                    <FFF/> 
               </DDD> 
          </XXX> 
          <CCC> 
               <DDD> 
                    <BBB/> 
                    <BBB/> 
                    <EEE/> 
                    <FFF/> 
               </DDD> 
          </CCC> 
          <CCC> 
               <BBB> 
                    <BBB
                         <BBB/> 
                    </BBB
               </BBB> 
          </CCC> 
     </AAA>

     <AAA
          <XXX
               <DDD
                    <BBB/> 
                    <BBB/> 
                    <EEE/> 
                    <FFF/> 
               </DDD
          </XXX
          <CCC
               <DDD
                    <BBB/> 
                    <BBB/> 
                    <EEE/> 
                    <FFF/> 
               </DDD
          </CCC
          <CCC
               <BBB
                    <BBB
                         <BBB/> 
                    </BBB
               </BBB
          </CCC
     </AAA>



4 Выражение в квадратных скобках позволяет задавать более четкие критерии для элемента. Так число в квадратных скобках обозначает позицию элемента в выбранном множестве. Функция last() позволяет указать последний элемент в выборке.

/AAA/BBB[1]

/AAA/BBB[last()]

     <AAA> 
          <BBB/> 
          <BBB/> 
          <BBB/> 
          <BBB/> 
     </AAA>

     <AAA> 
          <BBB/> 
          <BBB/> 
          <BBB/> 
          <BBB/> 
     </AAA>



5 Атрибуты определяются префиксом @.

//@id

//BBB[@id]

//BBB[@name]

     <AAA> 
          <BBB id = "b1"/> 
          <BBB id = "b2"/> 
          <BBB name = "bbb"/> 
          <BBB/> 
     </AAA>

     <AAA> 
          <BBB id = "b1"/> 
          <BBB id = "b2"/> 
          <BBB name = "bbb"/> 
          <BBB/> 
     </AAA>

     <AAA> 
          <BBB id = "b1"/> 
          <BBB id = "b2"/> 
          <BBB name = "bbb"/> 
          <BBB/> 
     </AAA>


Значения атрибутов могут служить критерием при выборке. Функция normalize-space() удаляет пробелы в начале и конце параметра, а все последовательности пробельных символов заменяет одиночным пробелом.

//BBB[@id='b1']

//BBB[@name='bbb']

//BBB[normalize-space(@name)='bbb']

     <AAA> 
          <BBB id = "b1"/> 
          <BBB name = " bbb "/> 
          <BBB name = "bbb"/> 
     </AAA>

     <AAA> 
          <BBB id = "b1"/> 
          <BBB name = " bbb "/> 
          <BBB name = "bbb"/> 
     </AAA>

     <AAA> 
          <BBB id = "b1"/> 
          <BBB name = " bbb "/> 
          <BBB name = "bbb"/> 
     </AAA>



6 Функция count() возвращает число элементов в указанном множестве.

//*[count(*)=3]

выбрать все, имеющие три дочерних элемента

//*[count(BBB)=2]

выбрать все, имеющие два дочерних элемента BBB

     <AAA
          <CCC
               <BBB/> 
               <BBB/> 
               <BBB/> 
          </CCC
          <DDD> 
               <BBB/> 
               <BBB/> 
          </DDD> 
          <EEE> 
               <CCC/> 
               <DDD/> 
          </EEE> 
     </AAA>

     <AAA> 
          <CCC> 
               <BBB/> 
               <BBB/> 
               <BBB/> 
          </CCC> 
          <DDD
               <BBB/> 
               <BBB/> 
          </DDD
          <EEE> 
               <CCC/> 
               <DDD/> 
          </EEE> 
     </AAA>



7 Функция name() возвращает имя элемента. Функция starts-with() возвращает истину, если строка первого аргумента начинается строкой второго аргумента. Функция contains() возвращает истину, если строка из первого аргумента содержит строку из второго.

//*[name()='BBB']

выбрать все с именем BBB, эквивалентно пути //BBB

//*[starts-with(name(),'B')]

выбрать все, имя которых начинается с B

//*[contains(name(),'C')]

выбрать все, имя которых содержит C

     <AAA> 
          <BCC> 
               <BBB/> 
               <BBB/> 
               <BBB/> 
          </BCC> 
          <DDB> 
               <BBB/> 
               <BBB/> 
          </DDB> 
          <BEC> 
               <CCC/> 
               <DBD/> 
          </BEC> 
     </AAA>

     <AAA> 
          <BCC
               <BBB/> 
               <BBB/> 
               <BBB/> 
          </BCC
          <DDB> 
               <BBB/> 
               <BBB/> 
          </DDB> 
          <BEC
               <CCC/> 
               <DBD/> 
          </BEC
     </AAA>

     <AAA> 
          <BCC
               <BBB/> 
               <BBB/> 
               <BBB/> 
          </BCC
          <DDB> 
               <BBB/> 
               <BBB/> 
          </DDB> 
          <BEC
               <CCC/> 
               <DBD/> 
          </BEC
     </AAA>


Функция string-length() возвращает число символов в строке.

//*[string-length(name()) = 3]

выбрать все, имя которых состоит из трех символов

//*[string-length(name()) < 3]

//*[string-length(name()) > 3]

     <AAA
          <Q/> 
          <SSSS/> 
          <BB/> 
          <CCC/> 
          <DDDDDDDD/> 
          <EEEE/> 
     </AAA>

     <AAA> 
          <Q/> 
          <SSSS/> 
          <BB/> 
          <CCC/> 
          <DDDDDDDD/> 
          <EEEE/> 
     </AAA>

     <AAA> 
          <Q/> 
          <SSSS/> 
          <BB/> 
          <CCC/> 
          <DDDDDDDD/> 
          <EEEE/> 
     </AAA>



8 Несколько путей можно объединить с помощью разделителя |.

/AAA/EEE | //BBB

/AAA/EEE | //DDD/CCC | /AAA | //BBB

     <AAA> 
          <BBB/> 
          <CCC/> 
          <DDD> 
               <CCC/> 
          </DDD> 
          <EEE/> 
     </AAA>

     <AAA
          <BBB/> 
          <CCC/> 
          <DDD> 
               <CCC/> 
          </DDD> 
          <EEE/> 
     </AAA>



9 Ось self содержит только сам элемент (//GGG/self::*). Ось child содержит дочерние элементы контекстного узла. Ось child является осью, применяемой по умолчанию, и может быть опущена, т.е. /child::AAA эквивалентно /AAA, /child::AAA/child::BBB эквивалентно /AAA/BBB и т.д. 

9 Ось descendant содержит потомков контекстного узла.

/AAA/BBB/descendant::*

//CCC/descendant::*

выбрать все, имеющие в качестве предка CCC

//CCC/descendant::DDD

выбрать DDD, имеющие в качестве предка CCC

     <AAA> 
          <BBB> 
               <DDD
                    <CCC
                         <DDD/> 
                         <EEE/> 
                    </CCC
               </DDD
          </BBB> 
          <CCC> 
               <DDD> 
                    <EEE> 
                         <DDD> 
                              <FFF/>
                         </DDD> 
                    </EEE> 
               </DDD> 
          </CCC> 
     </AAA>

     <AAA> 
          <BBB> 
               <DDD> 
                    <CCC> 
                         <DDD/> 
                         <EEE/> 
                    </CCC> 
               </DDD> 
          </BBB> 
          <CCC> 
               <DDD
                    <EEE
                         <DDD
                              <FFF/>
                         </DDD
                    </EEE
               </DDD
          </CCC> 
     </AAA>

     <AAA> 
          <BBB> 
               <DDD> 
                    <CCC> 
                         <DDD/> 
                         <EEE/> 
                    </CCC> 
               </DDD
          </BBB> 
          <CCC> 
               <DDD
                    <EEE> 
                         <DDD
                              <FFF/>
                         </DDD
                    </EEE> 
               </DDD
          </CCC> 
     </AAA>



10 Ось parent содержит родителя контекстного узла, если он существует.

//DDD/parent::*

     <AAA> 
          <BBB
               <DDD> 
                    <CCC
                         <DDD/> 
                         <EEE/> 
                    </CCC
               </DDD> 
          </BBB
          <CCC
               <DDD> 
                    <EEE
                         <DDD> 
                              <FFF/> 
                         </DDD> 
                    </EEE
               </DDD> 
          </CCC
     </AAA>



11 Ось ancestor содержит предков контекстного узла.

/AAA/BBB/DDD/CCC/EEE/ancestor::*

//FFF/ancestor::*

     <AAA
          <BBB
               <DDD
                    <CCC
                         <DDD/> 
                         <EEE/> 
                    </CCC
               </DDD
          </BBB
          <CCC> 
               <DDD> 
                    <EEE> 
                         <DDD> 
                              <FFF/> 
                         </DDD> 
                    </EEE> 
               </DDD> 
          </CCC> 
     </AAA>

     <AAA
          <BBB> 
               <DDD> 
                    <CCC> 
                         <DDD/> 
                         <EEE/> 
                    </CCC> 
               </DDD> 
          </BBB> 
          <CCC
               <DDD
                    <EEE
                         <DDD
                              <FFF/> 
                         </DDD
                    </EEE
               </DDD
          </CCC
     </AAA>



12 Ось following-sibling содержит все следующих братьев контекстного узла. Братьями называются те узлы, что имеют одного родителя с контекстным.

/AAA/BBB/following-sibling::*

//CCC/following-sibling::*

     <AAA> 
          <BBB> 
               <CCC/> 
               <DDD/> 
          </BBB> 
          <XXX
               <DDD> 
                    <EEE/> 
                    <DDD/> 
                    <CCC/> 
                    <FFF/> 
                    <FFF> 
                         <GGG/> 
                    </FFF> 
               </DDD> 
          </XXX
          <CCC
               <DDD/> 
          </CCC
     </AAA>

     <AAA> 
          <BBB> 
               <CCC/> 
               <DDD/> 
          </BBB> 
          <XXX> 
               <DDD
                    <EEE/> 
                    <DDD/> 
                    <CCC/> 
                    <FFF/> 
                    <FFF
                         <GGG/> 
                    </FFF
               </DDD> 
          </XXX> 
          <CCC> 
               <DDD/> 
          </CCC> 
     </AAA>



13 Ось preceding-sibling содержит всех предыдущих братьев контекстного узла.

/AAA/XXX/preceding-sibling::*

//CCC/preceding-sibling::*

     <AAA> 
          <BBB
               <CCC/> 
               <DDD/> 
          </BBB
          <XXX> 
               <DDD> 
                    <EEE/> 
                    <DDD/> 
                    <CCC/> 
                    <FFF/> 
                    <FFF> 
                         <GGG/> 
                    </FFF> 
               </DDD> 
          </XXX> 
          <CCC> 
               <DDD/> 
          </CCC> 
     </AAA>

     <AAA> 
          <BBB
               <CCC/> 
               <DDD/> 
          </BBB
          <XXX
               <DDD> 
                    <EEE/> 
                    <DDD/> 
                    <CCC/> 
                    <FFF/> 
                    <FFF> 
                         <GGG/> 
                    </FFF> 
               </DDD> 
          </XXX
          <CCC> 
               <DDD/> 
          </CCC> 
     </AAA>



14 Ось following содержит в том же порядке, что и в самом документе, все узлы, идущие после контекстного, за исключением всех предков, узлов атрибутов и пространств имен.

/AAA/XXX/following::*

//ZZZ/following::*

     <AAA> 
          <BBB> 
               <CCC/> 
               <ZZZ> 
                    <DDD/> 
                    <DDD> 
                         <EEE/> 
                    </DDD> 
               </ZZZ> 
               <FFF> 
                    <GGG/> 
               </FFF> 
          </BBB> 
          <XXX> 
               <DDD> 
                    <EEE/> 
                    <DDD/> 
                    <CCC/> 
                    <FFF/> 
                    <FFF> 
                         <GGG/> 
                    </FFF> 
               </DDD> 
          </XXX> 
          <CCC
               <DDD/> 
          </CCC
     </AAA>

     <AAA> 
          <BBB> 
               <CCC/> 
               <ZZZ> 
                    <DDD/> 
                    <DDD> 
                         <EEE/> 
                    </DDD> 
               </ZZZ> 
               <FFF
                    <GGG/> 
               </FFF
          </BBB> 
          <XXX
               <DDD
                    <EEE/> 
                    <DDD/> 
                    <CCC/> 
                    <FFF/> 
                    <FFF
                         <GGG/> 
                    </FFF
               </DDD
          </XXX
          <CCC
               <DDD/> 
          </CCC
     </AAA>



15 Ось preceding содержит в том же порядке, что и в самом документе, все узлы, идущие перед контекстным узлом, исключая любых предков, узлов атрибутов и пространств имен.

/AAA/XXX/preceding::*

//GGG/preceding::*

     <AAA> 
          <BBB
               <CCC/> 
               <ZZZ
                    <DDD/> 
               </ZZZ
          </BBB
          <XXX> 
               <DDD> 
                    <EEE/> 
                    <DDD/> 
                    <CCC/> 
                    <FFF/> 
                    <FFF> 
                         <GGG/> 
                    </FFF> 
               </DDD> 
          </XXX> 
          <CCC> 
               <DDD/> 
          </CCC> 
     </AAA>

     <AAA> 
          <BBB
               <CCC/> 
               <ZZZ
                    <DDD/> 
               </ZZZ
          </BBB
          <XXX> 
               <DDD> 
                    <EEE/> 
                    <DDD/> 
                    <CCC/> 
                    <FFF/> 
                    <FFF> 
                         <GGG/> 
                    </FFF> 
               </DDD> 
          </XXX> 
          <CCC> 
               <DDD/> 
          </CCC> 
     </AAA>



16 Ось descendant-or-self содержит контекстный узел и всех его потомков.

/AAA/XXX/descendant-or-self::*

//CCC/descendant-or-self::*

     <AAA> 
          <BBB> 
               <CCC/> 
               <ZZZ> 
                    <DDD/> 
               </ZZZ> 
          </BBB> 
          <XXX
               <DDD
                    <EEE/> 
                    <DDD/> 
                    <CCC/> 
                    <FFF/> 
                    <FFF
                         <GGG/> 
                    </FFF
               </DDD
          </XXX
          <CCC> 
               <DDD/> 
          </CCC> 
     </AAA>

     <AAA> 
          <BBB> 
               <CCC/> 
               <ZZZ> 
                    <DDD/> 
               </ZZZ> 
          </BBB> 
          <XXX> 
               <DDD> 
                    <EEE/> 
                    <DDD/> 
                    <CCC/> 
                    <FFF/> 
                    <FFF> 
                         <GGG/> 
                    </FFF> 
               </DDD> 
          </XXX> 
          <CCC
               <DDD/> 
          </CCC
     </AAA>



17 Ось ancestor-or-self содержит контекстный узел и всех его предков, таким образом, эта ось всегда содержит корневой узел.

/AAA/XXX/DDD/EEE/ancestor-or-self::*

//GGG/ancestor-or-self::*

     <AAA
          <BBB> 
               <CCC/> 
               <ZZZ> 
                    <DDD/> 
               </ZZZ> 
          </BBB> 
          <XXX
               <DDD
                    <EEE/> 
                    <DDD/> 
                    <CCC/> 
                    <FFF/> 
                    <FFF> 
                         <GGG/> 
                    </FFF> 
               </DDD
          </XXX
          <CCC> 
               <DDD/> 
          </CCC> 
     </AAA>

     <AAA
          <BBB> 
               <CCC/> 
               <ZZZ> 
                    <DDD/> 
               </ZZZ> 
          </BBB> 
          <XXX
               <DDD
                    <EEE/> 
                    <DDD/> 
                    <CCC/> 
                    <FFF/> 
                    <FFF
                         <GGG/> 
                    </FFF
               </DDD
          </XXX
          <CCC> 
               <DDD/> 
          </CCC> 
     </AAA>



18 Оператор div производит деление, оператор mod возвращает остаток от деления нацело. Функция floor - округление до ближайшего целого в сторону увеличения. Функция ceiling - в сторону уменьшения.

//BBB[position() mod 2 = 0 ]

выбрать все, позиция которых кратна 2

//BBB[ position() = floor(last() div 2 + 0.5) or position() = ceiling(last() div 2 + 0.5)]

//CCC[ position() = floor(last() div 2 + 0.5) or position() = ceiling(last() div 2 + 0.5)]

     <AAA> 
          <BBB/>
          <BBB/>
          <BBB/>
          <BBB/>
          <BBB/>
          <BBB/>
          <BBB/>
          <BBB/>
          <CCC/>
          <CCC/>
          <CCC/>
     </AAA>

     <AAA> 
          <BBB/> 
          <BBB/> 
          <BBB/> 
          <BBB/> 
          <BBB/> 
          <BBB/> 
          <BBB/> 
          <BBB/> 
          <CCC/> 
          <CCC/> 
          <CCC/> 
     </AAA>

     <AAA> 
          <BBB/> 
          <BBB/> 
          <BBB/> 
          <BBB/> 
          <BBB/> 
          <BBB/> 
          <BBB/> 
          <BBB/> 
          <CCC/> 
          <CCC/> 
          <CCC/> 
     </AAA>

 

Рассмотрим пару примеров на нашем файле: (Используя программу XMLPad http://xmlpad-mobile.com/wp-content/uploads/2014/03/XmlPad_3.0.4.1.zip )

 

 

 

 

Данное  выражение выбирает только узел Page[2] и в этом узле только узлы “Group”. Это избавляет нас от лишних циклов по узлам и описанием дополнительных условий.

 

Теперь непосредственно сам разбор данного XML файла при помощи Xpath и 1С 8.3

 

Небольшое уточнение, в приведенных скринах из программы XMLPad,  запрос написан без первого слеша - «/», 1С категорически не воспринимает такие запросы, и возвращает пустой результат, по этому запрос в 1С идет с первым слеш «/». И еще Имя узлов РЕГИСТРОЧУВСТВИТЕЛЬНЫ!!!

 

Пример кода:

&НаКлиенте
Процедура Сформировать(Команда)
Диалог = новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.ВыборКаталога);
Если не Диалог.Выбрать() Тогда
Возврат
Иначе
ФЛ = НайтиФайлы(Диалог.Каталог,"*.xml",Ложь);
	Для Каждого Ф Из ФЛ Цикл
	Дом = Новый ПостроительDOM;
	Чтение = Новый ЧтениеXML;
	Чтение.ОткрытьФайл(Ф.ПолноеИмя);
	ДокументДом = Дом.Прочитать(Чтение);
	РазименовывателиПИ = ДокументДом.СоздатьРазыменовательПИ(ДокументДОМ);
	Запрос = "/Report/Page[2]/Group/Item/Title | /Report/Page[2]/Group/Item/Value";
	Путь = ДокументДом.СоздатьВыражениеXPath(Запрос,РазименовывателиПИ);
	Результат = Путь.Вычислить(ДокументДом);
	Родитель = Результат.ПолучитьСледующий();
		Пока Родитель<>Неопределено Цикл 
		Если Родитель.ИмяУзла = "Title" Тогда
		Сообщить ("Имя "+Родитель.ТекстовоеСодержимое);
		Иначе 
		Сообщить ("Значение " + Родитель.ТекстовоеСодержимое);
		КонецЕсли;	
		Родитель=Результат.ПолучитьСледующий();	
		КонецЦикла;
		КонецЦикла;
	Чтение.Закрыть();
	КонецЕсли;
КонецПроцедуры
 

Данный код выводит следующий результат:

 

Имя Тип компьютера

Значение Многопроцессорный компьютер с ACPI

Имя Операционная система

Значение Microsoft Windows XP Professional

Имя Пакет обновления ОС

Значение Service Pack 3

Имя Internet Explorer

Значение 6.0.2900.5512

Имя DirectX

Значение 4.09.00.0904 (DirectX 9.0c)

Имя Тип ЦП

Значение DualCore Intel Core 2 Duo, 2400 MHz

Имя Системная плата

Значение Hewlett-Packard HP Compaq dc5800 Microtower

Имя Чипсет системной платы

Значение Intel Bearlake Q33

Имя Системная память

Значение 1015 Мб

Имя Тип BIOS

Значение Compaq (01/31/08)

Имя Коммуникационный порт

 

Согласитесь,  сам код сократился в разы, условных операторов только 2, при этом мы отсеяли на уровне запроса все лишнее.

 

Теперь попробуем сформировать древовидную структуру, т.к. отчет Everest в самой программе все таки имеет структуру дерева. Для этого немного переработаем наш запрос и код в 1С.

Запрос теперь выглядит вот так, мы взяли узел Page с номером 2 из узла Report, и выбрали все его подчиненные элементы.

Пример кода:

&НаКлиенте
Процедура Сформировать(Команда)
Диалог = новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.ВыборКаталога);
Если не Диалог.Выбрать() Тогда
Возврат
Иначе
ФЛ = НайтиФайлы(Диалог.Каталог,"*.xml",Ложь);
Для Каждого Ф Из ФЛ Цикл
Дом = Новый ПостроительDOM;
Чтение = Новый ЧтениеXML;
Чтение.ОткрытьФайл(Ф.ПолноеИмя);
ДокументДом = Дом.Прочитать(Чтение);
РазименовывателиПИ = ДокументДом.СоздатьРазыменовательПИ(ДокументДОМ);
Запрос = "/Report/Page[2]/Group/descendant-or-self::*";
Путь = ДокументДом.СоздатьВыражениеXPath(Запрос,РазименовывателиПИ);
Результат = Путь.Вычислить(ДокументДом);
Родитель = Результат.ПолучитьСледующий();
	Пока Родитель<>Неопределено Цикл 
	Если (Родитель.РодительскийУзел.ИмяУзла="Group") И (Родитель.ИмяУзла = "Title") Тогда
	Сообщить ("Имя группы "+Родитель.ТекстовоеСодержимое);
	ИначеЕсли 
	Родитель.ИмяУзла = "Title" Тогда
	Сообщить ("Имя элемента " + Родитель.ТекстовоеСодержимое);
	ИначеЕсли 	
	Родитель.ИмяУзла = "Value" Тогда
	Сообщить ("Значение элемента " + Родитель.ТекстовоеСодержимое);
	КонецЕсли;
	Родитель=Результат.ПолучитьСледующий();	
	КонецЦикла;
КонецЦикла;
	Чтение.Закрыть();
КонецЕсли;
КонецПроцедуры

Получаем следующий вывод сообщений. Как видно мы получили не только сами элементы, но и группы к ним.

 

Имя группы Компьютер

Имя элемента Тип компьютера

Значение элемента Многопроцессорный компьютер с ACPI

Имя элемента Операционная система

Значение элемента Microsoft Windows XP Professional

Имя элемента Пакет обновления ОС

Значение элемента Service Pack 3

Имя элемента Internet Explorer

Значение элемента 6.0.2900.5512

Имя элемента DirectX

Значение элемента 4.09.00.0904 (DirectX 9.0c)

Имя элемента Имя компьютера

Значение элемента Тестовый компьютер1

Имя элемента Имя пользователя

Значение элемента ТестовыйПользователь

Имя элемента Вход в домен

Значение элемента ТестовыйДомен

Имя элемента Дата / Время

Значение элемента 2014-09-23 / 13:21

Имя группы Системная плата

Имя элемента Тип ЦП

Значение элемента DualCore Intel Core 2 Duo, 2400 MHz

Имя элемента Системная плата

Значение элемента Hewlett-Packard HP Compaq dc5800 Microtower

Имя элемента Чипсет системной платы

Значение элемента Intel Bearlake Q33

Имя элемента Системная память

Значение элемента 1015 Мб

Имя элемента Тип BIOS

Значение элемента Compaq (01/31/08)

Имя элемента Коммуникационный порт

Значение элемента Последовательный порт (COM1)

 

Можно еще немного переработать код для красоты:

Пример кода:

&НаКлиенте
Процедура Сформировать(Команда)
Диалог = новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.ВыборКаталога);
Если не Диалог.Выбрать() Тогда
	Возврат
Иначе
ФЛ = НайтиФайлы(Диалог.Каталог,"*.xml",Ложь);
Для Каждого Ф Из ФЛ Цикл
	Дом = Новый ПостроительDOM;
	Чтение = Новый ЧтениеXML;
	Чтение.ОткрытьФайл(Ф.ПолноеИмя);
	ДокументДом = Дом.Прочитать(Чтение);
	РазименовывателиПИ = ДокументДом.СоздатьРазыменовательПИ(ДокументДОМ);
	Запрос = "/Report/Page[2]/Group/descendant-or-self::*";
	Путь = ДокументДом.СоздатьВыражениеXPath(Запрос,РазименовывателиПИ);
	Результат = Путь.Вычислить(ДокументДом);
	Родитель = Результат.ПолучитьСледующий();
	Пока Родитель<>Неопределено Цикл 
	Если (Родитель.РодительскийУзел.ИмяУзла="Group") И (Родитель.ИмяУзла = "Title") Тогда
		Сообщить ("Имя группы "+Родитель.ТекстовоеСодержимое);
		ИначеЕсли 
		Родитель.ИмяУзла = "Title" Тогда
		ИмяЭлемента = Родитель.ТекстовоеСодержимое;
		ИначеЕсли 	
		Родитель.ИмяУзла = "Value" Тогда
		ЗначениеЭлемента = Родитель.ТекстовоеСодержимое;
		Сообщить (Строка(ИмяЭлемента) +":"+Строка (ЗначениеЭлемента));
		КонецЕсли;
		Родитель=Результат.ПолучитьСледующий();	
		КонецЦикла;
		КонецЦикла;
		Чтение.Закрыть();
	КонецЕсли;
КонецПроцедуры

Имя группы Компьютер

Тип компьютера:Многопроцессорный компьютер с ACPI

Операционная система:Microsoft Windows XP Professional

Пакет обновления ОС:Service Pack 3

Internet Explorer:6.0.2900.5512

DirectX:4.09.00.0904 (DirectX 9.0c)

Имя компьютера: ТестовыйКомпьютер

 Имя пользователя: тестовый пользователь

 Вход в домен: Тестовый домен

Дата / Время:2014-09-23 / 13:21

Имя группы Системная плата

Тип ЦП:DualCore Intel Core 2 Duo, 2400 MHz

Системная плата:Hewlett-Packard HP Compaq dc5800 Microtower

Чипсет системной платы:Intel Bearlake Q33

Системная память:1015 Мб

Тип BIOS:Compaq (01/31/08)

 

Вывод: Как видно из приведенных примеров, использование выражений Xpath, в разы сокращяет сам код, а также повышает его читабельность, и уменьшает обработку не нужной информации.

За сим все.

Best regards!!!

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Dmitry E (harmer) 05.11.15 11:30
Для тех, кто не понял примеры из пункта "наиболее часто употребимые (по мнению автора) конструкции языка", сразу смотрите по приведенной в статье ссылке http://easywebscripts.net/useful/xpath.php.

Автор, выделите, пожалуйста, узлы в примерах для большей наглядности. Сейчас приведенные примеры бесполезны.
2. Дмитрий Тарасов (tarassov) 05.11.15 11:30
Полезный материал, плюсую. Но к сожалению автор не показал аналогичные и предшествующие работы. А они есть.
3. Алексей _ (iolko) 05.11.15 11:33
(1) harmer, Доброго дня. Действительно, скопипастилось не корректно, изменю в течении дня.
4. Дмитрий Тарасов (tarassov) 05.11.15 11:40
5. Алексей 1 (AlX0id) 05.11.15 12:24
Чот вот куча осей в статье, мне кажется, совсем излишня... Кому надо - найдут описание в инете, а все фишки XPath в статью все равно не перетащите..
6. Николай Степанов (Tapochki-tmn) 11.11.15 09:10
Спасибо большое !

Раньше стандартными средствами читал XML.
Разобраться с более простыми способами времени не было.
А тут все понятно, самая необходимая суть для базового освоения и главное - с примером доступным для копирования !
Плюсую !
7. Яков Коган (Yashazz) 22.01.16 16:21
Мдя... Куча малополезного, понадёрганная с интернетов... Некая левая прога... Основы, которые можно найти везде... И крайне мало по делу, т.е. по применению в 1С. А я уж обрадовался, что кто-то прояснит некоторые до сих пор туманные для меня аспекты... Жаль.
8. Алексей _ (iolko) 26.01.16 05:59
(7) Yashazz, Доброго дня. Малопонятная прога, необходима для наглядной демонстрации того как работает запрос Xpath. Применение в 1С ... ну уже куда детальней описывать, весь код показан, комментировать в нем (на мой взгляд) особо не чего, все читаемо. Если нужно прояснять аспекты, то гораздо проще показать сам аспект, и уже говорить непосредственно по конкретике.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа