bdd2

“Вес и Объем” в 1С:Управление торговлей 10.3

Опубликовал Denis Mir (prost_white_one) в раздел Программирование - Практика программирования

Доработка Счета на Оплату в 1С: Управление торговлей 10.3 с Весом и Объемом.

Очень удобная информация. Скажете, для чего это нужно? для логистики и вывода информации по “Номенклатуре” и подсчету веса и объема. Очень удобно, когда при выборе номенклатуры сразу выводится информация по товару в этом же окне, вес и объем, не надо сохранять и печатать как часто встречаются внешние печатные формы и обработки и отчеты.

Конфигуратор-Документ-СчетНаОплатуПокупателю-ФормаДокумента-ФормаДокумента-Модуль

Процедура ОбновитьПодвал()
//info
            Объем1=0;
            Вес1=0;
Для каждого Стр Из Товары Цикл
Объем1=Объем1+Стр.Количество*Стр.Номенклатура.ЕдиницаХраненияОстатков.Объем;            Вес1=Вес1+Стр.Количество*Стр.Номенклатура.ЕдиницаХраненияОстатков.Вес;    
КонецЦикла;   
           ЭлементыФормы.Объем.Значение=Объем1;
           ЭлементыФормы.Вес.Значение=Вес1;
//info
КонецПроцедуры // ОбновитьПодвал()

И еще если хотите, чтобы подсвечиволось номенклатура, в которой не проставлен Вес.

Конфигуратор-Документ-СчетНаОплатуПокупателю-ФормаДокумента-ФормаДокумента-Модуль

Процедура ТоварыПриПолученииДанных (Элемент, ОформленияСтрок)             

//info   
Для каждого ОформлениеСтроки из ОформленияСтрок Цикл
 Если ОформлениеСтроки.ДанныеСтроки.Номенклатура.ЕдиницаХраненияОстатков.Вес Тогда
  ЦветФона=Новый Цвет (255, 255, 255);
    Иначе
  ЦветФона=Новый Цвет (255, 147, 244);
КонецЕсли;
ОформлениеСтроки.ЦветФона=ЦветФона;
КонецЦикла;
//info


См. также

Добавить вознаграждение
Комментарии
1. Евгений Абдуразаков (asdfgcom) 43 18.01.17 23:45 Сейчас в теме
Денис. Нет роста. С 14 года мог бы и оригинальнее что-то..
Звезду за смелость.