gifts2017

Личная карточка Т-2 с выводом информации о повышении квалификации, профессиональной переподготовке, аттестации. ЗУП 2.5, ЗИК БУ 1.0

Опубликовал Дмитрий Котельников (kotlovD) в раздел Отчеты - Бухгалтерские

Вывод данных о дополнительном образовании в карточку Т-2 для конфигураций ЗУП 2.5, ЗИК БУ 1.0

Как многие знают, разработчики не предусмотрели данной возможности в вышеозвученных конфигурациях. На самом деле это не так сложно реализовать. Достаточно модифицировать одну процедуру переопределяемого модуля (так что при обновлении не должно возникнуть проблем).

Эта процедура находится в общем модуле "УнифицированнаяФормаТ2Переопределяемый":

Процедура СформироватьМакетДополнительно(ДополнительныеДанные, ТретьяСтраницаТ2, СтруктураПоискаФизЛицо, СтруктураПоискаСотрудник) Экспорт

На входе процедура имеет параметр ДополнительныеДанные, который можно инициализировать при программном формироании отчета. Параметр ТретьяСтраницаТ2 это область макета отчета "Т2_от_5_1_2004"Параметры СтруктурапоискаФизЛицо и СтруктураПоискаСотрудник содержат структуру со ссылкой на сотрудника и физика соответственно.

Выкладываю свой код по выводу данных о дополнительном образовании, думаю, разобраться будет несложно. Также замечу, что реквизиты с префиксом ИТ не типовые, так что бездумное копирование кода ни к чему хорошему не приведет.

 

	ВО_ПовышениеКвалификации = Справочники.ВидыОбразованияФизЛиц.НайтиПоНаименованию("Повышение квалификции");
	ВО_ПрофПереподготовка	 = Справочники.ВидыОбразованияФизЛиц.НайтиПоНаименованию("Профессиональная переподготовка");
	
	//ПОВЫШЕНИЕ КВАЛИФИКАЦИИ
	Запрос = Новый Запрос;
	Запрос.Текст =
		"ВЫБРАТЬ
		|	ФизическиеЛицаОбразование.ИТ_НачалоОбучения,
		|	ФизическиеЛицаОбразование.ИТ_ОкончаниеОбучения,
		|	ФизическиеЛицаОбразование.УчебноеЗаведение,
		|	ФизическиеЛицаОбразование.ИТ_НаименованиеДокумента,
		|	ФизическиеЛицаОбразование.Диплом,
		|	ФизическиеЛицаОбразование.ИТ_ДатаОкончания
		|ИЗ
		|	Справочник.ФизическиеЛица.Образование КАК ФизическиеЛицаОбразование
		|ГДЕ
		|	ФизическиеЛицаОбразование.Ссылка = &ФизЛицо
		|	И ФизическиеЛицаОбразование.ВидОбразования = &ВидОбр";
	Запрос.УстановитьПараметр("Физлицо", СтруктураПоискаФизЛицо.ФизЛицо);
	Запрос.УстановитьПараметр("ВидОбр", ВО_ПовышениеКвалификации);
	
	ном = 0;
	
	Выборка = Запрос.Выполнить().Выбрать();
	пока Выборка.Следующий() Цикл
		ном = ном + 1;
		
		Если ном > 6 тогда
			Прервать;
		КонецЕсли;
		
		ТретьяСтраницаТ2.Параметры["ДатаНачалаОбучения"+ном] 				= Выборка.ИТ_НачалоОбучения;
		ТретьяСтраницаТ2.Параметры["ДатаОкончанияОбучения"+Ном]				= Выборка.ИТ_ОкончаниеОбучения;
		ТретьяСтраницаТ2.Параметры["Учреждение"+Ном]                       	= Выборка.УчебноеЗаведение;
		ТретьяСтраницаТ2.Параметры["ДокументООбразование"+Ном]             	= Выборка.ИТ_НаименованиеДокумента;
		ТретьяСтраницаТ2.Параметры["СерияНомерДокументаОбразования"+Ном]   	= Выборка.Диплом;
		ТретьяСтраницаТ2.Параметры["ДатаДокументОбразования"+Ном]          	= Выборка.ИТ_ДатаОкончания;	
	КонецЦикла;
	
	//ПРОФ ПЕРЕПОДГОТОВКА
	Запрос.Текст =
		"ВЫБРАТЬ
		|	ФизическиеЛицаОбразование.ИТ_НачалоОбучения,
		|	ФизическиеЛицаОбразование.ИТ_ОкончаниеОбучения,
		|	ФизическиеЛицаОбразование.Специальность,
		|	ФизическиеЛицаОбразование.ИТ_НаименованиеДокумента,
		|	ФизическиеЛицаОбразование.Диплом,
		|	ФизическиеЛицаОбразование.ИТ_ДатаОкончания
		|ИЗ
		|	Справочник.ФизическиеЛица.Образование КАК ФизическиеЛицаОбразование
		|ГДЕ
		|	ФизическиеЛицаОбразование.Ссылка = &ФизЛицо
		|	И ФизическиеЛицаОбразование.ВидОбразования = &ВидОбр";
	Запрос.УстановитьПараметр("Физлицо", СтруктураПоискаФизЛицо.ФизЛицо);
	Запрос.УстановитьПараметр("ВидОбр", ВО_ПрофПереподготовка);
	
	ном = 0;
	
	Выборка = Запрос.Выполнить().Выбрать();
	пока Выборка.Следующий() Цикл
		ном = ном + 1;
		
		Если ном > 5 тогда
			Прервать;
		КонецЕсли;
		
		ТретьяСтраницаТ2.Параметры["ДатаНачалаПереподготовки"+ном] 		   	= Выборка.ИТ_НачалоОбучения;
		ТретьяСтраницаТ2.Параметры["ДатаОкончанияПереподготовки"+Ном]		= Выборка.ИТ_ОкончаниеОбучения;
		ТретьяСтраницаТ2.Параметры["Специальность"+Ном]                     = Выборка.Специальность;
		ТретьяСтраницаТ2.Параметры["ДокументОПереподготовка"+Ном]           = Выборка.ИТ_НаименованиеДокумента;
		ТретьяСтраницаТ2.Параметры["СерияНомерДокументаПереподготовки"+Ном] = Выборка.Диплом;
		ТретьяСтраницаТ2.Параметры["ДатаДокументПереподготовки"+Ном]        = Выборка.ИТ_ДатаОкончания;	
	КонецЦикла;
	
	//АТТЕСТАЦИИ
	Запрос.Текст =
		"ВЫБРАТЬ
		|	ОценкиКомпетенцийРаботниковСрезПоследних.ИТ_Специальность,
		|	ОценкиКомпетенцийРаботниковСрезПоследних.Период,
		|	ОценкиКомпетенцийРаботниковСрезПоследних.Регистратор.Номер КАК НомерПротокола,
		|	ОценкиКомпетенцийРаботниковСрезПоследних.Регистратор.Дата КАК ДатаПротокола,
		|	ОценкиКомпетенцийРаботниковСрезПоследних.Компетенция КАК Решение
		|ИЗ
		|	РегистрСведений.ОценкиКомпетенцийРаботников.СрезПоследних(&Период, ФизЛицо = &ФизЛицо) КАК ОценкиКомпетенцийРаботниковСрезПоследних";
	Запрос.УстановитьПараметр("Физлицо", СтруктураПоискаФизЛицо.ФизЛицо);
	Запрос.УстановитьПараметр("Период", ТекущаяДата());
	
	ном = 0;
	
	Выборка = Запрос.Выполнить().Выбрать();
	пока Выборка.Следующий() Цикл
		ном = ном + 1;
		
		Если ном > 6 тогда
			Прервать;
		КонецЕсли;
		
		ТретьяСтраницаТ2.Параметры["ДатаАттестации"+ном] 	= Выборка.Период;
		ТретьяСтраницаТ2.Параметры["РешениеКомиссии"+Ном]	= Выборка.Решение;
		ТретьяСтраницаТ2.Параметры["НомерПротокола"+Ном]   	= Выборка.НомерПротокола;
		ТретьяСтраницаТ2.Параметры["ДатаПротокола"+Ном]    	= Выборка.ДатаПротокола;	
	КонецЦикла;

Также бонусом выкладываю внешнюю печатную форму для формирования Т2 из карточки сотрудника. Печатная форма выводит типовой отчет с отбором по сотруднику.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ВПФ_т2
.epf 4,28Kb
02.12.15
10
.epf 1.0.0.0 4,28Kb 10 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Антон Коваленко (Kaval88) 03.06.16 13:19
ВО_ПовышениеКвалификации = Справочники.ВидыОбразованияФизЛиц.НайтиПоНаименованию("Повышение квалификции");

Это строка таит в себе подвох))
2. Дмитрий Котельников (kotlovD) 03.06.16 15:08
(1) Kaval88, ахах забавно, не заметил :)
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа