gifts2017

Блокировка работы пользователей по расписанию или как сохранить произвольные параметры для внешней обработки

Опубликовал alex G (alexx2510) в раздел Администрирование - Сервисные утилиты

Вариант сохранения произвольных параметров для внешних обработок на примере обработки по установке блокировки пользователей по расписанию.

В работе службы сопровождения 1С нередко возникают ситуации, когда нужно обеспечить отсутствие пользователей в базе для проведения каких-то регламетных процедур или сервисных работ. Некоторые такие процедуры должны выполняться регулярно, и было бы удобно настроить расписание установки блокировки на вход в информационную базу.

1) Создание обработки "Блокировка работы пользователей" для запуска по расписанию

Не секрет, что с некоторых пор в типовых конфигурациях 1С появилась возможность запуска дополнительных обработок по расписанию.

Для этого в модуле внешней обработки в процедуре СведенияОВнешнейОбработке добавляем команду  с вариантом использования "ВызовСерверногоМетода"

Функция СведенияОВнешнейОбработке() Экспорт
	
	СведенияОбОбработке = Новый Структура;
	
	СведенияОбОбработке.Вставить("Вид", "ДополнительнаяОбработка");
	
	СведенияОбОбработке.Вставить("Наименование ", "Блокировка работы пользователей (автозапуск)");
	
	СведенияОбОбработке.Вставить("Версия ", "3.0.1.0");
	
	СведенияОбОбработке.Вставить("БезопасныйРежим", Ложь);
	
	СведенияОбОбработке.Вставить("Информация", "Блокировка работы пользователей (автозапуск)");
	
	ТаблицаКоманд = ПолучитьТаблицуКоманд();
	ДобавитьКоманду(ТаблицаКоманд, "ЗаблокироватьПользователей", "ВыполнитьУстановку", "ВызовСерверногоМетода");
	СведенияОбОбработке.Вставить("Команды", ТаблицаКоманд);
	
	Возврат СведенияОбОбработке;
            
КонецФункции


Также добавляем в модуль процедуру "ВыполнитьКоманду(ИдентификаторКоманды)", которая будет обрабатывать вызов нашего серверного метода

Процедура ВыполнитьКоманду(ИдентификаторКоманды) Экспорт
	
	Если ИдентификаторКоманды = "ВыполнитьУстановку" Тогда
		ВыполнитьУстановку();
	КонецЕсли;
				
КонецПроцедуры


В процедуре "ВыполнитьУстановку" будем заполнять необходимые реквизиты блокировки и затем вызывать процедуру глобального контекста "УстановитьБлокировкуСеансов".

Теперь все готово для того, чтобы зарегистировать нашу обработку в списке дополнительных отчетов и обработок и настроить расписание запуска

 


Итак, теперь у нас есть обработка, которая запускается по расписанию и устанавливает блокировку работы пользователей.
Все здорово, кроме одного: параметры нашей блокировки (время начала, время окончания, текст сообщения для пользователей и т.д.) нам пришлось прописать непосредственно в коде обработки, соответственно, когда появится необходимость эти параметры поменять - нам придется менять код обработки и заново регистрировать ее.
Не очень красивое решение. Для решения этой проблемы создадим механизм, который позволит сохранять для нашей обработки произвольный набор параметров.

 

2) Сохранение произвольных параметров для дополнительных обработок

Для сохранения настроек воспользуемся объектом "ХранилищеОбщихНастроек" и его методом

Сохранить(<КлючОбъекта>, <КлючНастроек>, <Настройки>, <ОписаниеНастроек>, <ИмяПользователя>)


По умолчанию (если параметр <ИмяПользователя> не задан) настройки сохраняются для текущего пользователя. Однако, если у пользователя, вызвашего этот метод
есть права "АдминистрированиеДанных" он может работать с настройками других пользователей и к тому же ИмяПользователя это просто строка - этим-то мы и воспользуемся для решения своей задачи:
мы будем сохранять настройки для "пользователя" ДополнительныеОбработки(естественно никакого пользователя ДополнительныеОбработки у нас в базе нет, это просто ключ, в разрезе которого мы будем хранить настройки для внешних обработок)

<КлючОбъекта> в нашем случае ключом будет Имя внешней обработки для которой сохраняем настройки, а <КлючНастроек> - строка "ДополнительныеНастройки"(имя можно придумать любое).
Сами настройки передаются в параметре <Настройки> тип параметра произвольный. Для нашей задачи мы будем использовать, структуру.

Вот собственно и все. Теперь создаем еще одну внешнюю обработку "СохранениеНастроекДопОбработок" и делаем в ней удобную форму для работы с нашим методом "Сохранить".
На форме будем выбирать внешнюю обработку из списка зарегистрированных в базе, а в табличной части будем указывать настройки, которые хотим сохранить в виде "ИмяНастройки-ЗначениеНастройки".

 



 Теперь остается в обработке блокировки пользователей считать сведения о настройках для нашей обработки

Функция ПолучитьСведенияОНастройке()
	
	СведенияОНастройке = Новый Структура;
	СведенияОНастройке.Вставить("КлючОбъекта", СокрЛП(ЭтотОбъект.Метаданные().Имя)); // имя обработки из которой считываем настройки
	СведенияОНастройке.Вставить("КлючНастроек", "ДополнительныеНастройки"); // ключ настроек "ДополнительныеНастройки"
	СведенияОНастройке.Вставить("ВладелецНастроек", "ДополнительныеОбработки"); // виртуальный пользователь-владелец настроек
	
	Возврат СведенияОНастройке;
КонецФункции

прочитать настройки на основании полученных сведений и заполнить реквизиты обработки полученными значениями


В качестве примера реализации описанного выше подхода во вложении приведены обработки:

1. Внешняя обработка "Сохранение настроек доп.обработок" - сохраняет произвольный перечень параметров для выбранной на форме дополнительной обработки.

2. Внешняя обработка "Блокировка пользователей (автозапуск)" - позволяет запускать обработку блокировки по расписанию и считывать сохраненные для обработки настройки.

Скачать файлы

Наименование Файл Версия Размер
Сохранение настроек доп.обработок 6
.epf 9,92Kb
15.12.15
6
.epf 9,92Kb Скачать
Блокировка работы пользователей (автозапуск) 8
.epf 14,35Kb
15.12.15
8
.epf 14,35Kb Скачать

См. также

Подписаться Добавить вознаграждение
В этой теме еще нет сообщений.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа