gifts2017

УПД для реализации (УТ 10.3.32)

Опубликовал г. Казань Рустем Гумеров (Rustig) в раздел Печать - Печатные формы документов

Решена конкретная задача: в УПД для документа РеализацияТоваровУслуг в поле "Основание" ([8]-ая строка УПД) вывести Заказ покупателя №... от ....
1) Типовой механизм УТ 10.3 автоматом выводит Заказ (Счет) в это поле при условии, что в договоре с покупателем стоит признак "Взаиморасчеты ведутся: "по заказам (по счетам)". Если взаиморасчеты ведутся "по договору в целом", необходима доработка. Что и было мною сделано.
2) Представлена "почти типовая" внешняя печатная форма Универсального передаточного документа. Почему "почти" - потому что я переопределил параметр печати ДанныеДляПечати.Основание = ДанныеДокументы.Сделка, и этого оказалось достаточно. По умолчанию данный параметр заполняется договором.

Представлена "почти типовая" внешняя печатная форма Универсального передаточного документа. Почему "почти":
а) потому что разработчики типовой УТ 10.3 во все функции и процедуры, реализующие вывод УПД на печать, установили признак "Экспорт". И сейчас нет необходимости копировать все процедуры и функции из модулей типовой конфигурации, в частности общего модуля УчетНДС и модуля документа СчетФактураВыданный.

Для реализации непосредственно внешней формы мне пришлось скопировать только три типовые экспортные процедуры в модуль обработки, немного их доработал. Макет используется типовой общий.

 

Функция Печать() Экспорт
Возврат ПечатьУниверсальногоПередаточногоДокумента();
КонецФункции

//функция взята из модуля документа РеализацияТоваровУслуг
Функция ПечатьУниверсальногоПередаточногоДокумента()
КонецФункции

//функция взята из общего модуля УчетНДС.ПечатьУниверсальногоПередаточногоДокумента()
Функция УчетНДСПечатьУниверсальногоПередаточногоДокумента(ДанныеДокумента, СчетФактураТребуется, СтруктураОтбораСчетаФактуры = Неопределено, ТабДокумент = Неопределено)
КонецФункции // ПечатьУниверсальногоПередаточногоДокумента

//функция взята из модуля документа СчетФактураВыданный.ПодготовитьДанныеДляПечатиУниверсальногоПередаточногоДокумента()
Функция СчетФактураОбъектПодготовитьДанныеДляПечатиУниверсальногоПередаточногоДокумента(СчетФактураОбъект, ДанныеСчетФактуры = Неопределено)
КонецФункции // ПодготовитьДанныеДляПечатиУниверсальногоПередаточногоДокумента



б) понимая алгоритм формирования печатной формы, можно использовать уже имеющиеся поля и параметры для переопределения их своими значениями.

Для переопределения параметра печати добавил следующий код.

 

 

//типовой алгоритм
ДанныеДляПечати = УчетНДС.ПодготовитьДанныеДляПечатиУниверсальногоПередаточногоДокумента(ДанныеДокумента);
Если ДанныеДляПечати = Неопределено Тогда
Возврат Неопределено;
КонецЕсли;

//моя доработка: выводим Заказ в поле Основание
Основание = ОбщегоНазначения.СформироватьЗаголовокДокумента(ДанныеДокумента.ДокументСсылка.Сделка, Строка(ДанныеДокумента.ДокументСсылка.Сделка.Метаданные().Синоним));
РасшифровкаОснования = ДанныеДокумента.ДокументСсылка.Сделка;
ДанныеДляПечати.Вставить("Основание", Основание);
ДанныеДляПечати.Вставить("РасшифровкаОснования", РасшифровкаОснования);
//доработка



Обработка разрабатывалась на платформе 1С:Предприятие 8.3 (8.3.6.2299), на конфигурации УТ 10.3.32.2.

Для решения задачи можно было бы переопределить только функцию из общего модуля УчетНДС, а экспортную функцию из модуля документа СчетФактураВыданный - даже не копировать. И все же, в целом получилось решить задачу минимальными правками, сохранив конфигурацию на типовой поддержке. А также получился готовый шаблон внешней УПД для документа РеализацияТоваровУслуг для решения будущих интересных задач.


Всем успехов и всего доброго!
Центр автоматизации, г.Казань go-scan.ru

Скачать файлы

Наименование Файл Версия Размер
УПД для реализации 40
.epf 9,31Kb
15.12.15
40
.epf 9,31Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Евгений Ефремов (evgefremov) 12.01.16 10:34
хреново сделано...заполненность сделки кто за тебя проверять будет?
2. Евгений Ефремов (evgefremov) 12.01.16 10:39
да и данные по доверенности выводить надо!
3. Евгений Ефремов (evgefremov) 12.01.16 10:41
логично было бы поправить процедуру ЗаполнитьОснование, сделав вывод след.образом:
данные по договору; данные доверенности; данные по сделке
естеств-но если была заполненна соответств информация по каждому из данных!
4. г. Казань Рустем Гумеров (Rustig) 11.02.16 16:20
(2) evgefremov, решена конкретная задача, а не универсальная. ваши претензии не обоснованы.
5. г. Казань Рустем Гумеров (Rustig) 11.02.16 16:35
(3) evgefremov, ваши замечания пригодятся другим разработчикам. спасибо, что написали.
6. г. Казань Рустем Гумеров (Rustig) 14.02.16 01:41
(1) evgefremov, специфика работы фирмы - только по заказам - то есть нет реализаций без заказов (с пустой сделкой) - в моем случае не надо пустую сделку замещать на договор - не положено :)
доверенностей при отгрузках нет - отгрузка со склада фирмы - не представляю, в каких случаях могут быть доверенности?