gifts2017

Проблемы переноса данных бухгалтерского учета

Опубликовал Виктор Левченко (lvictor58) в раздел Обмен - Обмен через XML

Спецы 1С для удобства конечного пользователя создали специальные решения, позволяющие по нажатию кнопки выгрузить данные. Попробовал и я...

1.1. Ошибка записи объекта:
Тип объекта = Регистр сведений запись: Настройки учета страховых взносов
Описание ошибки = Ошибка при вызове метода контекста (Записать): Запись не верна! Значение поля "Организация" не может быть пустым.

Устранение ошибки: В ПКО "УчетСтраховыхВзносовНастройкиОрганизаций" для свойства "Организация" не указано ПКО

 

1.2. Ошибка в обработчике события ПередЗагрузкойДанных (конвертация)
Описание ошибки = Ошибка при вызове метода контекста (СоздатьНабор): Недопустимое значение параметра (параметр номер '1')

Устранение ошибки: Константа "ВедетсяДеятельностьПоДоговорамКомиссииНаПродажу" не существует. Удалил ссылку на нее.

 

1.3. Ошибка при загрузке данных: Поле объекта не обнаружено (ПоложенияПереходногоПериодаУСН)

Устранение ошибки: Указанный реквизит регистра сведений "УчетнаяПолитикаОрганизаций" переименован в "УдалитьПоложенияПереходногоПериодаУСН". Отключил для переноса.

 

1.4. Ошибка записи объекта
Тип объекта = Вид вычетов НДФЛ
Описание ошибки = Ошибка при вызове метода контекста (Записать): Не удалось записать "103 (Вид вычетов НДФЛ)"!

Устранение ошибки: Для ПКО "ВидыВычетовНДФЛ" поставил крыж "Не замещать существующие". Непонятно только почему для предопределенных объектов это не отслеживается в процессе загрузки по умолчанию!?


1.5. Ошибка записи объекта
Тип объекта = Договор
Описание ошибки = Ошибка при вызове метода контекста (Записать): Значение поля "Контрагент" не заполнено или заполнено неверно

Устранение ошибки: Так и не понял как с зтим бороться. Отключил загрузку реквизитов контрагента "Основной договор" и "Основной счет". Поставил крыж "Загружать только новые".

После выгрузки объекта отключил проверку ИНН и КПП

Если НЕ Объект.ЭтоГруппа Тогда
Объект.ИННВведенКорректно = Истина;
Объект.КППВведенКорректно = Истина;
КонецЕсли;

Вроде помогло.


1.6. Ошибка записи объекта
Тип объекта = Регистр сведений запись: Текущие кадровые данные сотрудников
Описание ошибки = Ошибка при вызове метода контекста (Записать): Ошибка при выполнении: Значение не является значением объектного типа (Ссылка)

Устранение ошибки: Такое ощущение, что шло зацикливание (при загрузке) когда в регистре шла ссылка на сотрудника, а в нем - на данный регистр, но почему при загрузке? Выгрузилось то нормально!
Создал ПКО "СотрудникиСсылка" (не замещать, а только новые) со свойствами для поиска:

  • Наименование
  • Организация
  • Физическое лицо

и сослался на него в свойстве "Сотрудник" указанного регистра 

1.7. Ошибка в обработчике события ПослеЗагрузкиДанных (конвертация)
Описание ошибки = Поле объекта не обнаружено (Организация)

Устранение ошибки: Для параметра "ОРГАНИЗАЦИЯ" проставил крыж "При загрузке" и указал правило конвертации "Организации"

 

1.8. Ошибка записи объекта
Тип объекта = Регистр сведений запись: Текущая тарифная ставка сотрудников
Описание ошибки = Ошибка при вызове метода контекста (Записать): Запись не верна! Значение поля "Физическое лицо" не может быть пустым!:

Устранение ошибки: Вместо двух свойств "Сотрудник" в правиле конвертации достаточно одного. И добавить "ФизическоеЛицо", "ТекущаяОрганизация"
Для "Сотрудник" назначил правило "СотрудникСсылка".

 

2. Теперь пытаемся загрузить документы.


2.1 Не проводятся после загрузки!
прописал в обработчик "Перед конвертацией объекта"

Если ТипЗначенияСтр(Источник) = "Документ" Тогда
Если (Источник.Вид() = "Счет")
ИЛИ (Источник.Вид() = "Доверенность")
ИЛИ (Источник.Вид() = "ПлатежноеПоручение")
Тогда
Если Источник.ПометкаУдаления() = 0 Тогда РежимЗаписи = "Проведение"; КонецЕсли;
Иначе
Если Источник.Проведен() = 1 Тогда РежимЗаписи = "Проведение"; КонецЕсли;
КонецЕсли;
КонецЕсли;

 

2.2 Ошибка при загрузке данных: Поле объекта не обнаружено (Услуги)
Смею предположить, что это "Счет на оплату покупателю" в котором указанную табличную часть подготовили к удалению.

Устранение ошибки: В ПКО "Счет" ее отключил и пометил на удаление. В коллекцию "Товары" добавил свойство "Содержание" и прописал его заполнение.

 

2.3 Ошибка записи объекта
Тип объекта = Договор
Описание ошибки = Ошибка при вызове метода контекста (Записать): Поле "Вид договора" заполнено некорректно.
Существуют документы, проведенные по договору. Реквизит не может быть изменен.

Устранение ошибки: В ПКО "Договоры контрагентов" свойство "ВидДоговора" вытащил из группы и назначил отбор по его значению (для элемента)
В ПКО "ДоговорыКонтрагентовПоВидам" - то же самое (не знаю зачем оно вобще нужно!).

Вообще с определением вида договора реальная проблема!
В ПКО документа "Счет" для свойства "Договор" перед выгрузкой прописал

Параметры.ПараметрыАлгоритмов.Установить("Документ",Источник);
Параметры.ПараметрыАлгоритмов.Установить("Договор",Источник.Договор);
ОпределитьВидДоговора();

подкорректировал апгоритм ОпределитьВидДоговора
1. Для документа "Платежное поручение".
2. Для пустого документа, когда передается только счет б/у.

В ПКО "ДоговорыКонтрагентов" закомментировал

//Параметры.ПараметрыАлгоритмов.Установить("ВидДоговора","");
//Параметры.ПараметрыАлгоритмов.Установить("ВесДоговора","");

Похоже, из-за этого вид договора не передавался в соответствующее свойство при выгрузке!

 

2.4 Ошибка записи объекта
Тип объекта = Сотрудник
Описание ошибки = Ошибка при вызове метода контекста (Записать): Значение "0000000009" поля "Таб. номер" не уникально

Устранение ошибки: Проблема загрузки Документа типа Выписка при перечислении зарплаты на л/с сотрудников. Попытка конвертации сотрудников в контрагенты.
В моей конкретной ситуации расчет зарплаты и кадровый учет ведется в ЗиК 77 (сейчас переходим на ЗУП 83) и переносится в бухгалтерию СВОДНО. Поэтому решил не заморачиваться, а просто прорисовать конкретную ситуацию.

Для того, чтобы добиться желаемого результата при переносе, пришлось:

  • добавить новый параметр "УчетПоСтрудникамСводно" (Зарплата без детализации по сотрудникам);
  • закомментировать несколько строк кода конвертации "Перед загрузкой данных";
  • настроил вручную параметры учета для блока "Зарплата и кадры".


2.5. Перекроил модуль "При выгрузке" ПКО "Выписка_Списание" (там много всего "по мелочам")
Ну, например, добавил реквизит "Налог". 
А в платежном поручении - "Налог" и "Вид операции".

После загрузки остатков обнаружил, что по забалансовому счету "001" виды субконто поменялись местами. Откорректировал алгоритм "Добавить Проводку".


2.6. Ошибка записи объекта
Тип объекта = Регистр сведений запись: Процент ЕНВД для учета затрат на зарплату
Описание ошибки = Ошибка при вызове метода контекста (Записать): Запись не верна! Значение поля "Организация" не может быть пустым!:

Устранение ошибки: В ПКО "ВводПроцентаДеятельностиЕНВД" для свойства "Организация" прописал правило конвертации

3. Кроме всего прочего

Для плана не все значения счетов могут быть синхронизированы. В нашем конкретном случае отсутствовали добавленные в ручную счета:

  • 50.2 с 50.02 «Операционная касса»;
  • 68.8 и 68.08 «Налог на имущество»;
  • субсчета счета 68.4 «Налог на прибыль».

Их нужно добавить в список значений ПКО "План счетов - Хозрасчетный"

См. также

Вознаграждение за ответ
Сумма: 0 $m
Добавили:
Владимир Командровский (Wefast) (0.10 $m)
Подписаться Добавить вознаграждение
Комментарии
1. Ирина Удачливая (config) 04.02.16 09:53
Добавить бы в публикацию на каких конфигурациях у вас повылазили все эти ошибки
2. Виктор Левченко (lvictor58) 12.02.16 10:34
(1) config,
Пардон. Вроде бы указывал при размещении публикации, но инфа где=то затерялась. Перенос осуществлялся из 1С:Бухгалтерия 7.7 (УСН релиз 7.70.250) в БП 3.0 номер релиза за давностью не помню, актуальный на первую декаду декабря 2015 года.
3. Елена (chudka) 03.04.16 23:46
Подскажите пожалуйста какой обработкой вы делали перенос, что пишете "Отключил для переноса"? Стандартная обработка, вроде, не позволяет отключать что-то или включать для переноса. По-крайней мере, я не вижу.
4. Владимир Командровский (Wefast) 28.04.16 17:41
    Объект                 =  Перенос данных ЗП_СЗФСС от 28.04.2016
    ОписаниеОшибки         =  Ошибка при вызове метода контекста (Записать): Запись с такими ключевыми полями существует! : ДанныеОВремениДляРасчетаСреднегоФСС: ФИО, ОРГАНИЗАЦИЯ_ИМЯ, 01.02.2015 0:00:00, Перенос данных ЗП_СЗФСС от 28.04.2016,  (Регистр сведений: Данные о времени для расчета среднего (ФСС); Номер строки: 27)

Вот такая ошибка возникает. Как вообще можно проверит и/или исключить эту дублирующуюся запись? ИЛи что вообще можно сделать как думаете?
5. Igo Gor (vertij) 11.08.16 12:06
1.2. Ошибка в обработчике события ПередЗагрузкойДанных (конвертация)
Описание ошибки = Ошибка при вызове метода контекста (СоздатьНабор): Недопустимое значение параметра (параметр номер '1')

Устранение ошибки: Константа "ВедетсяДеятельностьПоДоговорамКомиссииНаПродажу" не существует. Удалил ссылку на нее.

У меня такая ошибка. Кто нибудь подскажите более детально пожалуйста где и как удалить ссылку.