gifts2017

Обработка в JSON формате + бонус "Суперсила"

Опубликовал Stepan Tyumentsev (st-ty@ngs.ru) в раздел Обработки - Универсальные обработки

Пример обработки для чтения/Запись формата JSON, с источником/приемником com-массивом.

JSON

 Обработка для записи JSON потребовалась совсем недавно, заказчик переходит на данный формат, и сперва возник вопрос: зачем "?", разве не хватает xml? Но, немного почитав про данный формат, пришел к выводу, что он как раз может заменить "тормозной" и тяжелый xml, буквально на днях столкнулся с обработкой xml в данной публикации http://infostart.ru/public/428819/, где содержалось 100 тыс. объектов и 1С от этого числа буквально поплохело). Начиная с версии 8.3.6 данный формат подерживается  1С встроенными методами. 

ЗАПИСЬ

Из описания процедуры:

// При записи JSON вы самостоятельно формируете его структуру. Чтобы «подстраховать» вас от ошибок, объект ЗаписьJSON автоматически проверяет правильность записываемой структуры. 
// Для увеличения скорости работы эту проверку можно отключить. В примере ниже это строка:
ЗаписьJSON.ПроверятьСтруктуру = Ложь;

// Также при записи вы можете управлять некоторыми параметрами формируемого текста, например использованием двойных кавычек, переносом строк, символами отступа и экранированием символов. 

// Потоковая запись JSON может выглядеть следующим образом. Записывается массив из четырёх элементов. Три из них примитивного типа, а четвёртый элемент - это объект с двумя свойствами:
// Пример записи JSON. ЗаписьJSON = Новый ЗаписьJSON;
// Для увеличения скорости работы можно отключить автоматическую проверку // правильности структуры записываемого документа JSON. ЗаписьиЗСЖ.ПроверятьСтруктуру = Ложь;
// Для красоты результирующего текста можно увеличить "лесенку".
// Стандартный отступ - 1 пробел.
ПараметрыЗаписиJSON = Новый ПараметрыЗаписиJSON( , Символы.Таб);
// Либо открыть файл, в который будет выполнена запись,
// либо указать, что запись будет выполнена в строку, которую вернет метод Закрыть().
ЗаписьJSON.ОткрытьФайл("ИмяФайла", , , ПараметрыЗаписиJSON);
//ЗаписьJSON.УстановитьСтроку(ПараметрыЗаписиJSON);
// Записать массив.
ЗаписьJSON.ЗаписатьНачалоОбъекта();
ЗаписьJSON.ЗаписатьИмяСвойства("СвойствоТипаМассив");
ЗаписьJSON.ЗаписатьНачалоМассива();
// Первый элемент массива - Строка. ЗаписьJSON.ЗаписатьЗначение("Значение строка");
// Второй элемент массива - Число. ЗаписьJSON.ЗаписатьЗначение(12.345, Истина);
// Третий элемент массива - Булево. ЗаписьJSON-ЗаписатьЗначение(Истина);
// Четвертый элемент массива - объект с двумя свойствами. ЗаписьJSON.ЗаписатьНачалоОбъекта();
// Первое свойство объекта - Строка
ЗаписьJSON.ЗаписатьИмяСвойства("СвойствоТипаСтрока");
ЗаписьJSON.ЗаписатьЗначение("Значение строка");
// Второе свойство объекта - Неопределено
ЗаписьJSON.ЗаписатьИмяСвойства("СвойствоТипаНеопределено");
ЗаписьJSON.ЗаписатьЗначение(Неопределено);
ЗаписьJSON.ЗаписатьКонецОбъекта();
Запись JSON. ЗаписатьКонецМассива () ;
ЗаписьJSON.ЗаписатьКонецОбъекта();
ЗаписьJSON.Закрыть();
//CTpoKaJSON = ЗаписьJSON.Закрыть();  
 

Теперь как это выглядит в реальности на примере процедуры через com-массив. Почему именно массив "?", попробуйте прогнать "миллионную" таблицу через выборку полей RecordSet, и разница будет ощутимой Smile Основное назначение - синхронизация, обмен данными большого объема, структурированными данными без возможности соединиться с базами напрямую провайдерами. Если ваш EDI-провайдер еще не перешел на поддержку данного формата, это произойдет уже скоро ). 

&НаСервере
Процедура ПрайсЗаписьJSON() Экспорт

	Сообщить(" Выгрузка прайс-листа... ");

	Connection = Новый COMОбъект("ADODB.Connection");
	Connection.ConnectionString = "Provider=SQLOLEDB;User ID=sa;Password=;Initial Catalog=;Data Source="; 
	Connection.Open(); 

	ИмяФайла = "C:\Price.json";

	Query = "...запрос TSQL...";

	Попытка
		COMObject = Connection.Execute(Query); 
		COMSafeArray = COMObject.GetRows(); 
	Исключение
		Сообщить(Query + " // " + ОписаниеОшибки());
	КонецПопытки; 

	ЗаписьJSON = Новый ЗаписьJSON;
	ЗаписьJSON.ПроверятьСтруктуру = Ложь;

	ПараметрыЗаписиJSON = Новый ПараметрыЗаписиJSON( , Символы.Таб);
	ЗаписьJSON.ОткрытьФайл(ИмяФайла, , , ПараметрыЗаписиJSON);

	providerName = "ООО";
	updateDate = Формат(ТекущаяДата(),"ДФ=дд.ММ.гггг");

	ЗаписьJSON.ЗаписатьНачалоОбъекта();
	ЗаписьJSON.ЗаписатьИмяСвойства("providerName"); ЗаписьJSON.ЗаписатьЗначение(providerName);
	ЗаписьJSON.ЗаписатьИмяСвойства("updateDate"); ЗаписьJSON.ЗаписатьЗначение(updateDate);
	ЗаписьJSON.ЗаписатьИмяСвойства("items"); 
	ЗаписьJSON.ЗаписатьНачалоМассива();

	Для Индекс = 0 по COMSafeArray.GetUpperBound()-1 Цикл

		code                = Строка(COMSafeArray.GetValue(Индекс,0)); //Код товара поставщика
		name                = Строка(COMSafeArray.GetValue(Индекс,1)); //Наименование товара
		manufacturer        = Строка(COMSafeArray.GetValue(Индекс,2)); //Производитель
		manufacturerCountry = Строка(COMSafeArray.GetValue(Индекс,3)); //Страна
		barcode             = Строка(COMSafeArray.GetValue(Индекс,4)); //Штрихкод производителя
		quantity            = Число(COMSafeArray.GetValue(Индекс,5)); //Количество
		price               = Число(COMSafeArray.GetValue(Индекс,6)); //Цена с НДС, руб.
		Если Число(COMSafeArray.GetValue(Индекс,6)) > 0 Тогда
			multiplicity = (COMSafeArray.GetValue(Индекс,7)); //Кратность 
		Иначе 
			multiplicity = 1; //Кратность 
		КонецЕсли;
		ratends            = Число(COMSafeArray.GetValue(Индекс,8)); //Ставка НДС, %
		expirationDate     = ""; //Срок годности

		ЗаписьJSON.ЗаписатьНачалоОбъекта();
		  ЗаписьJSON.ЗаписатьИмяСвойства("code");                ЗаписьJSON.ЗаписатьЗначение(code);
		  ЗаписьJSON.ЗаписатьИмяСвойства("name");                ЗаписьJSON.ЗаписатьЗначение(name);
		  ЗаписьJSON.ЗаписатьИмяСвойства("manufacturer");        ЗаписьJSON.ЗаписатьЗначение(manufacturer);
		  ЗаписьJSON.ЗаписатьИмяСвойства("manufacturerCountry"); ЗаписьJSON.ЗаписатьЗначение(manufacturerCountry);
		  ЗаписьJSON.ЗаписатьИмяСвойства("barcode");             ЗаписьJSON.ЗаписатьЗначение(barcode);
		  ЗаписьJSON.ЗаписатьИмяСвойства("quantity");            ЗаписьJSON.ЗаписатьЗначение(quantity);
		  ЗаписьJSON.ЗаписатьИмяСвойства("price");               ЗаписьJSON.ЗаписатьЗначение(price);
		  ЗаписьJSON.ЗаписатьИмяСвойства("multiplicity");        ЗаписьJSON.ЗаписатьЗначение(multiplicity);
		  ЗаписьJSON.ЗаписатьИмяСвойства("ratends");             ЗаписьJSON.ЗаписатьЗначение(ratends);
		  ЗаписьJSON.ЗаписатьИмяСвойства("expirationDate");      ЗаписьJSON.ЗаписатьЗначение(expirationDate);
		ЗаписьJSON.ЗаписатьКонецОбъекта();

	КонецЦикла;

	  ЗаписьJSON.ЗаписатьКонецМассива();
	ЗаписьJSON.ЗаписатьКонецОбъекта();
	ЗаписьJSON.Закрыть();

	Connection.Close(); 
	
КонецПроцедуры


"СУПЕРСИЛА" - небольшое отступление от темы.

  Как создать формат json без цикла строк, казалось бы не реально? Но вот T-SQL запрос...)))

Аналог запроса можно проверить на "FOR xml PATH", "FOR json PATH" будет работать только на последней версии SQL Server.

  Посмотрел пару сериализаторов на паблике, но типовой от 1С на мой вкус самый простейший http://v8.1c.ru/o7/201501json/index.htm:

В результате будет получен файл JSON следующего содержания:

{
	"#type": "jcfg:CatalogObject.Контрагенты",
	"#value": {
		"IsFolder": false,
		"Ref": "3d710076-8d04-11dc-8ca0-000d8843cd1b",
		"DeletionMark": false,
		"Parent": "9d5c422c-8c4c-11db-a9b0-00055d49b45e",
		"Code": "000000012",
		"Description": "Мосхлеб ОАО",
		"Регион": "9d5c422f-8c4c-11db-a9b0-00055d49b45e",
		"Индекс": "456789",
		"Страна": "Россия",
		"Город": "Москва",
		"Улица": "Петровка",
		"Дом": "12",
		"Телефон": "+7(999)234-78-64",
		"ЭлектроннаяПочта": "mh@hleb.ru",
		"Факс": "",
		"ВебСайт": "",
		"ВидЦен": "9d5c4225-8c4c-11db-a9b0-00055d49b45e",
		"ДополнительнаяИнформация": "Поставка хлеба",
		"КонтактноеЛицо": "Громышева П.Р.",
		"Широта": 55.762744,
		"Долгота": 37.618102
	}
}


ЧТЕНИЕ

Рассмотрим, как происходит чтение, пример с обработкой формы заявки от покупателя будет опубликован чуть позже, сейчас как это выглядит в теории:

// Пример чтения JSON.
ЧтениеJSON = Новый ЧтениеJSON;
// Либо открыть файл, из которого будет выполняться чтение, // либо установить строку, из которой будет выполняться чтение.
ЧтениеJSON.ОткрытьФайл("ИмяФайла");
//ЧтениеJSON.УстановитьСтроку("СтрокаJSON");
Пока ЧтениеJSON.Прочитать() Цикл
  TипJSON = ЧтениеJSON.ТипТекущегоЗначения;
  Если TипJSON = ТипЗначенияJSON.Число ИЛИ TипJSON = ТипЗначенияJSON.Строка ИЛИ TипJSON =         ТипЗначенияJSON.Булево ИЛИ TипJSON = ТипЗначенияJSON.Null Тогда
  // Обработать значение
  Значение = ЧтениеJSON.ТекущееЗначение;
  ИначеЕсли ТипJSON = ТипЗначенияJSON.Комментарий Тогда
  // Обработать комментарий
  Комментарий = ЧтениеJSON.ТекущееЗначение;
  ИначеЕсли TипJSON = ТипЗначенияJSON.ИмяСвойства Тогда
  // Обработать имя свойства
  ИмяСвойства = ЧтениеJSON.ТекущееЗначение;
  ИначеЕсли TипJSON = ТипЗначенияJSON.НачалоМассива ИЛИ TипJSON = ТипЗначенияJSON.КонецМассива ИЛИ TипJSON =   ТипЗначенияJSON.НачалоОбъекта ИЛИ TипJSON = ТипЗначенияJSON.КонецОбъекта ИЛИ TипJSON =   ТипЗначенияJSON.Ничего Тогда
  // Обработать начало/конец массива/объекта или отсутствие данных, // ТекущееЗначение читать не нужно.
  КонецЕсли;
КонецЦикла;
ЧтениеJSON.Закрыть();
 ЗАЯВКА
Вот и пришла долгожданная заявка, но где же код адреса О_О? Пока разбираемся с этим вопросом, рассмотрим формат:
{  
   "providerName":"Феникс",
   "orderNumber":"23415",
   "orderDate":"01.12.2015",
   "filial":"Аптека 1",
   "address":"6afc1644-342c-11e6-80d6-00155d020c01",
   "items":[  
      {  
         "code":"4261",
         "name":"Капотен 25мг №40 табл Акрихин",
         "manufacturer":"Акрихин ХФК ОАО Россия",
         "manufacturerCountry":"Россия",
         "barcode":"4601969000580",
         "quantity":1,
         "price":185.92,
         "multiplicity":1,
         "expirationDate":"01.10.2019"
      },
      {  
         "code":"4264",
         "name":"Гастрофарм 2,5 №6 табл",
         "manufacturer":"НАЦИОНАЛЬНАЯ ДИСТРИБЬЮТОРСКАЯ КОМПАНИЯ",
         "manufacturerCountry":"Болгария",
         "barcode":"3800043700519",
         "quantity":2,
         "price":52.32,
         "multiplicity":1,
         "expirationDate":"01.05.2017"
      }
   ]
}
 Он особо не отличается от отправленного нами прайс-листа, попробуем его обработать через наш "коннектор 1С" и передать в КИС на базе СУБД MS SQL.
FileName = КаталогЗагрузки + "\"+ Строка(objFile.Name);

		Сообщить(FileName);				  																		
		
		items = 0;
		
		ЧтениеJSON = Новый ЧтениеJSON;
		ЧтениеJSON.ОткрытьФайл(FileName);
		Пока ЧтениеJSON.Прочитать() Цикл
			
			  TипJSON = ЧтениеJSON.ТипТекущегоЗначения;
			  Если TипJSON = ТипЗначенияJSON.Число ИЛИ TипJSON = ТипЗначенияJSON.Строка ИЛИ TипJSON = ТипЗначенияJSON.Булево ИЛИ TипJSON = ТипЗначенияJSON.Null Тогда
			 		Значение = ЧтениеJSON.ТекущееЗначение;				
			  ИначеЕсли TипJSON = ТипЗначенияJSON.Комментарий Тогда
			  		Комментарий = ЧтениеJSON.ТекущееЗначение;
			  ИначеЕсли TипJSON = ТипЗначенияJSON.ИмяСвойства Тогда		 
			  		ИмяСвойства = ЧтениеJSON.ТекущееЗначение;					
			  КонецЕсли;
				
			  Если      ИмяСвойства ="providerName" Тогда 	
		      	providerName=Значение;
			  ИначеЕсли ИмяСвойства ="orderNumber" Тогда	
			  	orderNumber=Значение;
			  ИначеЕсли ИмяСвойства ="orderDate" Тогда		
			  	orderDate=Значение;
			  ИначеЕсли ИмяСвойства ="filial" Тогда	
			  	filial=Значение;
			  ИначеЕсли ИмяСвойства ="address" Тогда	
			  	address=Значение;
			  КонецЕсли;
			  
			  Если TипJSON = ТипЗначенияJSON.НачалоМассива Тогда
			  	  items = 1;		  
				  
				  ТТ         = Справочники.ТорговыеТочкиАптек.НайтиПоРеквизиту("GUID",address,,);
			
				  Док = Документы.ЗаказыАптеки.СоздатьДокумент(); 
				  Док.Тип          = 30;
				  Док.Номер        = orderNumber;
				  Док.Дата         = ТекущаяДата();
				  Док.Контрагент   = ТТ.ТорговаяТочкаКИС.Ссылка;

			  КонецЕсли;
			  
			  Если items = 1 Тогда
				    
				  Если TипJSON =   ТипЗначенияJSON.НачалоОбъекта  и items = 1 Тогда		
		              СтрокаТовара = Док.ТабличнаяЧасть.Добавить();
				  КонецЕсли;
					  			 
				  Если      ИмяСвойства ="code" Тогда 	
			      	code=Значение;
				  ИначеЕсли ИмяСвойства ="quantity" Тогда	
				  	quantity=Значение;
				  ИначеЕсли ИмяСвойства ="price" Тогда		
				  	price=Значение;
				  КонецЕсли;
				  
				Если TипJSON =   ТипЗначенияJSON.КонецОбъекта  Тогда
					СтрокаТовара.Номенклатура = Справочники.Номенклатура.НайтиПоКоду(code);
					СтрокаТовара.Количество   = Число(quantity);
					СтрокаТовара.Цена         = price;//
				КонецЕсли;
				
			КонецЕсли;	
			
			Если TипJSON = ТипЗначенияJSON.КонецМассива Тогда
				items = 0;
			КонецЕсли;
		  
		КонецЦикла;
		ЧтениеJSON.Закрыть();
		
		//DocumentStatus
		Док.НомерКИС = orderNumber;

		Попытка
			Док.Записать(РежимЗаписиДокумента.Проведение);			 
		Исключение
			Сообщить(ОписаниеОшибки());	
		КонецПопытки;		
		
		Сообщить("Создан заказ № " + orderNumber);		
 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
json
.epf 6,73Kb
18.12.15
13
.epf 6,73Kb 13 Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение

Комментарии

1. Дмитрий Никс (aximo) 19.12.15 10:47
приятно видеть, что инструментарий платформы 1с развивается.
2. Ivan Khorkov (vano-ekt) 19.12.15 16:19
//сдесь получаем массив

сдесь желание смотреть код пропало
DrAku1a; BigB; +2 Ответить 2
3. Stepan Tyumentsev (st-ty@ngs.ru) 19.12.15 18:56
(2) vano-ekt, есть другие варианты обработать COMObject быстрее? Сами варианты то конечно есть...
Или имелось ввиду перегнать сразу за "пару секунд" массив в формат json, без циклов обхода строк, но тогда эта "сверхсекретная" информация не для данного паблика :)
4. Константин Гейнрих (CyberCerber) 21.12.15 09:52
(3) st-ty@ngs.ru, думаю, имелось в виду совсем другое... :-)
Получать массив нужно не сдесь, а здесь.
5. Андрей Гердт (AndreyNit) 22.12.15 09:00
Познавательно, автору плюс.
6. Сергей Галюк (dj_serega) 22.12.15 18:53
А почему:
        code                = Строка(COMSafeArray.GetValue(Индекс,0)); //Код товара поставщика
        name                = Строка(COMSafeArray.GetValue(Индекс,1)); //Наименование товара
        manufacturer        = Строка(COMSafeArray.GetValue(Индекс,2)); //Производитель
        manufacturerCountry = Строка(COMSafeArray.GetValue(Индекс,3)); //Страна
        barcode             = Строка(COMSafeArray.GetValue(Индекс,4)); //Штрихкод производителя
        quantity            = Число(COMSafeArray.GetValue(Индекс,5)); //Количество
        price               = Число(COMSafeArray.GetValue(Индекс,6)); //Цена с НДС, руб.
        Если Число(COMSafeArray.GetValue(Индекс,6)) > 0 Тогда
            multiplicity = (COMSafeArray.GetValue(Индекс,7)); //Кратность 
        Иначе 
            multiplicity = 1; //Кратность 
        КонецЕсли;
        ratends            = Число(COMSafeArray.GetValue(Индекс,8)); //Ставка НДС, %
...Показать Скрыть

И
        ЗаписьJSON.ЗаписатьИмяСвойства("code");                ЗаписьJSON.ЗаписатьЗначение(code);
          ЗаписьJSON.ЗаписатьИмяСвойства("name");                ЗаписьJSON.ЗаписатьЗначение(name);
          ЗаписьJSON.ЗаписатьИмяСвойства("manufacturer");        ЗаписьJSON.ЗаписатьЗначение(manufacturer);
          ЗаписьJSON.ЗаписатьИмяСвойства("manufacturerCountry"); ЗаписьJSON.ЗаписатьЗначение(manufacturerCountry);
          ЗаписьJSON.ЗаписатьИмяСвойства("barcode");             ЗаписьJSON.ЗаписатьЗначение(barcode);
          ЗаписьJSON.ЗаписатьИмяСвойства("quantity");            ЗаписьJSON.ЗаписатьЗначение(quantity);
          ЗаписьJSON.ЗаписатьИмяСвойства("price");               ЗаписьJSON.ЗаписатьЗначение(price);
          ЗаписьJSON.ЗаписатьИмяСвойства("multiplicity");        ЗаписьJSON.ЗаписатьЗначение(multiplicity);
          ЗаписьJSON.ЗаписатьИмяСвойства("ratends");             ЗаписьJSON.ЗаписатьЗначение(ratends);
          ЗаписьJSON.ЗаписатьИмяСвойства("expirationDate");      ЗаписьJSON.ЗаписатьЗначение(expirationDate);
 
...Показать Скрыть

не через общие функции реализовано?
7. Stepan Tyumentsev (st-ty@ngs.ru) 22.12.15 21:58
(6) dj_serega, задачи такой не ставилось, пример должен быть как можно проще, и каким образом этот сделать?
8. Stepan Tyumentsev (st-ty@ngs.ru) 22.12.15 22:56
(2) vano-ekt, специально для Вас бонус см. разделе "суперсила", дальше смотреть код и не нужно ;)
9. Иван Иванов (kosmo0) 23.12.15 10:44
А кусок кода на запись так и должна совпадать с кодом на чтение?
10. Stepan Tyumentsev (st-ty@ngs.ru) 23.12.15 11:05
(9) kosmo0, нет так не должно быть, блок записи исправил.
11. Allexey (alex_4x) 09.02.16 13:22
для 1С 8.2 нет реализации ? чтобы не типовыми методами 8.3 Чтение и запись делать....
12. Stepan Tyumentsev (st-ty@ngs.ru) 10.02.16 07:15
(11) alex_4x, для 8.2 самописные функции, примеры разные http://infostart.ru/public/59535/
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа