gifts2017

Расшифровка алкогольной акцизной марки (ЕГАИС)

Опубликовал Денис Саяпин (sdv88) в раздел Обработки - Обработка справочников

Думаю, с внедрением ЕГАИСа многие столкнулись с проблемой сопоставления собственной номенклатуры с номенклатурой ЕГАИС.

В справочниках ЕГАИСА очень много одинаковой номенклатуры с разными алкогольными кодами, возникает вопрос, какую номенлатуру связывать со своей.

Отсканировав марку, её можно расшифровать и определить акогольный код, тем самым идентифицировать бутылку в справочнике ЕГАИС и связать с собственной номенклатурой.

Думаю, "алкоголикам" будет полезно. 

Писал на коленке, можно было прикрутить сканер, пока некогда.

Скопируйте марку в поле "марка" и нажмите выполнить, в поле "алкогольный код" появится алкогольный код продукции по ЕГАИС

В марке также содержатся данные по:

  • идентификатору производителя
  • дате заявки на нанесение марки
  • номеру заявки на нанесение марки
  • серии марки
  • порядковому номеру марки

Если надо, добавлю позже.

Скачать файлы

Наименование Файл Версия Размер
Расшифровка марки 145
.epf 6,58Kb
13.01.16
145
.epf 6,58Kb Скачать

См. также

Contragent+ 5.0 от 2 500
Вознаграждение за ответ
Сумма: 0 $m
Добавили:
ivan (ayava) (0.05 $m)
Подписаться Добавить вознаграждение
Комментарии
1. Андрей Тарлыков (Tarlich) 14.01.16 16:25
Это марку руками вбивать ? -))
2. Денис Саяпин (sdv88) 14.01.16 16:29
(1) Tarlich, нет времени чтобы сделать считыванием со сканера, позже добавлю. пока просто делюсь алгоритмом.
3. rvs-slim (rvs-slim) 14.01.16 23:59
(2) sdv88,
Точно знаете по:
- идентификатору производителя
- дате заявки на нанесение марки
- номеру заявки на нанесение марки
- серии марки
- порядковому номеру марки
Напишите Всем с какой по какую позицию...
Например Так:
- алкогольный код с 8 поз. длина 12
...
Спасибо...
4. Денис Саяпин (sdv88) 15.01.16 05:04
(3) rvs-slim, Точно. там не так....
Там определенный алгоритм, идет перевод в другую систему счисления.
5. rvs-slim (rvs-slim) 15.01.16 19:34
(4) sdv88,
Все верно в другую...
в 36-ю ...
но позиции если Вам известны скажите Всем ... что здесь такого...
Жалко там даты розлива не зашито...сняло бы многие проблемы...
6. Николай (beard1) 16.01.16 13:28
присоединяюсь к вопросу. что в той марке? где какая изна за какой циферкой? если не секрет, конечно ;)
7. m-serg74 (m-serg74) 16.01.16 14:00
(5) rvs-slim,
Жалко там даты розлива не зашито

ее там в принципе быть не может - производитель заказывает марки до того как произвел продукцию, потому в справке А и указывают какой диапазон был использован для конкретной партии
8. rvs-slim (rvs-slim) 16.01.16 18:36
(7) m-serg74,
я и говорю ЖАЛКО!!!
9. Денис Саяпин (sdv88) 18.01.16 08:09
(5) rvs-slim, вообще можете скачать и посмотреть. я читаю символы с 8го 12 штук
10. Евгений (Berrimor) 18.01.16 16:56
вот цитата с форума РАРа

Цитата:
Re: Расшифровка штрих-кода PDF-417 акцизной марки

Сообщение operator9 » 11 дек 2015, 13:02
Данные полученные из марки ФСМ, пример:
136-102719868197240715410498397226

136- тип марки - в данном случае ФСМ, так как первая цифра "1" (если первые три цифры начинаются на "2", то это АМ)
Далее идет последовательность цифр, составляющая серию + номер марки + контрольная сумма.

Для ФСМ 12 цифр (серия + номер)

136- тип марки ФСМ
102- серия марки
719868197 - номер марки
240715410498397226 - контрольная сумма гознака

20N00001CGUMZYCB99J1NKN31105001000056NQQMS5VP4HTF5SB46ZSQQJD­8BNJP891
20 – Номер Версии ПС ЕГАИС
00001CGUMZYCB99J – Зашифрованный в кодировке Base36 код продукции(алккод)
1NKN31105001 – Номер заявки на печать.
000056 – номер марки на печать
NQQMS5VP4HTF5SB46ZSQQJD8BNJP891 - защитная последовательность
Famza; philya; beard1; +3 Ответить
11. Николай (beard1) 20.01.16 15:34
сильно смущало и не мог найти подтверждения, что в Приложении к Приказ № 33н от 12 мая 2010 года расписано так:
Символы Сведения
Символы   Сведения
--------------------------
   2       Версия ПС ЕГАИС
  17       Специальный идентификатор //алккод, как я понял
  12       Номер и дата заявки
   6       Номер марки в заявке
  31       Контрольная группа
...Показать Скрыть


т.е на алккод 17 символов, а во всех алгоритмах получения алккода, берут с 8 или 9 позиции

еще раз спасибо!
12. Максим Стрепетов (mstrepetov) 15.02.16 12:06
Чувак, у нас аналогичные публикации ))) забавно. Идея ведь на поверхности. Меня носом ткнул http://infostart.ru/profile/3651/
13. Наталья (Natali_77) 13.04.16 16:26
(9) sdv88, а можете добавить ещё как определить данные по:
идентификатору производителя
дате заявки на нанесение марки
номеру заявки на нанесение марки
серии марки
порядковому номеру марки

14. evgeniy Fomichev (cdrsu) 14.06.16 03:10
15. ivan (ayava) 04.07.16 13:31
Процедура КнопкаВыполнитьНажатие(Кнопка)
		Сч = 0;
	Значение=СокрЛП("22N00000XY8EURN31182NS2605180010097820RUFK56LES08GY4EBZCNZF­E0AKOSKD3");
	
	Если СтрДлина(Значение) <> 68 Тогда 
		Сообщить("Код марки некорректной длины");
//		Возврат Неопределено;
	КонецЕсли;
	
	Если Сред(Значение, 4, 5) = "00000" Тогда
		Значение = Сред(Значение, 9, 11);
		Сч = 11;
	Иначе
		Значение = Сред(Значение, 8, 12);
		Сч = 12;
	КонецЕсли;

	Результат = 0;

	Для Поз = 1 По Сч Цикл

		Множитель = 1;
		
		Для СчМ = 1 По Сч - Поз Цикл   
			Множитель = Множитель * 36;
		КонецЦикла;

		Результат = Результат + (Найти("0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ", Сред(Значение, Поз, 1)) - 1) * Множитель;

	КонецЦикла;

	Сообщить(Формат(Результат, "ЧЦ=19; ЧВН=; ЧГ=0"));

КонецПроцедуры
...Показать Скрыть
Famza; k_petrovich; +2 Ответить
16. Александр Александр (Компания БИТ) 12.07.16 12:50
(13) поддерживаю, информация о производителе/импортере необходима
17. Анатолий Бычин (tolyan_ekb) 04.08.16 09:40
Подскажите старые марки без букв расшифровываются?