gifts2017

Предложение удаленной помощи из 1С

Опубликовал Сергей Васильев (EVVasin) в раздел Обработки - Универсальные обработки

Внешняя обработка для предложения подключения к удаленному компьютеру в сети по msra

Для использования достаточно на удаленном компьютере поставить галку "Разрешить подключения удаленного помощника к этому компьютеру".

Данная обработка запускает стандартный удаленный помощник

 (Скрин windows 7), устанавливая параметр "имя компьютера", который берет из списка активных пользователей 1С.

 

Может использоваться программистами и администраторами для удаленного подключения к пользователю, не уточняя его ip  или имя компьютера. Достаточно лишь найти пользователя в списке и жмакнуть "подключиться".

Из дополнительных функций:

  • Вывод списка пользователей, которые запустили несколько приложений 1С; 
  • Отключение пользователей от базы 1С
Кусочек кода, возможно, прояснит программистам работу обработки
Если ЭлементыФормы.мОперСистема.Значение = 1 Тогда
// Windows XP
мПолноеИмяWinXP = мПутьWinXP + "\PCHealth\HelpCtr\Vendors\CN=Microsoft Corporation,L=Redmond,S=Washington,C=US\Remote Assistance\Escalation\Unsolicited\UnSolicitedRCUI+.htm";
ЭтотОбъект.ПолучитьМакет("УдаленныйПомощникXP").Записать(мПолноеИмяWinXP);

мИмяФайлаXP = мПутьWinXP + "\pchealth\helpctr\binaries\helpctr.exe /url";
ИмяФайлаXP = мИмяФайлаXP + " hcp://CN=Microsoft%20Corporation,L=Redmond,S=Washington,C=US/Remote%20Assistance/Escalation/Unsolicited/Unsolicitedrcui+.htm";
Иначе
// Windows 7
ИмяФайла7 = "msra.exe";
КонецЕсли;

ИмяФайла = ?(ЭлементыФормы.мОперСистема.Значение = 2, ИмяФайла7, ИмяФайлаXP);
Для Каждого мПользователь Из ТЧАктивныеПользователи Цикл
мПредлагатьПомощь = ?(мПользователь.ПредложитьПомощь, Истина, Ложь);
Если мПредлагатьПомощь Тогда
// Вызовем команду Windows 7 (msra /offerRA <Имя компьютера>) или Windows XP
мПолнаяКоммандаВызова = ?(ЭлементыФормы.мОперСистема.Значение = 2, ИмяФайла7 + " /offerRA " + мПользователь.Компьютер, ИмяФайлаXP + "?" + мПользователь.Компьютер);

ЗапуститьПриложение(мПолнаяКоммандаВызова);
КонецЕсли;
КонецЦикла;

 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Предложение удаленной помощи из 1С
.epf 25,11Kb
14.01.16
7
.epf 25,11Kb 7 Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение

Комментарии

1. Андрей Макаров (XOCTEP) 14.01.16 15:47
Поясните более подробно механизм работы
2. Сергей Васильев (EVVasin) 14.01.16 16:29
3. Андрей Макаров (XOCTEP) 15.01.16 12:10
(2) EVVasin, Я так понимаю, стандартный помощник работает только в пределах локальной сети?
4. Сергей Васильев (EVVasin) 15.01.16 14:56
(3) XOCTEP, да
Вообще это не моя обработка, я всего лишь ее представил на инфостарт. Подобной я здесь не нашел. Не буду присваивать заслуги других
5. VVV (V_V_V) 16.01.16 11:55
6. Сергей Васильев (EVVasin) 17.01.16 12:19
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа