IE2017

Вызов журнала регистрации из документов и справочников

Администрирование - Журнал регистрации

Внешняя обработка, позволяющая открыть из любого документа и справочника журнал регистрации с отбором по нему.

Подключается ко всем типовым конфигурациям на управляемых формах.

Полезна для тех, кто часто обращается к журналу регистрации, теперь вы можете вызвать его прямо здесь и сейчас.

Для подключения зайдите в Администрирование - Печатные формы, отчеты, обработки - Дополнительные отчеты и обработки - Создать - Выберите скачанный файл - Записать и закрыть

Для вызова откройте любую форму Документа или Справочника, нажмите "Заполнить", выберите обработку - ОК (или из списка по кнопке "Заполнение").

Скачать файлы

Наименование Файл Версия Размер
Вызов журнала регистрации из справочников и документов
.epf 6,81Kb
11.02.16
16
.epf 6,81Kb 16 Скачать

См. также

Комментарии
1. Oleg Bogdanov (OlegBog1971) 14 16.02.16 11:02 Сейчас в теме
Работает в последней БП 3.0.43.116, база на SQL
Только вот вопрос: как можно скрыть кнопку "Заполнить" из формы списка, чтобы доступ к ней был только из меню "Еще", причем для всех списков сразу?
2. Владислав Теут (darkmessiahan) 28 16.02.16 17:57 Сейчас в теме
(1) OlegBog1971, честно не знаю таких фокусов. Иногда не срабатывает из формы объекта, но при этом работает из списка объектов. Ошибка ссылается на код модуля внешних обработок.
3. Александр Журавлев (apostal86) 176 20.02.16 17:02 Сейчас в теме
Если учесть тот факт, что в 1С: Бухгалтерия предприятия ред. 3.0, 1С: Управление торговлей ред. 11 есть встроенный механизм версионирования объектов, то такая реализация обращения к журналу регистрации кажется морально старенькой. Тут бы логично обращения к отчету версий объектов, учитывая, что события журнала регистрации тоже попадают в версии.
4. Владислав Теут (darkmessiahan) 28 21.02.16 19:21 Сейчас в теме
Н(3) apostal86, Не совсем понял что между ними общего
Прикрепленные файлы:
5. Oleg Bogdanov (OlegBog1971) 14 15.04.16 09:28 Сейчас в теме
После 2-х месяцев использования выявилась следующая особенность ... В журнал попадают ненужные записи.
Посмотрев внимательно на те отборы которые делает разработка в журнале регистрации понял, что там кроме отбора по полю "данные" не хватает отбора по полю "метаданные" - если указать нужный объект метаданных, то все работает корректно.
Автор, исправьте плиз.
6. Владислав Теут (darkmessiahan) 28 08.07.17 19:58 Сейчас в теме
(5) Нет такого параметра

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	Если Параметры.Свойство("АвтоТест") Тогда // Возврат при получении формы для анализа.
		Возврат;
	КонецЕсли;
	
	УстановитьУсловноеОформление();
	
	МодельСервиса = ОбщегоНазначенияПовтИсп.РазделениеВключено()
		И ОбщегоНазначенияПовтИсп.ДоступноИспользованиеРазделенныхДанных();
	
	ОтборЖурналаРегистрации = Новый Структура;
	ОтборЖурналаРегистрацииПоУмолчанию = Новый Структура;
	ЗначенияОтбора = ПолучитьЗначенияОтбораЖурналаРегистрации("Событие").Событие;
	
	Если Не ПустаяСтрока(Параметры.Пользователь) Тогда
		Если ТипЗнч(Параметры.Пользователь) = Тип("СписокЗначений") Тогда
			ОтборПоПользователю = Параметры.Пользователь;
		Иначе
			ИмяПользователя = Параметры.Пользователь;
			ОтборПоПользователю = Новый СписокЗначений;
			ПоПользователю = ОтборПоПользователю.Добавить(ИмяПользователя, ИмяПользователя);
		КонецЕсли;
		ОтборЖурналаРегистрации.Вставить("Пользователь", ОтборПоПользователю);
	КонецЕсли;
	
	Если ЗначениеЗаполнено(Параметры.СобытиеЖурналаРегистрации) Тогда
		ОтборПоСобытию = Новый СписокЗначений;
		Если ТипЗнч(Параметры.СобытиеЖурналаРегистрации) = Тип("Массив") Тогда
			Для Каждого Событие Из Параметры.СобытиеЖурналаРегистрации Цикл
				ПредставлениеСобытия = ЗначенияОтбора[Событие];
				ОтборПоСобытию.Добавить(Событие, ПредставлениеСобытия);
			КонецЦикла;
		Иначе
			ОтборПоСобытию.Добавить(Параметры.СобытиеЖурналаРегистрации, Параметры.СобытиеЖурналаРегистрации);
		КонецЕсли;
		ОтборЖурналаРегистрации.Вставить("Событие", ОтборПоСобытию);
	КонецЕсли;
	
	Если МодельСервиса Тогда
		ОтборЖурналаРегистрации.Вставить("ДатаНачала", НачалоДня(ТекущаяДатаСеанса()));
		ОтборЖурналаРегистрации.Вставить("ДатаОкончания", КонецДня(ТекущаяДатаСеанса()));
	Иначе
		Если ЗначениеЗаполнено(Параметры.ДатаНачала) Тогда
			ОтборЖурналаРегистрации.Вставить("ДатаНачала", Параметры.ДатаНачала);
		КонецЕсли;
		
		Если ЗначениеЗаполнено(Параметры.ДатаОкончания) Тогда
			ОтборЖурналаРегистрации.Вставить("ДатаОкончания", Параметры.ДатаОкончания + 1);
		КонецЕсли;
	КонецЕсли;
	
	Если Параметры.Данные <> Неопределено Тогда
		ОтборЖурналаРегистрации.Вставить("Данные", Параметры.Данные);
	КонецЕсли;
	
	Если Параметры.Сеанс <> Неопределено Тогда
		ОтборЖурналаРегистрации.Вставить("Сеанс", Параметры.Сеанс);
	КонецЕсли;
	
	// Уровень - список значений.
	Если Параметры.Уровень <> Неопределено Тогда
		ОтборЖурналаРегистрации.Вставить("Уровень", Параметры.Уровень);
	КонецЕсли;
	
	// ИмяПриложения - список значений.
	Если Параметры.ИмяПриложения <> Неопределено Тогда
		СписокПриложений = Новый СписокЗначений;
		Для Каждого Приложение Из Параметры.ИмяПриложения Цикл
			СписокПриложений.Добавить(Приложение, ПредставлениеПриложения(Приложение));
		КонецЦикла;
		ОтборЖурналаРегистрации.Вставить("ИмяПриложения", СписокПриложений);
	КонецЕсли;
	
	КоличествоПоказываемыхСобытий = 200;
	
	ОтборПоУмолчанию = ОтборПоУмолчанию(ЗначенияОтбора);
	Если Не ОтборЖурналаРегистрации.Свойство("Событие") Тогда
		ОтборЖурналаРегистрации.Вставить("Событие", ОтборПоУмолчанию);
	КонецЕсли;
	ОтборЖурналаРегистрацииПоУмолчанию.Вставить("Событие", ОтборПоУмолчанию);
	Элементы.ПредставлениеРазделенияДанныхСеанса.Видимость = Не ОбщегоНазначенияПовтИсп.ДоступноИспользованиеРазделенныхДанных();
	
	Критичность = "ВсеСобытия";
	
	// Взводится в значение Истина, если нужно, чтобы формирование журнала регистрации проходило не в фоне.
	ЗапускатьНеВФоне = Параметры.ЗапускатьНеВФоне;
	
КонецПроцедуры
...Показать Скрыть
Оставьте свое сообщение