IE2017

Получение алкокода ЕГАИС по PDF417

Обработки - Обработка справочников

Обработка позволяет получить код алкогольной продукции в системе ЕГАИС по PDF417 (акцизная марка)

С помощью данной обработки Вы можете получить код алкогольной продукции в системе ЕГАИС по PDF417 (акцизной марке), например, по этому коду уже можно найти саму алкогольную продукцию в справочнике ЕГАИС.

Также код данной обработки можно использовать, например, для проверки корректности отсканированной акцизной марки, ну и много для чего еще...

 

Обработка обновлена, добавлена проверка на корректность отсканированного штрихкода PDF417.

Скачать файлы

Наименование Файл Версия Размер
Внешняя обработка Получения алкокода ЕГАИС по PDF417
.epf 7,04Kb
15.06.16
20
.epf 7,04Kb 20 Скачать

См. также

Комментарии
1. Станислав Косолапов (amoarok) 26 25.03.16 09:59 Сейчас в теме
2. fanlexa fanlexa (fanlexa) 2 25.03.16 13:09 Сейчас в теме
(1) amoarok, а в чем отличие между ними?
3. Igor Berezhnov (igorberezhnov) 74 06.04.16 16:26 Сейчас в теме
На этом же сайте свободно алгоритм лежит, не помню только ссылку:
Функция глДополнитьСтрокуЛ(Стр,Чем,Длина) 
	Добавить=Длина-СтрДлина(Стр);
	Добавок="";
	Для Сч = 1 По Добавить  Цикл
		Добавок=Добавок+Чем;
	КонецЦикла;
	Возврат Добавок+Стр;
КонецФункции

Функция ПолучитьИдТовараСмарки(НомерМарки) экспорт
	итр = 0;
	Значение = СокрЛП(НомерМарки);
	Если СтрДлина(Значение) <> 68 Тогда
		Возврат "";
	Иначе
		Если Сред(Значение,4,5) = "00000" Тогда
			Значение = Сред(Значение,9,11);
			итр = 11;
		Иначе
			Значение = Сред(Значение,8,12);
			итр = 12;
		КонецЕсли;
		Результат = 0;
		Для Х = 1 По итр Цикл
			М = 1;
			Для У = 1 По итр-Х Цикл
				М = М * 36;
			КонецЦикла;
			Результат = Результат + (Найти("0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ",Сред(Значение,Х,1))-1)*М;
		КонецЦикла;
		Возврат глДополнитьСтрокуЛ(СокрЛП(Формат(Результат, "Ч19")),"0", 19);
    КонецЕсли;
КонецФункции
...Показать Скрыть
4. fanlexa fanlexa (fanlexa) 2 15.06.16 10:22 Сейчас в теме
Обновил обработку, добавил проверку штрихкода PDF417 на валидность
Оставьте свое сообщение