gifts2017

Перенос больничных в конец месяца для правильного формирования 6-НДФЛ

Опубликовал Ирина Игнатенко (igni) в раздел Обработки - Обработка документов

Участники пилотного проекта ФСС вводят больничные  в течении месяца, но выплачивают часть "за счет работодателя" вместе с зарплатой, здесь предлагается настройка Универсального подбора и обработки (с диска ИТС) для обработки документов в конце месяца для успешного формирования 2 раздела 6-НДФЛ.

Участник Пилотного проекта по ФСС выплачивает Больничные за счет работодателя вместе с зарплатой, но рассчитывает их и формирует реестры в ФСС  в соответствии с законом в течении месяца. Для того, чтобы в 6-НДФЛ (раздел 2) соответствующие записи уподобить зарплате, можно воспользоваться обработкой Универсальный подбор и обработка объектов:

  1. Отобрать объекты по периоду
  2. На закладке Обработки задать следующий Произвольный алгоритм:
объект.комментарий = объект.дата;
  нд =КонецМесяца(объект.дата);
  объект.Дата = нд;
  объект.ДатаВыплатыДохода = нд;
   Для Каждого ТекущаяСтрока Из объект.ндфл Цикл
               ТекущаяСтрока.МесяцНалоговогоПериода = нд;
   КонецЦикла;
  объект.записать();
  Если объект.проведен тогда
                 объект.Записать(РежимЗаписиДокумента.Проведение);
  КонецЕсли;

После выполнения в комментариях документов останется первоначальная дата документа для связи с Реестрами, а даты для 6-НДФЛ станут последней датой месяца.

Скачать файлы

Наименование Файл Версия Размер
НАСТРОЙКА УНИВЕРСАЛЬНОГО ПОДБОРА.sav 8
.sav 2,29Kb
06.04.16
8
.sav 2,29Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Андрей Почукаев (RodinMax) 13.04.16 07:42
а почему только Участники пилотного проекта ФСС вводят больничные в течении месяца - и нужно переместить все больничные в конец месяца?
остальным так делать не нужно
2. Elena Yeriomina (ves.Parnas) 13.04.16 09:48
Да, что то тут не так. ВР "Оплата больничных листов за счет работодателя" считается прочим, незарплатным доходом. Его код 2300. В 6-НДФЛ в стр.100 и 110 с последней датой месяца данные по пособиям имеют право встать, если их выплата произведена этой последней датой. С зарплатными доходами (с кодом 2000) прочие доходы смешивать не надо.
3. Ирина Игнатенко (igni) 13.04.16 15:45
это доход выплачиваемый вместе с зарплатой - не промежуточная выплата
4. Ирина Игнатенко (igni) 14.04.16 10:40
Грянина рекомендует переносить на дату выплаты зарплаты - чуть позже доделаю
5. Илья Радченко (dbaser) 25.04.16 14:30
на исправленных больничных ругается и останавливается. не хватает кусочка....

ИмяРеквизита = "ПерерассчитываемыйДокумент";
		ДокументИсправления = ПроведениеРасчетов.ПолучитьДокументИсправление(Объект.Ссылка, , , ИмяРеквизита);
		Если ЗначениеЗаполнено(ДокументИсправления) Тогда
			Сообщить("Текущий документ был исправлен. Обрабатываем исправление: "+ДокументИсправления);
			Объект = ДокументИсправления.ПолучитьОбъект();
		КонецЕсли;
...Показать Скрыть