gifts2017

Печать ценников с подписью ответственного лица

Опубликовал Александр Гордеев (goldencity178) в раздел Печать - Ценники

Сегодня я расскажу, как сделать печать ценников с подписью ответственного лица в вашей конфигурации

1С Розница 1.0, в т.ч  решения от компании "Рарус".

Все решения Розница в 1.0 на обычных формах.

 !!! Небольшой комментарий !!!

Итак, Начнем. когда вы открываете обработку и вводите параметры для отбора при печати ценников, то подпись вы сразу не увидите, как не увидите и ФИО. Но если мы создадим новые реквизиты в справочнике "Физические лица", то мы сразу же сможем выводить на печать Подпись и ФИО.

 

Документация по интеграции расположена как в самой справочной информации, так и в самой статье.

В справочнике "Физические Лица" создаем следующие реквизиты:

1 "СотрАвтограф", заходим в свойства и указываем Тип "ХранилищеЗначения"

2. "ФамилияИО", заходим в свойства и указываем Тип "Строка"  (длину можно до 55 символов, это Фамилия и инициалы для печати на ценнике)

 

В справочнике "Физические Лица" в форме элемента мы сооздаем "Поле картинки" с именем "Подпись"

заходим в свойства и указываем в разделе Характеристики в поле ТекстНевыбраннойКартинки:

Подпись не добавлена , а после заходим в раздел События и в специальном поле НАЖАТИЕ создаем

Следующую процедуру "ПодписьНажатие"

Вот ее текст

 

Процедура ПодписьНажатие(Элемент)
      Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
      Диалог.Заголовок = "Выберите файл с подписью";
      Диалог.ПолноеИмяФайла = "";
      Диалог.ПредварительныйПросмотр = Истина;
      Диалог.Фильтр = "Все картинки (*.bmp;*.dib;*.rle;*.jpg;*.jpeg;*.tif;*.gif;*.png;*.ico;*.wmf;*.emf)|*.bmp;*.dib;*.rle;*.jpg;*.jpeg;*.tif;*.gif;*.png;*.ico;*.wmf;*.emf|"
      + "Формат bmp (*.bmp;*.dib;*.rle)|*.bmp;*.dib;*.rle|"
      + "Формат JPEG (*.jpg;*.jpeg)|*.jpg;*.jpeg|"
      + "Формат TIFF (*.tif)|*.tif|"
      + "Формат GIF (*.gif)|*.gif|"
      + "Формат PNG (*.png)|*.png|"
      + "Формат icon (*.ico)|*.ico|"
      + "Формат метафайл (*.wmf;*.emf)|*.wmf;*.emf|";// картинки
      Если Диалог.Выбрать() Тогда
           ВыбранноеФото = Новый Картинка(Диалог.ПолноеИмяФайла,Ложь);
           ЭлементыФормы.Подпись.Картинка = ВыбранноеФото;
           СправочникОбъект.СотрАвтограф =  новый ХранилищеЗначения(ВыбранноеФото,Новый СжатиеДанных(9))
      КонецЕсли;
  КонецПроцедуры


А в событиях формы "ПередОткрытием" создаем следующий код:

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)

ВыбранноеФото = СправочникОбъект.СотрАвтограф.Получить();
           Если ЗначениеЗаполнено(ВыбранноеФото) Тогда
                   ЭлементыФормы.Подпись.Картинка = ВыбранноеФото;
            КонецЕсли;

КонецПроцедуры

 

После этого добавляем на форму поле "ФамилияИО"  и ссылаемся на данные реквизита спр. ФЛ. "ФамилияИО"


А теперь нам с вами остается обновить конфигурацию (F7) и начать отладку (F5)


Если все правильно сделано то в справочнике "Физические лица" мы сможем выбрать автограф для нашего ответственного лица кликнув для этого на поле с картинкой и выбрать нужное изображение с автографом. (желательно с прозрачным фоном)

!!! Примечание !!!

Сервис для создания автографов можно найти в интернете. там их полным полно, большинство из них абсолютно и полностью бесплатные, позволяют создать автограф с нужными вам инициалами. Называется он примерно как то так "Онлайн генератор автографов или подписей"


При выборе картинки с автографом ошибок возникнуть не должно, так как код проверял на своей конфигурации и у меня он полностью работоспособный.

После выбора картинки можно вписать фамилию и инициалы в новое созданное нами поле.

После записать изменения и сохранить.

 

Если у вас уже набитая номенклатура со ШК и ценами, вы сможете смело попробовать напечатать новые первые ценники с вашей подписью. Другие сотрудники тоже смогут сделать себе личный автограф и выводить его на печать прямо на ценник, как лицо, ответственное за печать конкретного документа (Ценника)

Желаю вам приятного пользования.

Если вы обладаете знаниями языка запросов, вы смело сможете внедрить дополнительные колонки и выводить на печать гораздо больше информации, или если нет, то заказать внедрение.

Только для Розница в. 1.0.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Внешняя обработка печати ценников с подписью
.epf 28,05Kb
09.04.16
1
.epf 1.0.0.0 28,05Kb 1 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. V. L. (Vladal) 22.04.16 12:54
Ужас, какое вырвиглазное оформление шрифтов.
Меньше жирного и восклицательных знаков.
2. Екатерина Устинова (Razrabotka1C125) 24.04.16 12:07
Здравствуйте, Александр, а вы сможете сделать не только печать ценников но и этикеток?
3. Александр Гордеев (goldencity178) 24.04.16 12:13
Да, Екатерина, приветствую, конечно смогу. под какую конкретно конфигурацию Розница хотели бы видеть публикацию. Я могу сделать универсальные и встраиваемые обработки под конфигурацию Розница 1.0, которая спокойно справляются с печатью и несколько видов ценников и несколько видов этикеток, чтобы готовое решение могло подойти для всех стандартных и отраслевых решений Розница.
4. Александр Гордеев (goldencity178) 24.04.16 12:16
Версия Разработки 2.0 готовится к выходу с 15 мая. Там будет в комплекте обработки, которые способны печатать и ценники разных форм и этикетки разных размеров. я хочу сделать свои обработки универсальными и удобными в использовании
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа