gifts2017

Очистка номенклатуры контрагентов с выбором контрагента для УТ 10.3

Опубликовал Александр Сахин (programma) в раздел Обработки - Обработка справочников

Бывает так, что необходимо удалить номенклатуру по поставщикам, делать вручную не всегда быстро и удобно. Данная обработка удаляет весь список из регистра сведений по выбранному поставщику.

Будьте внимательны и осторожны, перед использованием обязательно убедитесь, что вы понимаете, что вы делаете. Перед использованием данной обработки рекомендую сделать бэкап информационной базы.

Конечно, данная обработка проста и примитивна, и сделать ее начинающему программисту не составит труда, но тем не менее для пользователей, кто не хочет вникать и разбираться, будет весьма кстати.

Номенклатура контрагента - используется в основном для связи номенклатуры и номенклатуры конрагента (наименование из прайса)

Скачать файлы

Наименование Файл Версия Размер
ОчисткаНоменклатурыКонтрагентов 4
.epf 6,48Kb
25.04.16
4
.epf 6,48Kb Скачать

См. также

Contragent+ 5.0 от 2 500
Подписаться Добавить вознаграждение
Комментарии
1. Антон Комаров (ardarik) 25.04.16 12:58
Не кучеряво 2$ за 6 строчек кода?
2. Александр Сахин (programma) 25.04.16 15:15
(1) ardarik, пожалуйста:
Процедура КнопкаВыполнитьНажатие(Кнопка)
    
    //запросить у пользователя контрагента
    КонтрагентДляУдаления = Контрагент; //здесь допишите код, и проверку не забудьте, если пользователь не введет контрагента, то просто - Возврат
		
	НаборЗаписей = РегистрыСведений.НоменклатураКонтрагентов.СоздатьНаборЗаписей();
    НаборЗаписей.Отбор.Контрагент.Установить(КонтрагентДляУдаления );
    НаборЗаписей.Записать();


КонецПроцедуры


Процедура КонтрагентДляУдаленияПриИзменении(Элемент)
		Если Вопрос(" При нажатии на кнопку (Выполнить)
			| удалится вся номенклатура данного контрагента, 
			| сохраненный прайс этого поставащика обнулится. 
			| 
			| Продолжить?",РежимДиалогаВопрос.ДаНет)= КодВозвратаДиалога.Нет Тогда
			Закрыть();
		КонецЕсли;
КонецПроцедуры
...Показать Скрыть