Печать QR-кода для доработанных ШТРИХ-М ФР-К из под 1С 7.7. Добавил печать для драйвера 4.13, поддерживающего 54-ФЗ

Оборудование - Фискальный регистратор

Обработка для печати QR-кода для доработанных ШТРИХ-М ФР-К из-под 1С 7.7. Печатает QR-код на кассовой ленте. Дописал для драйвера 4.13.

Писал на форум Штрих-М, но помощи не получил. Если пользоваться документацией для драйвера ФР 4.12,

то можно долго безрезультатно экспериментировать и не получить желаемого результата. Как-то так.

 Добавил для драйвера 4.13

До выхода драйвера 4.13 печатал QR код для алкоголя командой  PrintBarcodeGraph.
После обновления драйвера печать QR кода стала печататься не читабельно, или
при печати кода терялась связи с ККТ.

Пришлось переписать печать на команду Print2DBarcode.

//----------------------------------------------------------------------------------
Процедура ПечатьКЮР_Кода2(Стр)
	стрУТФ8=ПреобразоватьСтрокуВУТФ8(Стр);
	с16=Стр16(стрУТФ8);
	Для к=1 По Цел(СтрДлина(с16)/128)+1 Цикл
		FR.Password=10;
      	FR.BlockType = 0;
      	FR.BlockNumber = к-1;
      	FR.BlockDataHex = Сред(с16,1+(к-1)*128,125);
      	FR.LoadBlockData();
	КонецЦикла;
	FR.BarcodeType=3;		//тип ШК - QR
	FR.BarcodeDataLength=СтрДлина(с16)/2;
	FR.BarcodeStartBlockNumber=0;
	FR.BarcodeParameter1=0; //версия ШК 0-авто
	FR.BarcodeParameter2=0; //маска ШК 0-авто
	FR.BarcodeParameter3=5; //размер точки в ШК 3..8
	FR.BarcodeParameter4=0;
	FR.BarcodeParameter5=2; //уровень коррекции ошибок 0..3
	FR.BarcodeAlignment=0;  //выравнивание посередине
	FR.Password=10;
	FR.Print2DBarcode();
	FR.WaitForPrinting();

	FR.Password=10;
	FR.StringForPrinting=" ";
	FR.UseReceiptRibbon=1;
	FR.UseJournalRibbon=0;
	FR.PrintString();

	Для к=0 По Цел(СтрДлина(Стр)/ШиринаЧЛ) Цикл
		FR.Password=10;
		FR.StringForPrinting=Сред(Стр,1+(к*ШиринаЧЛ),ШиринаЧЛ);
		FR.UseReceiptRibbon=1;
		FR.UseJournalRibbon=0;
		FR.PrintString();
	КонецЦикла;

	Если Отрезать=1 Тогда
		Для к=1 По 5 Цикл
			FR.Password=10;
			FR.StringForPrinting=" ";
			FR.UseReceiptRibbon=1;
			FR.UseJournalRibbon=0;
			FR.PrintString();
		КонецЦикла;
		FR.Password=10;
		FR.CutType=1;
		FR.CutCheck();
	КонецЕсли;

КонецПроцедуры	// ПечатьКЮР_Кода2()
//----------------------------------------------------------------------------------

Скачать файлы

Наименование Файл Версия Размер
Отчет
.ert 7,50Kb
29.03.17
9
.ert 0 7,50Kb 9 Скачать
Печать QR-кода для драйвера 4.13
.ert 9,00Kb
29.03.17
5
.ert 0.001 9,00Kb 5 Скачать

См. также

Автор запретил комментарии