gifts2017

Деноминация в 1С Бухгалтерия 8 для Беларуси (1.6)

Опубликовал Сергей Черник (sercher88) в раздел Обработки - Обработка документов

Обработка предназначена для проведения деноминации в конфигурации 1С Бухгалтерия 8 для Беларуси (версия 1.6)

Обработка выполняет деноминацию остатков регистров накопления, остатков регистров бухгалтерии, значений реквизитов регистров сведений и справочников. При этом:

- значение остатка регистра накопления и регистра бухгалтерии уменьшается на разницу между  старым (до деноминации) и новым (деноминированным) значением (было 10000, должно стать 1, разница 9999 -> делается списание на сумму 9999)

- новое значение реквизита периодического регистра сведений записывается на 1 секунду или день (в зависимости от периодичности регистра)  позже старого значения:

Дата                               Значение    

01.04.2016 14:00:00          10000 

01.04.2016 14:00:01             1,00

- новое значение реквизита непериодического регистра сведений записывается вместо старого

- новое значение реквизита справочника записывается вместо старого

В ходе работы обработка создает документ "Корректировка записей регистров" на дату деноминации.

Процесс деноминации частично необратим из-за перезаписи реквизитов справочников и непериодических регистров сведений, поэтому перед выполнением процедуры настоятельно рекомендуется сделать копию базы.

Порядок выполнения деноминации:

1. сделать резервную копию базы 

2. удалить дату запрета редактирования данных

3. в настройках валюты "бел. рубль" изменить значение "Количество разрядов при выводе дробной части в виде числа" с 0 на "2 знака" 

4. запустить обработку "Деноминация" (Файл - открыть), указать дату деноминации и коэффициент (по умолчанию равен 10000), нажать "Выполнить"

5. Дождаться появления сообщения "Деноминация завершена"

Нормативно-правовых документов по отражению деноминации в учете пока не вышло. Поэтому я опирался только на свое понимание этого процесса. 

Скачать файлы

Наименование Файл Версия Размер
Деноминация 26
.epf 10,76Kb
14.05.16
26
.epf 10,76Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Алексей Новиков (Новиков) 16.05.16 10:53
Спасибо, добрый человек! А то я тоже измучился, думая как же это прокрутить.
2. Саўка Збянтэжаны (Збянтэжаны Саўка) 18.05.16 09:56
отсутствует ф-ия ПроверитьЗаполнение()
3. Сергей Черник (sercher88) 18.05.16 13:19
странно, это ведь метод формы...
попробуйте написать ЭтаФорма.ПроверитьЗаполнение()
или вообще это можно убрать, это всего лишь проверка на заполнение полей Коэф. деноминации и Дата деноминации
4. Саўка Збянтэжаны (Збянтэжаны Саўка) 18.05.16 18:56
спасибо за ответ
да это понятно, все прозрачно ибо тут и полей кот наплакал, но странно что у меня не подхватился этот метод - синтаксическую ошибку выдает

а вот с добавлением ЭтаФорма.ПроверитьЗаполнение() проверка проходит ОК.

5. Сергей Лех (LSM) 26.05.16 13:16
Добрый день.
А в регистрах бухгалтерии разве не может быть валютных сумм в белорусских рублях, которые тоже надо деноминировать?
6. Сергей Черник (sercher88) 26.05.16 13:55
Добрый день. А в каких случаях это может быть?
7. Сергей Лех (LSM) 26.05.16 15:27
Мне сложно сказать. Но теоретически можно сделать проводку по счету 60.11 и выбрать валюту белорусский рубль. В проводках же есть ВалютаДт, ВалютаКт, СуммаВВалютеДт, СуммаВВалютеКт.
8. Wlad Wasilew (wasiliy) 03.06.16 18:40
Проверил по бух.счетам. Корректно заработала, когда добавил фильтр Организация = &Организация в запрос .
9. olga pt (pt_olga) 07.06.16 13:02
Спасибо за обработку по деноминации Бух8 1.6
Скачали, будем пробовать! Франчи белорусские не радуют :( до сих пор никаких новостей по этой конфе, даже нет описания будующего алгоритма, чтобы к новой интеграции подготовится заранее
10. Геннадий (kejsi) 12.06.16 18:47
Добавь правки в КнопкаВыполнитьНажатие
при переоценке вал счетов (хозрасчетных) вопервых валюную сумму списывать не надо, во вторых надо указывать валюту (ДТ или кредит) которую заполнять в провдке

предлагаю
Если Стр.Сумма > 0 Тогда
....
				Если НоваяСтрока.Имя = "Хозрасчетный" Тогда
					Если ЗначениеЗаполнено(Стр.Валюта) тогда
						Движение.ВалютаКт=Стр.Валюта;
					КонецЕсли;
		            Движение.ВалютнаяСуммаДт=0;
		            Движение.ВалютнаяСуммаКт=0;
				КонецЕсли;
			ИначеЕсли Стр.Сумма < 0 Тогда
.....
				Если НоваяСтрока.Имя = "Хозрасчетный" Тогда
					Если ЗначениеЗаполнено(Стр.Валюта) тогда
						Движение.ВалютаДт=Стр.Валюта;
					КонецЕсли;
		            Движение.ВалютнаяСуммаКт=0;
		            Движение.ВалютнаяСуммаДт=0;
				КонецЕсли;
			КонецЕсли;
...Показать Скрыть
11. piton66 (piton66) 17.06.16 11:20
А зачем разницей делать. Может проще уже сумму с копейками сразу вводить. Ну чтобы в одной базе были только деноминированные суммы.
Т.е так Обрезка - Деноминация - Старые доки обрезки удаляем.
12. сергей сергей (sergei198821) 20.06.16 11:11
Добрый день.
при выполнении выдало ошибку:
{Форма.Форма.Форма(434)}: Ошибка при вызове метода контекста (Записать)
		ДокументКорректировки.Записать();
по причине:
Запись не верна! Поле "Валютная сумма" должно быть пустым! (Регистр бухгалтерии: Журнал проводок (бухгалтерский учет); Номер строки: 2)
...Показать Скрыть

Конфигурация: Бухгалтерия для Беларуси. УСН, редакция 1.6.65.1
Ошибка связанна с тем что со счета 000 пытается списаться валютная сумма.
Так же есть грубая ошибка при округлении малоценки. Согласно инструкциям по деноминации суммы которые после деленяи на 10 000 дают результат меньше чем 0.01, приравниваются к наименьшей денежной единице. т.е. к одной копейке (0.01)
13. Виталий Сергеевич (Slypower) 22.06.16 12:58
Форма.Форма.Форма(434): Ошибка при вызове метода контекста (Записать)
		ДокументКорректировки.Записать();
по причине:
Запись не верна! Поле "Валютная сумма" должно быть пустым! (Регистр бухгалтерии:  Журнал проводок (бухгалтерский учет); Номер строки: 154)

что с этим делать?
14. Сергей Черник (sercher88) 22.06.16 19:25
начиная со строки 338 подправить надо

заменить вот это:

Если НоваяСтрока.Имя = "Налоговый" Тогда
				Движение.ВидУчетаДт = Стр.ВидУчета;
				Движение.ВидУчетаКт = Стр.ВидУчета;
			КонецЕсли;


на вот это:

Если НоваяСтрока.Имя = "Налоговый" Тогда
				Движение.ВидУчетаДт = Стр.ВидУчета;
				Движение.ВидУчетаКт = Стр.ВидУчета;
			Иначе
				Движение.ВалютнаяСуммаДт = 0;
				Движение.ВалютнаяСуммаКт = 0;
			КонецЕсли;
...Показать Скрыть