gifts2017

ActiveX для просмотра изображений IP видеокамер

Опубликовал max1 max (scorpionkgma) в раздел Программирование - Внешние компоненты

ActiveX, написанный на c# для просмотра изображений IP видеокамер, позволяет получать поток с IP камер в виде MJPEG или JPEG (Snapshot).

ActiveX, написанный на c# (FrameWork 4.0) для просмотра изображений IP видеокамер, позволяет получать поток с IP камер в виде MJPEG или JPEG. В ActiveX используется сторонний фреймфорк Aforge.

Для регистрации необходимо запустить файл reg.cmd. Или заругистрировать вручную командой C:\Windows\Microsoft.NET\Framework\v4.0.30319\regasm.exe Video1C.dll /tlb /codebase

 

Требования: Net Framework 4.0

 

Имеются следующие параметры:

 

Процедура START_JPEG(Кнопка)
	
	// Можно использовать либо JPEG либо MPEG поток. 
	
	// JPEG - снимает скриншоты с камеры через определенный интервал времени (FrameInterval). JPEG менее ресурсоемкий по сравнение с MJPEG.
	// MJPEG - поток в формате MJPEG. Из плюсов: плавность движения на видео, из минисув: нагружает процессор.
	
	ЭлементыФормы.ActiveX.Stop();	
	
	//поток JPEG 
	ЭлементыФормы.ActiveX.Potok = "JPEG";
	
	ЭлементыФормы.ActiveX.URL = "http://192.168.2.60/dms?nowprofileid=2"; // URL путь получения снапшота камеры.
	
	ЭлементыФормы.ActiveX.FrameInterval = 250; // время опроса камеры. 250 - каждые 250мс получается новый кадр.
	
	ЭлементыФормы.ActiveX.RequestTimeout = 10000; // время ожидания ответа от камеры перед выдачей ошибки соединения.
	
	ЭлементыФормы.ActiveX.Login = "";
	
	ЭлементыФормы.ActiveX.Password = "";
	
	ЭлементыФормы.ActiveX.Start();
	
	
	
КонецПроцедуры

Процедура STOP(Кнопка)
	
	ЭлементыФормы.ActiveX.Stop();
	
КонецПроцедуры

Процедура START_MJPEG(Кнопка)
	
	ЭлементыФормы.ActiveX.Stop();
		// поток MJPEG 
	ЭлементыФормы.ActiveX.Potok = "MJPEG";
		
	ЭлементыФормы.ActiveX.URL = "http://cam.mnc.ru/axis-cgi/mjpg/video.cgi?camera=1&dummy=0.22951200%201466582223"; // URL путь получения потока камеры.  	

	ЭлементыФормы.ActiveX.RequestTimeout = 10000; // время ожидания ответа от камеры перед выдачей ошибки соединения.
	
	ЭлементыФормы.ActiveX.Login = "";
	
	ЭлементыФормы.ActiveX.Password = "";
	
	ЭлементыФормы.ActiveX.Start();

КонецПроцедуры

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ActiveX + обработка для 1С
.zip 150,78Kb
22.06.16
5
.zip 150,78Kb 5 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. max1 max (scorpionkgma) 25.06.16 05:17
Я не часто появляюсь на данном сайте, но очень уважаю мнение участников этого форума (не почтите за лесть :) ) Поэтому хотелось бы узнать мнение участников - есть ли спрос на подобные вещи. Стоит ли развивать данное направление (переделать например на COM объект)?
2. rinik 88 (rinik88) 29.11.16 16:17
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа