gifts2017

Деноминация 2016. Изменения в типовых конфигурациях Беларуси

Опубликовал Андрей Куришко (boggonzikov) в раздел Программирование - Практика программирования

С 1 июля 2016 г. в Республике Беларусь будет проведена деноминация официальной денежной единицы – белорусского рубля.
Многие работают на типовых, но не все планируют обновлять свои конфигурации обновлениями от 1С-Минск. Предлагаю обмениваться исправлениями для корректной работы после деноминации.
Пишите в комментариях буду включать в публикацию.

Изменения в типовых конфигурациях.

Бухгалтерия для Беларуси. Редакция 1.6

  1. Например для печати ТТН и ТН, документа «РеализацияТоваровУслуг» и других 
    "ЧЦ=19; ЧДЦ=0; ЧРГ=' '" 
    заменить на (можно глобальной заменой)
    ФормированиеПечатныхФорм.ФорматСуммПечать(ВалютаДокумента).
    где
    ФорматСуммПечать
    // Стандартная для данной конфигурации функция форматирования сумм
    //
    // Параметры: 
    // Сумма - число, которое мы хотим форматировать, 
    // Валюта - ссылка на элемент справочника валют, если задан, то к в результирующую строку
    // будет добавлено представление валюты
    // ЧН - строка, представляющая нулевое значение числа,
    // ЧРГ - символ-разделитель групп целой части числа.
    //
    // Возвращаемое значение:
    // Отформатированная должным образом строковое представление суммы.
    //
    Функция ФорматСуммПечать(Валюта) Экспорт
    СтрокаЗнаковДробнойЧасти = Валюта.ПараметрыПрописиНаРусском;
    СтрокаПараметров = СтрЗаменить(СтрокаЗнаковДробнойЧасти, ",", Символы.ПС);
    ЧислоЗнаковДрЧасти = ?(ЗначениеЗаполнено(СокрЛП(СтрПолучитьСтроку(СтрокаПараметров, 9))),СокрЛП(СтрПолучитьСтроку(СтрокаПараметров, 9)),0);
    ФорматнаяСтрока = "ЧЦ=19; ЧДЦ=" + ЧислоЗнаковДрЧасти + "; ЧРГ=' '";
    
    Возврат ФорматнаяСтрока;
    КонецФункции // ФорматСумм()
     
  2. Изменить Регистры сведений КурсыВалют     Точность числа 4
  3. Проверить разрядность КурсВзаиморасчетов, внекоторых документах стоит Число(10,2)),например в документе ПлатежноеПоручениеВходящее  и ПлатежноеПоручениеИсходящее.

Управление торговлей для Беларуси, редакция 2.0

  1. Например для печати ТТН и ТН, документа «РеализацияТоваровУслуг» и других 
    Пример
СуммаНДС   = Окр(Строка.СуммаНДС,0,1);

заменить на

СуммаНДС   = ОбщегоНазначения.ОкруглитьСумму(Строка.СуммаНДС, ВалютаДокумента);

Где

ОкруглитьСумму

//НачМинск// Функция округляет сумму в соответствии с количеством знаков в дробной части ,
//указанных в справочнике "Валюты"
//Параметры:
//Валюта - тип СправочникСсылка.Валюты
//Сумма  - тип число,сумма ,которую необходимо округлить
//Возвращаемое значение:
//число
//
Функция ОкруглитьСумму(Сумма,Валюта) Экспорт
              
               Если Не ПустаяСтрока(Валюта.ПолеПрописиДлинаДробнойЧасти)
                               И Найти("0123456789", СокрЛП(Валюта.ПолеПрописиДлинаДробнойЧасти))>0 Тогда
                                               ЧислоЗнаковДрЧасти = Число(Валюта.ПолеПрописиДлинаДробнойЧасти);
                                               РезСумма           = Окр(Сумма,ЧислоЗнаковДрЧасти,1);
                                               Возврат РезСумма;      
               Иначе
                               Возврат Сумма;
               КонецЕсли;
              
                              
КонецФункции//ОкруглитьСуммуВСоответствииССправочникомВалюты()

 

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Андрей Куришко (boggonzikov) 30.06.16 14:33
Бухгалтерия 1.6.71.2 (ознакомительная)
Было
			
ОбластьМакета.Области.СпецИтогоСумма.Формат		    = "ЧЦ=19; ЧДЦ=0; ЧРГ=' '";
ОбластьМакета.Области.СпецИтогоНДС.Формат          	= "ЧЦ=19; ЧДЦ=0; ЧРГ=' '";
ОбластьМакета.Области.СпецИтогоСуммаСНДС.Формат 	= "ЧЦ=19; ЧДЦ=0; ЧРГ=' '";
...Показать Скрыть

Стало
ОбластьМакета.Области.СпецИтогоСумма.Формат		    = "ЧЦ=19; ЧДЦ=" + ?(ДоДеноминации,0,2) + "; ЧРГ=' '";
ОбластьМакета.Области.СпецИтогоНДС.Формат          	= "ЧЦ=19; ЧДЦ=" + ?(ДоДеноминации,0,2) + "; ЧРГ=' '";
ОбластьМакета.Области.СпецИтогоСуммаСНДС.Формат 	= "ЧЦ=19; ЧДЦ=" + ?(ДоДеноминации,0,2) + "; ЧРГ=' '";
...Показать Скрыть

И так встречается 500 раз.
А если позже нужно будет что-то исправить? Что за студенты локализуют типовую Бухгалтерию..
ice-net; alest; pt_olga; +3 Ответить
2. Ivan Khorkov (vano-ekt) 30.06.16 17:53
дэк новую валюту вроде как вводить надо, не?
3. Dim Dragonim (Dragonim) 02.07.16 10:11
(2) vano-ekt,
Есть валюта регламинтированного учёта которая вводится на стадии первоначальной настройки программы до ввода первого документа, в дальнейшем данную валюту поменять нельзя (по правде можно, но результат очень плачевный), все остальные расчёты переводятся в валюту регламинтированного учёта для сдачи отчётность. Проще говоря, ввод новой валюты не поможет, т.к. надо менять валюту регламинтированного учёта.
4. Андрей Куришко (boggonzikov) 04.07.16 12:26
Задача деноминации разбита на 2 этапа:
1. Деноминация данных. Ссылка
Разработана Подсистема «Деноминация 2016».
С помощью ее деноминировал Управление торговлей, Розница для Беларуси, Бухгалтерия для Беларуси.

2. Деноминация конфигурации (исправление алгоритмов). Ссылка
Глобальных изменений в типовых не требуется. Нужно исправить печатные формы и добавить разрядность в некоторых местах.
5. Макс ХЗ (DomovoiGL) 04.07.16 13:12
(2) Найти бы того дурака, который придумал валюту добавить. "Руки бы оторвал и голову на всякий случай."
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа