IE2017

Оповещение пользователей 1С (сообщения между пользователями, уведомления, управляемое и обычное приложение)

Администрирование - Системное

В организации около 300 пользователей 1С и 6 конфигураций 1С управляемых и обычных. При работе иногда возникают ситуации когда нужно уведомить пользователей о технических работах, обновлениях и доработках, о необходимости завершить работу, сразу или например вечером к 20:00. Обзванивать или писать письма не эффективно. Оповещение через Active Directory очень маленькое его легко не заметить, так же отвлекает пользователей домена не использующих в работе 1С. Поэтому возникла необходимость разработать систему оповещений пользователей с минимальными изменениями всех конфигураций, подходящую для управляемых и обычных форм, и сообщениями, которые нельзя пропустить.

Разработка предназначена для уведомления пользователей как выборочно так и всех, так же можно просто писать сообщения или вести переписку между пользователями.

Разработка представляет собой регистр сведений и изменение в модуле управляемого или обычного приложения.
Для запуска оповещения необходимо добавить запись в регистр сведений, пользователи будут получать уведомления в период указанный между началом и концом времени оповещения.

УПРАВЛЯЕМОЕ ПРИЛОЖЕНИЕ


ОБЫЧНОЕ ПРИЛОЖЕНИЕ



Окно оповещения показываемое в программе пользователя блокирует весь интерфейс и пользователи работающие в данный момент в программе не пропустят оповещение и соответственно прочитают.

УПРАВЛЯЕМОЕ ПРИЛОЖЕНИЕ


ОБЫЧНОЕ ПРИЛОЖЕНИЕ


Список регистра

В списке оповещений можно просмотреть кому доставлено оповещение и кто прочитал.

УПРАВЛЯЕМОЕ ПРИЛОЖЕНИЕ



ОБЫЧНОЕ ПРИЛОЖЕНИЕ




Для внедрения разработки в свою конфигурацию необходимо:

  1. Установить возможность редактирования конфигурации.
  2. Сравнить с конфигурацией поставляемой в данной публикации. Будет добавлен регистр сведений "ОповещенияПользователей" и запись в модуле обычного или управляемого приложения, в зависимости от основного режима запуска приложения.

    Запись модуля обычного или управляемого приложения различаются:


    УПРАВЛЯЕМОЕ ПРИЛОЖЕНИЕ
Процедура ПриНачалеРаботыСистемы()
    //Модификация типовой конфигурации для оповещению пользователей программы (отправке сообщению любому пользователю)
    //Подходить для всех конфигураций
    ПодключитьОбработчикОжидания("modОбработчикОбработкиОповещения", 60);
КонецПроцедуры // ПриНачалеРаботыСистемы()

//Модификация типовой конфигурации для оповещению пользователей программы (отправке сообщению любому пользователю)
//Подходить для всех конфигураций
//Вызов обработчика ожидания продолжается пока форма не будет закрыта 
//или пока не будет вызван метод формы
Процедура modОбработчикОбработкиОповещения() Экспорт
    
    СообщениеПользователю = ПолучитьФорму("РегистрСведений.ОповещенияПользователей.Форма.ФормаОтправкиУпр").ПолучитьСообщенияОбработкиОповещения();
       
    Если Не СообщениеПользователю = Неопределено Тогда
        
        Форма = ПолучитьФорму("РегистрСведений.ОповещенияПользователей.Форма.ОповещениеУпр");
        Если Не Форма.Открыта() Тогда
            ЗаполнитьЗначенияСвойств(Форма,СообщениеПользователю,,"ТолькоПросмотр");
            Форма.Открыть();
        Иначе
            Форма.Активизировать(); 
        КонецЕсли; 
        
    КонецЕсли;           
                            
КонецПроцедуры 


ОБЫЧНОЕ ПРИЛОЖЕНИЕ

Процедура ПриНачалеРаботыСистемы()

    //Модификация типовой конфигурации для оповещению пользователей программы (отправке сообщению любому пользователю)
    //Подходить для всех конфигураций
    ПодключитьОбработчикОжидания("modОбработчикОбработкиОповещения", 60);

КонецПроцедуры // ПриНачалеРаботыСистемы()

//Модификация типовой конфигурации для оповещению пользователей программы (отправке сообщению любому пользователю)
//Подходить для всех конфигураций
//Вызов обработчика ожидания продолжается пока форма не будет закрыта 
//или пока не будет вызван метод формы
Процедура modОбработчикОбработкиОповещения() Экспорт
    
    СообщениеПользователю = РегистрыСведений.ОповещенияПользователей.ПолучитьСообщенияОбработкиОповещения();
    
    Если Не СообщениеПользователю = Неопределено Тогда
        
        Форма = ПолучитьФорму("РегистрСведений.ОповещенияПользователей.Форма.ОповещениеОбыч");
        Если Не Форма.Открыта() Тогда      
            ЗаполнитьЗначенияСвойств(Форма,СообщениеПользователю,,"ТолькоПросмотр");
            Форма.ОткрытьМодально();
        Иначе
            Форма.Активизировать();
        КонецЕсли;
    КонецЕсли;
    
КонецПроцедуры 

Внедрение разработки бесплатно, производиться в течении 10 минут.

Бесплатная техподдержка в течении 30 дней.

В 
Разработка предназначена для платформы 8.3, различных типовых и  нетиповых конфигураций, в режиме тонкого, толстого клиента и веб-клиента.

Возможна самостоятельная доработка, код открыт для редактирования.

Причины купить

Очень удобный вариант для оповещения, уведомления пользователей 1С об технических работах, доработках конфигураций, обновлениях, возможность вести переписку между пользователями 1С в рамках 1-й программы.

Достоинства

1) 100% доставка оповещений ко всем пользователям, в отличие от аналогов. 
2) Возможность отправки картинок.
3) Просмотр активности пользователей в списке сообщений (кому доставлено, кто прочитал).
4) Возможность написать ответ отправившему оповещение.
5) Не влияет на другие объекты, при обновлениях конфигураций, с установленной возможностью редактирования.

Гарантия возврата денег

Гарантия возврата денег

ООО "Инфостарт" гарантирует Вам 100% возврат оплаты, если программа не соответствует заявленному функционалу из описания. Деньги можно вернуть в полном объеме, если вы заявите об этом течение 14-ти дней со дня поступления денег на наш счет.

Программа настолько проверена в работе, что мы с полной уверенностью можем дать такую гарантию. Мы хотим, чтобы все наши покупатели оставались довольны покупкой.

Для возврата оплаты просто свяжитесь с нами.

Скачать файлы

Наименование Файл Версия Размер
Оповещение пользователей 1С (сообщения между пользователями, уведомления, управляемое и обычное приложение)
16.11.2016
1.11 1000 руб.

Моментальная
доставка

Оповещение пользователей 1С (сообщения между пользователями, уведомления, управляемое и обычное приложение): Техподдержка 1 месяц
25.07.2016
3000 руб.

См. также

PowerTools от 1 000
Комментарии
1. евг волк (ben19791010) 27.07.16 07:58 Сейчас в теме
стесняюсь спросить а ни чего, что здесь уже такое выкладывалось (тем более с изменением кунфу) бесплатно/безвозмездно, т.е. даром? О_о
2. Галахад (dmt) 25 27.07.16 08:17 Сейчас в теме
Сама идея монетизации немного странная.
Если пользователей много, то и программисты найдутся, которые что-то подобное напишут.
Если пользователей мало, то и позвонить не проблема.
3. Сочи Софт (Alexsur) 40 27.07.16 10:19 Сейчас в теме
(1) ben19791010, простите, хило было, все смотрел и побывал. Подобные может только внешне, где нужно добавить кучу справочников, кучу модулей и работает через заднее место, через раз.
Здесь все гениально, просто и удобно и со стороны программистов и пользователей.
Протестировано в течении 6 месяцев на 4 конфигурациях.
Если хотите берите бесплатные и исправляйте глюки и недоработки.
4. Сочи Софт (Alexsur) 40 27.07.16 10:24 Сейчас в теме
(2) dmt, вы правы отчасти.
Пусть пишут, если бы я знал заранее сколько придется выкорчевать "подводных камней" при реализации, то за 1000 р. сам бы купил.

5. Сергей Д (dddxddd) 27.07.16 20:16 Сейчас в теме
Смешно смотрится на форме кнопоШка - прочитать позднее, в сообщении о срочных работах и предупреждении о закрытии незакрытых сеансов...
6. Сочи Софт (Alexsur) 40 27.07.16 21:44 Сейчас в теме
(5) dddxddd, ))) Согласен, ну бывает всякое)))
7. Ден Вар (vardo) 43 28.07.16 12:09 Сейчас в теме
Цвета - кошмар просто!
mnemchinov; BigB; dour-dead; +3 Ответить 1
8. Сочи Софт (Alexsur) 40 28.07.16 14:09 Сейчас в теме
(7) vardo, Это специально сделано чтобы отличалось от стандартных цветов, и обращало на себя внимание!!!
9. podelis podelis (podelis) 05.12.16 23:56 Сейчас в теме
купил, поставил, роль себе назначил, форма списка регистра открывается, но возможности добавить сообщение нету. что делаю не так? зы управляемое приложение, интерфейс не такси. бух. 3.0
10. Сочи Софт (Alexsur) 40 06.12.16 06:54 Сейчас в теме
(9) что то не так с ролями, в личку пишите разберемся.
11. Artem Shamsutdinov (smartem) 06.12.16 07:11 Сейчас в теме
(0)
Решил ли здесь вопрос с автоматическим завершением сеансов пользователей?
Или это необходимо настраивать через типовую блокировку работы пользователей?
12. Сочи Софт (Alexsur) 40 06.12.16 10:49 Сейчас в теме
(11) В новой версии, отлаживаю и тестирую пока.
13. Andrew (andr2510) 6 26.12.16 09:45 Сейчас в теме
Добрый день
Несколько вопросов:
1. Если конфа использует БСП (УТ11, БП 3.0) то нельзя вот так просто добавлять обработчики в "ПриНачалеРаботыСистемы". Она будет ругаться при старте с ключом "/C ЗапуститьОбновлениеИнформационнойБазы". Это произойдет если при старте будет выполнено условие и должна будет открыться форма. Должно произойти. У вас нормально работает?
2. Как решен вопрос блокировок? Если нужно часто оповещать и быстрее чем раз/минуту. Ведь происходит не только чтение но и запись, когда пользователь "просмотрел". Я не знаю как у вас при 300 пользователях, но при подобном решении этой задачи для 20 пользователей но проверкой раз/5 сек (нужно очень оперативно реагировать) возникали блокировки.
3. Я так понимаю, что оповещение создается для каждого пользователя? Если да, то как решен вопрос с добавлением нового после того как было сформировано оповещение? То есть оповещение сделали. Для каждого сформировалась запись. А потом завели нового и он вошел в базу. Я правильно понимаю, что он не увидит ничего?
14. Сочи Софт (Alexsur) 40 26.12.16 15:19 Сейчас в теме
(13) Добрый день
1) Нормально с БСП.
2) Блокировки будут в новой версии, пока конфликтов нет.
3) Если ему не отправили оповещение то он и не получит.
15. Юрий Н (graphbuh) 141 01.02.17 10:28 Сейчас в теме
Добрый день. А есть ли опция завершения спящих сеансов (указание время спящего сеанса и период опроса) с предварительным предупреждением пользователей (работа будет завершена - да / нет).
16. Сочи Софт (Alexsur) 40 01.02.17 12:47 Сейчас в теме
Оставьте свое сообщение