gifts2017

Старые обработки в новом (Управляемом) интерфейсе

Опубликовал Валерий Швабинский (valerasv) в раздел Программирование - Практика программирования

Многие разработчики привыкли использовать какие-либо обработки, разработанные для приложений с обычным интерфейсом. Но они не работают в приложениях на управляемых формах. Как вариант, эту обработку можно включить в состав конфигурации, указать в свойствах конфигурации, что возможно использование обычных форм

Идея, как таковая, принадлежит не мне, а автору всем известной подсистемы "Инструменты разработчика" http://infostart.ru/public/15126/

Многие разработчики привыкли использовать какие либо обработки, разработанные для приложений с обычным интерфейсом.

Но они не работают в приложениях на управляемых формах. Как вариант, эту обработку можно включить в состав конфигурации, указать в свойствах конфигурации, что возможно использование обычных форм, и радоваться…

Но не всегда есть такая возможность, например если конфигурация стоит на поддержке.

Для таких случаев можно произвести небольшую модификацию внешней обработки.

Для этого необходимо через меню Сервис->Параметры на закладке общие указать, что будет использоваться режим запуска «Управляемое приложение и обычное приложение»

После чего станет возможным добавить в нашу обработку управляемую форму.

В самой форме размещаем команду, которая запустит нашу конфигурацию в режиме обычного приложения и автоматически откроет нашу обработку.

В обработчике команды прописываем код, который произведет запуск в обычном режиме


&НаКлиенте
Процедура ЗапуститьОбычноеПриложение(Команда)
	
	#Если ВебКлиент Тогда
		Сообщить("Команда недоступна веб клиенте");
	#Иначе
		ПараметрыЗапуска = "";
		СтрокаСоединения = СтрокаСоединенияИнформационнойБазы();
		ПараметрыЗапуска = ПараметрыЗапуска + " ENTERPRISE";
		ПараметрыЗапуска = ПараметрыЗапуска + " /IBConnectionString""" + СтрЗаменить(СтрокаСоединения, """", """""") + """";
		ПараметрыЗапуска = ПараметрыЗапуска + " /RunModeOrdinaryApplication";
		ИспользуемоеИмяФайла = ПолучитьИспользуемоеИмяФайла(ИмяКомпьютера());
		Если ЗначениеЗаполнено(ИспользуемоеИмяФайла) Тогда
			ПараметрыЗапуска = ПараметрыЗапуска + " /Execute""" + ИспользуемоеИмяФайла + """";
		КонецЕсли; 
		ЗапуститьПриложение(КаталогПрограммы() + "1cv8.exe " + ПараметрыЗапуска);
	#КонецЕсли 
	
КонецПроцедуры

&НаСервере
Функция ПолучитьИспользуемоеИмяФайла(ИмяКомпьютера)
	
	Если ИмяКомпьютера = ИмяКомпьютера() Тогда
		Возврат РеквизитФормыВЗначение("Объект").ИспользуемоеИмяФайла;
	Иначе
		Возврат Неопределено;
	КонецЕсли; 
	
КонецФункции

Радуемся использованию инструмента, который много раз выручал и выручит еще не раз.

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Константин Жигалло (zhyhallo) 16.08.16 07:22
Интересная идея. Удобная для пользователя. Спасибо за статью.
moolex; valerasv; +2 Ответить
2. Илья Козлов (Dem1urg) 17.08.16 10:02
В большинстве случаев хватает отдельного ярлыка для запуска 1С в котором в параметрах прописан ключ RunModeOrdinaryApplication
7OH; monkbest; +2 Ответить
3. Валерий Швабинский (valerasv) 17.08.16 14:35
Если это на одном компьютере, можно и ярлык создать.
А если где то на выезде или при удаленном соединении?...
Тут даже задумываться о ярлыках не нужно. К тому же такую обработку
можно отдать в пользование обычному пользователю....
4. v i (vis_tmp) 24.08.16 07:09
5. Сергей Шевченко (demon_infernal) 29.09.16 08:08
А если конфигурация еще и базовая - то между запуском этой команды и открытием окна обычного приложения нужно успеть закрыть сеанс управляемого приложения, что очень неудобно.
6. Валерий Швабинский (valerasv) 02.10.16 19:08
(5) demon_infernal,
Для этого, в самом простом случае, достаточно прописать ЗавершитьРаботуСистемы().
Посложнее -
Если ЗакрыватьОкноПриложения Тогда
ЗавершитьРаботуСистемы();
КонецЕсли;

Где "ЗакрыватьОкноПриложения" типа Булево, выведенное на форму....
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа