Сохранение прайс-листа в эксель с группами товаров на отдельных листах. УТ 10.3

Обработки - Ценообразование, прайсы

Стандартный прайс для УТ 10.3, но позволяет сохранить его в Эксель так, чтобы определенные группы товаров формировались на отдельных листах + если сделать небольшие доработки в базе, то можно будет выгружать картинки к группе товаров

В прайсе добавлена кнопка "Выгрузить в Эксель", само формирование прайса стандартно, при сохранении в эксель группы товаров, в названии которых есть фраза "(ВО)" будут выгружены на отдельный лист. Это удобно, когда вы рассылаете ваши прайсы покупателям. К примеру, на одной вкладке продукты, на след хоз. товары и т.д. Вкладка будет называться так же, как и группа товаров, следует помнить, что у экселя есть ограничение на название листа. Также если сделать небольшие доработки в базе, то на листе в заголовке будет выгружаться картинка. Для этого надо в справочнике Номенклатура у реквизита "основное изображение" указать использование - Для Группы И Элементов. На форме группы добавить поле картинки (я назвал его так же, как реквизит "ОсновноеИзображение"). И далее заменить код в форме группы на этот:

Перем мТекущееОсновноеИзображение;

Процедура ДействияФормыРедактироватьКод(Кнопка)
	МеханизмНумерацииОбъектов.ИзменениеВозможностиРедактированияНомера(Метаданные(), ЭтаФорма, ЭлементыФормы.ДействияФормы.Кнопки.Подменю, ЭлементыФормы.Код);
КонецПроцедуры

// Процедура - обработчик события "ПриОткрытии" формы.
//
Процедура ПриОткрытии()

	МеханизмНумерацииОбъектов.УстановитьДоступностьПоляВводаНомера(Метаданные(), ЭтаФорма, ЭлементыФормы.ДействияФормы.Кнопки.Подменю, ЭлементыФормы.Код);

	Если ЭтоНовый() И НЕ ЗначениеЗаполнено(ВидНоменклатуры) Тогда
		ВидНоменклатуры = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глЗначениеПеременной("глТекущийПользователь"), "ОсновнойВидНоменклатуры");
	КонецЕсли;

	//РУТ
	мТекущееОсновноеИзображение = ОсновноеИзображение.Хранилище.Получить();
	ПоказатьОсновноеИзображение();
КонецПроцедуры // ПриОткрытии()

//РУТ----------------------------------------
Процедура ОсновноеИзображениеНажатие(Элемент)
	Если Не РаботаСДиалогами.ЗаписатьНовыйОбъектВФорме(ЭтаФорма) Тогда
		Возврат;
	КонецЕсли;

	РаботаСФайлами.ОткрытьФормуИзображения(ЭтаФорма, ОсновноеИзображение, Ссылка);
КонецПроцедуры


Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)
	Если ТипЗнч(ЗначениеВыбора) = Тип("СправочникСсылка.ХранилищеДополнительнойИнформации") Тогда
		Если ОсновноеИзображение <> ЗначениеВыбора Тогда
			ОсновноеИзображение = ЗначениеВыбора;
		КонецЕсли;

		мТекущееОсновноеИзображение = ОсновноеИзображение.Хранилище.Получить();
		ПоказатьОсновноеИзображение();

	КонецЕсли;
КонецПроцедуры

Процедура ПоказатьОсновноеИзображение() Экспорт
	
	Если мТекущееОсновноеИзображение = Неопределено Тогда
		ЭлементыФормы.ОсновноеИзображение.Картинка = Новый Картинка;
	Иначе
		ЭлементыФормы.ОсновноеИзображение.Картинка = мТекущееОсновноеИзображение;
	КонецЕсли;

КонецПроцедуры // ПоказатьОсновноеИзображение()



Это код для сохранения изображения, в принципе, он такой же, как и у элемента номенклатуры в форме элемента.       

Скачать файлы

Наименование Файл Версия Размер
Прайс
.epf 53,14Kb
05.09.16
7
.epf 53,14Kb 7 Скачать

См. также

В этой теме еще нет сообщений.
Оставьте свое сообщение