gifts2017

Оптимизация кода 1С: простые приемы

Опубликовал Владисав Утюмов (utyv) в раздел Администрирование - Оптимизация БД (HighLoad)

Речь пойдет о проблемах с производительностью, которые могут возникнуть из-за кода наподобие этого: Для каждого СтрокаТовары из Товары Цикл Количество = СтрокаТовары.Количество * СтрокаТовары.Коэффициент / СтрокаТовары.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент; КонецЦикла; Дело в том, что этот, с виду ни чем не примечательный код, содержит запрос в цикле.
Для каждого СтрокаТовары из Товары  Цикл
    //.....................
    Количество = СтрокаТовары.Количество * СтрокаТовары.Коэффициент / СтрокаТовары.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент;
    //......................
КонецЦикла;

В чем проблема?

Когда мы обращаемя к реквизиту объекта базы "через точку", программа выполняет запрос к базе, чтобы вытащить из базы значение этого реквизита. Строго говоря, это происходит не всегда. Известно, что при чтении одного реквизита считываются значения всех реквизитов этого объекта. Считанные значения кэшируется, но кэш имеет ограниченный размер, и ограниченное время жизни.

Такой запрос выполняется довольно быстро, и обычно не дает заметной задержки. Задрежку, заметную для пользователя, можно получить, если в цикле будет более 100 таких опеаций. Задержки на выполнении запросов более заметны в клиент-серверном режиме, чем в файл-серверном. Зачастую, после перевода файловой базы, которая работала в терминале, на SQL пользователи начинаются жаловаться на то, что программа стала тормозить. Проблема может быть как раз в этих микрозапросах, которые выполяются в цикле. Судя по всему, задержка на выполнение такого микрозапроса складывается в основном из накладных расходов: нужно сформировать текст запроса, отправить его на сервер, откомпилировать, построить план получить результат и т.д. Я могу ошибаться в том, откуда эти накладные расходы берутся, но они есть, в этом я не раз убеждался на практике.

Кэширование, которое выполняет платформа, не всегда спасает: если в цикле каждый раз считывается новая номенклатура, то ее еще нет в кэше, и мы каждый раз несем те самые накладные расходы.

Я лично сталкивался с ситуацией, когда такой вот неаккуратный код замедлял проведение размещение заказа покупателя в 10 раз (справедливости разди, в заказе было 800 строк).

Естественно, нет необходимости переписывать все такие случаи. Если есть потребность оптимизировать какую-то операцию, то надо сначала сделать замер производительности (такая функция есть в конфигураторе, в меню "Отладка"). В нашем случае, мы с топе увидим простую операцию, которая выполняется многократно и съедает много времени. Не забудьте, что замер надо делать на клиент-серверной базе, а не на файловой копии.

Исправляем

Т.к. проблема в накладных расходах, то считав все необходимые данные одним запросом, мы многократно снизим накладные расходы и решим проблему. Первое что приходит в голову, это написать что-то наподобие такого кода:

//....................
Запрос.Текст = 
//............
|НакладнаяТовары.Количество КАК Количество,
|НакладнаяТовары.Коэффициент КАК Коэффициент,
|НакладнаяТовары.Номенклатура.БазоваяЕдиницаИзмерения.Коэффициент КАК НоменклатураБазоваяЕдиницаИзмеренияКоэффициент,
//.........
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
    //.................
    Количество = Выборка.Количество*Выборка.Коэффициент*Выборка.НоменклатураБазоваяЕдиницаИзмеренияКоэффициент;
    //.................
КонецЦикла;


Это решит проблему, только мы можем столкнуться с некоторыми неудобствами. Во-первых нам придется везде заменить СтрокаТовары на Выборка. Хорошо, обзовем выборку "СтрокаТовары" (что не очень красиво) или выгрузим запрос в таблицу значений (что уже лучше).

Во-вторых, если запрос сложный, собирается по-частям где-то в общих модулях типовой конфигурации, то мы не захотим его менять. Потому что боимся что-нибудь поломать, а еще не хотим усложнять себе обновление типовой конфигурации с сохранением сделанных настроек.

Поразмыслив, пишем более приятный и удобный вариант:

Запрос.Текст = 
"ВЫБРАТЬ
|Номенклатура.Ссылка,
|Номенклатура.ЕдиницаХраненияОстатков.Коэффициент КАК ЕдиницаХраненияОстатковКоэффициент
|ИЗ
|Справочник.Номенклатура КАК Номенклатура
|ГДЕ
|Номенклатура.Ссылка В (&МассивНоменклатуры)";
Запрос.Параметры.Вставить("МассивНоменклатуры", Товары.ВыгрузитьКолонку("Номенклатура"));
тзРеквизитовНоменклатуры = Запрос.Выполнить().Выгрузить();
тзРеквизитовНоменклатура.Индексы.Добавить("Ссылка");
Для каждого СтрокаТовары из Товары Цикл
    СтрокаНоменклатуры = тзРеквизитовНоменклатуры.Найти(СтрокаТовары.Номенклатура, "Ссылка");
    Если СтрокаНоменклатуры = Неопределено Тогда
        ВызватьИсключение "Не найдена номенклатура"+СтрокаТовары.Номенклатура;
    КонецЕсли;
    //...................
    Количество = СтрокаТовары.Количество*СтрокаТовары.Коэффициент*СтрокаНоменклатуры.ЕдиницаХраненияОстатковКоэффициент;
    //....................
КонецЦикла;

Мы внесли в код локальные измененения:

  1. Перед циклом вытащили из базы то, что нам нужно, и сложили в таблицу значений.
  2. В начале цикла нашли в этой таблице нужную строку.
  3. Везде, где есть обращение к полям "через точку", заменили на обращение к строке таблицы значений.

Необходимость добавлять индекс в таблицу значений - вопрос спорный, я рассуждаю так:

  1. Индексирование маленькой тз не даст заметной задержки. Даже если мы потеряем больше времени, чем сэкономим - мы не гонимся за рекордами, нам важно, чтобы пользователю было комфортно.
  2. Отсутствие индекса в большой тз может дать заметную задержку. Справедливости ради, таблица должна быть действительно большой, начиная с 1000 записей, если я ничего не путаю.

Немного сложнее

Бывает, что неявный микрозапрос, который многократно вызывается, закопан глубоко в общих модулях, да еще используется по всей конфигурации. Что делать в этом случае? Рассмотрим пример:

Функция ПолучитьКурсВалюты(Валюта, ДатаКурса) Экспорт
	
	Структура = РегистрыСведений.КурсыВалют.ПолучитьПоследнее(?(ДатаКурса = Дата('00010101'),ТекущаяДата(),ДатаКурса), Новый Структура("Валюта", Валюта));
	Возврат Структура;
	
КонецФункции // ПолучитьКурсВалюты()

Если многократный вызов этой функции съедает время наших пользователей, мы можем ее усовершенствовать:

Функция ПолучитьКурсВалюты(Валюта, ДатаКурса, СтруктураКэш = Неопределено) Экспорт
	
	// добавили тут
	лкДата = ?(ДатаКурса = Дата('00010101'),ТекущаяДата(),ДатаКурса);
	Если СтруктураКэш <> Неопределено Тогда
		Если НЕ СтруктураКэш.Свойство("КэшКурсов") Тогда
			СтруктураКэш.Вставить("КэшКурсов", Новый ТаблицаЗначений);
			СтруктураКэш.КэшКурсов.Колонки.Добавить("Валюта");
			СтруктураКэш.КэшКурсов.Колонки.Добавить("Период");
			СтруктураКэш.КэшКурсов.Колонки.Добавить("Курс");
			СтруктураКэш.КэшКурсов.Колонки.Добавить("Кратность");
		КонецЕсли;
		СтрокиКэш = СтруктураКэш.КэшКурсов.НайтиСтроки(Новый Структура("Валюта, Период", Валюта, лкДата));
		Если СтрокиКэш.Количество() > 0 Тогда
			Возврат Новый Структура("Курс, Кратность", СтрокиКэш[0].Курс, СтрокиКэш[0].Кратность);
		КонецЕсли;
	КонецЕсли;
	
	Структура = РегистрыСведений.КурсыВалют.ПолучитьПоследнее(лкДата, Новый Структура("Валюта", Валюта));
	
	// и тут
	Если СтруктураКэш <> Неопределено Тогда
		НоваяСтрока = СтруктураКэш.КэшКурсов.Добавить();	
		НоваяСтрока.Валюта = Валюта;
		НоваяСтрока.Период = лкДата;
		НоваяСтрока.Курс = Структура.Курс;
		НоваяСтрока.Кратность = Структура.Кратность;
	КонецЕсли; 
	
	Возврат Структура;
	
КонецФункции // ПолучитьКурсВалюты()

Теперь нам надо объявить переменную СтруктураКэш в модуле того объекта, который оптимизируем. Иницилизировать ее не надо, пусть будет Неопределено. Будем передавать эту переменную во все процедуры, которые в конечном итоге вызывают ПолучитьКурсВалюты() - отладчик, замер производительности и стек вызовов в помощь. Придется добавить в типовые процедуры параметр СтруктураКэш = Неопределено, ничего не поделаешь. Но в общем и целом изменений в типовом коде получится немного, а не затронутые нами участки типового кода будут работать по-старому.

Вывод

Оптимизация работы системы не всегда требует чего-то сложного, наподобие анализа блокировок или планов запроса. Часто простой замер производительности и чистка запросов в цикле дает более, чем ощутимый результат.

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Петр Базелюк (pbazeliuk) 20.09.16 16:11
Количество = Выборка.Количество*Выборка.Коэффициент*Выборка.НоменклатураБазоваяЕдиницаИзмеренияКоэффициент;

Может правильнее это уже посчитать в запросе?

Номенклатура.Ссылка В (&МассивНоменклатуры)

Для небольших массивов имеет право на жизнь, но для больших лучше предварительно поместить во временную таблицу и в следующем запросе выполнить отсечение.

Если вас беспокоит микро-запрос, сделайте вручную индекс в базе данных под запрос.
Так же можно включить "Повторно использование возвращаемых значений" в общем модуле, то есть создать свой ОбщийМодульПовтИсп (повторного использования) и выполнять переадресацию на него из базового модуля.
i_a; Vlad_M; CSiER; Zhilyakovdr; +4 Ответить 2
2. Владисав Утюмов (utyv) 20.09.16 22:17
Решения о том что нужно оптимизировать, а что нет лучше принимать на основании замеров. Я набросал несколько искусственных примеров, которые демонстрирую суть проблемы.

Код с микро-запросами в цикле:
	Для каждого СтрокаТЧ из ЗаказПокупателя.СтруктураИзделияТЧ Цикл
		Артикул = СтрокаТЧ.Номенклатура.Артикул;
	КонецЦикла;
...Показать Скрыть

Замер - 6,2 сек после прогрева на документе с примерно 2000 строк.

Один запрос вытаскивает те же данные. Отбор массивом:
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	Номенклатура.Ссылка,
	|	Номенклатура.Артикул
	|ИЗ
	|	Справочник.Номенклатура КАК Номенклатура
	|ГДЕ
	|	Номенклатура.Ссылка В(&МассивНоменклатуры)";
	Запрос.Параметры.Вставить("МассивНоменклатуры", ЗаказПокупателя.СтруктураИзделияТЧ.ВыгрузитьКолонку("Номенклатура"));
	Выборка = Запрос.Выполнить().Выбрать();
	Пока Выборка.Следующий() Цикл
		Артикул = Выборка.Артикул;
	КонецЦикла;
...Показать Скрыть

Замер 200 мс.

Фильтрация с использованием временной таблицы, те же данные:
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ РАЗЛИЧНЫЕ
	|	ВЫРАЗИТЬ(ЗаказПокупателяСтруктураИзделияТЧ.Номенклатура КАК Справочник.Номенклатура) КАК Номенклатура
	|ПОМЕСТИТЬ втНоменклатуры
	|ИЗ
	|	Документ.ЗаказПокупателя.СтруктураИзделияТЧ КАК ЗаказПокупателяСтруктураИзделияТЧ
	|ГДЕ
	|	ЗаказПокупателяСтруктураИзделияТЧ.Ссылка = &Ссылка
	|
	|ИНДЕКСИРОВАТЬ ПО
	|	Номенклатура
	|;
	|
	|////////////////////////////////////////////////////////////­////////////////////
	|ВЫБРАТЬ
	|	Номенклатура.Ссылка,
	|	Номенклатура.Артикул
	|ИЗ
	|	Справочник.Номенклатура КАК Номенклатура
	|ГДЕ
	|	Номенклатура.Ссылка В
	|			(ВЫБРАТЬ
	|				т.Номенклатура
	|			ИЗ
	|				втНоменклатуры КАК т)";
	Запрос.Параметры.Вставить("Ссылка", ЗаказПокупателя);
	Выборка = Запрос.Выполнить().Выбрать();
	Пока Выборка.Следующий() Цикл
		Артикул = Выборка.Артикул;
	КонецЦикла;
...Показать Скрыть

Замер 70 мс.

Так что, в данном случае, в первую очередь надо убирать микрозапросы, потом думать о способе фильтрации, если разница в 130 мс нас еще беспокоит.
Индексы тут не помогут, потому что поле Ссылка и так всегда проиндексировано. Повторное использование возвращаемых значений - далеко не всегда подойдет. Это надо чтобы значения на самом деле повторно вычислялись, и была на готове функция, которую можно туда записать.

Сравнивать по скорости умножение в запросе и во встроенном языке нет особого желания. Я бы стал этим заниматься, если бы на замере увидел, что умножение у меня - самая медленная операция. Но такого пока не было, поэтому я не стесняюсь умножать там где мне удобнее.
A7_Sash; Yit; sevushka; tormozit; orfos; mrflatcher; Evil Beaver; корум; dj_serega; Sholl; GATTUSO; swiss-garant; herfis; eskor; servs; NeviD; karpik666; orefkov; +18 Ответить 1
3. Vladimir Kuzmenko (t278) 21.09.16 02:57
На мой взгляд, в статью нужно добавить примеры других статей по оптимизации. То, что здесь описано (точнее основная суть) оно уже где-то упоминалось, и регулярно упоминается., Что сократить число обращений к базе. Ценность статьи , освежить память, что БД ссылаться минимальное число раз.
4. Алексей Редин (bonk) 21.09.16 08:06
На мой взгляд статья отличная, если рассматривать ее для разработчиков с небольшим опытом.
Чтобы прийти к таком пониманию, придется потратить не один год, причем именно на разработку и качественную.

Спасибо автору, содержательно и доступно.
5. Виталий (nafa) 21.09.16 08:37
Я бы добавил в статью, что все это касается ссылок (т.е. "Товары" - это ТЧ объекта "ДокументССылка"), а то кто-нибудь из начинающих точно к объекту ("ДокументОбъект") применит с соответствующим результатом.
6. Максим *** (premier) 21.09.16 08:54
(0)
программа выполяет запрос к базе
считываются значения всех реквизтов
надо сначала сделасть замер производительности
написать что-то надобоие такого кода
мы можем столкнуться с некоторыми неудобстами
Потому-то боимся что-нибуль поломать

Автор, не ломайте русский язык. Статья - прописные истины для программиста 1С.
А фраза то надо сначала сделасть замер производительности (такая функция есть в конфигураторе, в меню "Отладка") просто в шок повергла: а мужики-то не знали!
Krasnyj; Uncore; ZOMI; Evil Beaver; Frogger1971; +5 Ответить
7. Галахад (dmt) 21.09.16 09:25
Статья понравилась. Оптимизация минимальными усилиями.
8. Иван Коротеев (kiv1c) 21.09.16 11:46
В примере с курсами валют для минимальных изменений нужно использовать Временное Хранилище.
Если мы еще не получали курс данной валюты на текущий день, получим и сохраним в Хранилище. Если получали, то возьмем из Хранилища без запроса к базе.
код примерно такой:

Перем АдресВременногоХранилищаКурсов;
Функция ПолучитьКурсВалюты(Валюта, ДатаКурса) 
	перем структураНайдено;
	ДатаКурсаВРегистр = ?(ДатаКурса = Дата('00010101'),КонецДня(ТекущаяДата()),ДатаКурса);
	КлючПоиска = Строка(Валюта)+Формат(ДатаКурсаВРегистр,"ДФ=dd_MM_yyyy");//ключ для хранилища - комбинация валюты и даты.
	сообщить("Ключ="+КлючПоиска);
	если АдресВременногоХранилищаКурсов=неопределено тогда
		//еще не клали ничего в хранилище
		СтруктураХранилищаНовая = Новый Структура();
		Структура = РегистрыСведений.КурсыВалют.ПолучитьПоследнее(ДатаКурсаВРегистр, Новый Структура("Валюта", Валюта));
		СтруктураХранилищаНовая.Вставить(КлючПоиска,Структура);
		АдресВременногоХранилищаКурсов = ПоместитьВоВременноеХранилище(СтруктураХранилищаНовая);
		сообщить("еще не клали, адрес="+АдресВременногоХранилищаКурсов);
		Возврат Структура;
	иначе		
		//тип Структура, ключ - КлючПоиска, значение - Структура с полями Курс, Кратность.
		СтруктураКурсов = ПолучитьИзВременногоХранилища(АдресВременногоХранилищаКурсов);
		//теперь поищем записи в СтруктураКурсов по ключу
		
		если СтруктураКурсов.Свойство(КлючПоиска,структураНайдено) тогда
			//нашли, вернем...
			сообщить("Нашли, возвращаем..."+АдресВременногоХранилищаКурсов);
			СтруктураКурса = структураНайдено;
			Возврат СтруктураКурса;
		иначе
			//такого ключа нет,получим из базы и поместим в Хранилище
			сообщить("Ключа="+КлючПоиска+" еще нет, поместим в хранилище");
			
			Структура = РегистрыСведений.КурсыВалют.ПолучитьПоследнее(ДатаКурсаВРегистр, Новый Структура("Валюта", Валюта));
			СтруктураКурсов.Вставить(КлючПоиска,Структура);
			АдресВременногоХранилищаКурсов = ПоместитьВоВременноеХранилище(СтруктураКурсов,АдресВременногоХранилищаКурсов);
			Возврат Структура;
		конецесли;		
	конецесли;
КонецФункции // ПолучитьКурсВалюты()
...Показать Скрыть



Фактически, у нас есть куча модулей которым нужен курс валюты, и в каждом добавлять переменную СтруктураКэш очень накладно.
корум; +1 Ответить
9. Петр Самчук (Frogger1971) 21.09.16 13:24
(1) pbazeliuk,
Если вас беспокоит микро-запрос, сделайте вручную индекс в базе данных под запрос.

снова временная таблица, а учитывая, если ведущие параметры не индексируются - будем иметь дополнительный тормоз
10. Петр Базелюк (pbazeliuk) 21.09.16 13:37
(9) Frogger1971, речь идет о другом, для MS SQL, например, будет что-то на подобие такой команды:
CREATE INDEX [missing_index_294875_294874__InfoRg4215] ON [yt11].[dbo].[_InfoRg4215] ([_Fld4217RRef], [_Fld11175]) INCLUDE ([_Fld4216_TYPE], [_Fld4216_RTRef], [_Fld4216_RRRef], [_Fld4218_TYPE], [_Fld4218_L], [_Fld4218_N], [_Fld4218_T], [_Fld4218_S], [_Fld4218_RTRef], [_Fld4218_RRRef])
11. DenisCh Гейтс (DenisCh) 21.09.16 14:12
(10) pbazeliuk, и попрощайся с этим индексом после реструктуризации ))
12. Дмитрий Т (Dmitri_1C) 21.09.16 14:42
Не совсем понятно, в чем заключается оптимизация, для первого примера.
Особенно строка:
СтрокаНоменклатуры = тзРеквизитовНоменклатуры.Найти(СтрокаТовары.Номенклатура, "Ссылка");


Уже не говоря о смысле примера:
То есть запросом получили таблицу значений, затем её перебираем, в цикле осуществляем поиск самого себя, а потом уже делаем расчеты.

Когда 10 элементов - это еще куда не шло.
А когда 1000 элементов для обработки и справочник номенклатура на 100 000 элементов
Сколько по времени будет выполняться данный цикл?

Оптимизация - это расчет внутри запроса, результатом которого будет готовая таблица.
13. Сан Саныч (herfis) 21.09.16 15:16
(12) Dmitri_1C, Смысл оптимизации очень простой - исключение лишних обращений к БД.
Это самая существенная оптимизация которая может быть сделана в 1С.
А когда 1000 элементов для обработки и справочник номенклатура на 100 000 элементов
Сколько по времени будет выполняться данный цикл?

Чем больше элементов для обработки - тем существеннее будет выигрыш.
Поиск по индексированной структуре данных в памяти - штука быстрая, хоть и выглядит громоздко.
Размер справочника вообще не имеет значения, т.к. считываются только необходимые данные.
Простор для оптимизации, конечно, остается. Но на фоне первого и главного этапа оптимизации выжать получится слезы.
Это только кажется - оооо, мы исключили операцию поиска в цикле на 1000 элементов! На практике это будут доли секунды.
В то время, как первичная оптимизация сэкономит минуты.
Если, конечно, можно не затрачивая усилий переписать чтобы вообще все запросом делалось - ну, отлично, чо.
Но в статье говорилось о внедрении оптимизации минимальными усилиями в существующий код. Пусть вас не обманывает простота примера. Он упрощен для легкости восприятия статьи.
dj_serega; utyv; +2 Ответить
14. Петр Базелюк (pbazeliuk) 21.09.16 15:35
(11) DenisCh, каждое блюдо нужно уметь готовить.
Там где сейчас работаю, реструктуризация делась недавно впервые за 4 года, что бы настроить сжатие DB на лету, плюс полное журналирование. Рейд на SSD дисках под рабочую DB заменить не было возможности. Следующая реструктуризация неизвестно когда будет, возможно, через пару лет (торговля 24/7).
В высоко нагруженных проектах, специфичные индексы дают ощутимый прирост скорости работы.
Без специфичных индексов очередь к высокопроизводительному рейду на SSD дисках, где размещены только файлы tempdb, достигала 50-100. После создания необходимых индексов, очередь всего 0.1-0.5.

Тему оптимизации кода\запросов\планирования индексов в конфигураторе не подымаю. :)
15. Петр Базелюк (pbazeliuk) 21.09.16 15:45
(12) Dmitri_1C, там есть строчка -
тзРеквизитовНоменклатура.Индексы.Добавить("Ссылка"); 

Поиск очень быстро выполняется по индексу, но это действительно плохой пример.
Более адекватный пример, когда нужно проанализировать результат запроса -> таблицу значений по разной комбинации колонок (по дереву настроек). Кто сталкивался с матричным управлением ассортиментом по специфическим характеристикам, оборачиваемости и полкоместам, наверняка сталкивался.
16. Владисав Утюмов (utyv) 21.09.16 16:27
pbazeliuk, эта статья конечно для новичков, я даже не собирался ставить тег hiload - это модератор мне прицепил. Хардкор с ручным прикручиванием индекса и терабайтными базами 24*7 не рассматриваю.
17. Андрей Овсянкин (Evil Beaver) 22.09.16 00:03
Господи-боже... еще один вдруг понял, что разыменование ссылок приводит к запросу в СУБД....
А еще, внезапно, ДокументСсылка.Номер приведет к считыванию в память документа со всеми его табличными частями, ага. В документации написано. И про объектный кеш, и много еще чего, но кто же читает то...

С курсами валют вообще не догнал, ад какой-то....
awa; NeeDiGeo; _also; orfos; Новиков; PrinzOfMunchen; kraynev-navi; корум; webester; minimajack; pbazeliuk; Rik30; karpik666; zqzq; Noxie41; ZOMI; t278; +17 1 Ответить 1
18. Дмитрий Б (bdimaw) 22.09.16 09:52
О проблеме получения данных по точке знал, но не придавал особого значения, старался просто редка использовать.
Протестировал на практике, эффект колоссальный, в некоторый места производительность повысилась в 4 раза, документ стал быстрее открываться.
Спасибо автору, подтолкнул к изменениям.
19. ivanov660 ivanov660 (ivanov660) 22.09.16 10:12
Считаю что приведенные решения по оптимизации не завершенные, а полумеры:

- оптимально в первом примере все оставшиеся действия вынести в запрос - умножения и деления;
- во втором примере также в конечном варианте получать данные запросом.

Придумывайте более адекватные примеры.
20. Александр Хомяк (logarifm) 22.09.16 11:14
Поставил плюс.
Я вот что хочу сказать. Статья расчитана для начинающих оптимизаторов. Ну и также напоминает большим дядькам или мужикам как это было сказано в http://forum.infostart.ru/forum24/topic158625/message1623673/#message1623673
Не забываем, что маленькие но зато весьма частые вызовы также могут делать проблемы. И то что отследить такое поведение очень и очень не просто даже мужикам с большой буквы М.

Потому как в нагрузочных тестах СКЛ мы в топах не увидим это и накладных расходов тоже практически ничего не увидим кроме как количества вызовов за время.

Насчет кэш валюты ну а что ведь не плохо и к примеру при уже на выходе 8.3.9 никто не мешает -то сделать &Вместо не меняя штатную конфигурацию.

Да и статья - не закончена это только начало ИЗ возможных всех проблем. Да тут есть примеры и т.д. Но это крайне глубокая тема и как мне кажеться для этого надо развивать в подфорумы вот где и будут статьи такого рода объединяться в опыт.
21. Роман Ложкин (webester) 22.09.16 16:28
Старая шутка и не интересная :) если написать:
Ребят обращение к данным через несколько точек, это плохо и приводит к чрезмерной нагрузке на БД. Запомните это правило ибо оно написано кровью многих хороших 1Сников.

Будет слишком коротко, и все до одного напишут "и чо?". А вот если размазать на пару абзацев с запросами... то сразу найдутся те кто напишут "для начинающих самое то!" Вон некоторым, что бы это осознать вообще надо несколько лет качественной разработки. Про курс валют, соглашусь с (17), ни в коем случае не открывай модуль приложения в торговле. Вдруг там за тебя че нить уже оптимизировали.
22. Роман Уничкин (unichkin) 22.09.16 21:06
А вот этого лучше не делать:
тзРеквизитовНоменклатуры = Запрос.Выполнить().Выгрузить();

Причем "не делать" в двух частях.
1) Выборка к оперативке более лояльна чем тз, и для обработки результата (тем более при проведении) лучше использовать именно выборку. Еще у нее есть метод "НайтиСледующий()" - это если тз нужна была для поиска.
2) Для себя давно уже сделал аксиомой писать не "Запрос.Выполнить().Выбрать()" или "Запрос.Выполнить().Выгрузить()", а "РезультатЗапроса = Запрос.Выполнить(); Выборка = РезультатЗапроса.Выгрузить()" - чтобы удобнее в отладчике работать.
_
Запрос.Параметры.Вставить("МассивНоменклатуры", Товары.ВыгрузитьКолонку("Номенклатура")); 

- и это, я думаю - лишние накладные расходы. Можно передать в запрос ссылку, и отобрать необходимые данные табл. части.
Evil Beaver; +1 Ответить 2
23. Роман Уничкин (unichkin) 22.09.16 21:11
(19) ivanov660, не всегда хорошо формулы выносить в запрос. имхо - этого как раз нужно избегать, применяя только там где совсем никак без них не обойтись. Запрос - инструмент сбора данных, а не обработки. Формулы усложняют чтение, и в запросе их нельзя отладить. Лучше потратить 5 копеек производительности, и иметь возможность отладки формулы в читабельном коде.
eugeniezheludkov; +1 Ответить 2
24. Галахад (dmt) 23.09.16 04:03
(22) unichkin,
1. А как быстрее? Там в таблице индекс для скорости добавлен.
2. Документ не обязательно записан - из ссылки брать не чего.
25. Евгений Ванжула (minimajack) 23.09.16 08:03
(23) unichkin, Очень спорное предложение...
ИМХО лучше переложить по максимуму в запрос, чем вычислять ручными операциями
26. Сан Саныч (herfis) 23.09.16 09:17
(23) (25) Есть простой критерий.
Если разница производительности несущественна, то руководствоваться нужно соображениями читабельности и удобства сопровождения.
Иногда удобно так, иногда - эдак.
Если формулы простые и понятные, то глупо ради их расчета прикручивать дополнительный этап постобработки.
И наоборот, если постобработка и так уже есть по какой-то причине, а расчетные формулы сложные, то глупо их расчет запихивать в запрос ради выигрыша пары миллисекунд.
unichkin; Artem-B; mrflatcher; корум; +4 Ответить
27. DenisCh Гейтс (DenisCh) 23.09.16 09:22
(22) unichkin,
Выборка к оперативке более лояльна чем тз


На клиенте да. Но вот на sql-сервере... Там же курсор открывается и висит...
28. Евгений (Ekovichev) 23.09.16 14:02
1. В первом случае умножаем в запросе и не парим мозг;
2. Во втором случае кэширование в таблице значений неоптимально из-за медленного поиска. Следует использовать соответствие, где Ключ = Валюта, Значение = соответствие (Ключ = Дата, Значение = Структура("Курс, Кратность",...).

Функция ПолучитьКурсВалюты(Валюта, ДатаКурса, СтруктураКэш = Неопределено) Экспорт
	
	// добавили тут
	лкДата = ?(ДатаКурса = Дата('00010101'),ТекущаяДата(),ДатаКурса);
	
	Если СтруктураКЭШ = Неопределено Тогда
		СтруктураКэш = Новый Соответствие;
	КонецЕсли;
		
	Попытка                                     			
		Если СтруктураКэш[Валюта][ДатаКурса] = Неопределено Тогда ВызватьИсключение(""); КонецЕсли;				
		Возврат СтруктураКэш[Валюта][ДатаКурса];    		
	Исключение
		ДобавитьСрезВалютыВКЭШ(СтруктураКэш, Валюта, лкДата);
		Возврат СтруктураКэш[Валюта][ДатаКурса];
	КонецПопытки; 	                                
	
КонецФункции // ПолучитьКурсВалюты()

Функция ДобавитьСрезВалютыВКЭШ(СтруктураКэш, Валюта, лкДата)
	
	Структура = РегистрыСведений.КурсыВалют.ПолучитьПоследнее(лкДата, Новый Структура("Валюта", Валюта));	
	Если СтруктураКэш[Валюта] = Неопределено Тогда
		СтруктураСрезКурсаНаДату = Новый Соответствие
		СтруктураСрезКурсаНаДату[лкДата] = Структура;
		СтруктураКэш[Валюта] = СтруктураСрезКурсаНаДату;
	Иначе
		СтруктураКэш[Валюта][лкДата] = Структура;
	КонецЕсли;
	
КонецФункции
...Показать Скрыть


Писал на коленке, торговли нет проверять. Посмотрите метод с курсом и если он быстрее то вставьте его в статью. Новичкам это сэкономит еще больше времени:)
29. Роман Уничкин (unichkin) 23.09.16 22:19
(27) DenisCh, "на sql-сервере... Там же курсор открывается и висит..." - таких глубоких познаний sql у меня нет:) Мой подход прост: при разработке нужно следовать ИТС, если тормоза\тупняки - начинать изобретать. Имхо в контексте данной публикации говорить такое - опасно для неопытной публики)) Для такого обсуждения лучше подошел бы 1С++ или миста.
(24) dmt,
1) Не обязательно будет быстрее, но оперативки будет жрать меньше. Я уже ответил как: использовать выборку и метод "НайтиСледующий()"
2) В статье речь о проведении документа вроде-бы? При проведении он записан 100% :) Если зачем-то перед записью это делать то да... Но лучше все-же сперва подумать. Особенно, если есть многостраничные доки.

з.ы. ИТС: Оптимизация использования оперативной памяти
30. Роман Семенов (roma_semenov79) 23.09.16 22:59
Для типовых бухгалтерий и ЗуПов все это ведь малоактуально. До первого обновления такая оптимизация.
31. Сергей Носков (Sergey.Noskov) 26.09.16 17:36
(1) pbazeliuk,
>>Номенклатура.Ссылка В (&МассивНоменклатуры)
Для небольших массивов имеет право на жизнь, но для больших лучше предварительно поместить во временную таблицу и в следующем запросе выполнить отсечение.
а вот тут спорно, если массив более 128 элементов, платформа сама переделает на временную таблицу, лучше, по возможности, просто передать ссылку
32. DenisCh Гейтс (DenisCh) 26.09.16 17:39
(29) unichkin,
Для такого обсуждения лучше подошел бы 1С++ или миста.


На 1с++ это и так знают, а миста - это скопище ненатуралов. Тут намного более профессиональный форум.
artbear; Evil Beaver; +2 Ответить 1
33. Сергей Носков (Sergey.Noskov) 26.09.16 18:02
"в ИТС, конечно, написано, но кто ж его читает"(с) Поэтому автор правильно сделал, напоминать об этом периодически надо.
(2) utyv, не понятное сравнение запросов с фильтрацией по массиву и по временной таблице. Если бы в последнем запросе так же была передача именно массива, то мы увидим эффект именно от временной таблицы, точнее увидели бы, что стало хуже т.к. весь профит (200мс VS 70мс) получен из-за передачи ссылки а не от использования ВТ.
Если просто передать в запрос ссылку без временных таблиц
ВЫБРАТЬ РАЗЛИЧНЫЕ
	ВЫРАЗИТЬ(ЗаказПокупателяСтруктураИзделияТЧ.Номенклатура КАК Справочник.Номенклатура) КАК Номенклатура,
	ВЫРАЗИТЬ(ЗаказПокупателяСтруктураИзделияТЧ.Номенклатура КАК Справочник.Номенклатура).Артикул КАК Артикул
ИЗ
	Документ.ЗаказПокупателя.СтруктураИзделияТЧ КАК ЗаказПокупателяСтруктураИзделияТЧ
ГДЕ
	ЗаказПокупателяСтруктураИзделияТЧ.Ссылка = &Ссылка
...Показать Скрыть
то будет еще быстрее.
Evil Beaver; +1 Ответить
34. Андрей Овсянкин (Evil Beaver) 26.09.16 19:39
(27) DenisCh,
на sql-сервере... Там же курсор открывается и висит...


Насколько я знаю, сотрудники 1С отвечали, что нет никакого курсора. Выборка вся размещается в памяти сервера приложений 1С, несмотря на "Следующий()". Курсорные (вернее, порционные) запросы на больших объемах предлагают реализовывать самостоятельно.
35. Сан Саныч (herfis) 27.09.16 09:35
(34) Evil Beaver,
Выборка вся размещается в памяти сервера приложений 1С, несмотря на "Следующий()"

Да ладно. На ИТС прямым текстом говорится о блочном считывании (как для динамических списков) и о связанных с этим особенностях.
Курсоров в самом деле вроде нет (в 7.7 кажись использовались), на 8-ке реализовали свой механизм "скользящих" выборок на обычных запросах. В основном из соображений кроссплатформенности, как я понимаю.
36. Сан Саныч (herfis) 27.09.16 09:40
Хотя, пожалуй, я гоню. К выборке результата запроса это скорее всего не относится...
37. Сан Саныч (herfis) 27.09.16 09:43
(32) DenisCh, А 1С++ это хде? :)
Я только сайт проекта знаю...
38. Андрей Овсянкин (Evil Beaver) 28.09.16 14:08
(35) herfis, блочное (а если точнее - интервальное) считывание есть ТОЛЬКО в дин. списках. И отборы интервалов строит сама платформа, можно видеть в профайлере SQL, например.

В обычных пользовательских запросов интервальности нет. Хотя, я, возможно, чего-то не видел.
40. Сан Саныч (herfis) 28.09.16 15:05
(38) Evil Beaver, Да, я уже скумекал. Но не только в дин-списках, еще в тех выборках которые объектные. Они по тому же принципу. А в выборках результата запроса - нет. Но оно и понятно, если подумать. Интервальный просмотр с предсказуемой производительностью только по индексу можно сделать. Хотя вот в динамических списках с произвольным текстом запроса - таки делают. Но там и производительность ровно такая, насколько сложна выборка и насколько она ложится на индексы основной таблицы. В запросах такого даром не надо. Во-первых, интервальный просмотр данных БД никак не сочитается с транзакционностью, во-вторых он на сложных выборках будет тормозить вообще пипец как.
(39) Зашел, посмотрел на активность, почтил память.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа