gifts2017

Использование поля Код в Платежном поручении для своих целей

Опубликовал Дмитрий Жиляков (Zhilyakovdr) в раздел Программирование - Практика программирования

Хочу поделиться небольшой доработкой, которая может упростить работу с банковскими выписками и не только.

Думаю, все мы совершаем платежи в бюджет, например, такие как штрафы. С недавних пор (уже года два) для идентификации наших оплат в БД государство используются УИНы, это 25-значные последовательности из букв и цифр, позволяющие идентифицировать платеж (КЭП)))). 1С дала нам возможность использовать в своих типовых решениях это поле в своих целях, т.е. по сути мы можем уместить в эти 25 символов любой набор информации. 

Для чего нам это может быть нужно? Все ограничено вашей фантазией и необходимостью, например, я записываю в это поле "ссылку" на платежное поручение при оплате, это нужно, чтобы при получении оплаты другим нашим юр. лицом всю цепочку соответствующих документов можно было создать автоматически. Тот же подход использован при формировании счета на оплату. Если клиент хочет, чтобы его оплата была обработана как можно быстрее, он обязательно укажет этот идентификатор, и система сама сможет его разнести по системе. Думаю, к этому моменту уже многие догадались, что далее будет описан вариант алгоритма запаковки нужных данных в поле длиной лишь 25 символов.

Как я писал выше, в моем случае нужные данные это ссылка на платежное поручение или заказ.

Для этого понадобится 4 простых функции:

Функция ПолучитьИдентификаторПлатежаПоСсылке(Ссылка) Экспорт
	
	guid	= Ссылка.УникальныйИдентификатор();
	с10		= Из_Любой_В_10(стрЗаменить(guid,"-",""), 16);
	
	Возврат Из_10_В_Любую(с10, 36);

КонецФункции // ПолучитьИдентификаторПлатежа()

Функция ПолучитьПлатежноеПоручениеПоИдентификатору(с36) Экспорт
	
	попытка
 
		Если СтрДлина(с36) < 24 тогда возврат Документы.ПлатежноеПоручение.ПустаяСсылка(); КонецЕсли;
		
		с10	= Из_Любой_В_10(с36, 36);
		с16	= Из_10_В_Любую(с10, 16);
		//Проверяем, нужен ли лидирующий ноль
		Если СтрДлина(с36) = 24 тогда
			с16	= "0" + с16;
		КонецЕсли;
		мас	= новый массив;
		мас.добавить(сред(с16,1,8));
		мас.добавить(сред(с16,9,4));
		мас.добавить(сред(с16,13,4));
		мас.добавить(сред(с16,17,4));
		мас.добавить(сред(с16,21));
		стргуид	= нрег(стрсоединить(мас,"-"));
		
		
		НовыйGUID	= Новый УникальныйИдентификатор(стргуид);
		
		СсылканаПП	= Документы.ПлатежноеПоручение.ПолучитьСсылку(НовыйGUID);
		
		Возврат СсылканаПП;
		
	Исключение
		возврат Документы.ПлатежноеПоручение.ПустаяСсылка();
	КонецПопытки;	
	
КонецФункции 

Функция Из_10_В_Любую(Знач Значение=0,Нотация=36) Экспорт
	
	Если Нотация <= 0 Тогда Возврат("")		КонецЕсли;	
	Значение	= Число(Значение);
	Если Значение <=0 Тогда Возврат("0")	КонецЕсли; 
	набор		= "0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ";
	Значение	= Цел(Значение);
	Результат	= "";
	Пока Значение > 0 Цикл
		Результат	= Сред(набор, Значение % Нотация + 1, 1) + Результат;
		Значение	= Цел(Значение / Нотация) ;
	КонецЦикла;
	
	Возврат Результат;
	
КонецФункции

Функция Из_Любой_В_10(Знач Значение = "0", Нотация = 36) Экспорт
	
	Если Нотация <= 0	Тогда Возврат(0) КонецЕсли;
	Значение	= СокрЛП(Значение);
	Если Значение = "0" Тогда Возврат(0) КонецЕсли;
	набор		= "0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ";
	Результат	= 0;
	Длина		= СтрДлина(Значение);
	Для н = 1 По Длина Цикл
		символ		= найти(Набор, Врег(сред(Значение, н, 1))) - 1;
		сумма		= число(символ) * Pow(Нотация, Длина - н);
		Результат	= Результат + сумма;
	КонецЦикла;
	
	Возврат Окр(Результат);
	
КонецФункции

Использовать достаточно просто, при вызове функции ПолучитьИдентификаторПлатежаПоСсылке(Ссылка), где ссылка - это ссылка на любой объект ее имеющий, мы получаем нашу ссылку, свернутую до 25 символов, при вызове функции ПолучитьПлатежноеПоручениеПоИдентификатору(с36), где с36 - это строка из 25 символов полученная предыдущей функцией, мы получаем ссылку на объект, в данном случае это ПП.

На этом все, надеюсь, информация, изложенная в этой мини статье, будет полезна не только мне.

п.с. Предложения и замечания приветствуются.

См. также

Подписаться Добавить вознаграждение
В этой теме еще нет сообщений.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа