gifts2017

Удаление документа из-под самого себя

Опубликовал Аркадий Кучер (Abadonna) в раздел Программирование - Практика программирования

По ряду причин потребовалось проверить позицию нового документа и в случае определенных условий удалить его из базы. Понятно, что ПолучитьПозицию() для незаписанного документа нельзя.
Поэтому сначала его необходимо записать, а потом при определенных условиях "замочить"
Реализация:
В документе в процедуре ПриЗакрытии() по нужным нам условиям вызываем обработку
ОткрытьФорму("Отчет",ТекущийДокумент(),КаталогИБ()+"ExtForms\УдалитьДок.ert");

//Сама обработка УдалитьДок:
Процедура УдалитьДок()
// таймер выключили

Форма.ОбработкаОжидания("УдалитьДок",0);  
	

//зверски удаляем документ 

Док=СоздатьОбъект("Документ");         

Док.НайтиДокумент(Форма.Параметр); Док.Удалить(0);
Форма.Закрыть();

КонецПроцедуры

ПроцедураПриОткрытии()

Если  ПустоеЗначение(Форма.Параметр)=1 Тогда 

Форма.Закрыть();
	

КонецЕсли;                 
	// дадим вызывающему документу время закрыться (разблокироваться), 1 секунда 

Форма.ОбработкаОжидания("УдалитьДок",1);  
//СтатусВозврата(0) к сожалению ставить нельзя, // не пройдет ОбработкаОжидания (придется форму наблюдать на время удаления) 
КонецПроцедуры 

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Епрст (Ёпрст) 09.10.08 14:24
2. Аркадий Кучер (Abadonna) 09.10.08 14:25
(1) Ну я не спорю, что можно. На мисте я б искал час минимум, набросал за 5 минут ;)
3. Епрст (Ёпрст) 09.10.08 14:26
И еще... В сабже говорите о Не записаном документе, а потом вот это ??
ОткрытьФорму("Отчет",ТекущийДокумент(), // ТекущийДокумент() - для незаписанного ничего не даст.
4. Аркадий Кучер (Abadonna) 09.10.08 14:28
(3)Читай внимательно: "Понятно, что ПолучитьПозицию() для незаписанного документа нельзя", что означает, что для получения позиции я его именно записываю
А уж потом мочу в зависимости от результата ПолучитьПозицию()
5. Епрст (Ёпрст) 09.10.08 14:29
(4) В сабже как-то мутно написано :))
6. Аркадий Кучер (Abadonna) 09.10.08 14:30
(5) Щас подправлю чуток :)))
7. Епрст (Ёпрст) 09.10.08 14:31
Вот еще хороший приём для обхода блокировок, очень красиво :
http://www.sinor.ru/%7Emy1c/knowhow/skpblock.html

8. Аркадий Кучер (Abadonna) 09.10.08 14:34
По мне ОбработкаОжидания, которая отрабатывает всего один раз - самое то. Я и для других целей ее активно использую. До появления замечательной Формекс использовал как процедуру ПослеОткрытия()
9. Епрст (Ёпрст) 09.10.08 14:38
(8) Я тоже видел удивление в глазах юзверей, когда они открывают модальные окошки и после их закрытия исчезают доки в журнале :))
10. VasilyKushnir (vasilykushnir) 09.10.08 14:53
11. Епрст (Ёпрст) 09.10.08 15:01
Чем плохи эти методы - мелкание формы обработки ... :(
12. Аркадий Кучер (Abadonna) 09.10.08 15:02
(11)На форме как раз напишу что-то типа "Ты, юзверь, лоханулся, поэтому документик почикаем " ;)))
13. Михаил Семенов (Shaman100M) 09.10.08 15:36
Ну, можно и без Обработки ожидания

Код
Процедура   ПриЗакрытии() //УдалитьДок()   
   Если ПустоеЗначение(Форма.Параметр)=0 Тогда
     Док=СоздатьОбъект("Документ");         
     Док.НайтиДокумент(Форма.Параметр);
     Док.Удалить(0); 
   КонецЕсли;
КонецПроцедуры

Процедура ПриОткрытии()   
  Форма.Закрыть();
КонецПроцедуры
Показать полностью


Выложил по старой памяти, требует проверки.
14. Аркадий Кучер (Abadonna) 09.10.08 15:40
>Выложил по старой памяти, требует проверки.
Проверил. При вводе нового Дока сразу модальное окошко "Сохранить документ?":(
15. Аркадий Кучер (Abadonna) 09.10.08 15:49
Кстати, в моем конкретно случае появление окошка обработки как раз кстати - оно мне вместо Предупреждение отработает с соответствующей надписью
16. Михаил Семенов (Shaman100M) 09.10.08 15:52
(14) это текст открываемой обработки. Судя по вопросу "Сохранить документ?", проверялось в форме документа.
17. Аркадий Кучер (Abadonna) 09.10.08 15:56
(16) Проверю. Успеет ли док разблокироваться? Так я ему цельную секунду давал.. Тем более там в ПриЗакрытии хрен его знает что еще может выполняться
18. Епрст (Ёпрст) 09.10.08 15:59
(14) спасёт положение вот это:
Процедура ПриОткрытии()
Форма.Закрыть(0);
КонецПроцедуры
19. Епрст (Ёпрст) 09.10.08 16:00
(17) нормально там всё будет, только вот мелькание окошка :(
20. Михаил Семенов (Shaman100M) 09.10.08 16:03
+(16) проверил, - работает. И обработка не мелькает. :)
21. Аркадий Кучер (Abadonna) 09.10.08 16:04
22. Михаил Семенов (Shaman100M) 09.10.08 16:05
Все же мелькает, но совсем чуть чуть.
23. Епрст (Ёпрст) 09.10.08 16:09
(22) это и есть способ в (1) ...всё старо как мир :)
24. Аркадий Кучер (Abadonna) 09.10.08 16:15
Короче, мен все равно надо юзверя попугать/информировать. Так что оставлю ОбработкуОжидания, еще и время увеличу секунд до 3-х ;)
25. Михаил Семенов (Shaman100M) 09.10.08 16:17
(23) почитал (1). Уж больно мудрено, открываем обработку, обработка закрывает документ, документ закрывает обработку, обработка в ПриЗакрытии() уже выполняет все что надо. Хотя, главное действие делается в ПриЗакрытии() в модуле обработки в обоих случаях, (13) проще, - просто при закрытии документ открывает обработку, а она уж сама далее...
26. Аркадий Кучер (Abadonna) 09.10.08 16:19
(25) И я того же мнения ;) Моего-то кода тут 2 строчки ;) А ОбработкаОжидания - дело вкуса. Ставил на всяк случай, чтобы уж ЖЕЛЕЗНО док успел закрыться
27. Епрст (Ёпрст) 09.10.08 16:22
(25) Там тот же принцип один в один... просто там меняют Дату/время/ и т.д
28. Аркадий Кучер (Abadonna) 09.10.08 16:31
(20) Кстати, форма торчит все время пока происходит удаление документа (Док.Удалить). А на приличных доках, двигающих регистры, и с многими строками (ЗаявкаПокупателя, например) происходит далеко не мелькание, а конкретное присутствие формы.
Так что несчастная ОбработкаОжидания в секунду там погоды не делает
29. Артур Аюханов (artbear) 10.10.08 07:19
ИМХО для проверки точного закрытия документа нужно юзать Блокировка(), а уж только потом пытаться закрывать документ.
В этом случае мы не зависим от времени отработки закрытия документа.
30. Артур Аюханов (artbear) 10.10.08 07:21
А вот если юзать ВК ФормЕкс, то возможно сделать закрытие без открытия/мелькания формы :)
Сервис::ОбработкаОжидания или Таймер помогут.
ЗЫ это для тех, кто не боится юзать сторонние и проверенные в бою внешние компоненты.
31. Артур Аюханов (artbear) 10.10.08 07:22
(29+) Чуть опечатался :(
"а уж только потом пытаться закрывать документ" читать как "а уж только потом пытаться удалять документ"
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа