gifts2017

Демонстрация быстрого поиска(отбора) в справочнике (1sqlite)

Опубликовал Romarius (Romarius) в раздел Программирование - Практика программирования

Представляю к вниманию, каким образом возможно организовать быстрый поиск с отбором в справочниках (аналог быстрых отборов в 1С 8.1) с использованием 1sqlite

При реализации использовал следуюющие компоненты:
1C++ (версия 3.0.1.22)
FormEx (2.0.5.95)
1sqlite.dll (1.0.2)

За основу был взят алгоритм поиска Александра Орефкова с использованием 1sqlite

 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Быстрый поиск с отбором
.rar 8,55Kb
13.11.09
192
.rar 8,55Kb 192 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Епрст (Ёпрст) 29.09.09 22:21
Оригинально конечно, использовать ТП для этих целей..
Но выглядит как-то кривовато..
за счет быстрого поиска в самом ТП.
2. Епрст (Ёпрст) 29.09.09 22:22
Да и ИспользоватьСписокЭлементов не самый быстрый метод..
3. Алексей Башта (bashta.aleksey) 29.09.09 22:46
Кинь ссылочку на "алгоритм поиска Александра Орефкова" если есть
4. Александр (sashas09) 30.09.09 01:32
5. Алексей (alexqc) 30.09.09 09:30
(2) Раз "не самый быстрый метод" значит есть альтернативы? Побыстрее? Можете поделиться?
6. Епрст (Ёпрст) 30.09.09 09:33
(5) ну вот, например, можете у Олега посмотреть:
http://rikcenter.ru/solutions.php
http://rikcenter.ru/download/Demo_RiK.rar

там всё на Табличном поле сделано..
Или сюда еще:
http://www.1cpp.ru/forum/YaBB.pl?num=1248941896
7. Romarius (Romarius) 30.09.09 11:36
Вообщем отбор работает довольно быстро. Идея была такова - сделать с небольшими изменениями справочника быстрый отбор. Создавалось для поиска нужных контрагентов, которые разбросаны по разным папкам, по части наименований. Если ктото протестирует на больших справочниках и выскажет свое мнение на счет быстроты работы, буду благодарен.
8. Алексей (alexqc) 30.09.09 12:24
(6) Ну, то ТП, я думал есть вариант обычного отбора...
А вот за ссылку на супер-поставщик данных спасибо :), будем посмотреть.
Давненько я на форум 1С++ не заглядывал
9. rasswet (rasswet) 05.10.09 09:56
м.. у меня филиалов много им к сожалению три вк установить..так проще вообще не начинать, но разработка кому-то конечно пригодится.
10. 62chma 19.12.11 10:20
Спасибо ! Поставил у "себя" - менеджеры в восторге.
11. FIZIK FIZIK (FIZIK) 10.01.12 00:16
Класс, с такими фишками и восьмерка ненужна.
13. znh (znh) 28.02.12 15:08
При сложном поиске например "Привет Вася" ошибка near "descr": syntax error
Переделал
Для Индекс=1 По СтрКоличествоСтрок(РазбиваемаяСтрока) Цикл
Слово=СтрПолучитьСтроку(РазбиваемаяСтрока,Индекс);
Если ПустоеЗначение(Слово)=0 Тогда
//текст=текст+" descr LIKE '%"+Слово+"%'";
Если Индекс=1 Тогда
Стр_Слова = "'%"+Слово+"%'";
ИначеЕсли Индекс>1 Тогда
Стр_Слова = Лев(Стр_Слова,СтрДлина(Стр_Слова)-1) + "%"+Слово+"%'"; //Убираем символ "'"
КонецЕсли;

КонецЕсли;
КонецЦикла;
текст=текст+" descr LIKE "+ Стр_Слова;
14. Romarius (Romarius) 20.03.12 15:29
(13) znh, Очень странно, я очень часто делаю поиск по нескольким словам, ошибки никогда не выскакивала.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа