gifts2017

Редактор журнала зарплата

Опубликовал Сергей Ломоносов (djserega) в раздел Программирование - Инструментарий

Любые изменения в журнале зарплата за любой период времени, без пересчетов, добавление и удаление записи в любом периоде, подмена родительского документа, редактирование атрибутов, а также выполнение групповых изменений.

Очень полезная обработка для исправления программных и пользовательских глюков за предыдущие периоды по сотруднику или по всем записям с фильтром. Редактирование всех реквизитов журнала зарплата (объекта, вида расчета, документа, дат начала и окончания, результата и всех признаков записи: исправлена вручную, рассчитана, сторно, зафиксирована), добавление и удаление записей в любом периоде.

Обработкой пользоваться аккуратно, т.к. изменения не обратимы (рассчетчикам не давать!)

Скачать файлы

Наименование Файл Версия Размер
Редактор ЖЗ 263
.ert 240,50Kb
08.10.12
263
.ert 240,50Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. 1Bonya (bonya_by) 09.10.09 14:57
Чтобы заработало в белорусской Юколе нужно добавить в начало
Перем глСпрВидыРасчетов;
Перем ТаблицаОткрытыхФорм;

Эти функции
Функция глПолучитьТекущегоСотрудника() Экспорт
	
	Для Номер = -ТаблицаОткрытыхФорм.КоличествоСтрок() по -1 Цикл
		ТаблицаОткрытыхФорм.ПолучитьСтрокуПоНомеру(-Номер);
		Если ПустоеЗначение(ТаблицаОткрытыхФорм.КонтекстФормы)=1 Тогда
			ТаблицаОткрытыхФорм.УдалитьСтроку(-Номер);
		Иначе
			КонтекстФормы = ТаблицаОткрытыхФорм.КонтекстФормы;
			Попытка
				ВидФормы=КонтекстФормы.Вид();
			Исключение
				Продолжить
			КонецПопытки;
			Если ВидФормы="Сотрудники" Тогда
				Если КонтекстФормы.ЭтоГруппа()=0 Тогда
					Если ПустоеЗначение(КонтекстФормы.ТекущийЭлемент())=0 Тогда
						Возврат КонтекстФормы.ТекущийЭлемент()
					КонецЕсли;
				КонецЕсли;
			ИначеЕсли (ВидФормы="Зарплата")
				  или (ВидФормы="Дополнительный") Тогда
				Если ПустоеЗначение(КонтекстФормы.Объект)=0 Тогда
					Возврат КонтекстФормы.Объект
				КонецЕсли;
			КонецЕсли;
		КонецЕсли;
	КонецЦикла;
	Возврат ПолучитьПустоеЗначение("Справочник.Сотрудники")
	
КонецФункции	// глПолучитьТекущегоСотрудника

Функция глСменитьПериод(ДатаАктуальности,Направление=0) Экспорт
	ЖР = СоздатьОбъект("ЖурналРасчетов.Зарплата");
	Если ТипЗначения(ДатаАктуальности)<>3 Тогда
		ДатаАктуальности = ЖР.КонецТекущегоПериода()
	КонецЕсли;
	Если Направление=1 Тогда
		ДатаАктуальности = ЖР.КонецПериодаПоДате(ЖР.КонецПериодаПоДате(ДатаАктуальности)+1)
	ИначеЕсли Направление=-1 Тогда
		ДатаАктуальности = ЖР.НачалоПериодаПоДате(ДатаАктуальности)-1
	КонецЕсли;
	Возврат ЖР.ОписательПериода(ДатаАктуальности)
КонецФункции	// глСменитьПериод  

Функция глПредставлениеВидаРасчета(ПарамВидРасчета) Экспорт

	Если ПустоеЗначение(ПарамВидРасчета) = 1 Тогда
		Возврат "";
	КонецЕсли;
	Если ТипЗначения(ПарамВидРасчета) <> 14 Тогда
		Возврат "";
	КонецЕсли;
	
	// возможно, названия в.р. могут быть и в документе

	Если глСпрВидыРасчетов.НайтиПоРеквизиту("Расчет",ПарамВидРасчета,1) = 1 Тогда
		Если ПустоеЗначение(глСпрВидыРасчетов.Наименование) = 0 Тогда
			Возврат глСпрВидыРасчетов.Наименование
		КонецЕсли;
	КонецЕсли;
	Возврат Метаданные.ВидРасчета(ПарамВидРасчета.Код).Представление()

КонецФункции // глПредставлениеВидаРасчета 
...Показать Скрыть


Это в самый конец
глСпрВидыРасчетов		= СоздатьОбъект("Справочник.ВидыРасчетов");
ТаблицаОткрытыхФорм = СоздатьОбъект("ТаблицаЗначений");
ТаблицаОткрытыхФорм.НоваяКолонка("Значение");
ТаблицаОткрытыхФорм.НоваяКолонка("КонтекстФормы");

И еще закоментировать это
//вНомерСтрокиДокумента=ТЗ.Запись.НомерСтрокиДокумента;
//вСтрокаИсправления=ТЗ.Запись.СтрокаИсправления;


Буду смотреть дальше. Полезная обработка можно править записи с выплатами :)
Nicholas; +1 Ответить
2. Александр Рытов (Арчибальд) 09.10.09 15:46
Мож таки не "...журнала зарлата", а "...журнала. Заплата" ;)
djserega; +1 Ответить
3. Александр Рытов (Арчибальд) 09.10.09 15:48
Однако ж поддержу. Борьба с зарплатой - дело нелегкое 8)
Nicholas; +1 Ответить
4. Сергей Ломоносов (djserega) 09.10.09 17:42
:) Извиняюсь набирал левой ногой, поторопился...
5. NPMar (NPMar) 10.10.12 10:48
Да, очень жаль, что раньше не встретилась подобная обработка. А сейчас мы собираемся переходить на восьмерку. А иногда такая необходимость бывает ...
6. NPMar (NPMar) 10.10.12 10:54
Все очень понравилось, наверное, скачаю все-таки. Сейчас конец года скоро. Наверняка вылезет какая-нибудь бяка. Эх раньше бы... Все равно спасибо большое!
7. Сергей Ломоносов (djserega) 10.10.12 15:51
Она и раньше была с 2004г.: сначала на про-клуб 1С, затем сюда выложил
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа