gifts2017

Работаем с пропускной системой Perco прямо из 1С

Опубликовал Ugu (ge_ni) в раздел Программирование - Внешние компоненты

Система работы с карточками пропусков достаточно распространена.
Зачастую приходится пользоваться некими выгрузками из этой системы, но можно работать и напрямую.
Данная обработка посвящена именно этому.

В первую очередь огромное спасибо автору библиотеки Bdebase.dll BioAngel
http://www.infostart.ru/public/14148/
 
 Библиотеку Bdebase.dll необходимо скопировать либо в каталог программы,  либо в ExtForms, либо в каталог базы данных.
 Если обработка выдаст отсутствие библиотеки - придется ее регистрировать  классическим методом:

Перем БДЕ Экспорт;
 ....................
 ....................
Попытка БДЕ = СоздатьОбъект("Addin.BDEBase");
Исключение
    Если ЗагрузитьВнешнююКомпоненту(КаталогИБ() + "Bdebase.dll") <> 1 Тогда
        Если ЗагрузитьВнешнююКомпоненту(КаталогИБ() + "ExtForms\" + "Bdebase.dll") <> 1 Тогда  
            Если ЗагрузитьВнешнююКомпоненту(КаталогПрограммы() + "Bdebase.dll") <> 1 Тогда
                Сообщить("> Отказано в запуске обработки","!");
                Сообщить("> Не найдена компонента Bdebase.dll (работа с внешними DB файлами)...","!");
                СтатусВозврата(0);
                Возврат;
            КонецЕсли; 
        КонецЕсли;
    КонецЕсли;
    БДЕ = СоздатьОбъект("Addin.BDEBase");
КонецПопытки;

Поместите этот текст в процедуру ПриНачалеРаботыСистемы()
Теперь собственно о работе:

  1. Для защиты пропускной системы от блокировки создайте командный файл или скопируйте вручную из каталога Perco файлы STAFF.DB,STAFF.МB - это файлы списка сотрудников (копировать только вместе)и файл EVENTS.DB - это файл списка событий, в удобный для Вас каталог.
  2. Запустите обработку ПеркоОпер.ert.
  3. На закладке "Основной" выберите дату обработки событий.
  4. На закладке "Основной" выберите имя реквизита справочника Сотрудники 1С:Предприятия, содержащего табельный номер сотрудников (по умолчанию выбирается Код).
  5. На закладке "Сотрудники" выберите файл, из скопированных Вами баз данных сотрудников в системе Perco STAFF.DB.
  6. На закладке "События" выберите файл, из скопированных Вами баз данных EVENTS.DB.
  7. Таблицы значений будут заполнены данными из скопированных Вами баз данных Perco.
  8. Вернитесь на первую закладку "Основной" и нажмите кнопку "Сформировать".

Вся информация будет представлена в таблице на этой закладке.

  • Столбец "П" - количество событий прихода
  • Столбец "У" - количество событий ухода
  • Столбец "Секунды" - суммарное время отработанное в секундах
  • Столбец "Часы" - суммарное время отработанное в часах(минуты через точку).

Есть возможность загрузить таблицу событий по фильтру "Сотрудник" и просмотреть посещаемость по конкретному сотруднику:"Сотрудник" -> ...закладка "События"... -> выбрать EVENTS.DB -> ...закладка "Основной"... -> "Сформировать".

Если Структура документа "Табель" соответствует моей: Дни с 1 числа по 31 число месяца представлены реквизитами типа "Д1" .... "Д15" ...."Д31", тогда можно нажимать и на кнопку "Загрузить в табель", иначе исправьте процедуру выгрузки в Табель.

Не закрывая обработку устанавливаем на закладке "Основной" новую дату отбора, переходим на закладку "События", выбираем EVENTS.DB, переходим на закладку "Основной" и нажимаем на кнопку "Сформировать", грузим результаты в Табель. И так весь месяц, а можно только один день.

Приятной работы.

Скачать файлы

Наименование Файл Версия Размер
ПеркоОпер 146
.ert 262,50Kb
20.10.09
146
.ert 262,50Kb Бесплатно
Библиотека 136
.dll 764,00Kb
20.10.09
136
.dll 764,00Kb Бесплатно

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Vad Shevelev (VShevelev) 21.10.09 11:15
Обработку не смотрел, библиотечку не скачивал, плюсую только для моральной поддержки. У нас на фирме тож ставили мегасистему управления доступом, орлы внедрятели получили бабло, выставили счет еще на половину суммы и ушли в глухой отказ. Чуствую, пригодится твоя библтотечка!!! :D
2. guliver2003 (guliver2003) 21.10.09 11:25
С какой версией Perco работает?
3. Ugu (ge_ni) 21.10.09 12:12
К самой Perko меня не подпускают. Версию не знаю. Открыли доступ только к базам данных в режиме "Только чтение", вот и извлек... Работает система с 2007 года. Версию посчитайте сами. Был администратор, который работал с этой системой но его уволили :( :(
4. White (White__) 22.10.09 10:24
+ хорошая вещь! Жалко, что мне уже не надо... :|
5. Mark (mark_iz) 22.10.09 12:10
О-о-х, боюсь, пригодится. ПЛЮС.
6. Андрей Зайцев (zaic) 22.10.09 14:50
У нас PERCo-S-600, вариант с урезанными отчетами. Отчеты какие есть не очень удобны, а в одинэсе чего хочешь можно сделать, посмотрим. Посещаемость нам оттуда не вытащить, поскольку сидит охранница и от скуки всех пускает через турникет без пропуска. Но через турникет ходят сотрудники шести фирм, т.е. теоретически можно пользоваться сводной базой сотрудников этих фирм.
8. Ruzel (ruzelka) 03.12.09 15:14
Замечательная весч, а для какой конфы вы её используете?
9. Ugu (ge_ni) 09.12.09 16:08
К сожалению конфигурация с табелем специфической собственной разработки. Табель объединяет и задачу табеля и задачу графика, т.к. практически ни один из моих клиентов не поддерживает стандартный подход к графику :( Это значит "Пусть график будет как табель...". Сотрудник ходит по некоему произвольному графику, который можно фиксировать с использованием табеля, затем на основании табеля заполняется график и только после этого вносятся отклонения в табеле
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа