gifts2017

JSON в 1С

Опубликовал BigB (BigB) в раздел Программирование - Практика программирования

Функция для преобразования в JSON.
Функция JSON(Значение) Экспорт

    Разделитель="";
   
    ТипЗн=ТипЗнч(Значение);

    Если ТипЗн=Тип("Строка") Тогда
        Стр=""""+Маскировать(Значение)+""""

    ИначеЕсли ТипЗн=Тип("Число") ИЛИ ТипЗнч(Значение)=Тип("Булево") Тогда
        Стр=XMLСтрока(Значение)

    ИначеЕсли ТипЗн=Тип("Дата") Тогда
        Стр=""""+?(ЗначениеЗаполнено(Значение),XMLСтрока(Значение),"")+""""

    ИначеЕсли ТипЗн=Тип("Структура") Тогда
        Стр="{";
        Для Каждого Параметр Из Значение Цикл
            Стр=Стр+Разделитель+Символы.ПС+""""+Параметр.Ключ+""":"+JSON(Параметр.Значение);
            Разделитель=","
        КонецЦикла;
        Стр=Стр+Символы.ПС+"}";

    ИначеЕсли ТипЗн=Тип("Массив") Тогда
        Стр="[";
        Для Каждого Элемент Из Значение Цикл
            Стр=Стр+Разделитель+Символы.ПС+JSON(Элемент);
            Разделитель=","
        КонецЦикла;
        Стр=Стр+Символы.ПС+"]";

    ИначеЕсли ТипЗн=Тип("ТаблицаЗначений") Тогда
        Колонки=Значение.Колонки;
        Массив=Новый Массив;
        Для Каждого СтрокаТЗ Из Значение Цикл
            Структура=Новый Структура;
            Для Каждого Колонка Из Колонки Цикл
                Структура.Вставить(Колонка.Имя,СтрокаТЗ[Колонка.Имя])
            КонецЦикла;
            Массив.Добавить(Структура);
        КонецЦикла;
        Стр=JSON(Массив)

    ИначеЕсли Значение=Неопределено Тогда
        Стр="null"

    Иначе
        Стр=""""+Маскировать(Значение)+""""
    КонецЕсли;

    Возврат Стр
КонецФункции

Функция ФорматированныйJSON(Значение,Отступ="") Экспорт
    Разделитель="";
   
    ТипЗн=ТипЗнч(Значение);

    Если ТипЗн=Тип("Строка") Тогда
        Стр=""""+Маскировать(Значение)+""""

    ИначеЕсли ТипЗн=Тип("Число") ИЛИ ТипЗнч(Значение)=Тип("Булево") Тогда
        Стр=XMLСтрока(Значение)

    ИначеЕсли ТипЗн=Тип("Дата") Тогда
        Стр=""""+?(ЗначениеЗаполнено(Значение),XMLСтрока(Значение),"")+""""

    ИначеЕсли ТипЗн=Тип("Структура") Тогда
        Стр="{";
        Для Каждого Параметр Из Значение Цикл
            Стр=Стр+Разделитель+Символы.ПС+Отступ+""""+Параметр.Ключ+""":"+ФорматированныйJSON(Параметр.Значение,Отступ+Символы.Таб);
            Разделитель=","
        КонецЦикла;
        Стр=Стр+Символы.ПС+Отступ+"}";

    ИначеЕсли ТипЗн=Тип("Массив") Тогда
        Стр="[";
        Для Каждого Элемент Из Значение Цикл
            Стр=Стр+Разделитель+Символы.ПС+Отступ+ФорматированныйJSON(Элемент,Отступ);
            Разделитель=","
        КонецЦикла;
        Стр=Стр+Символы.ПС+Отступ+"]";

    ИначеЕсли ТипЗн=Тип("ТаблицаЗначений") Тогда
        Колонки=Значение.Колонки;
        Массив=Новый Массив;
        Для Каждого СтрокаТЗ Из Значение Цикл
            Структура=Новый Структура;
            Для Каждого Колонка Из Колонки Цикл
                Структура.Вставить(Колонка.Имя,СтрокаТЗ[Колонка.Имя])
            КонецЦикла;
            Массив.Добавить(Структура);
        КонецЦикла;
        Стр=ФорматированныйJSON(Массив)

    ИначеЕсли Значение=Неопределено Тогда
        Стр="null"

    Иначе
        Стр=""""+Маскировать(Значение)+""""
    КонецЕсли;

    Возврат Стр
КонецФункции

Функция Маскировать(Знач Стр)
    Стр=СтрЗаменить(Стр,Символы.ПС,"\n");
    Стр=СтрЗаменить(Стр,Символы.ВК,"\r");
    Стр=СтрЗаменить(Стр,"""","\""");
    Стр=СтрЗаменить(Стр,"'","\'");
    Возврат Стр
КонецФункции

Примеры вызовов функции JSON:

Структура=Новый Структура("sIP,sDefaultGateway,nNode,nRing");

ЗаполнитьЗначенияСвойств(Структура,Источник);
Структура.Вставить("Error",Новый Структура("Code,Description",0,"OK"));
Возврат JSON(Структура)

или так

Запрос=Новый Запрос("ВЫБРАТЬ * ИЗ Справочник.Абоненты");
Возврат JSON(Запрос.Выполнить().Выгрузить());

Просьба не пинать, так как это моя первая публикация.

См. также

Подписаться Добавить вознаграждение

Комментарии

1. dushelov (Душелов) 26.10.09 13:59
А почему ссылочные типы не сериализовать?
2. Трактор Трактор (Трактор) 26.10.09 14:06
Прикольно. И главное жизненно. Можно AJAJ делать без обточки в ПХП.
3. BigB (BigB) 26.10.09 14:14
(1) да как то не было надобности, но впринцепе можно сделать
4. Роман (PRoman) 27.10.09 10:37
а как обратно преобразовать?
5. BigB (BigB) 28.10.09 10:19
7. Евгений Шабалин (xzorkiix) 18.10.13 13:05
Спасибо, сберегло время на разборы.
8. Юрий Лазаренко (TitanLuchs) 11.04.14 16:44
Спасибо автору, сберег время
9. Сергей Карташев (Elisy) 28.11.14 08:01
По скорости, если кому-то интересно. Сериализация Json работает очень медленно по сравнению с XML-сериализацией.
Оптимизация делалась для веб-сайта http://www.oboi.kg
На данных из примерно 5 тысяч записей таблицы значений перевод в XML уменьшил время обработки со 120 секунд (2 минуты) до 4 секунд.
Трактор; +1 Ответить
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа