gifts2017

Анализ счета с фильтром BS

Опубликовал Сергей Бояновский (ZeBeR) в раздел Отчеты - Бухгалтерские

Анализа счета и оборотно-сальдовая ведомость по счету в одном флаконе.
Развороты по субсчетам, субконто, периодам (доки, дни...), корсчетам в различных комбинациях. Фильтр по корсчетам и корсубконто.

Это доработка одного старого отчета опубликованного в proclub, вот ссылка на исходник:

http://1c.proclub.ru/modules/mydownloads/personal.php?cid=5&lid=1060

Все доработки родились в процессе практической работы с отчетом. Т.е. это не сложно, но очень удобно. До появления "Интерактивной ОСВ"  этот отчет у меня был основным, так как заменяет практически все ходовые стандартные отчеты 1С.

По сравнению с оригиналом в отчет добавлены следующие возможности:

1. Фильтрация по кор.субконто

2. Возможность вывода количества и цены

3. Сортировка по коду

4. Возможность вывода кода элементов справочников

5. Возможность вывода представления субконто

6. Отлажены механизмы сохранения и восстановления формы отчета

7. Отлажены механизмы обновления, настройки отчета и перепроведения документов. Чтоб работали эти кнопки в печатной форме надо запускать отчет из ExtForms рабочей базы.

Скачать файлы

Наименование Файл Версия Размер
Внешний отчет "Анализ счета с фильтром BS" 314
.ert 124,00Kb
18.03.13
314
.ert 124,00Kb Бесплатно
"Анализ счета с фильтром BS" с разделителем 79
.ert 123,50Kb
18.03.13
79
.ert 123,50Kb Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Вячек Т (viacht) 04.11.09 10:30
Мне под украинский ПУб пришлось дорабатывать ручками, т.к. ругался:
РазделительУчета=БухИтоги<<?>>.ИспользоватьРазделительУчета();
{C:\РАБОЧИЙ СТОЛ\ANALIZ_SF_BSK.ERT(672)}: Переменная не определена (БухИтоги)
РазделительУчета=БухИтоги<<?>>.ИспользоватьРазделительУчета();
{C:\РАБОЧИЙ СТОЛ\ANALIZ_SF_BSK.ERT(957)}: Переменная не определена (БухИтоги)
2. Iosif Sedun (Ionik) 04.11.09 16:01
Работает...показывает...плюс
3. rasswet (rasswet) 05.11.09 11:17
ВидОтбора[3]=ВидОтбора3.ПолучитьЗначение(ИндексВидОтбора[3]);
{Z:ANALIZ_SF_BSK.ERT(231)}: Индекс не входит в границы списка значений.
пир открытии ругается на все три индекса.
4. Сергей Бояновский (ZeBeR) 05.11.09 11:35
(3) блин, думал, что убрал этот косяк, буду смотреть еще.
Он появляется только при первом открытии отчета в базе. Надо выбрать любой счет и виды отбора и закрыть форму. При повторном открытии этого не будет .
5. rasswet (rasswet) 05.11.09 13:43
(4) ещё жаль, что нет настройки по разделителю учета в форме...
6. Сергей Бояновский (ZeBeR) 05.11.09 14:07
(5) мне оно без надобности, даже тестировать негде. Думаю это нетрудно поправить, как это сделал viacht.
7. Вячеслав Кадацкий (marsohod) 05.11.09 19:15
(0) (3) Просто в строку 997 добавьте условие:
Если Счет.Выбран() <> 0 Тогда
		Если ИндексВидОтбора[1] = 0 Тогда
			УстВидОтбора1(1);
		КонецЕсли;
		Если ИндексВидОтбора[2] = 0 Тогда
			УстВидОтбора2(1);
		КонецЕсли;
		Если ИндексВидОтбора[3] = 0 Тогда
			УстВидОтбора3(1);
		КонецЕсли;
	КонецЕсли;
...Показать Скрыть

и перестанет ругаться.
Неплохо бы еще добавить объявление переменной БухИтоги... ;)
8. Сергей Бояновский (ZeBeR) 06.11.09 11:28
(7) (3) Спасибо за подсказку. Все гениальное просто :)
По поводу переменной БухИтоги не согласен. В бухгалтерии это глобальная переменная, откуда собственно и берется резделитель и т.д., если ее объявить, то она нафиг не нужна.

Выложил исправленный файл, в т.ч. добавлен разделитель в форму. Разделитель сделел по аналогии с типовыми отчетами, но проверить нет возможности. :( Проверьте плиз и откоментируйте. :?:
9. Вячеслав Кадацкий (marsohod) 06.11.09 13:36
(8) Нормально :)

P.S. В конфигурации может быть объявлено БИ, глБИ, БухИт или еще бог знает как...
Чтобы отчет был универсальным можно объявить:
Перем БухИтоги;
Перем ИспользуетсяРазделительУчета;
БухИтоги = СоздатьОбъект("БухгалтерскиеИтоги");
ИспользуетсяРазделительУчета = Метаданные.РазделительУчета.Выбран();

И соответственно расписать видимость элементов формы и алгоритм формирования отчета. Но это всего-лишь пожелание, себе я уже переделал ;)
10. Вячеслав Кадацкий (marsohod) 06.11.09 13:48
Прикольно ... ответ на восьмой комментарий - восьмерка в скобках - получается в виде смайлика (8)
11. Сергей Бояновский (ZeBeR) 06.11.09 14:41
(9) в стандартных отчетах эта переменная не объявляется, а отчет сделан именно под 1С бухгалтерию, так что у кого по другому пусть сами поправляют.
12. rasswet (rasswet) 06.11.09 16:35
(8) Если РазделительУчета.Выбран() = 1 Тогда
{W:\ANALIZ_SF_BSK.ERT(691)}: Значение не представляет агрегатный объект (Выбран)
по всем подглючило. в отдельности по каждому-нормально работает.
13. Сергей Бояновский (ZeBeR) 06.11.09 17:08
(12) поправил, попробуй еще разок
14. rasswet (rasswet) 12.11.09 09:57
(13) по-моему всё нормально, спасибо!
15. Галина (ignio) 07.12.09 12:06
Выдает ошибку: неправильный формат файла. Это же для бухии 7.7 ?
16. Сергей Бояновский (ZeBeR) 07.12.09 12:17
(15) а как открываете?
Файл - стандартный ert. Можно открыть через Меню/Открыть файл или скопировать в ExtForms и добавить в Меню/Сервис/Дополнительные возможности.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа