Игра «Завиток»

Сообщество - Игры

Несколько увлекательных минут в день с игрой «Завиток» помогут Вам скрасить серые рабочие будни!

Такая простая игра, но как всё закручено! :)

С каждым ходом компьютер подбрасывает Вам несколько новых цветных кубиков, стройный ряд которых неуклонно продвигается к центру завитка. Игра прекратится, как только первый кубик достигнет центра.

Как помешать этому? Всё очень просто!

При каждом своём ходе выбирайте в ряду такой кубик, чтобы, поменявшись местами с центральным, он образовал группу из двух и более кубиков одинакового цвета. Все такие группы, получившиеся в результате Вашего хода, исчезнут, замедлив продвижение кубиков к центру. Очков начисляется тем больше, чем больше кубиков в группе и чем больше самих групп, убранных за Ваш ход.

Продержитесь как можно дольше в игре и наберите как можно больше очков, но помните, что по мере накопления Вами очков компьютер с каждым ходом вбрасывает всё больше новых кубиков!

Скачать файлы

Наименование Файл Версия Размер
Игра «Завиток» (релиз 1.01.009)
.epf 70,84Kb
30.10.09
153
.epf 70,84Kb 153 Скачать бесплатно

См. также

Комментарии
1. Анатолий (hame1e00n) 469 30.10.09 14:35 Сейчас в теме
Ааа прикольно!!!)) Тока че так тормозит :( А так супер!
2. Анатолий (hame1e00n) 469 30.10.09 14:38 Сейчас в теме
3. Анатолий (hame1e00n) 469 30.10.09 15:09 Сейчас в теме
4. Анатолий (hame1e00n) 469 30.10.09 15:10 Сейчас в теме
Да я повелитель завитка!)) :D
5. Анатолий (hame1e00n) 469 30.10.09 15:27 Сейчас в теме
556, все видимо больше не смогу)))
6. Анатолий (hame1e00n) 469 30.10.09 15:29 Сейчас в теме
автор объясни как эта обработка работает. что за функция V8G_ВызватьСОднимПараметром(Параметр) и где она находится?
7. Ёпрст (Ёпрст) 1017 30.10.09 16:20 Сейчас в теме
{ВнешняяОбработка.Завиток}: Слишком много фактических параметров (ЗапуститьПриложение)
{ВнешняяОбработка.Завиток}: Процедура или функция с указанным именем не определена (ЗапуститьПриложение)
8. команда проекта 1CV8GAMES (1CV8GAMES) 86 30.10.09 23:10 Сейчас в теме
(7) Подскажите, какой релиз 1С:Предприятия 8.1 Вы используете?
9. команда проекта 1CV8GAMES (1CV8GAMES) 86 30.10.09 23:11 Сейчас в теме
(6) Эта функция находится в модуле обработки
10. Serj (Serj1C) 462 02.11.09 07:15 Сейчас в теме
Все внешние обработки от 1CV8GAMES очень интересно реализованы с точки зрения скрытия исходного кода, все формы генерируются динамически, очень прикольно и оригинально.
11. Ёпрст (Ёпрст) 1017 02.11.09 08:29 Сейчас в теме
12. Ёпрст (Ёпрст) 1017 02.11.09 08:30 Сейчас в теме
13. команда проекта 1CV8GAMES (1CV8GAMES) 86 02.11.09 13:12 Сейчас в теме
(10) Благодарим за лестные оценки!

Мы планируем постепенно раскрыть все секреты реализации в выпусках рассылки "Школа 1С", так что програмистам, может быть, будет интересно! ;)

Сами модули обработок открывать пока не планируем. Причина, надо думать, очевидна ;)
14. команда проекта 1CV8GAMES (1CV8GAMES) 86 02.11.09 13:15 Сейчас в теме
(11,12) Мы тестируем наши игры на совместимость с платформой релизов 8.1.10+
Гарантировать совместимость с более ранними релизами, к сожалению, не можем.
15. Александр Сергиенко (AXoxol) 04.11.09 01:49 Сейчас в теме
(1) Вот я кому то поиграю в рабочее время..... :evil:
16. Artem N (Artem N) 90 04.11.09 09:30 Сейчас в теме
Э... Снова без исходников ;) Причина не очевидна!
17. NoMAx (NoMax) 232 05.11.09 10:21 Сейчас в теме
(13) Сами модули обработок открываются на раз, а вот как формируется "КартинкаВСтроке" мне непонятно.
18. Владимир (KnightAlone) 7 05.11.09 11:18 Сейчас в теме
20. Владимир (KnightAlone) 7 05.11.09 17:49 Сейчас в теме
22. Andrey St (st2009st) 18.07.10 19:58 Сейчас в теме
как это сделано? модуля нет :( мой мыл st00 собака bk.ru
23. Andrey St (st2009st) 26.12.10 11:29 Сейчас в теме
сделай подарок, раскрой тайну, как текст в модуле спрятать, так то его читаю )))
мыло оставлял st00 собака bk.ru
Процедура V8G_ВызватьСОднимПараметром(Элемент) Экспорт
Перем ИмяКнопки;
Перем НомерКлетки;
Если НЕ ИдетАнимация Тогда
Если Элемент.Имя = "Баннер" Тогда
Если НЕ ПустаяСтрока(Линк) Тогда
ЗапуститьПриложение(Линк,,Ложь);
КонецЕсли;
ИначеЕсли Сред(Элемент.Имя,1,6) = "Кнопка" Тогда
ИмяКнопки = СокрЛП(Сред(Элемент.Имя,7));
Если ИмяКнопки = "Да" Тогда
ЗаполнитьФормуИгры();
ИначеЕсли ИмяКнопки = "Нет" Тогда
ТекущаяФорма.Закрыть();
КонецЕсли;
ИначеЕсли Сред(Элемент.Имя,1,6) = "Клетка" Тогда
ТекущаяФорма.ТекущийЭлемент = ВыбЭлемент;
НомерКлетки = Число(Сред(Элемент.Имя,7));
Нажать(НомерКлетки);
КонецЕсли;
Иначе
ТекущаяФорма.ТекущийЭлемент = ВыбЭлемент;
КонецЕсли;
КонецПроцедуры
Оставьте свое сообщение